17:01:24 <andreaf> #startmeeting qa
17:01:28 <openstack> Meeting started Thu Aug  3 17:01:24 2017 UTC and is due to finish in 60 minutes.  The chair is andreaf. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:31 <openstack> The meeting name has been set to 'qa'
17:02:06 <andreaf> Hello who's here for the meeting today?
17:02:08 <andreaf> o/
17:02:26 <blancos> o/
17:02:46 <martinkopec> o/
17:02:58 <felipemonteiro_> o/
17:03:02 <mguiney> o/
17:03:17 <andreaf> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_August_3rd_2017_.281700_UTC.29 Today's agenda
17:03:57 <andreaf> welcome everyone
17:04:00 <andreaf> let's start
17:04:28 <andreaf> #topic Previous Meeting Action review
17:04:54 <andreaf> #action gmann to send ML for upcoming removal of deprecated interfaces and its affect on stable branches
17:05:09 <andreaf> This one an action from past week - still tbd I think ^^^
17:05:25 <andreaf> #topic PTG
17:05:42 <andreaf> #link https://etherpad.openstack.org/p/qa-queens-ptg
17:06:11 <andreaf> For the PTG day 3 to 5 I asked for a room for 10 to 12 people
17:06:53 <andreaf> but it would be good to be able to know roughly who's going to be there, so if you will or perhaps will please add your name to the etherpad
17:07:55 <andreaf> Also please add proposals for discussion to the etherpad so that we may come up with a plan / schedule
17:08:07 <andreaf> it's best to have that so we can try to avoid conflicts as much as possible
17:08:30 <andreaf> the earlier the ideas for discussion the better we can prepare for them as well :)
17:09:57 <andreaf> one last thing, for the first two days we need volunteers to run the help hours and/or help out with the proposed sessions - so if you are available please add your name there
17:10:19 <andreaf> so again we can try to make a schedule that avoid conflicts with SIG sessions in other rooms
17:10:42 <andreaf> questions / comments?
17:11:19 <mtreinish> sounds straightforward enough
17:11:26 * mtreinish added some things to the etherpad
17:11:36 <andreaf> thanks
17:12:06 <andreaf> ah yes stestr is a good one :)
17:13:02 <andreaf> ok moving on
17:13:15 <andreaf> #topic Gate stability
17:13:25 <andreaf> Nothing special to report on my side
17:14:14 <andreaf> #topic Specs Reviews
17:14:24 <andreaf> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
17:14:39 <mtreinish> andreaf: well I was going to point out our low classification rate: http://status.openstack.org/elastic-recheck/data/integrated_gate.html
17:14:50 <mtreinish> you went to quickly on that topic...
17:14:58 <andreaf> mtreinish: eh sorry
17:15:07 <andreaf> #undo
17:15:08 <openstack> Removing item from minutes: #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
17:15:11 <clarkb> also we just updated the method used to consume our pypi mirror (reverse proxy rather than webserver with "local" data from afs)
17:15:17 <andreaf> #topic Specs Reviews
17:15:43 <andreaf> #topic Gate stability
17:15:51 <andreaf> so maybe I get it right...
17:16:03 <clarkb> so uh let us know if you see any weirdness related to installing packages in devstack-gate jobs
17:16:11 <clarkb> (I'm hoping it makes things more reliable and quicker though)
17:16:21 <andreaf> clarkb: ok will keep an eye on that
17:17:35 <andreaf> mtreinish: regarding the low classification rate I tried to get help with https://etherpad.openstack.org/p/pike-gate-issue-categotisation but it was not very successful
17:18:00 <andreaf> perhaps I should lead the way spending some time on that myself
17:18:28 <mtreinish> clarkb: I haven't seen anything noticeable on the pip side so far
17:18:37 <mtreinish> which is probably a good sign
17:19:03 <mtreinish> andreaf: heh, yeah lead the way :)
17:19:58 <andreaf> I also added a session proposal in the etherpad about monitoring the SUT overtime
17:20:52 <andreaf> like graphing the memory footprint of services, the total amount it takes for devstack and tests (that we do already) and perhaps other key indicators
17:21:08 <andreaf> so we can see changes that introduce a large deviation
17:21:17 <andreaf> and also we can monitor small changes over time
17:21:59 <andreaf> it's a very rough idea so far I'll try to put down something more concrete, and get comments before the PTG
17:22:10 <andreaf> I think it could be a qa + infra effort
17:22:17 <clarkb> mtreinish: ya and once e-r catches up we'll have good data on whether or not it is more reliable
17:22:30 <mtreinish> andreaf: a historical graph across runs?
17:22:56 <mtreinish> clarkb: heh, yeah. Assuming I can ever manage to push a patch to the worker without a syntax error :)
17:23:00 <andreaf> mtreinish: yes or at least a current value for rolling average to use as comparison with the current run
17:25:03 <andreaf> ok moving on
17:25:13 <andreaf> #topic Spec Reviews
17:25:19 <andreaf> for real this time
17:26:06 <andreaf> probably open specs should be either discussed at the PTG or closed
17:26:40 <andreaf> I want to do a spec  / bp cleanup before the PTG to make sure we have a good picture of what we want to work on in there
17:26:58 <andreaf> #link https://review.openstack.org/#/q/status:open+project:openstack/qa-specs,n,z
17:27:10 <andreaf> anything on specs?
17:27:52 <mtreinish> andreaf: a spec cleanup? there are only 6 :)
17:28:40 <andreaf> mtreinish: heh ok
17:28:44 <andreaf> mtreinish:  but we have many blueprints
17:29:46 <andreaf> ok moving on
17:29:50 <andreaf> #topic Tempest
17:30:45 <andreaf> martinkopec: thanks for running bug triage this week
17:30:50 <andreaf> martinkopec: anything to report?
17:31:10 <martinkopec> andreaf, yes, I found few bugs|reviews which need a little attention
17:31:16 <martinkopec> I wrote them to the report
17:31:18 <martinkopec> #link
17:31:27 <martinkopec> #link https://etherpad.openstack.org/p/tempest-weekly-bug-report
17:31:47 <martinkopec> they are longer time unnoticed
17:32:20 <andreaf> ok, thanks for finding / pointing these out
17:33:03 <martinkopec> I just went through In progress bugs and checked If they are still valid .. so this is all from my side
17:33:30 <andreaf> thank you
17:33:51 <andreaf> anything else on tempest?
17:33:52 <mtreinish> martinkopec: cool, thanks. I saw a bunch of bug updates from you go by on my lp mail folder this morning
17:34:02 <mtreinish> andreaf: I had one patch to discuss
17:34:04 <mtreinish> one sec
17:34:17 <mtreinish> #link https://review.openstack.org/364414
17:34:28 <mtreinish> that's been something that's been broken for >1 yr
17:35:05 <mtreinish> I'm trying to figure out how to make it move again
17:35:46 <andreaf> mtreinish: ok I haven't checked that patch in a long time
17:36:48 <mtreinish> it fell through the cracks when I wasn't working last fall
17:36:54 <andreaf> mtreinish: is it ready for review from your POV? I had some comments on PS#6 - I haven't check #9 I will do tomorrow
17:37:07 <mtreinish> and I feel kinda bad, because we have a bunch of users who want the proxy support
17:37:20 <mtreinish> well it needs to be rebased again, but I think it's ready for review after I take care of that
17:38:02 <andreaf> mtreinish: ok sure we should be able to finish that work quickly - I'm not opposed to it at all
17:38:33 <andreaf> I only had a couple of technical issues to be fixed
17:39:20 <andreaf> thanks for pointing that out
17:39:29 <andreaf> anything else on tempest?
17:39:54 <andreaf> I'm still trying to get the work on stable clients.py finished
17:40:13 <andreaf> sorry I meant stable test.py
17:40:19 <andreaf> which requires clients.py as well
17:40:36 <andreaf> there was good progress but still a few things missing
17:40:50 <andreaf> #link https://review.openstack.org/#/c/484384 I would like opinions on this one
17:41:18 * mtreinish still can't believe the cred providers are in lib
17:41:23 <mtreinish> that was like 2 years in the making
17:41:46 <andreaf> mtreinish: thanks for pushing that forward!
17:41:57 <andreaf> mtreinish: that warrants a success tag in IRC :)
17:42:21 <mtreinish> andreaf: is there any advantage to doing that? It's not like initing a client object has any api traffic
17:43:02 <andreaf> mtreinish: the advantage is to expose hidden dependencies in tests to specific API versions or services which are not explicitly declared
17:44:26 <mtreinish> how so? it fails with an exception on calling the object vs failing on the wire for a non-existent api version
17:44:32 <mtreinish> it fails in both cases
17:45:41 <andreaf> mtreinish: if we just change tempest configuration we can find such cases, even if the version is actually running
17:46:17 <mtreinish> heh, personally that seems like a pretty far out edge case. But we can discuss it more after the meeting
17:46:38 <andreaf> mtreinish: but I see your point, it's not a strong need for that
17:47:06 <andreaf> mtreinish: in the past we had the glance client doing API calls at __init__ time but we fixed that long time ago
17:47:35 <mtreinish> yeah, that was a really long time ago. We fixed that as part of making tempest import safe for discovery
17:47:56 <mtreinish> must be like 4 yrs ago now
17:48:05 * mtreinish can't believe its been that long
17:48:18 <andreaf> heh
17:48:22 <andreaf> the other bit I need to make stable is validation_resources
17:48:47 <andreaf> but I would like to avouid refactoring that - I think simply removing dependencies from CONF should be enough
17:49:09 <mtreinish> if it has unit tests and docs, that's probably fine then
17:49:09 <andreaf> I will prepare the patch - hopefully there are no strong objections to that
17:49:47 <andreaf> mtreinish: yeah I know the unit tests are probably missing I'll see what I can do
17:50:22 <andreaf> ok time is running out
17:50:27 <andreaf> next topic?
17:50:35 <andreaf> #topic Patrole
17:50:46 <andreaf> anything to be discussed on patrole?
17:51:17 <andreaf> 3...
17:51:21 <andreaf> 2..
17:51:27 <andreaf> 1.
17:51:34 <andreaf> #topic Critical Reviews
17:51:53 <andreaf> Any review that requires urgent attention?
17:51:58 <andreaf> beside what discussed already?
17:52:42 <andreaf> ok I guess not
17:52:47 <andreaf> #topic Open Discussion
17:54:05 <andreaf> ok. thanks everyone for joining the meeting today
17:54:15 <andreaf> #endmeeting