17:00:33 <andreaf> #startmeeting qa
17:00:33 <openstack> Meeting started Thu Aug 17 17:00:33 2017 UTC and is due to finish in 60 minutes.  The chair is andreaf. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:37 <openstack> The meeting name has been set to 'qa'
17:00:53 <andreaf> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_August_17th_2017_.281700_UTC.29 Today's agenda
17:00:55 <andreaf> o/
17:01:02 <andreaf> who's here today for the meeting?
17:01:03 <oomichi> hi
17:01:04 <dustins> \o
17:01:11 <blancos> o/
17:02:50 <andreaf> mtreinish, afazekas: around?
17:03:28 <andreaf> ok let's get started
17:03:58 <andreaf> previous week actions are still for gmann
17:04:15 <andreaf> #action gmann to send ML for upcoming removal of deprecated interfaces and its affect on stable branches
17:04:16 <guinm> o/
17:04:34 <andreaf> o/
17:04:40 <andreaf> #topic PTG
17:05:22 <andreaf> For the PTG, Mon/Tue we will share a room with infra/release/requirements/stable for the help hours
17:05:59 <andreaf> Since questions are likely to span across the responsibility of multiple teams
17:06:16 <andreaf> like Tempest plugins is a lot about setting up the repo which is infra like mtreinish mentioned
17:06:35 <andreaf> also it will make it easier for the room to always be attended by someone
17:07:33 <oomichi> andreaf: how about after Wed?
17:07:56 <andreaf> If you are going to be at the PTG and plan to join QA sessions please do add your name to the list in https://etherpad.openstack.org/p/qa-queens-ptg
17:08:18 <andreaf> oomichi: after Wed we'll have a room dedicated to QA for QA team discussions and code sprint
17:08:20 <oomichi> andreaf: do you have separated room for qa project for separated topic on Wed?
17:08:33 <andreaf> so Wed through Friday
17:08:39 <oomichi> andreaf: cool, I'd like to join online
17:09:25 <andreaf> oomichi: I'll try to make a decent schedule for people who want to join remotely
17:09:53 <oomichi> andreaf: thanks, that will be helpful for us
17:10:07 <andreaf> oomichi: remote attendance at PTG may be tricky but we'll see what we can do, we can always setup a quick hangout or so if it makes sense
17:10:48 <andreaf> another thing will be the ptg bot - it will be possible for people to see what's going on in different rooms in real time via a web page (or in IRC)
17:10:48 <oomichi> andreaf: yeah, it is nice to have discussion on the same time even if that is remotely for moving forward together
17:11:01 <andreaf> as long as room owners will provide the info of course
17:11:21 * oomichi nods
17:13:08 <andreaf> we have quite a few ideas for things to do at the PTG
17:13:14 <andreaf> #link https://etherpad.openstack.org/p/qa-queens-ptg
17:13:52 <andreaf> if there is anything that needs to be discussed before the PTG for preparation please add it to the meeting agenda
17:14:07 <andreaf> and if you have more ideas / things to be discussed please add them in there
17:14:36 <andreaf> I expect each session will be lead/moderated by the person proposing it, unless stated otherwise
17:15:07 <andreaf> one last thing
17:15:14 <oomichi> yeah, each person needs to
17:16:03 <andreaf> if you have special scheduling needs in terms of conflicting meetings or late arrival / early departure you may want to track this on the etherpad as well
17:16:28 <andreaf> ok enough for the PTG from my side
17:16:48 <andreaf> anything else?
17:16:59 <andreaf> #topic Gate Stability
17:17:53 <andreaf> Gate failure categorisation rate is still pretty low - partly my fault since I've been busy with test.py patches and ignored by duty on that
17:18:11 <andreaf> I scheduled myself for next week to get more categorization in place
17:18:51 <andreaf> The gate usage is still pretty high, a lot of time we are using all nodes available
17:19:15 <andreaf> and failure rates seems to be still a bit too high looking at the graphs
17:19:42 <andreaf> #link https://goo.gl/ptPgEw
17:19:58 <oomichi> yeah, the usage seems still maximum
17:20:32 <andreaf> I knew folks in infra were investigating networking issues and slow nodes, but I don't have any news on that
17:21:51 <andreaf> anything else on gate stability?
17:21:59 <andreaf> ok moving on
17:22:04 <andreaf> #topic Specs Reviews
17:22:13 <andreaf> anything on specs?
17:22:29 <andreaf> just a reminder for folks to please review open specs before the PTG
17:22:50 <andreaf> so we get there prepared and we can plan queens work accordingly
17:23:18 <andreaf> ok moving on
17:23:21 <andreaf> #topic Tempest
17:23:29 <oomichi> oh, I notice now https://review.openstack.org/#/c/173334/ needs to be updated. OK, I will do before PTG
17:24:14 <andreaf> prateek: around?
17:24:27 <andreaf> Anything on Tempest to be discussed?
17:25:08 <mtreinish> oomichi: heh, it's only been 2 yrs so far :p
17:25:40 <oomichi> mtreinish: yeah, that is the same age of my last kid :)
17:25:46 <andreaf> oomichi: do you think you'll have bw to work on that during queens?
17:25:49 <andreaf> :D
17:26:26 <oomichi> andreaf: yeah, the spec working item will be I can work in queens
17:26:44 <andreaf> oomichi: cool :)
17:26:45 <oomichi> I want to make it grow
17:27:09 <andreaf> oomichi: do you know any user / cloud that would benefit from that?
17:27:55 <oomichi> andreaf: yeah, my company folks want to use it for system integrations
17:28:08 <oomichi> before releasing it on production
17:28:17 <andreaf> oomichi: cool good to hear some feedback on that
17:28:33 <oomichi> I guess that is usual use case of the feature
17:29:27 <andreaf> oomichi: if you have any more description / use cases from NEC to be put in an etherpad or so it might be useful as well
17:29:45 <andreaf> oomichi: yeah indeed
17:30:02 <andreaf> oomichi: I was going to use that for Helion ... long time ago
17:30:33 <oomichi> andreaf: yaeh, ok I make them write on that
17:30:40 <andreaf> thanks
17:30:45 <andreaf> ok moving on
17:30:48 <andreaf> This week I've been working on two things on Tempest side
17:31:15 <andreaf> one is cleanup the console log of the unit test jobs which has become polluted with pieces of logs from various tests
17:31:42 <andreaf> #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:cleanup_test_log
17:32:02 <andreaf> that's still in progress
17:32:37 <andreaf> one of fixes breaks fwaas and another one removes a stable interface so it's not really straight forward
17:33:51 <andreaf> mtreinish: https://review.openstack.org/#/c/494197/ do you think we need deprecation for DEFAULT_PARAMS?
17:34:18 <andreaf> it's a stable interface but it has been so for only a few days :S
17:34:43 <mtreinish> andreaf: I'm totally fine just deleting it
17:35:32 <andreaf> oomichi: perhaps you want to weigh in as well, if we can get consensus on deletion it would great I don't think this is worth a lot of extra effort really
17:36:34 <andreaf> The other thing I've been working on is making validation resources and test.py stable
17:36:39 <andreaf> #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:test_module_stable
17:36:50 <andreaf> I've found some interesting unit test issues
17:36:51 <oomichi> andreaf: humm, I could not follow  ^^^, maybe that is gmann?
17:37:10 <oomichi> gmann puts -1 on that
17:37:41 <andreaf> oomichi: yeah gmann recommends we go through deprecation
17:37:55 <andreaf> oomichi: but I'm not fully convinced it's worth it in this case
17:38:47 <oomichi> andreaf: I am good to remove it directly if we never say it as stable interface even if users exist
17:39:24 <andreaf> oomichi: the module was declared as a stable interface a few days ago
17:39:43 <oomichi> andreaf: omg, that is..
17:39:51 <andreaf> #link https://review.openstack.org/#/c/487482/
17:40:17 <andreaf> 7 days ago to be precise :D
17:41:02 <oomichi> I need to be your enemy on this case ;)
17:41:06 <andreaf> oomichi: also that dict is not the correct one to use, so if we leave it around we should fix it
17:42:10 <oomichi> andreaf: ok, I will check it more carefully after meeting
17:42:17 <andreaf> oomichi: cool thanks
17:43:41 <andreaf> so anything else on Tempest?
17:44:20 <andreaf> #topic Patrole
17:44:30 <andreaf> anything on Patrole to be discussed?
17:44:55 <blancos> Felipe has a few things for the PTG
17:45:04 <blancos> but nothing urgent that I can think of
17:45:26 <andreaf> blancos: ok
17:46:00 <andreaf> if nothing else, I'll move to open discussion
17:46:09 <andreaf> #topic Open Discussion
17:46:41 <mtreinish> on the stestr migration stuff, I think the ostestr patch is ready:
17:47:00 <mtreinish> #link https://review.openstack.org/488441
17:47:25 <mtreinish> I'm hoping people could test it out, because I'm sure I'm missing an edge case somewhere
17:47:54 <mtreinish> like just the other day I realized most projects won't have an .stestr.conf, so ostestr will have to parse the .testr.conf and pass the args to stestr
17:48:22 <mtreinish> but overall I'm really happy with that transition, it makes the code so much cleaner
17:48:56 <mtreinish> and eventually we can hopefully remove the testr transition bits and make it just a straight passthrough command (and eventually maybe even delete the ostestr entrypoint)
17:49:42 <andreaf> cool
17:49:43 <andreaf> I will try it out
17:49:43 <ltosky[m]> couldn't that issue (missing .stestr) and potentially others be discovered with some.targeted reviews?
17:50:24 <andreaf> eventually we'll have to migrate .testr.conf to .stestr.conf - but I guess we can do that over time
17:51:32 <andreaf> mtreinish: I wss wondering - is there support in stestr for the test bisect - to find dependencies between to tests?
17:51:52 <mtreinish> andreaf: yeah: http://stestr.readthedocs.io/en/latest/MANUAL.html#automated-test-isolation-bisection
17:52:04 <andreaf> mtreinish: I had to do that today, I didn't manage to get testr doing that for me so I handed up scripting it myself quickly
17:52:09 <mtreinish> that was just straight ported over from testr though
17:52:15 <mtreinish> so I haven't really tested it
17:52:32 <andreaf> mtreinish: ok I will test it
17:52:33 <mtreinish> andreaf: ah, ok. Well we can work on fixing that to make it easier
17:52:57 <mtreinish> ltosky[m]: targeted reviews?
17:53:19 <mtreinish> ltosky[m]: like getting people to look at it? Or throwaway test patches?
17:53:34 <ltosky[m]> the latter
17:53:53 <ltosky[m]> Well, not that the former is bad :)
17:54:02 <mtreinish> yeah, I thought about doing that, but I didn't want to waste test nodes right now
17:54:29 <ltosky[m]> right
17:57:02 <andreaf> one last thing
17:57:12 <andreaf> what should I name the module in https://review.openstack.org/#/c/493668/
17:57:25 <andreaf> changing that name in that patch is daunting process
17:57:33 <andreaf> so I'd rather do it once only :D
17:57:43 <andreaf> #link https://review.openstack.org/#/c/493668/
17:57:48 <mtreinish> andreaf: I'm happy with the name there now
17:57:54 <andreaf> suggestions on the patch are welcome
17:59:11 <andreaf> mtreinish: heh ok thanks
18:00:11 <andreaf> ok thanks for joining everyone :)
18:00:16 <andreaf> #endmeeting