08:01:37 <gmann> #startmeeting qa
08:01:38 <openstack> Meeting started Thu Oct  5 08:01:37 2017 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:01:42 <openstack> The meeting name has been set to 'qa'
08:01:56 <gmann> who all here today
08:02:46 * andreaf lurking around but may have to drop off at some point o/
08:03:42 <gmann> masayukig: chandankumar dmellado afazekas .
08:04:07 <masayukig> o/
08:04:27 <masayukig> gmann: thanks for your pinging :)
08:05:06 <gmann> let's wait fro more min.
08:05:13 * masayukig nods
08:05:14 <gmann> masayukig: np. :)
08:06:46 <martinkopec> o/,  hi all
08:06:54 <gmann> hi
08:07:21 <masayukig> \o/
08:07:29 <gmann> let's start
08:07:35 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_October_5th_2017_.280800_UTC.29
08:07:40 <gmann> ^^ today agenda
08:08:24 <gmann> #topic Previous Meeting Action review
08:08:41 <gmann> no action item seems #link http://eavesdrop.openstack.org/meetings/qa/2017/qa.2017-09-28-17.00.html
08:08:53 <gmann> #topic PTG Summary
08:09:03 <gmann> #link http://lists.openstack.org/pipermail/openstack-dev/2017-September/122295.html
08:09:20 <gmann> PTg summary from andreaf . we almost cover those in last meeting
08:09:47 <gmann> i would like to move further if there is nothing to discuss from anyon\e
08:10:07 <andreaf> gmann: I submitted one session for the forum
08:10:20 <gmann> #topic Forum Topics for Sydney Summit
08:10:25 <andreaf> same as Boston about input on QA tools from users / operators
08:10:26 <gmann> andreaf: yea, now:)
08:10:37 <gmann> #link http://forumtopics.openstack.org/cfp/details/56
08:10:43 <andreaf> heh sorry
08:11:07 <gmann> aone sessions andreaf submitted. i saw some more sessions on o-h feedback etc
08:11:48 <masayukig> o-h feedback?
08:11:49 <gmann> andreaf: we will be having onboarding sessions also. which should be coming out on ML soon
08:12:18 <andreaf> gmann: oh is it? ok I didn't see anything about it yet
08:12:45 <gmann> there is one mroe on stetrs from mtreinish
08:12:48 <gmann> #link http://forumtopics.openstack.org/cfp/details/34
08:13:02 <gmann> #link http://forumtopics.openstack.org/cfp/details/35
08:14:20 <masayukig> gmann: andreaf: do we have a list of QA topics?
08:14:59 <gmann> masayukig: for forum ?
08:15:07 <andreaf> masayukig: not really, but I can add the links now back in the original etherpad
08:15:10 <masayukig> gmann: yes, for forum
08:15:11 <gmann> deadline for final schedule fro forum is oct 30
08:15:32 <dmellado> o/
08:15:35 <dmellado> hi guys, I'm late
08:15:38 <gmann> #link https://etherpad.openstack.org/p/qa-sydney-forum-topics
08:15:41 <gmann> dmellado: hi np
08:15:55 <masayukig> andreaf: sounds nice
08:16:04 <gmann> masayukig: ^^ we did not had much topic this time. deadline to submit was sept 29
08:17:19 <masayukig> gmann: thanks, I think it's good to gather the topic URLs
08:17:28 <gmann> anything else on forum things
08:17:36 <andreaf> #link https://etherpad.openstack.org/p/qa-sydney-forum-topics The etherpad with links
08:17:51 <gmann> andreaf: thanks
08:18:49 <masayukig> andreaf: thanks, I added the titles
08:19:35 <gmann> #topic Bug triage
08:19:50 <gmann> like we discussed in PTG about bug triage things.
08:19:59 <gmann> we will go with Bug Czar approach
08:20:09 <gmann> proposal is here
08:20:11 <gmann> #link https://etherpad.openstack.org/p/qa-bug-czar
08:21:12 <gmann> please provide your feedback if you have any
08:21:20 <andreaf> chandankumar graciously offered himself for the role
08:21:46 <gmann> yea, thanks chandankumar
08:22:10 <gmann> Bug review will be in office hours instead of qa meeting
08:22:33 <gmann> we need to select the appropriate time for office hour
08:22:58 <andreaf> gmann: right, I hope we can go through critical bugs in there and get actions for folks to take away :)
08:23:00 <gmann> seems like 2 time proposal on etherpad
08:23:07 <chandankumar> \o/
08:23:15 <gmann> andreaf: coeect
08:23:15 <andreaf> chandankumar o/
08:23:21 <gmann> *correct
08:23:59 <chandankumar> andreaf: gmann i will be dropping an email to openstack-dev mailing list regarding office hour and with etherpad link so that people can participate
08:24:22 <gmann> chandankumar: we need to select the office hour timing
08:24:32 <gmann> 1 time proposal is 17UTC and other is 8 UTC
08:24:40 <chandankumar> as discussed yesterday above is the time
08:24:52 <gmann> it will be biweekly, alternate to meeting day
08:24:56 <andreaf> chandankumar: before you do that I would like to send an email about QA czar and tell about what it will be
08:25:03 <chandankumar> andreaf: sure
08:25:38 <dmellado> andreaf: qa czar?
08:25:38 <andreaf> so 17 UTC won't work for a lot of people right?
08:25:39 <gmann> with what time we are ok.
08:25:48 <gmann> andreaf: yea
08:25:55 <andreaf> dmellado: qa bug czar
08:25:56 <dmellado> I'd love to hear about that
08:26:02 <gmann> it is 2 Am for me and masayukig :)
08:26:03 <dmellado> looks like a fancy new title xD
08:26:06 <masayukig> yeah
08:26:10 <andreaf> dmellado: https://etherpad.openstack.org/p/qa-bug-czar
08:26:49 <gmann> andreaf: we can move it little bit late like 9UTC etc if 8UTC is too early for you
08:27:31 <chandankumar> 9 UTC is also fine.
08:27:36 <andreaf> gmann: yeah 9 UTC would be easier for me if it works for you
08:28:06 * masayukig was actually waking up last night 2am to watch the Google event, though :-p
08:28:11 <gmann> yea works for me
08:28:22 <gmann> masayukig: 9UTC ok for you?
08:28:43 <masayukig> gmann: yeah, it works for me
08:29:07 <gmann> ok let's lock the 9 UTC for bug review office hour. on every alternate week.
08:29:19 <gmann> one week qa meeting and next week office hour
08:29:30 <chandankumar> +1
08:29:31 <andreaf> gmann: cool thanks - it will be in the qa channel
08:30:08 <gmann> yea, in #opebnstack-qa
08:30:55 <gmann> added in etherpad also
08:31:26 <gmann> #action andreaf to float mail about bug czar introduction
08:31:40 <andreaf> I will do that today
08:31:43 <gmann> anything else ?
08:31:46 <gmann> andreaf: thanks
08:32:08 <gmann> #topic Tempest
08:32:20 <gmann> 1. Test.py to be stable:
08:33:00 <gmann> this is dependent on object storage client to be moved to lib
08:33:33 <gmann> there is conflict for name conflict of service methods name
08:33:35 <gmann> #link https://review.openstack.org/#/c/504439/
08:34:25 <gmann> oomichi_afk: suggested to go with wrapper approach for create_* and keep update_* for PUT APi
08:35:00 <gmann> it is long pending patch and we should merge it
08:35:36 <gmann> oomichi_afk: and andreaf discussed the best possible way over qa channel.
08:36:05 <gmann> i will check with oomichi_afk  on create_update thing if i can catch him tonight
08:36:46 <gmann> otherwise we will with same(wrapper) approach by tomorrow
08:37:04 <andreaf> gmann: thanks
08:37:16 <gmann> i will make sure those pactches are ready by tomorrow
08:37:42 <gmann> andreaf: do you have anything to review meanwhile for test.py ?
08:38:20 <andreaf> gmann: no, I will prepare a patch for it
08:38:27 <gmann> ok
08:38:30 <andreaf> gmann: it's going to be release notes / docs only
08:38:40 <gmann> nice
08:39:07 <andreaf> #action andreaf prepare a patch to make test.py stable
08:39:21 <gmann> thanks
08:39:28 <gmann> 2. Scenario refactoring
08:39:42 <gmann> zhufl is not here, but i saw she started working on this
08:40:03 <gmann> may be it will be good to have a common topic for that to make fast review
08:40:26 <gmann> i will ping her once she is back from holiday
08:40:51 <gmann> anything else on Tempest ?
08:42:10 * andreaf has to leave, have a good rest of the meeting o/
08:42:17 <gmann> ok, let's move
08:42:23 <gmann> andreaf: thanks.
08:42:25 <gmann> #topic Critical Reviews
08:42:56 <gmann> paste your critical reviews here if you have any
08:43:55 <masayukig> andreaf: I'd like to know about this https://review.openstack.org/#/c/509242/
08:44:11 <gmann> i will have tomorrow about object service clients.
08:45:12 <gmann> masayukig: its for zullv3 migration right
08:45:57 <masayukig> yeah, I was thinking about that, do we need this immediately?
08:46:44 <gmann> i am not sure immediately  but we can review it
08:47:17 <masayukig> gmann: yeah, is there any docs about zuulv3 to understand this patch?
08:48:04 <gmann> i do not know. it is complete series
08:48:05 <gmann> #link https://review.openstack.org/#/q/topic:zuulv3-tempest+(status:open+OR+status:merged)
08:48:45 <gmann> we can refer this series
08:48:48 <gmann> #link https://review.openstack.org/#/q/topic:zuulv3+(status:open+OR+status:merged)
08:49:23 <masayukig> gmann: ok, thanks, I'll check them
08:49:30 <gmann> masayukig: thanks
08:50:01 <masayukig> gmann: https://docs.openstack.org/infra/zuul/ this is also useful?
08:50:31 <gmann> yea thanks
08:50:59 <gmann> #topic Open Discussion
08:51:09 <gmann> anything else anyone want to discuss
08:52:28 <gmann> ok, let's close the meeting if nothing else
08:52:35 <gmann> 3 ...
08:52:41 <gmann> 2 ..
08:52:41 <chandankumar> 2..
08:52:46 <masayukig> heh
08:52:49 <gmann> 1 ..
08:52:52 <gmann> :)
08:52:54 <gmann> thanks all for joining
08:52:58 <masayukig> o/
08:53:01 <gmann> #endmeeting