17:00:22 <andreaf> #startmeeting qa
17:00:23 <openstack> Meeting started Thu Oct 12 17:00:22 2017 UTC and is due to finish in 60 minutes.  The chair is andreaf. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:26 <openstack> The meeting name has been set to 'qa'
17:00:41 <andreaf> Good morning, good evening everyone
17:00:44 <andreaf> o/
17:00:48 <dustins> \o
17:00:54 <andreaf> Who's here for the meeting today?
17:01:02 <andreaf> hello dustins
17:01:11 <dustins> andreaf: howdy
17:01:44 <andreaf> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_October_12th_2017_.281700_UTC.29 Today's agenda
17:02:32 <andreaf> afazekas, oomichi, mtreinish around?
17:02:36 <mguiney> po/
17:02:41 <mguiney> * o/
17:03:43 <andreaf> mguiney o/
17:03:59 <mguiney> sorry, typo'd
17:04:44 <andreaf> since it's only the few of us, I'll do a quick fly through the agenda for the record and then open the floor to open discussion if that's ok
17:04:47 <andreaf> stop me anytime :)
17:05:10 <andreaf> #topic last meeting actions
17:05:17 <andreaf> There were two actions for me
17:05:33 <andreaf> #link http://eavesdrop.openstack.org/meetings/qa/2017/qa.2017-10-05-08.01.html
17:05:42 <andreaf> Send an email about bug czar: done
17:05:54 <andreaf> Prepare a patch for test.py -> tbd
17:06:07 <andreaf> #action andreaf prepare a patch for test.py release notes and docs
17:06:31 <andreaf> #topic Forum Topics for Sydney Summit
17:06:46 <andreaf> We have three topics accepted for the forum
17:06:53 <mtreinish> andreaf: I'm kinda around
17:07:05 <andreaf> mtreinish o/ ok
17:07:22 <andreaf> #link https://etherpad.openstack.org/p/qa-sydney-forum-topics the three sessions are tracked here
17:08:06 <andreaf> In short, openstack health, stestr and runners, users and operators adoption of qa tools
17:08:26 <andreaf> Also we will have a QA onboarding session
17:08:42 <andreaf> I asked gmann_afk and masayukig to help prepare the session ^^^
17:09:10 <andreaf> more volunteers to help prepare the session are always welcome
17:09:25 <andreaf> #topic  Office Hours
17:09:34 <andreaf> We had earlier today our first office hours
17:09:40 <andreaf> I feel it went well
17:09:57 <andreaf> We did mostly bug triage, there was one question only about devstack
17:10:06 <andreaf> next one is in two weeks
17:11:04 <andreaf> #link http://lists.openstack.org/pipermail/openstack-dev/2017-October/123520.html Report of office hours
17:11:15 <andreaf> #topic Tempest
17:11:36 <andreaf> We're still trying to get test.py stable, there are three patches left for the object storage client
17:11:52 <andreaf> #link https://review.openstack.org/#/c/511156
17:12:00 <andreaf> #link https://review.openstack.org/#/c/511173
17:12:10 <andreaf> #link https://review.openstack.org/#/c/510841
17:12:28 <andreaf> #info patches for object storage client to be reviewed ^^^ for test.py stable
17:12:47 <andreaf> Also on Tempest you may have seen ansible patches
17:12:55 <andreaf> #link https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:zuulv3-tempest zuulv3 native jobs
17:13:22 <andreaf> I'm working with infra on setting up base tempest job in zuul v3 native format
17:13:38 <mtreinish> andreaf: there was a 100% breakage introduced by the object client cleanup
17:13:50 <andreaf> that will be the basis for most devstack + tempest jobs in the zuulv3 world
17:14:13 <andreaf> mtreinish: what do you mean by 100% breakage?
17:14:15 <mtreinish> andreaf: https://bugs.launchpad.net/tempest/+bug/1722164
17:14:16 <openstack> Launchpad bug 1722164 in tempest "Senario test: test_swift_acl_anonymous_download is always failed" [High,In progress] - Assigned to Jeremy Zhang (jeremy.zhang)
17:14:39 <mtreinish> andreaf: as in we broke a test so it never works after some of the cleanups
17:14:56 <mtreinish> it's not the latest round, but some of the earlier patches
17:15:21 <andreaf> mtreinish: yeah I may be a bit too keen on getting those merged :(
17:16:34 <andreaf> mtreinish: do we run that test anywhere?
17:17:12 <mtreinish> andreaf: in the scenario jobs
17:17:15 <mtreinish> which are nv
17:17:38 <andreaf> mtreinish: uhm ok we need to be more careful with -nv jobs
17:17:52 <mtreinish> it's been broken since https://review.openstack.org/#/c/504439/ (which showed the failure)
17:17:55 <andreaf> #info object storage refactor broke test_swift_acl_anonymous_download running on non-voting
17:18:29 <andreaf> #info object storage refactor broke ceilometer plugin as well, which runs on non-voting puppet job
17:18:38 <andreaf> #info we need to take care of non-voting jobs
17:19:34 <andreaf> mtreinish: thanks for bringing it up
17:19:59 <andreaf> Anything else on Tempest?
17:20:10 <andreaf> ...
17:20:11 <andreaf> ..
17:20:12 <andreaf> .
17:20:15 <mguiney> just another plea for reviews!
17:20:42 <mtreinish> mguiney: link?
17:20:43 <mguiney> #link https://review.openstack.org/#/c/500470/
17:20:43 <andreaf> mguiney: sure. link?
17:20:48 <mguiney> sorry, took a sec
17:21:43 <andreaf> mguiney: I did review that, but it's not clear to me what the test is about
17:21:46 <andreaf> I left a comment on the patch
17:21:53 <mguiney> ah ok, thank you
17:21:56 <mguiney> will take a look!
17:23:12 <andreaf> ok ping me if you want to chat about it - I may online a bit later after dinner
17:23:28 <andreaf> #topic critical reviews
17:23:38 <andreaf> any other patch that needs urgent review?
17:24:58 <andreaf> #topic open discussion
17:25:13 <andreaf> ok anything else anyone?
17:26:08 <andreaf> I have one question to the attendees, mguiney dustins mtreinish - do you find this meeting useful?
17:26:37 <mguiney> well
17:26:54 <andreaf> I'm considering keeping only the APAC TZ meeting since there's more activity there but I don't want to take away a place for people to report issues or so
17:27:02 <mguiney> as someone trying to get more involved, it is helpful to be able to ask and listen to people directly
17:27:21 <dustins> andreaf: I do find it useful, even if I don't have much to say
17:27:23 <mguiney> i may be able to pop up then instead, what is the time?
17:27:42 <andreaf> 8:00 UTC
17:28:00 <dustins> And it's this or wake up for a 03:00 meeting :)
17:28:08 <andreaf> so now we have 8:00 UTC meeting alternating with 9:00 UTC office hours
17:28:28 <andreaf> uhm that's way too early
17:28:57 <dustins> Also explains why I haven't heard of the office hours, that's at 04:00
17:29:05 * dustins is not a morning person
17:29:12 <andreaf> :D
17:29:37 <dustins> Oh man, and with Daylight Savings it moves back another hour, oof
17:29:45 <mtreinish> andreaf: it's not super useful to me. But, it's also around my lunch time so I'm not super active
17:30:32 <andreaf> I could perhaps cancel this meeting and setup a second office hours around 2pm UTC or so
17:31:04 <dustins> 11:00 EST, yeah?
17:31:37 <dustins> That would be during the Manila upstream meeting for me, at least
17:31:46 <andreaf> ok
17:32:09 <andreaf> I'll send a proposal in the ML to get a bit more input then, I can propose a few slot and ask for people to vote
17:32:24 <dustins> andreaf: sounds good to me, thanks, andreaf!
17:32:31 <andreaf> ok
17:33:07 <andreaf> #action andreaf send email about office hours in ~ UTC afternoon to replace this meeting
17:33:21 <andreaf> shall we wrap up?
17:33:41 <andreaf> anything else
17:33:42 <andreaf> ?
17:33:45 <andreaf> thanks for attending!
17:33:55 * andreaf waves goodbye
17:33:59 <andreaf> #endmeeting