07:59:47 <gmann_> #startmeeting qa
07:59:48 <openstack> Meeting started Thu Mar  8 07:59:47 2018 UTC and is due to finish in 60 minutes.  The chair is gmann_. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:59:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:59:51 <openstack> The meeting name has been set to 'qa'
08:00:01 <gmann_> who all here today?
08:01:25 <masayukig[m]> o/
08:01:47 <gmann_> masayukig[m]: seems like 2 of us, let;'s wait for more people
08:01:54 <gmann_> andreaf: afazekas chandankumar ping
08:02:02 <masayukig[m]> yeah
08:02:59 * masayukig[m] is sitting next to gmann now
08:03:28 <gmann_> let's start or we can just speak f2f with some drink :)
08:03:39 <masayukig[m]> heh
08:03:45 <gmann_> anyways let's start.
08:03:52 <gmann_> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_Mar_8th_2018_.280800_UTC.29
08:03:56 <gmann_> today agenda ^^
08:04:21 <gmann_> This is probably last meeting as we discussed in PTG to have office hours only
08:04:38 <gmann_> So i will be using this meeting as publishing the new office hour time etc
08:04:56 <gmann_> #topic Previous Meeting Action review
08:04:58 <andreaf> o/
08:05:09 <gmann_> #link http://eavesdrop.openstack.org/meetings/qa/2018/qa.2018-02-22-08.00.html
08:05:19 <gmann_> this is more pre PTG things and all done
08:05:20 <gmann_> andreaf: hi
08:05:33 <gmann_> #topic Rocky PTG Summary
08:05:49 <gmann_> i sent the summary for PTG over mail
08:05:52 <gmann_> #link http://lists.openstack.org/pipermail/openstack-dev/2018-March/128002.html
08:06:11 <gmann_> you can also find the details on etherpad #link https://etherpad.openstack.org/p/qa-rocky-ptg
08:07:10 <masayukig[m]> gmann_: thanks for the mail! I think we actually still need to discuss interop things
08:07:45 <masayukig[m]> in the dev-ml, gerrit, etc
08:07:46 <gmann_> we captured the Rocky priority also #link https://etherpad.openstack.org/p/qa-rocky-ptg-rocky-priority
08:08:02 <gmann_> masayukig[m]: yea, so that we will keep discussing on gerrit probably
08:08:29 <gmann_> #link https://review.openstack.org/#/c/521602/
08:08:38 <masayukig[m]> gmann_: yeah, that should be the good place
08:08:40 <gmann_> or the new patch mentioned in that
08:09:02 <gmann_> from QA perspetive, it become little hard to own the new plugins repo
08:09:30 <gmann_> i am totally fine to help and share the review bandwidth for interop tests
08:09:56 <gmann_> but owning the new interop plugin repo might be difficult for us
08:10:20 <andreaf> gmann_  the proposal was only to have them under QA governance it doesn't mean we have to write the tests or anything
08:10:53 <andreaf> gmann_ there is not much difference in being responsible for reviews in tempest or in a plugin from my perpsective
08:11:17 <andreaf> gmann_ the only difference would be with heat since their tests are in gabbi
08:11:39 <gmann_> andreaf: yea, i agree. and i think that's was our wed discussion to have the in tempest
08:11:40 <andreaf> gmann_ but pretty much reviews for interop tests would be "do not change it" in most cases
08:12:24 <gmann_> so it is not very clear to me that it should go under QA repos as it was mentioned that it is project own things
08:12:31 <andreaf> gmann_ well with teams using plugins it would be much less work for us and for the teams
08:13:13 <masayukig[m]> gmann_: yeah, I agree. It should be described more details
08:13:38 <gmann_> current gerrit and comments does not say clearly that it has to be in QA repo.
08:14:08 <andreaf> what do you mean by "QA repo"?
08:14:34 <masayukig[m]> Who should write, review, maintain, etc..?
08:14:37 <gmann_> under QA governance as QA maintained deliverables .
08:15:37 <masayukig[m]> I feel some gaps are still there
08:15:48 <andreaf> well devstack-plugin-ceph and devstack-plugin-container are under QA governance and we do not do really much with those
08:16:36 <andreaf> having the repo under the QA governance by itself is not a burden at all I think
08:16:59 <gmann_> i am waiting to have clear view on this patch and see what it mean for us as per maintenance and owning means - https://review.openstack.org/#/c/550571/
08:17:01 <gmann_> #link https://review.openstack.org/#/c/550571/
08:17:03 <masayukig[m]> andreaf: It's nice if everyone think so
08:17:41 <gmann_> yea let's see how it is structure and what all team are in core team which are the key.
08:17:49 <masayukig[m]> anyway, I think we can clarify that in that patch
08:18:16 <andreaf> masayukig[m] the only thing that is expected from the qa team is to do reviews on interop tests
08:18:50 <andreaf> but thats true with any solution we may come up with, whether it's tempest, original plugins, extra plugins
08:18:53 <gmann_> agree but that was not written clearly. it is being written as plugins repo own by QA team. which is not clear to me
08:19:12 <masayukig[m]> andreaf: yeah, that's my expectation
08:19:17 <gmann_> review with all plugin repo is all fine.
08:19:41 <gmann_> anyways, i think chris is putting it in more better and clear way in his patch.
08:19:55 <gmann_> we can discuss there.
08:19:57 <andreaf> ok
08:20:19 <gmann_> as long as core team is more than QA and interop and projects it make sense than having only QA team as core
08:20:49 <gmann_> let's move next as we are in ops meetup and about to close the venue
08:21:07 <gmann_> #topic Vancouver Summit Planning
08:21:13 <gmann_> i sent mail for QA Brainstorming ideas. Forum Topic.
08:21:22 <gmann_> #link http://lists.openstack.org/pipermail/openstack-dev/2018-March/127947.html
08:21:43 <gmann_> please write the ideas of Forum topic  on mentioned etherpad
08:21:55 <gmann_> #link https://etherpad.openstack.org/p/YVR-qa-brainstorming
08:22:15 <masayukig[m]> gmann_: sure
08:22:17 <masayukig[m]> thanks
08:22:33 <gmann_> #topic Updated Meeting Time
08:22:45 <gmann_> as we discussed the new time for QA meeting.
08:23:05 <gmann_> we will have only office hours on every Thursday at 9:00 UTC and 17:00 UTC.
08:23:15 <gmann_> no more meeting.
08:23:39 <gmann_> if that went well we will continue on with office hour otherwise we can think of bringing meeting back
08:23:48 <gmann_> i will update the wiki and send mail also.
08:23:59 <masayukig[m]> ++
08:24:05 <gmann_> #action gmann_ to update the meeting things on wifi and ML
08:24:19 <gmann_> #topic Tempest
08:24:28 <gmann_> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
08:24:35 <gmann_> current open reviews ^^
08:25:03 <gmann_> anything on tempest or i would like to jump on open discussion
08:25:52 <masayukig[m]> move to the open discussion?
08:26:00 <gmann_> k
08:26:03 <gmann_> #topic Open Discussion
08:26:14 <gmann_> anything to discus more
08:26:37 <masayukig[m]> nothing from my side
08:26:59 <gmann_> andreaf: ?
08:27:10 <andreaf> https://review.openstack.org/#/q/status:open+topic:multinode_zuulv3 could use some review love :)
08:27:31 <gmann_> andreaf: sure, i will try to do next week.
08:27:44 <gmann_> we are in OPS meetup straight from PTG
08:27:47 <masayukig[m]> same here
08:28:10 <andreaf> ah right cool
08:28:17 <gmann_> #link https://review.openstack.org/#/q/status:open+topic:multinode_zuulv3
08:28:28 <andreaf> gmann_ perhaps you want ask if people is interested in QA SIG?
08:28:39 <gmann_> ah yea
08:29:11 <gmann_> we had discussion on QA tools but did not specify the SIG things
08:29:39 <gmann_> but we are discussing having OPS meetup and PTG together and that will be good for QA SIG  thing also
08:29:55 <gmann_> but that is not decided it is just input from people
08:31:27 <gmann_> anythings else
08:32:38 <andreaf> not from me
08:32:44 <gmann_> let's close then.
08:32:52 <gmann_> masayukig[m]: andreaf thanks for joining
08:33:02 <gmann_> #endmeeting