09:00:49 <gmann> #startmeeting qa
09:00:49 <openstack> Meeting started Thu Jul 12 09:00:49 2018 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:52 <openstack> The meeting name has been set to 'qa'
09:01:01 <gmann> PING LIST- gmann, andreaf, masayukig, chandankumar, felipemonteiro, frickler, mbindlish
09:01:12 <gmann> masayukig: mbindlish_ hi
09:01:13 <masayukig> \o/
09:02:33 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
09:02:36 <gmann> agenda for today ^^
09:03:10 <gmann> let's start
09:03:21 <gmann> Announcement and Action Item (Optional)
09:03:24 <gmann> #topic Announcement and Action Item (Optional)
09:03:37 <gmann> no announcement this week.
09:04:35 <gmann> i have AI i think
09:04:38 <gmann> #link http://eavesdrop.openstack.org/meetings/qa/2018/qa.2018-07-05-09.00.html
09:04:50 <gmann> 1. gmann to track each planned item and send ML for more volunteer etc
09:05:10 <gmann> i did not do that, i will target this again for coming week
09:05:17 <gmann> so repeating the AI again
09:05:22 <gmann> #action gmann to track each planned item and send ML for more volunteer etc
09:05:31 <masayukig> ok, thanks
09:05:40 <gmann> #topic Rocky Priority Items progress
09:06:00 <gmann> #link https://etherpad.openstack.org/p/qa-rocky-priorities-tracking
09:06:36 <gmann> first 2 has no progress on this week so i am skipping those
09:06:39 <gmann> 3. Tempest Items:
09:07:00 <gmann> i remember we merged all the schema gap patches
09:07:27 <gmann> 4. Running patrole on gate- felipemonteiro
09:07:51 <gmann> felipe working on this and i am reviewing the patches. Doc patches going on currently
09:08:24 <gmann> other 2 also no progress
09:08:26 <gmann> 8. Future of OpenStack-Health - masayukig
09:08:37 <gmann> this is merged now - #link https://review.openstack.org/#/c/547866/
09:08:43 <gmann> masayukig: mtreinish thanks
09:09:01 <gmann> masayukig: how it looks now>
09:09:16 <masayukig> yeah, thanks!
09:10:27 <masayukig> gmann: yeah, looks good http://status.openstack.org/openstack-health/#/job/openstack-tox-py35-tricircle
09:10:30 <masayukig> like this
09:11:11 <masayukig> or like this http://status.openstack.org/openstack-health/#/job/tempest-full
09:11:45 <masayukig> "Job Run Time" graph
09:12:16 <gmann> masayukig: -  Unable to load this page! An API error occurred.
09:12:40 <masayukig> gmann: hmm, reload?
09:12:45 <gmann> masayukig: when i change resolution to min or sec, this error comes
09:12:49 <gmann> ok
09:13:25 <masayukig> gmann: ah, I see. it might be a bug
09:13:29 <masayukig> :(
09:13:42 <masayukig> We need to dig it
09:14:03 <gmann> masayukig: with min it worked after reload but with sec resolution it is always error
09:14:18 <masayukig> gmann: yeah
09:14:29 <masayukig> something wrong...
09:15:34 <masayukig> gmann: anyway, go ahead, I'll dig it tomorrow
09:15:34 <gmann> ok
09:15:39 <gmann> thanks
09:16:06 <gmann> overall, i will say slow progress on Rocky items and we have not left much time for Rocky release
09:16:45 <gmann> i will put this on ML and ask for volunteer and before that i will add those items with little background somewhere on doc
09:17:08 <gmann> #topic OpenStack Events Updates and Planning
09:17:46 <gmann> i have created the etherpad for Denver PTG
09:17:52 <gmann> #link  https://etherpad.openstack.org/p/qa-stein-ptg
09:18:17 <gmann> sent ML also for notification
09:18:19 <gmann> #link http://lists.openstack.org/pipermail/openstack-dev/2018-July/132149.html
09:18:52 <gmann> start adding your item you want to discuss in PTG
09:19:16 <masayukig> gmann: ++ thanks
09:19:21 <gmann> we do not have PTG schedule out yet but we have enough space for QA.
09:19:38 <masayukig> yeah
09:20:04 <gmann> 1+3 days i think.
09:20:31 <masayukig> help room & discussion ?
09:20:36 <gmann> yea
09:20:43 <gmann> 1 day help room and 3 days discussion
09:21:27 <gmann> anything else on PTG or we move next
09:22:15 <gmann> #topic Sub Teams highlights (Sub Teams means individual projects under QA program)
09:22:23 <gmann> Tempest
09:22:42 <gmann> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
09:22:53 <gmann> open review for tempest
09:24:16 <gmann> there is bug for force_tenant_isolation tests, which gets failed than skip when there is no admin cred in config and account cred are configured
09:24:50 <gmann> #link https://bugs.launchpad.net/tempest/+bug/1780404
09:24:50 <openstack> Launchpad bug 1780404 in tempest "Tests failing with pre-provisioned admin credentials" [Undecided,In progress] - Assigned to Ghanshyam Mann (ghanshyammann)
09:25:52 <gmann> fix will be to check the  admin cred in config fro force_tenent_isolation in is_admin_available method
09:25:54 <gmann> #link https://review.openstack.org/#/c/580344/
09:26:10 <gmann> it seems failing on tests, i will fix that after meeting.
09:26:50 <masayukig> cool, thanks
09:27:03 <gmann> on same line i will try to review the series of patches which removing the force_tenant_isolation from few tests
09:27:27 <gmann> which is good if those tests really do not need the isolation
09:28:29 <gmann> other things on same line is moving the account cred job to main pipeline which are currently in experimental pipeline
09:28:46 <gmann> frickler: is working on that, he added that patch as critical review also in agenda
09:28:56 <gmann> #link https://review.openstack.org/580364
09:29:45 <gmann> which is good idea so that we can track the account cred working. currently we will add those job as voting only (if i remember correctly ) and once we feel they are stable then make them voting
09:30:01 <gmann> but it seems race happening on swift marker tests.
09:30:23 <gmann> andreaf: was facing the same i feel when he was trying to make this job voting
09:31:25 <gmann> there are open question on patch which i will reply on gerrit.
09:31:42 <gmann> basically we do not need py3 and stable coverage for this job.
09:32:31 <gmann> #link https://bugs.launchpad.net/tempest/+bug/1775553
09:32:31 <openstack> Launchpad bug 1775553 in tempest "tempest.api.object_storage.test_account_services.AccountTest.test_list_containers_with_{end_marker,limit_and_end_marker,marker} tests failure in periodic jobs" [Undecided,New] - Assigned to Manik Bindlish (manikbindlish)
09:32:41 <gmann> this is bug
09:33:18 <gmann> mbindlish_: seems assigned to you, any update you found on this ?
09:33:50 <mbindlish_> @gmann , not started working yet on it, i was working on different tempest issues
09:35:06 <gmann> mbindlish_: ok, may be you can unassign till you start this.
09:35:19 <mbindlish_> @gmann ok
09:35:21 <gmann> i did not check this yet. will try for tomororw
09:35:24 <gmann> tomorrow
09:35:35 <gmann> anything else on tempest side ?
09:36:45 <mbindlish_> @gmann Have you got some conclusion pointer over " https://bugs.launchpad.net/tempest/+bug/1778003" ?
09:36:45 <openstack> Launchpad bug 1778003 in tempest "Config item 'create_isolated_networks' can't work for some test cases" [Undecided,New] - Assigned to Manik Bindlish (manikbindlish)
09:37:02 <gmann> ah forgot about that
09:37:12 <gmann> what is issue on this?
09:38:19 <mbindlish_> create_isolated_networks when set to false, it still created isolated network
09:39:00 <gmann> i see and there was another config options to allow isolation
09:39:34 <mbindlish_> i think it has some dependency over shared_physical_network
09:39:53 <gmann> i think that was introduced for ironic tests but i need to dig into both config
09:40:17 <gmann> i will check and reply on bug during next week some time
09:40:49 <gmann> let's move next
09:40:54 <gmann> #topic Patrole
09:41:17 <gmann> this we already covered for stable release target
09:41:43 <gmann> anything else on subteam topic ?
09:42:00 <masayukig> nope
09:42:07 <gmann> #topic Bug Triage
09:42:33 <gmann> we do not have updated link for this.
09:42:41 <gmann> and seems lot of new bugs.
09:43:17 <gmann> today i am not in condition of triaging the bug here as my mind is almost done for week.
09:43:54 <gmann> next week i can target more. or if chandan come back
09:44:16 <tosky> chkumar|ruck: ^
09:44:29 <gmann> tosky: thanks :)
09:44:39 <masayukig> gmann: yea
09:44:50 <gmann> mbindlish_: you want to discuss anything on bug?
09:44:58 <chkumar|ruck> gmann: tosky sure, Till this week I am on rucking on tripleo CI
09:45:17 <gmann> here he is :)
09:45:24 <mbindlish_> @gmann i have confusion on that bug only
09:45:48 <gmann> mbindlish_: ok. i will reply on that next week.
09:46:02 <mbindlish_> on some of bugs waiting for queries ans from reporter of bug
09:46:04 <mbindlish_> ok sir
09:46:07 <chkumar|ruck> gmann: masayukig http://logs.openstack.org/80/581180/1/check/tripleo-ci-centos-7-scenario002-multinode-oooq-container/6c5be42/logs/tempest.html.gz
09:46:28 <chkumar|ruck> we are hitting this issue few times in tripleo ci
09:46:33 <chkumar|ruck> sometimes it comes and vanished
09:47:20 <gmann> humm
09:47:25 <chkumar|ruck> from tempest.log I found this http://logs.openstack.org/80/581180/1/check/tripleo-ci-centos-7-scenario002-multinode-oooq-container/6c5be42/logs/undercloud/var/log/containers/tempest/tempest.log.txt.gz#_2018-07-11_11_55_40_505
09:48:16 <gmann> 412
09:48:25 <chkumar|ruck> Here is the temepst.conf http://logs.openstack.org/80/581180/1/check/tripleo-ci-centos-7-scenario002-multinode-oooq-container/6c5be42/logs/undercloud/home/zuul/tempest/etc/tempest.conf.txt.gz
09:48:33 <gmann> did you check swift log?
09:48:44 <chkumar|ruck> gmann: there is nothign in swift logs
09:49:10 <chkumar|ruck> gmann: http://logs.openstack.org/80/581180/1/check/tripleo-ci-centos-7-scenario002-multinode-oooq-container/6c5be42/logs/subnode-2/var/log/swift/
09:49:25 <chkumar|ruck> it is empty, may be they were dumping the logs somewhere else
09:50:02 <gmann> yea i cannot find swift log file
09:50:49 <chkumar|ruck> gmann: I have asked for more info, apart from swift log file and anythign I need to look?
09:51:12 <gmann> i think swift log can tell why returning 412 to tempest.
09:51:21 <gmann> first time i am seeing 412 though
09:51:58 <gmann> ask swift logs from author and we can debug if any issue on tempest side
09:52:04 <chkumar|ruck> http://zuul.openstack.org/builds.html?job_name=tripleo-ci-centos-7-scenario002-multinode-oooq-container
09:52:42 <chkumar|ruck> all failed one are hitting, it is also seen in puppet-openstack-intregration scenario2 jobs sometime as mwhahaha said
09:52:45 <chkumar|ruck> gmann: sure
09:53:31 <gmann> ok, let's wait for swift logs
09:54:14 <gmann> though that CI still using api_extensions for compute ? it is no more nova honor and i am merging the code also in rocky :)
09:54:27 <gmann> anyways that different issue
09:55:23 <gmann> 5 min left let's move to open
09:55:26 <gmann> #topic Open Discussion
09:55:47 <gmann> critical review we already covered, i will reply on patch
09:56:18 <gmann> anything else to discuss from anyone
09:57:03 * gmann chkumar|ruck config remind me to configure devstack for api_extensions. TODO for tomorrow
09:57:08 <tosky> not to discuss, just a plea: masayukig already commented, but please take a look at this patch by chkumar|ruck and felipemonteiro for storyboard-based skip decorator: https://review.openstack.org/#/c/540852/
09:57:35 <gmann> tosky: sure, i need to re-review it.
09:57:43 <tosky> oki, thanks
09:57:51 <gmann> thanks for reminder.
09:58:20 <masayukig> tosky: thanks, I will do it  again
09:58:30 <gmann> any other review to bring up?
09:59:15 <gmann> ok, if nothing else then let's close it.
09:59:20 <gmann> thanks all for joining
09:59:24 <gmann> #endmeeting