13:30:37 <gmann> #startmeeting qa
13:30:38 <openstack> Meeting started Tue Jan  7 13:30:37 2020 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:30:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:30:41 <openstack> The meeting name has been set to 'qa'
13:30:47 <gmann> who all here today ?
13:31:11 <soniya29> gmann: I am there
13:33:09 <gmann> ok, let's start
13:33:26 <kopecmartin> hi
13:33:30 <soniya29> gmann: sure
13:33:31 <gmann> this is the agenda
13:33:33 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
13:34:10 <gmann> #topic Announcement and Action Item (Optional)
13:34:29 <gmann> one announcement is this new time for office hour.
13:35:09 <gmann> no action items from last meeting
13:35:15 <gmann> moving t next topic
13:35:17 <gmann> #topic Ussuri Priority Items progress
13:35:29 <gmann> #link https://etherpad.openstack.org/p/qa-ussuri-priority
13:35:54 <gmann> this is the etherpad we prepared during PTG and will be used to track the priority items for ussuri.
13:36:24 <tosky> hi
13:36:35 <gmann> this can be extended as we progress on cycle. so feel free to add the items you are working on and think good to report the progress or discuss in office hour
13:37:27 <gmann> we will quickly go through the updated on each items.
13:37:30 <gmann> 1. Remove/migrate the .testr.conf to .stestr - masayuki
13:37:44 <gmann> masayukig: ^^
13:37:56 <gmann> its little late for him not sure he is available
13:39:11 <gmann> 2. RBAC testing strategy (reader/member/admin X project/domain/system)
13:39:27 <gmann> i have not reviewed the new stack. i am adding that for today.
13:39:49 <gmann> 3. py2.7 drop plan for QA - gmann
13:40:18 <gmann> this is not started. plan is to drop the py2.7 support during end of the m-2 sometime in early feb.
13:41:40 <gmann> only thing we need to take care is we keep running the  py2 jobs on stable branches and py3-only on master. that might need few adjustment in job definition or just remove the job from pipeline from master tempest gate.
13:41:59 <gmann> i will give thought on that and same we need to do for all tempest plugins also.
13:42:15 <gmann> next is - Adding New glance tests to tempest - gmann/Abhishek
13:42:57 <gmann> i have not heard much on this from abhishek. this is to help glance team to add the tests and jobs for new features
13:44:08 <gmann> - new whitebox plugin for tempest- i have not reviewed this spec which should be done by now. if you are around, please review this one - https://review.opendev.org/#/c/656890/
13:44:20 <gmann> - Improving Tempest cleanup: mkopec/chandan
13:44:22 <gmann> kopecmartin: ^^
13:44:34 <kopecmartin> yeah, regarding the cleanup imporovementes
13:45:07 <kopecmartin> most of the patches were already merged, there's just one last one which will allow us to test it in other gate jobs even outside tempest project
13:45:14 <kopecmartin> #link https://review.opendev.org/#/c/698610/ so when free, please have a look
13:45:51 <kopecmartin> regards other improvements, we'll see when the cleanup will be executed in other jobs or so, i'm sure something will come up :)
13:47:12 <kopecmartin> that's all from my side speaking about tempest cleanup improvements at the moment
13:47:21 <gmann> kopecmartin: ok. I did check that quickly but reviewed that.
13:48:01 <gmann> kopecmartin: we were lacking of unit tests for Tempest CLI and improved a lot during past cycles. but do you think we have enough testing for cleanup CLI ?
13:48:55 <kopecmartin> unit testing? yes, functional testing? no but that's in progress started by the review above .. it's a start
13:49:03 <gmann> yeah unit tests
13:49:32 <kopecmartin> i think unit testing in cleanup is solid .. I'll check the coverage after the meeting to get exact numbers
13:49:51 <gmann> cool thanks. I will add action item for that
13:50:06 <gmann> #action kopecmartin need to check and report the unit test coverage for cleanup CLI.
13:50:15 <gmann> thanks kopecmartin for working on that.
13:50:50 <gmann> next item is  - 'Bug triage status report before office hour'
13:50:59 <gmann> we do not have assignee for this yet.
13:51:36 <kopecmartin> i think me and soniya29 could have a look on that before meetings
13:51:58 <kopecmartin> what exactly would be expected from us?
13:52:02 <soniya29> gmann: kopecmartin, sure
13:53:26 <gmann> kopecmartin: soniya29 thanks. we need to report the bug triage/newbugs/critical bugs to discuss etc. we have etherpad for that which i can check and let you guys know what exactly tobe done
13:54:00 <kopecmartin> gmann: great, that would be great .. maybe put a link to the wiki if it's not already there
13:54:12 <gmann> basically triage the new bugs and discuss in office hour if something we all needs to.
13:54:31 <gmann> sure. I will prepare that and let you guys know
13:54:40 <kopecmartin> gmann: thank you
13:55:01 <soniya29> gmann: thanks
13:55:09 <gmann> moving next
13:55:11 <gmann> #topic OpenStack Events Updates and Planning
13:55:35 <gmann> - Shanghai Summit & PTG
13:55:54 <gmann> we already finished this and I summarized it on ML too
13:56:25 <gmann> I will remove this from agenda and next event will be open infra summit in vancouver in june which is little far
13:56:42 <gmann> #topic Sub Teams highlights (Sub Teams means individual projects under QA program)
13:56:44 <gmann> Tempest
13:56:56 <gmann> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
13:57:05 <gmann> open reviews for Tempest ^^
13:57:56 <gmann> anything to discuss for Tempest ?
13:58:16 <kopecmartin> gmann: yes, i'd like to bring this review to the attention #link https://review.opendev.org/#/c/692375/
13:59:01 <gmann> yeah, i have that in my list. Let's see if i can review that today during the cricket game :)
13:59:16 <kopecmartin> gmann: thank you!
13:59:28 <gmann> Next is Patrole:
14:00:10 <gmann> Rick is fixing the gate failure  - #link https://review.opendev.org/#/c/700949/
14:00:28 <gmann> which occurred due to my change on nova policy.
14:00:51 <gmann> admin policies is fixed but somehow stable/queens job is failing.
14:01:08 <gmann> other reviews are done/replied for patrole.
14:01:30 <gmann> that's all on Patrole
14:02:06 <gmann> I am adding grenade next to discuss especially for zuulv3 job
14:02:40 <gmann> tosky: as we discussed, what time you think is good to hack on those grenade base job review/discussions
14:03:36 <gmann> I would like to do that with infra/zuul team so that we can merge the base job soon and ready for projects
14:04:28 <gmann> I will catch him later.
14:04:31 <gmann> moving next
14:04:34 <gmann> #topic Bug Triage
14:04:47 <gmann> this we already discussed.
14:04:56 <gmann> #topic Critical Reviews
14:05:09 <gmann> any critical review other than what we already discussed ?
14:05:50 <kopecmartin> gmann: soniya29 has a few deprecation reviews (old cli deprecation)
14:06:11 <gmann> yeah
14:06:11 <gmann> #topic Open Discussion
14:06:13 <soniya29> gmann: yeah, I would like bring those to attention
14:06:20 <gmann> go ahead
14:06:41 <kopecmartin> soniya29: sure, i'll review after the meeting ( if i haven't already)
14:06:41 <soniya29> 1. https://review.opendev.org/#/c/699160/
14:06:56 <soniya29> 2. https://review.opendev.org/#/c/700516/
14:07:06 <soniya29> 3. https://review.opendev.org/#/c/700514/
14:07:34 <soniya29> gmann: you have reviewed them.
14:07:48 <gmann> soniya29: yeah, second one need reno otherwise lgtm
14:07:57 <gmann> i can re-review those which will be quick.
14:08:09 <tosky> gmann: sorry, double booking today
14:08:15 <tosky> the grenade patches were ready for review for a long time, at least about the general structure, with the exception of some issues with the heat multinode job
14:08:20 <tosky> after the recent changes (py3 and so on) I had to refresh them and before the holidays the base patch is working, but not the ones which use the plugins, so I guess more work is needed
14:08:24 <tosky> That said, if you notice anything weird with the general structure/idea (there was a comment from Sean, for example), they are welcome
14:08:38 <tosky> next week I will recheck the failures for the jobs which use the plugins
14:08:56 <soniya29> gmann: Okay, I will add the reno to the second one
14:09:12 <gmann> tosky: nice, thanks. those are separate patch or in single ?
14:09:16 <gmann> soniya29: thanks.
14:09:23 <tosky> gmann: separate patches, same topic
14:10:38 <gmann> tosky: ok, I will check on those. do you think we need a dedicated time/meeting for those or just review as those are working fine?
14:10:47 <gmann> soniya29: anything else ?
14:11:26 <tosky> gmann: as you prefer, really; after checking them, if you think there are more issues to discuss, we can definitely set up a meeting
14:11:41 <tosky> it may be useful if you want to involve other people
14:12:03 <soniya29> gmann: How can I improve this patch:-https://review.opendev.org/#/c/696068/?
14:12:03 <gmann> yeah. let me check.
14:12:40 <soniya29> gmann: kopecmartin, Can you have a look over the above patch?
14:12:54 <gmann> tosky: thanks again for working on those. btw i commented on your zuulv3 migration goal patch also and grenade base job thing also.
14:13:35 <kopecmartin> soniya29: gmann as tosky brought up , the question there is if it's worth to bump stestr version because of a flag which is mentioned in a doc
14:14:01 <tosky> gmann: uh, something I haven't addressed yet on both patches?
14:14:40 <gmann> tosky: np!, just to notify you. i agree with you on greande job things.
14:15:20 <tosky> oh, old comments from last year then; I was wondering if there was something new :)
14:15:38 <gmann> kopecmartin: soniya29 yeah. we need to bump the min version for that as tosky mentioned.
14:15:39 <tosky> (or better, if it was about something new)
14:16:02 <gmann> i will check that patch soniya29 and comment.
14:16:25 <gmann> tosky: i will ping that on tc channel also to move that patch fast and goal ready for v cycle
14:16:49 <gmann> kopecmartin: your both review listed in agenda already discussed i think.
14:17:01 <kopecmartin> gmann: yes
14:17:15 <soniya29> gmann: Okay
14:18:01 <gmann> one thing i forgot to add in agenda and we discussed in PTG is- to track the community goal during office hour like slaweq does for neutron. that will be really helpful for us.
14:18:19 <gmann> I will add that in agenda next time with assignee and report.
14:18:35 <gmann> #action gmann to add the community goal tracking for QA in office hour agenda.
14:18:35 <slaweq> gmann: hi, HNY :)
14:18:50 <slaweq> sorry, You have meeting now, I will ping You later :)
14:19:01 <gmann> slaweq: i really liked the way neutron track those.
14:19:13 <slaweq> gmann: thx, it was mlavalle's idea
14:19:19 <slaweq> I just continue it now
14:19:20 <gmann> we are almost done
14:19:23 <gmann> great.
14:19:35 <gmann> anything else to discuss before we close it ?
14:20:29 <gmann> ok, let's close the office hour. thanks all for joining.
14:20:34 <gmann> #endmeeting