13:31:09 <gmann> #startmeeting qa
13:31:10 <openstack> Meeting started Tue Jan 21 13:31:09 2020 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:31:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:31:13 <openstack> The meeting name has been set to 'qa'
13:31:21 <gmann> who all here today
13:31:34 <soniya29> gmann: Hi
13:31:39 <kopecmartin> hi
13:31:50 <tosky> hi
13:32:01 <rh-jelabarre> hello
13:32:23 <bigdogstl> hi
13:32:50 <gmann> let's start
13:33:03 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
13:33:08 <gmann> ^^ agenda for today
13:33:21 <gmann> #topic Announcement and Action Item (Optional)
13:34:16 <gmann> only action from previous meeting is - gmann to add the community goal tracking for QA in office hour agenda.
13:34:25 * masayukig is read only mode. sorry...
13:34:41 <gmann> I have not finished that. created bug triage etherpad but forgot about this.
13:34:47 <gmann> I am re-adding this as AI
13:35:08 <gmann> #action gmann to add the community goal tracking for QA in office hour agenda.
13:35:20 <gmann> #topic Ussuri Priority Items progress
13:35:34 <gmann> #link https://etherpad.openstack.org/p/qa-ussuri-priority
13:35:53 <gmann> Remove/migrate the .testr.conf to .stestr - masayukig
13:36:08 <gmann> there is no progress than previously discussed i think
13:36:19 <gmann> - Moving subunit2html script from os-testr to tempest or stestr or python-subunit project
13:36:30 <gmann> this is no action so i am marking the same on ethgerpad
13:37:10 <gmann> i am jumping to py2 drop one as other has no progress to report
13:37:12 <gmann> - py2.7 drop plan for QA
13:37:58 <gmann> This is in progress and as other project/ lib droppping the py2 support, stable branch testing failing for queens and rocky.
13:38:51 <gmann> I am doing the Tempest release for last version to support py2 and then I will start the work for py2 drop
13:39:22 <gmann> - Improving Tempest cleanup
13:39:25 <gmann> kopecmartin: ^^
13:39:44 <kopecmartin> unfortunately i don't have any updates since last meeting
13:40:29 <gmann> ok. i still need to review your cleanup CLI on job patch.
13:40:48 <gmann> - Bug triage status report before office hour
13:40:58 <gmann> I created the etherpad for this
13:41:04 <gmann> #link https://etherpad.openstack.org/p/qa-bug-triage-ussuri
13:41:27 <gmann> number are not actual number just to show how we need to report the bugs triage
13:41:46 <gmann> i added the link also on how to triage
13:42:00 <gmann> and a section to add the bug links which need discussions in office hour
13:42:20 <gmann> we will do weekly triage and report the same to office hour.
13:42:33 <gmann> as of now kopecmartin and soniya29 volunteer to start it.
13:42:53 <gmann> even you are not available for offiice hour, you can update the etherpad and drop a msg to me about it.
13:43:15 <gmann> any question on this ?
13:43:59 <gmann> kopecmartin: soniya29 from you ?
13:44:14 <soniya29> No
13:44:17 <kopecmartin> gmann: no, we'll start triaging and share the status next week
13:44:36 <gmann> coool, thanks. you can always ping us for any query.
13:44:46 <gmann> #topic OpenStack Events Updates and Planning
13:45:08 <gmann> no recent event as of now. Planning is not started yet.
13:45:21 <gmann> #topic Sub Teams highlights (Sub Teams means individual projects under QA program)
13:45:25 <gmann> Tempest
13:45:42 <gmann> we are facing two issue for stable testing.
13:46:24 <gmann> one is for py2 drop from lib and Temepst running on <3.6 env fail which is queens and rocky.
13:46:55 <gmann> I am trying to install py3.6 on xenial node and see if that works fine or not
13:47:31 <gmann> #link https://review.opendev.org/#/c/703476/
13:47:52 <gmann> which need to define the py3 env for tox env
13:47:54 <gmann> #link https://review.opendev.org/#/c/703011/
13:48:11 <gmann> I have started the discussion in ML also
13:48:17 <tosky> gmann: do you think that trying to use py35 would be problematic?
13:48:41 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-January/012038.html
13:49:01 <gmann> tosky: lib dropping py2 making require python as 3.6
13:49:06 <gmann> neutron-lib is first example
13:49:30 <gmann> https://github.com/openstack/neutron-lib/blob/1d9d6d7bf5095efe96191741a93f37446ca4d1a4/setup.cfg#L9
13:49:31 <tosky> I see
13:50:04 <gmann> if that does not work well then pinning the Tempest and plugins with py2-compatible version is second option
13:50:28 <gmann> It is mainly for rocky only as queens is EM and I will pin Tempest there soon.
13:50:52 <gmann> #link https://bugs.launchpad.net/neutron/+bug/1860033
13:50:52 <openstack> Launchpad bug 1860033 in tempest "Tempest jobs broken on stable branches due to requirements neutron-lib upgrade (the EOLing python2 drama)" [Critical,In progress] - Assigned to Ghanshyam Mann (ghanshyammann)
13:50:55 <gmann> this is first bug
13:51:39 <gmann> second is about queens branch not able to run Tempest, neutron-tempest-plugin master
13:51:43 <gmann> #link https://bugs.launchpad.net/devstack/+bug/1859988
13:51:43 <openstack> Launchpad bug 1859988 in neutron "neutron-tempest-plugin tests fail for stable/queens" [Critical,In progress] - Assigned to Bernard Cafarelli (bcafarel)
13:52:10 <gmann> if Temepst master failure is valid on queens then it is time to pin the Tempest and plugins there.
13:52:26 <yoctozepto> o/
13:52:27 <gmann> i asked about in-compatible change info on bug
13:53:04 <gmann> currently neutron-tempest-plugin is pinning the Tempest and plugin version via zuul job
13:53:28 <gmann> but to solve the issue for all other plugins and jobs, we need to do it on devstack stable/queens
13:54:04 <gmann> for that I am releasing the Tempest for End of support for Queens so that we can drop queens job from master and pin Tempest for stable/queens
13:54:20 <gmann> #link https://review.opendev.org/#/c/703521/
13:54:55 <gmann> I will keep posting the updates on ML.
13:55:19 <gmann> anything else on Tempest side ?
13:56:16 <gmann> next is Patrole
13:56:20 <chandankumar> gmann, on TripleO CI side, we have pinned tempest version
13:56:41 <gmann> chandankumar: ok. so we are good to drop py2 from Temepst ?
13:56:55 <chandankumar> is it to move to 23.0.0 tag ? or we first test it and report it works fine
13:57:13 <gmann> chandankumar: if most recent py2 compatible tag you need, this is one https://review.opendev.org/#/c/703521/
13:57:40 <gmann> chandankumar: yeah, last tag guaranteed to work will be 23.0.0
13:58:05 <gmann> we have not done any changes to drop py2 on tempest side yet.
13:58:23 <chandankumar> gmann, ok, then I will try to update the version and get back the results
13:58:34 <chandankumar> once new tag gets available
13:58:35 <gmann> chandankumar: thanks.
13:58:54 <gmann> moving next, Patrole
13:59:11 <gmann> I am release patrole also to drop queens support #link https://review.opendev.org/#/c/703523/
14:00:10 <gmann> patrole gate is up. and pending few patches from Rick on soe resource leakage etc.
14:00:28 <gmann> that's it from my side on Patrole. anything else ?
14:00:29 <bigdogstl> Rick is working them but is OOO today
14:01:03 <gmann> ok
14:01:24 <gmann> once we fix these stable branch things, I will reply on his comments
14:01:36 <gmann> i remember, two patches i have on my side
14:02:11 <gmann> Any other (active sub team will add their status reporting here)
14:02:30 <gmann> one things on devstack.
14:03:22 <gmann> we had nova gate blocked for ~2 days due to nova-live-migration job failure due to g-reg changes on devstack. which is reverted and gate is up now.
14:03:39 <gmann> re-revert of those fixes is in progress
14:04:02 <gmann> anything else from anyone ?
14:04:40 <bigdogstl> I Have a general question for the end of the meeting
14:04:41 <gmann> #topic Bug Triage
14:04:46 <bigdogstl> ok
14:04:59 <gmann> bigdogstl: sure, we will discuss on open discussion
14:05:12 <gmann> we already talked about bug triage
14:05:14 <gmann> #link https://etherpad.openstack.org/p/qa-bug-triage-ussuri
14:05:24 <gmann> from next week we will get actual number and bugs to discuss.
14:05:37 <gmann> #topic Critical Reviews
14:06:06 <gmann> anyone has any critical review other than we already discussed ?
14:06:44 <kopecmartin> gmann: i implement your suggestions here: https://review.opendev.org/#/c/692375/
14:06:52 <kopecmartin> *implemented
14:07:23 <tosky> not critical as blocker, but there is this new test: https://review.opendev.org/#/c/695967/
14:07:27 <frickler> https://review.opendev.org/688614 [dnm] testing centos-8 bringup
14:07:31 <gmann> kopecmartin: thanks, i will check.
14:07:47 <tosky> and also https://review.opendev.org/#/c/698598/
14:07:51 <frickler> if we don't get devstack running on centos8 by rc1, I guess we need to drop it as platform for ussuri
14:07:56 <gmann> frickler:  nice thanks.
14:08:16 <frickler> 561597 Revert "Do not use pip 10 or higher"
14:08:26 <frickler> we should get that merged before rc1, too
14:08:31 <tosky> and an subunit2html fix: https://review.opendev.org/#/c/700778/
14:08:33 <gmann> tosky: yeah, i will check those later
14:09:00 <gmann> frickler: ah, that is not merged? linkl
14:10:38 <gmann> got it. https://review.opendev.org/#/c/561597/
14:10:44 <gmann> i will check right after meeting
14:11:05 <gmann> frickler: i have few of them for you. first 3 for pike https://review.opendev.org/#/q/status:open+project:openstack/devstack+branch:stable/pike
14:11:28 <gmann> frickler: and first 2 from queens - https://review.opendev.org/#/q/status:open+project:openstack/devstack+branch:stable/queens
14:11:53 <gmann> let's move
14:11:56 <gmann> #topic Open Discussion
14:12:05 <gmann> bigdogstl: go ahead
14:12:10 <bigdogstl> When you do a "stestr run --subunit"
14:13:16 <lyarwood> https://review.opendev.org/#/q/topic:negative_multiattach_swap_volume_tests - is ready for wider core review if anyone has time this week btw
14:14:11 <gmann> bigdogstl: as i remember that is for exit code
14:14:33 <gmann> lyarwood: yeah, afazekas masayukig once you are online - https://review.opendev.org/#/q/topic:negative_multiattach_swap_volume_tests
14:15:22 <bigdogstl> it is a event for logging in tempest the file_name is pythonlogging and for the other test case we are using it is stdout and I cannot find out why
14:15:45 <bigdogstl> it is a unittest testtool and subunit relationship
14:16:01 <bigdogstl> any mail list suggestion to ask the question on?
14:16:23 <gmann> bigdogstl: yeah, that will be good. I do not know the complete answer for that
14:16:54 <bigdogstl> I try the openstack maillist thanks
14:17:03 <bigdogstl> gmann thanks
14:17:04 <gmann> i am not sure if that control the logging things
14:17:16 <bigdogstl> yup
14:17:36 <bigdogstl> it also involves oslo.config and osl.log
14:17:56 <gmann> yeah
14:18:04 <bigdogstl> Thanks I send the emai
14:18:10 <gmann> ok
14:18:11 <gmann> anything else from anyone ?
14:18:43 <tosky> just a quick update on grenade before closing: after some discussions, it seems the failures come from the py2 version of "openstack <foo>"
14:19:14 <tosky> and it seems that there something that affects only train/py3 (which is the source point of upgrades right now)
14:19:17 <gmann> tosky:  "openstack <foo>" ?
14:19:21 <tosky> as it tries to install both versions
14:19:29 <gmann> ohk.
14:19:43 <gmann> yeah. many pkg we can see are installed on py2 also on py3 jobs
14:20:06 <gmann> tosky: mainly it was due to openstack client ?
14:20:08 <tosky> basically grenade jobs which use a plugin try to create some resources, and they do that by "openstack <something>" (openstack dataprocessing for sahara, etc)
14:20:28 <tosky> despite the fact that python-saharaclient is installed, "openstack dataprocessing" is not found (same for heat)
14:20:54 <gmann> python-saharaclient is installed on py3 ?
14:20:54 <tosky> so my guess is that the py2 version of python-openstackclient is used for the "openstack" executable
14:21:05 <tosky> according the logs, it is
14:22:10 <gmann> but can we completely  stop  python-openstackclient to be installed on py2 ? not sure if swift need that
14:22:54 <tosky> uhm
14:23:20 <tosky> maybe we just need to make sure that, if both versions are installed, the openstack entry point is provided by the py3 version
14:23:27 <tosky> do you know if it's a matter of installation ordering?
14:23:46 <tosky> or whether it can be changed after the installation without removing and reinstalling?
14:23:50 <frickler> iirc first installation wins, yes
14:24:17 <gmann> but is devstack or greande installing it on py2 ?
14:24:48 <tosky> good question; I think devstack
14:25:22 <tosky> sean-k-mooney pointed out some code which was later removed from devstack
14:25:56 <tosky> but uhm, I'm not sure then; the py3 version should be installed first
14:25:58 * tosky confused
14:26:53 <gmann> same here. I am not sure why py2 will be first and used.
14:27:42 <gmann> ok, let's check on review if anyone find out.
14:28:03 <gmann> anything else before we close office hour.
14:28:24 <gmann> thanks everyone for joining.
14:28:25 <soniya29> gmann, Can you have a look over this patch:- https://review.opendev.org/#/c/702808/
14:28:43 <gmann> soniya29: sure. added in list
14:28:46 <gmann> #endmeeting