13:30:41 <gmann> #startmeeting qa
13:30:42 <openstack> Meeting started Tue Feb 11 13:30:41 2020 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:30:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:30:46 <openstack> The meeting name has been set to 'qa'
13:30:52 <gmann> who all here today
13:30:59 <kopecmartin> hi
13:31:02 <soniya29> Hello
13:31:07 <bigdogstl> hi
13:32:20 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting
13:32:32 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
13:32:34 <gmann> today agenda ^^
13:32:47 <gmann> #topic Announcement and Action Item (Optional)
13:33:20 <gmann> no action item from  previous meeting
13:33:42 <gmann> #topic Ussuri Priority Items progress
13:33:57 <gmann> #link https://etherpad.openstack.org/p/qa-ussuri-priority
13:34:44 <gmann> I am jumping to py things as other do not have much progress
13:34:46 <gmann> - py2.7 drop plan for QA
13:35:18 <gmann> this is in-progress work and fixing stable testing for this. we will talk more on those in later section
13:35:58 <gmann> other part to share is about scenario manager.
13:36:05 <arxcruz> o/
13:36:19 <gmann> kopecmartin has created a etherpad to start this work #link https://etherpad.openstack.org/p/tempest-scenario-manager
13:36:39 <gmann> i have not got chance to review/add things in this. I will be doing right after meeting.
13:37:15 <gmann> anything else on ussuri priority ?
13:37:48 <gmann> #topic OpenStack Events Updates and Planning
13:38:39 <gmann> we have to  give number for QA attendance in Vancouver PTG. I need to start the etherpad and collect possible number of attendees.
13:38:55 <gmann> #action gmann to start the planning for Vancouver PTG.
13:39:17 <gmann> #topic Sub Teams highlights (Sub Teams means individual projects under QA program)
13:40:27 <gmann> before jumping to each project status, I would like to update the fixes we did last week for py2 drop in multiple projects for stable testing.
13:40:29 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-February/012462.html
13:41:13 <gmann> i summarized/updated the bugs in above ML. stable branch testing for Tempest installing with stable u-c are green now.
13:41:54 <gmann> and another bug of using 'all-plugin' for tempest run has been fixed for designate and if any other project facing the same issue they can fix it in similar way.
13:42:20 <gmann> Tempest
13:43:15 <gmann> In Tempest we have moved the tox env default basepython to py3. Now i will rebase my dropping py2 patch. that will reduce huge number of jobs on master gate.
13:43:24 <gmann> #link https://review.opendev.org/#/q/project:openstack/tempest+status:open
13:43:28 <gmann> these are open reviews.
13:43:45 <gmann> any special things to discuss on Tempest, any bug you are aware of etc ?
13:44:15 <kopecmartin> I put all interesting bugs to triage etherpad
13:44:27 <gmann> kopecmartin: thanks.
13:44:31 <gmann> Patrole
13:44:38 <gmann> anything on patrole ?
13:45:20 <gmann> any other project updates ?
13:45:34 <tosky> devstack: there was an issue reported between devstack and ironic-tempest-plugin reported earlier by dtantsur|brb; stephenfin and yoctozepto may know a bit more
13:45:43 <tosky> grenade: reviews are ready
13:45:54 <gmann> ohk, i need to check the logss
13:46:23 <gmann> tosky: thanks. i did not get chance to review grenade due to those py2 thongs. I will be doing those in this week for sure.
13:46:52 * yoctozepto feels mentions but will read later (very busy)
13:47:04 <tosky> gmann: np, there have been many fires in the last week
13:47:11 <gmann> yeah
13:47:47 <gmann> let's move next
13:47:49 <gmann> #topic Community goal tracking
13:48:08 <gmann> #link https://etherpad.openstack.org/p/qa-community-wide-goals-tracking
13:48:17 <gmann> 1. Drop Python 2.7 Support
13:48:55 <gmann> this is ongoing work and we have patches up for review. I will be merging those soon and do release before m-2 on 13th Feb.
13:49:04 <gmann> 2. Project Specific PTL and Contributor Documentation
13:50:07 <gmann> this is not started, we talked about on tc channel last week about what exactly to do. there will be update on goal doc for that regarding keeping CONTRIBUTING.rst and new doc/source/contributing.rst
13:50:36 <gmann> #topic Bug Triage
13:50:44 <tosky> yep, better avoid duplication (re CONTRIBUTING)
13:50:53 <gmann> true
13:51:20 <kopecmartin> triaging, the numbers are still going down as can be seen in the etherpad, which is great
13:51:22 <kopecmartin> # link https://etherpad.openstack.org/p/qa-bug-triage-ussuri
13:51:30 <gmann> one things i would like mention again. if you see any py2 related bug, keep reporting and fixing. we have to keep gate as stable as possible for this work
13:51:34 <gmann> kopecmartin: yeah, go ahead
13:52:02 <kopecmartin> i would like to mention, that we have a lot of reviews which seem to be ready for final review
13:52:26 <kopecmartin> so I put bugs which are about to be fixed and all reviews i find ready for a core review to the ethepad
13:53:16 <gmann> kopecmartin: thanks.
13:53:26 <kopecmartin> i'd like to suggest, that I'll keep filtering the reveiws and bugs and put the almost ready one to the etherpad and i'd like to ask cores to go through the etherpad from time to time
13:53:27 <tosky> kopecmartin: I think there was an extra space between "#" and "link" in your link earlier, so it was not highlighted in the logs
13:53:46 <kopecmartin> #link https://etherpad.openstack.org/p/qa-bug-triage-ussuri
13:53:48 <kopecmartin> my bad :)
13:53:58 <gmann> kopecmartin: yeah, very less core are active but this will help us
13:54:25 <gmann> kopecmartin: one question, 34->28  in NEW. does this triage all bugs or include invalid also ?
13:54:43 <dulek> gmann: Hello! I'm figuring out problems on this thing: https://review.opendev.org/#/c/682531/. Is devstack-ipv6 job having just ipv6 ifaces on the nodepool VM?
13:55:21 <kopecmartin> gmann: i put there links only to triaged  under 'Bugs with patches' section
13:55:54 <gmann> kopecmartin: means? those number reduce is you raised the fixes for those ?
13:56:12 <gmann> i would like to know the category of those reduce which is great
13:57:18 <gmann> dulek: it does ipv6 iface like any other testing VM and this job just enable the services listen on IPv6.
13:57:32 <kopecmartin> gmann: oh, you mean this, the numbers are current ones, meaning what launchpad currently shows .. those bugs or reviews I put there explicitly are related to bugs in In Progress state no New
13:58:03 <dulek> gmann: Oh, probably DNS (unbound?) too? Seems like Docker is unable to connect, probably because it has no IPv6 iface.
13:58:36 <gmann> kopecmartin: yeah that i got, I mean 34->28 on new bugs, did you traige those 8 bugs or few of them are invalid also
13:59:04 <gmann> dulek: that might be possible, monasca faces same issue for kafka not able to listen on ipv6
13:59:37 <kopecmartin> gmann:  I triaged them, either put to Confirmed or Invalid state .. or proposed a change to fix it
14:00:06 <dulek> gmann: Cool, in our case it shouldn't be impossible to solve, so I'll take a look.
14:00:28 <gmann> kopecmartin: great.  this is really great reduction in # of NEW bug and if with this rate we will make it in single digit or 0 soon.
14:01:12 <gmann> dulek: i see. may be we can do it once  docker is ready because 3rd party we can do much
14:01:38 <gmann> kopecmartin: let's move to individual bugs you would like to discuss
14:02:28 <gmann> i did not find any on etherpad except review request.
14:02:36 <kopecmartin> gmann: i have one python-stestr bug: https://review.opendev.org/#/c/700778/ for exmaple
14:03:12 <gmann> ok.
14:03:29 <kopecmartin> gmann: i think right now only reviews are needed, i don't have prepared any bug which I'd like to discuss atm
14:03:53 <gmann> kopecmartin: ok, i will try to review those before next meeting and add status on etherpad.
14:04:14 <gmann> thanks for all this help.
14:04:27 <gmann> #topic Critical Reviews
14:04:42 <gmann> any critical review from anyone ?
14:05:13 <kopecmartin> just that one i shared already related to os-testr: https://review.opendev.org/#/c/700778/
14:05:28 <gmann> ok
14:06:07 <gmann> #topic Open Discussion
14:06:15 <gmann> anything else to discuss ?
14:07:04 <gmann> ok, thanks all for joining.
14:07:07 <gmann> #endmeeting