14:02:30 <gmann> #startmeeting qa
14:02:31 <openstack> Meeting started Tue Nov 17 14:02:30 2020 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:34 <openstack> The meeting name has been set to 'qa'
14:02:39 <gmann> who all here today
14:03:22 <paras333> o/
14:04:10 <paras333> FYI, I have a hard stop at 9:30 am
14:04:14 <tosky> hello
14:04:24 <gmann> ohk
14:04:34 <tosky> kopecmartin is not around, public holiday
14:04:35 <gmann> kopecmartin: masayukig cannot join
14:04:37 <gmann> yeah
14:05:01 <gmann> let's star and we can finish early
14:05:22 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
14:05:27 <gmann> today agenda ^^
14:06:19 <gmann> there is no AI form previous meeting but we have few from last to last week meeting
14:06:22 <gmann> gmann paras333 to review the open patches for hacking and then release
14:06:22 <gmann> add release liaison in release team doc
14:06:22 <gmann> gmann to bring the gabbi-tempest on ML and accordingly move forward on tempest bug
14:06:22 <gmann> gmann to updatae agenda to move Bug triage at last
14:06:45 <gmann> all these are done except 2nd. I will add patch on release repo to add the liaison
14:07:15 <gmann> #topic Wallaby Priority Items progress
14:07:23 <gmann> #link https://etherpad.opendev.org/p/qa-wallaby-priority
14:07:43 <gmann> I do not have progress to share today,
14:07:56 <gmann> paras333:  you on run validation if started ?
14:08:22 <paras333> gmann: I didn't start yet, will update with the patch probably next week
14:08:35 <gmann> sure, no hurry
14:08:36 <paras333> was very busy with some downstream work
14:08:50 <paras333> gmann: thanks
14:08:52 <gmann> yeah, me too in conference recording and so
14:09:06 <gmann> #topic OpenStack Events Updates and Planning
14:09:21 <gmann> no planned event for now.
14:09:39 <gmann> #topic Sub Teams highlights (Sub Teams means individual projects under QA program)
14:10:07 <gmann> Tempest
14:10:22 <gmann> gate is green but we have lot of open patches to review
14:10:24 <gmann> #link https://review.opendev.org/#/q/project:openstack/tempest+status:open
14:10:49 <gmann> also this patch is stuck for long,
14:11:08 <gmann> masayukig: is not here as his comments are replied nd he need to re-review - https://review.opendev.org/#/c/673342/3
14:11:10 <gmann> #link https://review.opendev.org/#/c/673342/3
14:11:37 <gmann> anything else on Tempesy
14:11:39 <gmann> Tempest
14:12:38 <gmann> Patrole
14:12:49 <gmann> gate is broken for patrole
14:12:59 <paras333> gmann: I have one patch up for review in tempest  #link https://review.opendev.org/#/c/758848/
14:13:33 <gmann> paras333: sorry, I think you brought this earlier also
14:13:46 <gmann> I will review it today for sure. opened the tab
14:14:01 <paras333> gmann: yeah no worries, no rush though
14:14:10 <paras333> gmann++
14:14:28 <gmann> nova removed the os-agents API so patrole test for this API failing.
14:15:07 <openstackgerrit> Ghanshyam Mann proposed openstack/patrole master: Fix gate: Add feature flag for nova policies removed in Wallaby  https://review.opendev.org/762937
14:15:13 <gmann> this ^^ is fix
14:15:30 <gmann> Devstack
14:15:49 <gmann> gate is green there
14:15:52 <gmann> #link https://review.opendev.org/#/q/project:openstack/devstack+status:open
14:16:04 <gmann> any urgent patch to look ?
14:16:41 <gmann> Grenade
14:16:54 <gmann> gate is green here too
14:17:14 <gmann> I think we should add gate status also in start of agenda so keep eyes on each project gate status
14:17:32 <gmann> if fine I will add update the agenda
14:17:58 <paras333> gmann: yup , that make sense
14:18:08 <gmann> #action gmann to add 'Gate Status Checks' in Agenda.
14:18:11 <gmann> done
14:18:15 <gmann> #link https://review.opendev.org/#/q/project:openstack/grenade+status:open
14:18:33 <gmann> seems we need to review few open patches which are since long
14:18:48 <gmann> I will check and catch yoctozepto to cleanup the open queue
14:19:20 <gmann> tosky: is this still WIP/  https://review.opendev.org/#/c/748413/
14:19:22 <gmann> #link https://review.opendev.org/#/c/748413/
14:19:43 <tosky> yes, because it doesn't fix the issue
14:19:49 <tosky> or at least it's not the complete fix
14:19:55 <tosky> but I couldn't work on it for a while
14:20:25 <gmann> sure, just checking if that is missed
14:20:25 <tosky> this is the reason for that change: https://review.opendev.org/#/c/724258/
14:21:05 <gmann> i see
14:21:11 <gmann> thanks
14:21:12 <gmann> yoctozepto: please check this, quick one but missed to review for long time #link https://review.opendev.org/#/c/749364/
14:21:47 <tosky> I'm not really sure how to properly fix it, because the real issue is that there is a indirect dependency on barbican
14:22:00 <tosky> but anyway, please refer to the barbican review and its comments for more details
14:22:16 <gmann> sure, I will check.
14:23:54 <gmann> I think we can add few more projects integration grenade jobs in grenade queue which are stable. currently we do not test much project specific there
14:24:21 <gmann> if anyone find any project specific grenade job stable feel free to add in grenade gate
14:24:42 <gmann> we are missing lot of hidden issue there
14:25:51 <gmann> anyways moving next
14:25:52 <tosky> would it make sense to create a multiproject grenade job instead, to spare some resources?
14:25:53 <gmann> Hacking
14:26:12 <gmann> tosky: +1 unless that does not timeout
14:27:13 <gmann> at least a set of related projects
14:27:26 <paras333> gmann: no reviews pending on hacking as of now #link https://review.opendev.org/#/q/project:openstack/hacking+status:open
14:27:36 <paras333> so we are good here
14:27:53 <gmann> yeah there are few but merge conflict seems
14:27:59 <paras333> yeah
14:28:20 <gmann> hacking 4.0.0 is also available
14:28:46 <gmann> I will publish it on ML so that projects can start moving towards it and remove the common checks if they have any
14:28:58 <paras333> gmann: ack
14:29:10 <gmann> #action gmann to publish the hacking 4.0.0 on ML
14:29:19 <gmann> anything else from any other subteam ?
14:30:09 <gmann> #topic Community goal tracking
14:30:11 <gmann> #link https://etherpad.opendev.org/p/qa-community-wide-goals-tracking
14:30:25 <gmann> we have both goal finalized for Wallaby now
14:30:34 <gmann> 1. Migrate from oslo.rootwrap to oslo.privsep
14:30:48 <gmann> I need to check if anything needed for this goal in QA side or not
14:30:57 <gmann> I think no but still to double check
14:31:05 <gmann> 2. Migrate RBAC Policy Format from JSON to YAML
14:31:13 <gmann> #link https://governance.openstack.org/tc/goals/selected/wallaby/migrate-policy-format-from-json-to-yaml.html
14:31:35 <gmann> no update needed for QA on this as there is no RBAC things for us
14:32:24 <gmann> updated the etherpad
14:32:40 <gmann> #topic Gate Blocker Fix / Urgent Change
14:33:13 <gmann> any other gate blocker than Patrole one #link https://review.opendev.org/#/c/762937/2
14:33:52 <gmann> I will keep eyes on it to check if that make gate green
14:34:34 <gmann> #topic Open Discussion
14:34:43 <gmann> anything else to discuss today?
14:35:14 <paras333> nops
14:35:31 <yoctozepto> gmann: done
14:35:33 <yoctozepto> \o/
14:35:34 <gmann> ok
14:35:36 <gmann> yoctozepto: thanks
14:35:49 <yoctozepto> at least once made it to the meeting
14:35:52 <yoctozepto> thehe
14:36:01 <gmann> \o/
14:36:37 <gmann> #topic Bug Triage
14:36:49 <gmann> kopecmartin: is not here today but we can check few of them
14:37:05 <gmann> #link https://bugs.launchpad.net/tempest/+bug/1880219
14:37:06 <openstack> Launchpad bug 1880219 in devstack "Older Tempest is using master constraint for stein and train job" [Undecided,In progress] - Assigned to Ghanshyam Mann (ghanshyammann)
14:38:17 <gmann> this is still not fixed
14:38:26 <gmann> this was for py2 jobs on stein/train
14:38:31 <gmann> #link https://review.opendev.org/#/c/729722/6
14:38:52 <gmann> I will check this patch again. I totally forget about it
14:39:47 <gmann> we need to use appropriate constraint on devstack side. nothing needed for Tempest side
14:39:58 <gmann> https://bugs.launchpad.net/tempest/+bug/1784263
14:40:00 <openstack> Launchpad bug 1784263 in tempest "Fix usage of network clients among compute or neutron" [Low,Confirmed] - Assigned to Ghanshyam Mann (ghanshyammann)
14:40:47 <gmann> This is not yet fixed, we need to be careful on not losing the coverage for stable branhes
14:41:18 <gmann> we slowly need to move to neutron API as nova-network is no more thing. But for stable branch testing we also need to keep it.
14:41:32 <gmann> may be some flag or branch detection can help here
14:43:04 <gmann> updated etherpad too
14:43:29 <gmann> let's update etherpad for other bug as we triage.
14:43:43 <gmann> that's all from my side today. any critical or other bug to discuss ?
14:44:56 <gmann> if nothing let's end office hour
14:45:03 <gmann> #endmeeting