14:02:15 <gmann> #startmeeting qa
14:02:16 <openstack> Meeting started Tue Dec 15 14:02:15 2020 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:21 <openstack> The meeting name has been set to 'qa'
14:02:27 <gmann> who all here today?
14:02:33 <kopecmartin> hi o/
14:02:40 <yoctozepto> o/
14:04:22 <gmann> let's start
14:04:40 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
14:04:44 <gmann> ^^ today agenda
14:04:53 <gmann> #topic Announcement and Action Item (Optional)
14:05:19 <gmann> no action item from previous meeting
14:05:49 <gmann> skipping event thing as no coming planned event yet
14:05:52 <gmann> #topic Gate Status Checks
14:06:01 <gmann> there are many failure in gate in last week
14:06:36 <gmann> stable/rocky is still broken due to stackviz pulling the latest requirement on py3.5
14:07:12 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-December/019431.html
14:07:37 <gmann> amotoki: and I are trying few fixes for that. I will continue on this after office hour
14:08:02 <gmann> #link https://review.opendev.org/c/openstack/stackviz/+/767063 #link https://review.opendev.org/c/openstack/horizon/+/767066
14:08:41 <gmann> bandit fixes are not landed in stable/train yet #link https://review.opendev.org/c/openstack/devstack/+/766622
14:09:09 <gmann> lyarwood commented on review about the current failure on that patch which are valid one and need to fix first
14:09:10 <yoctozepto> yup, broke on sdk
14:09:37 <gmann> yoctozepto: do we have fix up?
14:10:04 <yoctozepto> not one that I know of
14:10:22 <gmann> ok
14:10:24 <yoctozepto> worth focusing on it I guess
14:10:43 <gmann> yeah, stable/rocky is EM so let priority on stable/train first
14:11:43 <gmann> any other gate failure need more attention ?
14:12:33 <amotoki> do we have periodic jobs to check our stable gate is healthy?
14:12:46 <amotoki> we usually detect our breakage when soemone proposes a backport.
14:12:58 <gmann> yes, we have tempest job also running periodic for stable
14:13:28 <gmann> amotoki: #link https://github.com/openstack/tempest/blob/master/zuul.d/project.yaml#L137
14:13:51 <gmann> we run for all stable branch but how much we monitor that is question
14:14:00 <gmann> may be we should check those in office hour at elast
14:14:03 <gmann> least
14:14:03 <amotoki> okay, so perhaps we need to check job results periodically
14:14:08 <gmann> yeah
14:14:37 <gmann> #action gmann add periodic jobs result checks in office hour agenda
14:14:47 <amotoki> thanks. we already have good stuffs :)
14:15:46 <gmann> let's keep working on current failure after office hour on priority
14:15:52 <gmann> #topic Sub Teams highlights
14:16:07 <gmann> Tempest
14:16:44 <gmann> I have started the release process to end the support of stable/stein which is now Extended maintenance now
14:16:46 <gmann> same for patrole
14:16:57 <gmann> I will push the release patches today
14:17:39 <gmann> Devstack
14:17:54 <gmann> anything else on devstack side other than the current gate failure on stable
14:18:37 <gmann> Grenade ?
14:19:36 <gmann> Hacking
14:20:26 <gmann> I saw project started moving towards 4.0.0. at least during the l-c failure where we had conflcit on pyflake and hacking version things
14:20:46 <gmann> #topic Community goal tracking
14:20:55 <gmann> #link https://etherpad.opendev.org/p/qa-community-wide-goals-tracking
14:21:33 <gmann> I have marked both goal as no  work for QA repo
14:21:45 <gmann> I will remove it from agenda also for Wallaby cycle.
14:22:01 <gmann> #action gmann remove community goal tracking from agenda
14:22:11 <gmann> #topic Gate Blocker Fix / Urgent Change
14:22:30 <gmann> for gate failure fixes we already discussed.
14:22:39 <gmann> any other urgent review request ?
14:23:41 <gmann> #topic Open Discussion
14:24:03 <gmann> nothing on agenda so let's move
14:24:06 <gmann> #topic Bug Triage (last 30 min)
14:24:09 <gmann> kopecmartin: go ahead
14:24:43 <gmann> may be a quick update if you have otherewise we can skip the bug triage today and work on gate failure ?
14:24:53 <kopecmartin> i don't have any updates regarding bug triaging .. i've been working on some refstack, refstack-client and tempestocnf maintenance
14:25:06 <gmann> ok, thanks
14:25:30 <gmann> let's close the office hour then. thanks all for joining
14:25:35 <gmann> #endmeeting