14:00:03 <masayukig> #startmeeting qa
14:00:05 <openstack> Meeting started Tue Feb 23 14:00:03 2021 UTC and is due to finish in 60 minutes.  The chair is masayukig. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:08 <openstack> The meeting name has been set to 'qa'
14:00:18 <masayukig> hi, who all here today?
14:00:22 <soniya29> hello
14:00:27 <kopecmartin> hi o/
14:00:33 <lpiwowar> hi
14:01:33 <masayukig> ok, let's start
14:01:40 <gmann> o/
14:01:40 <masayukig> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting
14:01:51 <masayukig> ^^^^^ Today's agenda
14:01:54 <jhouser> o/
14:02:07 <masayukig> #topic Announcement and Action Item (Optional)
14:02:20 <masayukig> #link http://eavesdrop.openstack.org/meetings/qa/2021/qa.2021-02-16-14.00.html
14:02:33 <masayukig> I see a couple of Action Items
14:03:39 <masayukig> gmann: do we have to check of them?
14:03:58 <gmann> yeah we can check
14:04:16 <masayukig> 1. gmann to open bug for devstack/tempest for plugins not tested with Tempest master.
14:04:32 <gmann> I have not done that yet, may be can carry that AI
14:05:03 <masayukig> ok, np
14:05:14 <masayukig> #action gmann to open bug for devstack/tempest for plugins not tested with Tempest master
14:05:18 <masayukig> just paste
14:05:24 <gmann> +1
14:05:33 <masayukig> 2. gmann to cut the Tempest new release after required patches merged
14:05:45 <masayukig> How about this?
14:05:48 <gmann> we still waiting for the few fixes to merge
14:06:00 <jhouser> what are the required patches
14:06:02 <gmann> I am on that and should release new tag by this week. let's see
14:06:14 <gmann> we discussed in last meeting,
14:06:31 <gmann> 1 is this
14:06:33 <gmann> #linkl https://review.opendev.org/c/openstack/tempest/+/774913
14:06:36 <gmann> #link https://review.opendev.org/c/openstack/tempest/+/774913
14:06:52 <gmann> #link https://review.opendev.org/c/openstack/tempest/+/773177
14:07:01 <gmann> I remember these two.
14:07:37 <masayukig> gmann: thanks. This is the last meeting log for the reference #link http://eavesdrop.openstack.org/meetings/qa/2021/qa.2021-02-16-14.00.log.html#l-40
14:07:48 <jhouser> thanks
14:08:08 <masayukig> And, 3. kopecmartin /gmann to follow up on six removal patches
14:08:25 <gmann> so we can continue the tempest release action too
14:08:39 <gmann> for six, review is going on and few might be merged. we are on those
14:08:59 <masayukig> #action gmann to cut the Tempest new release after required patches merged
14:09:09 <gmann> jhouser: I am working on those on priority and will have newtag soon
14:09:14 <masayukig> #link https://review.opendev.org/q/project:openstack/tempest+status:open+topic:remove-six
14:11:07 <masayukig> gmann: ++
14:11:54 <masayukig> ok, let's move on if nothing else on this topic
14:12:13 <masayukig> #topic Wallaby Priority Items progress
14:12:15 <gmann> yeah
14:12:28 <masayukig> #link https://etherpad.opendev.org/p/qa-wallaby-priority
14:12:40 <masayukig> any updates for the priorities?
14:13:11 <soniya29> masayukig, scenario manager effort is in progress
14:13:25 <masayukig> soniya29: cool :)
14:13:37 <gmann> this one we can discuss #link https://review.opendev.org/c/openstack/tempest/+/776932
14:13:50 <gmann> so cinder-tempest-plugin need to have copy of scenario manager
14:14:01 <gmann> which i pushed the patch but there is already one in queue
14:14:11 <gmann> #link https://review.opendev.org/c/openstack/cinder-tempest-plugin/+/702495
14:14:14 <gmann> this one ^^
14:14:44 <gmann> once this is merged we are safe to merge tempest patch
14:15:04 <masayukig> cool, let's wait for that
14:15:05 <gmann> kopecmartin: i replied to your comment about old release of cinder-tempest-plugin and tempest master.
14:15:11 <soniya29> gmann which tempest patch?
14:15:25 <gmann> soniya29: this one #link https://review.opendev.org/c/openstack/tempest/+/776932
14:15:32 <gmann> after you fix the other review comments
14:15:39 <kopecmartin> gmann: thanks
14:15:56 <gmann> kopecmartin: for every cycle we have compatible version of tempest and plugins.
14:16:18 <gmann> Tempest master is hard to be keep compatible with all other combination
14:17:06 <gmann> and copying the scenario manager is the agreed way from all plugins. cinder-tempest-plugins was missed because it came later
14:17:29 <kopecmartin> ok
14:17:54 <gmann> kopecmartin: soniya29 and same for any other scenario manager change patches also, we do not need to keep old method for plugins instead just notify them or keep copy of it if it does not exist
14:18:32 <soniya29> gmann okay
14:19:27 <masayukig> any other updates or discuss for this topic?
14:20:20 <masayukig> Or let's move on to the next topic
14:20:22 <gmann> let me check if any horizon test work is pending
14:20:26 <tosky> hopefully the cinder-tempest-plugin fixes will merge soon
14:20:52 <masayukig> gmann: thanks
14:20:56 <masayukig> tosky: ++ yeah
14:21:00 <gmann> that is all done, few patches for stable branch pending but they can be merged
14:21:10 <masayukig> cool
14:21:15 <gmann> I have crossed that in etehrpad
14:21:17 <gmann> etehrpad
14:21:52 <masayukig> thanks
14:22:09 <gmann> and for testr to stestr move
14:22:20 <gmann> after kopecmartin email, we have lot of patches for that
14:22:22 <gmann> #link https://review.opendev.org/q/topic:stestr
14:22:34 <jhouser> still on testr? wow
14:22:35 <kopecmartin> great
14:22:35 <gmann> in charm
14:22:43 <gmann> jhouser: yeah :)
14:23:00 <gmann> hope we get clean those up this time.
14:23:13 <masayukig> cool
14:24:08 <gmann> that's all from me on wallaby things
14:24:24 <gmann> just to note, March 12 is m-3
14:24:31 <gmann> which is out feature freeze too
14:24:33 <gmann> our
14:24:52 <masayukig> thanks for the heads up
14:25:04 <masayukig> let's move on to the next topic
14:25:18 <masayukig> #topic OpenStack Events Updates and Planning
14:25:40 <masayukig> gmann: already mentioned about it :)
14:26:06 <masayukig> let's skip for now
14:26:07 <masayukig> #topic Gate Status Checks
14:26:31 <masayukig> any gate blocker?
14:26:38 <gmann> we have two issue breaking stable/stein and due to tempest venv constarints
14:26:52 <gmann> which was again painful to debug
14:27:09 <gmann> one is breaking the stable/stein legacy jobs
14:27:11 <openstackgerrit> Jeremy Houser proposed openstack/tempest master: Finally remove the old data-utils  https://review.opendev.org/c/openstack/tempest/+/499869
14:27:21 <masayukig> :(
14:27:32 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-February/020631.html
14:27:34 <jhouser> whoops
14:27:40 <gmann> tempest fix is merged
14:27:49 <gmann> d-g gate is +A but waiting for devstack fix
14:27:57 <gmann> devstack fix is stuck as no review
14:28:04 <gmann> #link https://review.opendev.org/c/openstack/devstack/+/776811
14:28:16 <gmann> we need to get this merge asap to unblock the stable/stein gate
14:28:40 <gmann> can we do that?
14:28:56 <masayukig> checking
14:29:15 <gmann> this is d-g fix #link https://review.opendev.org/c/openstack/devstack-gate/+/776722
14:29:54 <gmann> and result of all fixes can be seen in #link https://review.opendev.org/c/openstack/designate/+/775903
14:30:01 <gmann> which is green now
14:30:54 <masayukig> gmann: +2 for 776811 now, or do you want me to +A?
14:31:29 <gmann> do not know, let's wait if frickler or yoctozepto can +A today otherwise you can
14:31:40 <masayukig> gmann: ++
14:31:42 <gmann> 2nd is about fixing the py2 job on stable/train and stein
14:32:00 <gmann> this is reported from networking-generic-switch stable/train
14:32:07 <gmann> #link https://review.opendev.org/c/openstack/networking-generic-switch/+/773335/13
14:32:34 <gmann> and these are fix #link https://review.opendev.org/q/topic:%22standardize-tempest-tox-constraints%22+(status:open%20OR%20status:merged)
14:33:12 <gmann> this also standardize the tempest venv constraints so that job on stable using the old tempest can also have a way to provide the constraints to use
14:33:38 <gmann> it will avoid the current way to set the env var which we do in many places. like discussed in earlier bug
14:34:12 <gmann> #link result can be seen in #link https://review.opendev.org/c/openstack/networking-generic-switch/+/773335/13
14:34:18 <gmann> which is green now
14:34:41 <gmann> networking-generic-switch stable/train is blocked due to this
14:36:03 <masayukig> cool, thanks
14:36:55 <gmann> so same, review request on these
14:38:13 <gmann> that's all on gate bugs for this week
14:39:09 <masayukig> ac, but I'm not sure I'll have bandwidth for that this week.. I'll try
14:39:11 <masayukig> thanks
14:39:26 <masayukig> #topic Periodic jobs Status Checks
14:39:34 <gmann> ok, because these are gate blocker so we need to merge them soon
14:39:35 <masayukig> #link Periodic stable: https://zuul.openstack.org/builds?job_name=tempest-full-victoria-py3&job_name=tempest-full-ussuri-py3&job_name=tempest-full-train-py3&pipeline=periodic-stable
14:39:43 <masayukig> #link Periodic master: https://zuul.openstack.org/builds?job_name=tempest-all&job_name=tempest-full-oslo-master&pipeline=periodic
14:39:54 <gmann> this already been more 1 week i think
14:40:06 <gmann> anyways I will frickler and yoctozepto again.
14:40:39 <masayukig> thanks
14:41:07 <gmann> frickler: yoctozepto this is about this series, please re-review as this is blocking stable train gate for networking-generic-switch  #link #link https://review.opendev.org/q/topic:%22standardize-tempest-tox-constraints%22+(status:open%20OR%20status:merged)
14:42:03 <masayukig> regarding periodic stable, it seems that they are almost green?
14:42:13 <gmann> yeah
14:42:28 <masayukig> cool
14:43:00 <masayukig> move on to the next topic
14:43:04 <masayukig> #topic Sub Teams highlights (Sub Teams means individual projects under QA program)
14:43:19 <masayukig> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
14:44:04 <masayukig> Any tempest patches to discuss?
14:44:30 <kopecmartin> i did some cleanup and found this
14:44:31 <kopecmartin> #link https://review.opendev.org/c/openstack/tempest/+/563801
14:44:34 <kopecmartin> still relevant?
14:45:14 <gmann> kopecmartin: thanks, 3 years old :). let me check that in this week if i can recall itr
14:45:15 <gmann> it
14:45:27 <kopecmartin> sure, np
14:45:40 <kopecmartin> yeah, i went through old patches..
14:46:07 <masayukig> oh, wow
14:46:13 <gmann> thanks for picking it
14:46:28 <masayukig> ++
14:46:59 <masayukig> #link https://review.openstack.org/#/q/project:openstack/patrole+status:open
14:46:59 <jhouser> looking for movement on this as well
14:47:01 <jhouser> #link https://review.opendev.org/c/openstack/tempest/+/775830
14:47:57 <gmann> jhouser: ack, will review today
14:48:21 <jhouser> gmann: tyvm
14:48:59 <masayukig> thanks
14:49:29 <masayukig> anything else on tempest?
14:50:18 <masayukig> How about patrole? #link https://review.opendev.org/c/openstack/tempest/+/775830
14:50:24 <masayukig> oops
14:50:37 <masayukig> #link https://review.openstack.org/#/q/project:openstack/patrole+status:open
14:51:02 <gmann> not checked the patrole last week.
14:52:15 <tosky> could you please vote on this devstack victoria backport? https://review.opendev.org/c/openstack/devstack/+/757827
14:52:36 <gmann> ack
14:53:12 <masayukig> Devstack: #link https://review.openstack.org/#/q/project:openstack/devstack+status:open
14:53:26 <gmann> I have one priority patch for devstack which i thought it was merged
14:53:28 <gmann> #link https://review.opendev.org/c/openstack/devstack/+/774524
14:53:42 <gmann> removing the setting of 'member' role
14:54:41 <gmann> this is needed for new rbac reader role testing and also octavia need this to test the specific role. both of these are not possible currently because devstack configure 'member' role for tempest to assign
14:54:46 <gmann> for all dynamic users
14:55:34 <masayukig> +A
14:55:45 <gmann> thank
14:55:48 <gmann> thanks
14:55:56 <gmann> tosky: +A on the backport too
14:56:11 <gmann> other gate fixes on devstack side we already discussed
14:56:52 <masayukig> ok
14:57:24 <masayukig> #topic Bug Triage (last 30 min)
14:57:34 <masayukig> #link https://etherpad.openstack.org/p/qa-bug-triage-wallaby
14:57:57 <gmann> we have 3 min left only. may be we can check if any critical bug which we have not discussed yet?
14:58:00 <kopecmartin> numbers are recorded, i don't have anything special to discuss, i didn't have much time for bug triaging this week
14:58:08 <masayukig> ok
14:58:23 <masayukig> sorry for my bad time management.
14:58:25 <gmann> k
14:58:40 <masayukig> #topic Open Discussion
14:58:44 <gmann> I have also not seen any critical bug
14:59:26 <masayukig> thanks
14:59:29 <masayukig> anything else to discuss?
15:00:49 <masayukig> let's close the office hour since it's the time
15:01:02 <masayukig> thanks for attending
15:01:12 <masayukig> #endmeeting