14:00:23 <kopecmartin> #startmeeting qa
14:00:24 <openstack> Meeting started Tue Mar 30 14:00:23 2021 UTC and is due to finish in 60 minutes.  The chair is kopecmartin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:27 <openstack> The meeting name has been set to 'qa'
14:00:42 <kopecmartin> hi, who all here today?
14:01:35 <gmann> o/
14:01:43 <lpiwowar> hi o/
14:01:45 <soniya29> hello
14:01:57 <amodi> o/
14:02:26 <kopecmartin> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting
14:02:32 <kopecmartin> ^^^^^^ today's agenda
14:02:45 <kopecmartin> let's start
14:02:52 <kopecmartin> #topic Announcement and Action Item (Optional)
14:03:06 <kopecmartin> I have one topic, tempest 27.0.0 has been released \o/
14:03:17 <artom> amodi, ack - I've removed my vote, thanks for bringing it up. For future reference, please mark patches as WIP if you know there's stuff outstanding :)
14:03:32 <kopecmartin> which includes the stable scneario.manager
14:03:40 <kopecmartin> soniya29: thanks for the patches!
14:04:11 <amodi> artom: okay, i had commented on first patch asking for suggestions, but will keep it WIP in future, thanks!!
14:04:26 <soniya29> kopecmartin, :)
14:04:31 <gmann> kopecmartin: yeah and I think tox using master constraints also merged
14:04:43 <kopecmartin> yeah, they are
14:04:51 <kopecmartin> after a few rechecks :/
14:04:53 <gmann> # link https://review.opendev.org/c/openstack/tempest/+/783320
14:05:10 <gmann> kopecmartin: any release we are missing, we did for Tempest, Patrole.
14:05:28 <kopecmartin> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting
14:05:29 <gmann> do we need to release hacking, os-testr etc ?
14:05:39 <kopecmartin> oh, i wanted this
14:05:41 <kopecmartin> #link https://wiki.openstack.org/wiki/QA/releases
14:05:49 <kopecmartin> checking
14:05:53 <gmann> if there are many changes after the last release
14:06:22 <gmann> all those are independent release model so not tied to cycle release but just in case we need to release any of them
14:07:31 <kopecmartin> ~6 new commits in hacking since the last release in Oct 2020
14:08:16 <kopecmartin> ~11 in os-testr
14:08:18 <gmann> kopecmartin: yeah not release candidates so let's wait
14:08:42 <kopecmartin> gmann: so are we good with releases?
14:09:01 <gmann> I think same for os-testr
14:09:17 <kopecmartin> okey then
14:09:24 <gmann> kopecmartin: yeah we are good for releases
14:09:27 <kopecmartin> perfect
14:09:45 <kopecmartin> another , not so new, announcement is PTG
14:09:49 <gmann> kopecmartin: we can take next steps for tempest/patrole for reno page etc and then follow all steps for devstack/grenade once release team give go ahead
14:09:53 <kopecmartin> less than 3 weeks away
14:10:15 <kopecmartin> gmann: sure
14:10:26 <kopecmartin> the PTG document
14:10:27 <kopecmartin> #link https://etherpad.opendev.org/p/qa-xena-ptg
14:10:32 <gmann> kopecmartin: thanks, I will work with you on those.
14:10:46 <kopecmartin> if anyone has any topic which would like to discuss, add to the etherpad
14:10:50 <kopecmartin> gmann: thanks
14:10:59 <gmann> may be we need more topics in etherpad though we have time
14:11:42 <kopecmartin> yeah, i'll try to think of something (a backup topic if any time left)
14:11:53 <gmann> nice, +1
14:12:02 <kopecmartin> ok, let's move on if nothing else
14:12:06 <gmann> I am also going to spend next week onwards on PTG things
14:12:22 <kopecmartin> gmann: cool
14:12:28 <kopecmartin> #topic Wallaby Priority Items progress
14:12:33 <kopecmartin> #link https://etherpad.opendev.org/p/qa-wallaby-priority
14:12:56 <kopecmartin> as mentioned, scenario.manager is done!
14:13:16 <gmann> yeah great work kopecmartin soniya29
14:13:36 <tosky> thanks for all the work on this stabilization!
14:13:45 <kopecmartin> any other updates?
14:13:47 <gmann> we can update this on ML
14:13:51 <soniya29> gmann, thanks
14:13:55 <kopecmartin> yeah
14:13:56 <gmann> so that plugins start consuming it
14:14:24 <kopecmartin> +1, i'll write an email
14:14:47 <kopecmartin> #action kopecmartin to write an email to ML to announce scenario.manager effort being done
14:15:12 <kopecmartin> #action kopecmartin to update the list of priority items, check the status etc ..
14:15:12 <gmann> cool, thanks
14:15:16 <soniya29> gmann, kopecmartin if you are too much consumed or anything else you can always ping me and I will do that
14:15:43 <kopecmartin> sure, thank you for that soniya29
14:15:54 <gmann> soniya29: sure, thanks for all your work.
14:16:33 <kopecmartin> #topic OpenStack Events Updates and Planning
14:16:39 <kopecmartin> #link https://etherpad.opendev.org/p/qa-xena-ptg
14:16:52 <kopecmartin> the time slots are booked
14:16:58 <kopecmartin> i sent an email about it to ML as well
14:17:23 <kopecmartin> I filled the vptg survey last week , so i think we should be ok here
14:18:19 <kopecmartin> to summarise , we have booked:
14:18:21 <kopecmartin> Mon Apr. 19th 13 - 15 UTC (2 slots)
14:18:25 <kopecmartin> Tue Apr. 20th 13 - 14 UTC (1 slot)
14:18:30 <kopecmartin> Wed Apr. 21th 13 - 14 UTC (1 slot)
14:18:46 <gmann> +1
14:18:51 <kopecmartin> #topic Gate Status Checks
14:19:12 <kopecmartin> any blockers or urgent patches?
14:20:14 <kopecmartin> i noticed many failures in a tempestconf job
14:20:28 <kopecmartin> it keeps failing as POST_FAILURE
14:20:36 <kopecmartin> #link https://zuul.opendev.org/t/openstack/builds?job_name=python-tempestconf-tempest-devstack-admin-plugins&project=osf/python-tempestconf
14:20:41 <gmann> general one of specific to tempest conf
14:20:49 <kopecmartin> specific to tempestconf
14:21:07 <gmann> hope not caused by Tempest.
14:21:12 <kopecmartin> but it's just a wrapper around devstack and it runs tempest plugins
14:21:22 <gmann> yeah
14:21:23 <kopecmartin> all tests are passing, so probably not
14:21:38 <kopecmartin> but i can't explain why only this one fails
14:21:40 <gmann> I did not see other consistent  gate failure than volume one
14:22:15 <gmann> kopecmartin: it failing in 'Export journal'
14:22:41 <kopecmartin> yeah .. should i bring this up with infra?
14:23:12 <gmann> may be
14:23:37 <kopecmartin> ok, will do
14:23:44 <kopecmartin> #topic Periodic jobs Status Checks
14:23:51 <kopecmartin> #link https://zuul.openstack.org/builds?job_name=tempest-all&job_name=tempest-full-oslo-master&pipeline=periodic
14:24:12 <gmann> all green here
14:24:31 <kopecmartin> one failure , not related to tempest
14:24:34 <kopecmartin> good
14:24:47 <kopecmartin> #topic Sub Teams highlights (Sub Teams means individual projects under QA program)
14:24:53 <kopecmartin> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
14:25:09 <kopecmartin> #link https://review.openstack.org/#/q/project:openstack/devstack+status:open
14:25:22 <kopecmartin> #link https://review.opendev.org/q/project:openstack/hacking+status:open
14:25:48 <kopecmartin> i was triaging a little and rebased this patch for devstack
14:25:49 <kopecmartin> #link https://review.opendev.org/c/openstack/devstack/+/768363
14:25:55 <kopecmartin> please review
14:26:31 <gmann> kopecmartin: may be after wallaby ? or is it blocking
14:26:37 <kopecmartin> i checked several projects and my goal is to first deal with almost fixed bugs / forgotten patches very close to merge and etc
14:26:49 <kopecmartin> no it's not , yeah, after the release it's fine
14:27:06 <gmann> yeah, let's not cause any risk at release time
14:27:16 <kopecmartin> agree
14:27:27 <gmann> may be we should be able to cut the devstack branch by this or next weekearly
14:27:30 <gmann> week early
14:27:59 <kopecmartin> let's do rather sooner than later
14:28:12 <kopecmartin> there are some public holidays here at the end of the week
14:28:22 <tosky> reminder about cinder-backup devstack refactor/s3 support: https://review.opendev.org/c/openstack/devstack/+/770171
14:28:30 <gmann> kopecmartin: we need to wait for that until all projects used in devstack have stable branch
14:28:33 <tosky> required to test the new s3 cinder driver
14:28:44 <kopecmartin> #link https://review.opendev.org/c/openstack/devstack/+/770171
14:28:47 <gmann> kopecmartin: that will be notified by release team and then QA team start the process
14:28:56 <kopecmartin> gmann: ack
14:29:21 <gmann> kopecmartin: I will help on that if you are on holiday, timing of those are little critical during release
14:29:56 <kopecmartin> tosky: required to merge before release, right?
14:30:06 <tosky> hopefully, yes :)
14:30:14 <kopecmartin> gmann: sure, i'll be around more or less anyway
14:30:25 <gmann> cool
14:30:29 <tosky> so we can deploy and merge the job which tests the s3 driver
14:30:53 <kopecmartin> tosky: ok, i'll have a look, i see some testing patches ..
14:31:54 <kopecmartin> regarding hacking
14:32:01 <kopecmartin> #link https://review.opendev.org/q/project:openstack/hacking+status:open
14:32:27 <kopecmartin> there are 3 new patches (low hanging fruit type)
14:32:46 <kopecmartin> as we're not doing any release now, we might have a look
14:33:05 <gmann> kopecmartin: checking, we can merge those without worry about release
14:33:10 <kopecmartin> gmann: btw, what's the status of core contributors for hacking?
14:33:29 <kopecmartin> zbr|rover: volunteered to help there with maintenance
14:34:01 <gmann> kopecmartin: sure, it will be nice to add more core. not many core are around there
14:34:13 <gmann> i think yoctozepto might be interested also
14:34:42 <kopecmartin> gmann: good, what's the process? should i write an email about new cores to ML as well?
14:34:59 <yoctozepto> yes, I am fine with that, can help
14:35:15 <gmann> kopecmartin: either way, ML or we can discuss in next meeting also to see if any objection
14:35:19 <gmann> yoctozepto: great
14:35:22 <kopecmartin> yoctozepto: thanks
14:35:25 <kopecmartin> gmann: ok
14:35:38 <kopecmartin> #action kopecmartin to send an email about ^^ to ML
14:35:59 <kopecmartin> anything else on this topic?
14:36:10 <zbr|rover> happy to help, i can keep an eye on it doing normal maintenance and review incoming patches, eventually abandoning orphan ones.
14:36:47 <kopecmartin> zbr|rover: perfect, thank you
14:36:53 <kopecmartin> #topic Open Discussion
14:37:06 <kopecmartin> Anyone anything to discuss?
14:37:26 <gmann> nothing from me
14:37:48 <gmann> zbr|rover: thanks for help.
14:38:32 <yoctozepto> I think with gmann we are tc liaisons for qa this cycle
14:38:45 <yoctozepto> might be worth knowing :-)
14:39:10 <gmann> yoctozepto: yeah.
14:39:29 <gmann> kopecmartin: for your notice :) if you need any help from TC or so
14:39:45 <kopecmartin> gmann: ack, thanks
14:40:10 <kopecmartin> #topic Bug Triage (last 30 min)
14:40:17 <kopecmartin> #link https://etherpad.opendev.org/p/qa-bug-triage-wallaby
14:40:28 <kopecmartin> I had a little time so i did some triage
14:40:42 <kopecmartin> most of the bugs in grenade weren't in progress
14:41:11 <kopecmartin> in general numbers went down
14:41:36 <kopecmartin> apart from that i don't have anything in particular to discuss
14:41:44 <gmann> two critical on devstack ?
14:42:14 <gmann> ohk both fixed #link https://bugs.launchpad.net/devstack/+bugs?search=Search&field.importance=Critical&field.status=New&field.status=Incomplete&field.status=Confirmed&field.status=Triaged&field.status=In+Progress&field.status=Fix+Committed
14:42:23 <gmann> after wallaby release we can mark them Fixed released
14:42:47 <kopecmartin> perfect
14:42:51 <gmann> got worried from numbers  :)
14:43:07 <kopecmartin> :D
14:43:15 <gmann> I updated it etherpad to mark it 0
14:43:33 <kopecmartin> ok
14:43:41 <kopecmartin> if nothing else to discuss, we can close the office hour
14:44:04 <kopecmartin> thanks all
14:44:05 <kopecmartin> #endmeeting