14:00:15 <gmann> #startmeeting qa
14:00:16 <openstack> Meeting started Tue May  4 14:00:15 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:19 <openstack> The meeting name has been set to 'qa'
14:00:21 <gmann> who all here today?
14:00:41 <yoctozepto> \o/
14:01:27 <soniya29> hello
14:01:56 <gmann> let's start
14:02:13 <gmann> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
14:02:17 <gmann> today agenda ^^
14:02:25 <gmann> #topic Announcement and Action Item (Optional)
14:02:31 <gmann> no action item form previous meeting
14:02:41 <gmann> I do not have any announcement too
14:02:53 <gmann> #link Xena Priority Items progress
14:03:10 <gmann> #topic Xena Priority Items progress
14:03:27 <gmann> #link https://etherpad.opendev.org/p/qa-xena-priority
14:04:03 <gmann> I pushed some of the patches for plugins+tempest master testing and run-tempest role
14:04:21 <gmann> but could not make much progress for their results and checking with requirement team
14:04:30 <gmann> I will do that this week
14:04:45 <gmann> any other updates on any of the Xena item?
14:05:44 <yoctozepto> na-ah
14:05:54 <gmann> #topic OpenStack Events Updates and Planning
14:06:11 <gmann> nothing on this, we finished the PTG and kopecmartin summarized it on ML too.
14:06:22 <gmann> #topic Gate Status Checks
14:06:44 <gmann> one race happening in image import tests were fixed #link https://review.opendev.org/c/openstack/tempest/+/788856
14:07:11 <gmann> any other failure you are seeing on gate? (any project but related to QA)
14:07:54 <yoctozepto> nothing reported to me, though I wonder if mrunge succeeded fixing gates for telemetry
14:08:09 <gmann> ok
14:08:26 <gmann> #topic Periodic jobs Status Checks
14:08:27 <mrunge> gates for telemetry still in semi-good shape
14:08:37 <gmann> #link https://zuul.openstack.org/builds?job_name=tempest-full-victoria-py3&job_name=tempest-full-ussuri-py3&job_name=tempest-full-train-py3&pipeline=periodic-stable
14:08:38 <yoctozepto> mrunge: any way QA could help?
14:08:55 <gmann> #link https://zuul.openstack.org/builds?job_name=tempest-all&job_name=tempest-full-oslo-master&pipeline=periodic
14:09:07 <gmann> mrunge: yeah, what are the failure?
14:09:12 <mrunge> good question. It would be awesome if more people would look at stable jobs and also on periodic jobs
14:09:43 <yoctozepto> I wonder if you could introduce us to the issues
14:09:48 <yoctozepto> are you tracking them somewhere?
14:09:50 <mrunge> for now, I have switched integration tests to non-voting
14:10:13 <mrunge> other than trying to remember, I am not tracking it somewhere. but I should
14:10:16 <yoctozepto> blasphemy in this channel :D
14:10:47 <mrunge> not sure if this would derail discussion in this meeting?
14:10:56 <yoctozepto> this is office hours
14:11:08 <gmann> yeah we can discuss now or later also.
14:11:18 <gmann> feel free to ping us
14:11:19 <mrunge> integration tests fail in clean-up phase
14:11:28 <mrunge> thank you, I really appreciate it
14:11:52 <yoctozepto> all right, any details, name of the job?
14:12:08 <mrunge> just a sec, will look it up
14:12:24 <gmann> i think this one? https://review.opendev.org/c/openstack/telemetry-tempest-plugin/+/787739
14:12:26 <gmann> #link https://review.opendev.org/c/openstack/telemetry-tempest-plugin/+/787739
14:12:51 <mrunge> that's the link of switching it to non-voting
14:13:04 <gmann> Details: {'type': 'SecurityGroupInUse', 'message': 'Security Group e5f886b0-4a09-4348-88cc-efd4a5ea34c3 in use.', 'detail': ''}
14:13:11 <mrunge> yes
14:13:19 <yoctozepto> interesting
14:13:30 <gmann> anyways let's debug it after office hour.
14:13:35 <mrunge> yes
14:13:50 <gmann> any other gate failure we need to keep eyes/help on?
14:14:25 <gmann> ok, let's move then
14:14:28 <gmann> periodic jobs
14:14:35 <gmann> #link https://zuul.openstack.org/builds?job_name=tempest-full-victoria-py3&job_name=tempest-full-ussuri-py3&job_name=tempest-full-train-py3&pipeline=periodic-stable
14:14:36 <gmann> #link https://zuul.openstack.org/builds?job_name=tempest-all&job_name=tempest-full-oslo-master&pipeline=periodic
14:14:39 <gmann> they seems green
14:14:44 <yoctozepto> periodic happy
14:14:58 <gmann> yeah
14:15:01 <gmann> #topic Sub Teams highlights
14:15:06 <gmann> Tempest
14:15:17 <gmann> #link https://review.openstack.org/#/q/project:openstack/tempest+status:open
14:15:52 <gmann> nothing on Tempest to discuss
14:16:10 <gmann> Patrole
14:16:20 <gmann> #link https://review.opendev.org/q/project:openstack/patrole+status:open
14:17:04 <gmann> few open reviews but seems gate is not happy there. I will check and fix it if any service policy is changed
14:17:15 <gmann> #action gmann to check/fix the patrole gate
14:17:22 <gmann> Devstack
14:17:32 <gmann> #link https://review.opendev.org/q/project:openstack/devstack+status:open
14:17:53 <yoctozepto> always something open
14:17:55 <gmann> one is Drop Bionic support
14:18:12 <gmann> we are getting response on ML from projects on confirmation about this
14:18:45 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-April/022141.html
14:18:45 <yoctozepto> yeah, but it seems projects understand the need well
14:19:18 <gmann> yeah,
14:19:45 <gmann> what date we should merge the devstack?
14:20:00 <gmann> i said 2nd week of May in ML
14:20:15 <gmann> which can be 14th May as last
14:20:21 <yoctozepto> I agree that should be just fine
14:20:24 <gmann> ok
14:20:35 <yoctozepto> let's see what opendev does with the base job as well
14:20:41 <gmann> still 10 more days to fix if needed
14:20:44 <gmann> yeah
14:20:44 <yoctozepto> that could be funnier
14:20:57 <gmann> agree
14:20:58 <yoctozepto> well, at this point in cycle it should be relatively safe
14:21:04 <yoctozepto> let's see
14:21:13 <yoctozepto> we can't stay on bionic forever anyway
14:21:27 <gmann> yeah, from devstack side I am sure we will get complained on 3rd party CI side
14:21:44 <yoctozepto> yeah, but what can we do
14:21:44 <gmann> as what happened in xenail case
14:22:09 <gmann> yoctozepto: nothing, we notified them and asked them to migrate in many platform
14:22:19 <yoctozepto> well, at least now we are not switching python version as well
14:22:29 <gmann> so if anyone ask us to fix for Bionic we just tell them to migrate to Focal
14:22:41 <gmann> good point, so less breakage may be
14:22:51 <yoctozepto> now print it and put it in a frame :D
14:22:59 <yoctozepto> "so if anyone ask us to fix for Bionic we just tell them to migrate to Focal"
14:23:02 <gmann> :)
14:23:14 <gmann> anything else on devstack?
14:23:23 <yoctozepto> nope
14:23:27 <gmann> ok
14:23:28 <gmann> Grenade
14:23:42 <gmann> #link https://review.opendev.org/q/project:openstack/grenade+status:open
14:24:49 <yoctozepto> you know my opinion
14:25:03 <yoctozepto> but at least it's shorter than devstack's
14:25:06 <yoctozepto> :-)
14:25:13 <gmann> :)
14:25:19 <yoctozepto> perhaps we could abandon old ones
14:25:25 <gmann> I will check this patch after office hour #link https://review.opendev.org/c/openstack/grenade/+/788239
14:25:45 <gmann> yeah, I will see what all are fine to continue otherwise we can cleanup
14:25:53 <soniya29> gmann, can we close this out since it is not updated from feb 2019 :- https://storyboard.openstack.org/#!/story/2004771?
14:25:58 <yoctozepto> regarding that review
14:26:08 <yoctozepto> I wonder if we need those files any more
14:26:19 <yoctozepto> but dropping that part should not hurt anyway
14:26:35 <yoctozepto> I understand grenade was meant to upgrade any->any
14:26:48 <yoctozepto> yet ended up any->+1
14:27:15 <gmann> yeah, will be ok but will check the placement things workaround. I do not think we need it
14:27:29 <gmann> soniya29: i see this patch is not yet merged #link https://review.opendev.org/c/openstack/patrole/+/630647/
14:27:37 <gmann> soniya29: any other commit fixed that?
14:28:31 <soniya29> gmann, I dont think so, atleast I am not aware of any such
14:30:01 <gmann> soniya29: ok, may be we can see if that is still happening or not then close or fix
14:30:03 <gmann> fix
14:30:07 <soniya29> gmann, Do we require this fix any more?
14:30:26 <gmann> I need to check what was failure, will do and comment after office hour
14:30:35 <soniya29> sure
14:30:52 <gmann> thanks for brining this up
14:30:54 <gmann> Hacking
14:30:59 <gmann> any news on hacking?
14:31:47 <yoctozepto> it's happy with its review queue down to 0 waiting for review
14:31:54 <gmann> +1, nice
14:32:00 <gmann> thanks for help there
14:32:01 <yoctozepto> (just 1 with -1 from zbr)
14:32:06 <yoctozepto> sure thing
14:32:22 <yoctozepto> but most thanks go to zbr for his cleanup
14:32:34 <gmann> yeah thanks zbr
14:32:37 <gmann> #topic Gate Blocker Fix / Urgent Change
14:32:47 <gmann> #link https://review.opendev.org/q/label:Review-Priority%253D%252B2+status:open+(project:openstack/tempest+OR+project:openstack/patrole+OR+project:openstack/devstack+OR+project:openstack/grenade+OR+project:openstack/hacking)
14:32:50 <gmann> nothing there
14:33:01 <gmann> #topic Open Discussion
14:33:06 <gmann> nothing here too
14:33:19 <gmann> #topic Bug Triage
14:33:30 <gmann> #link https://etherpad.opendev.org/p/qa-bug-triage-xena
14:33:38 <gmann> I will check if any critical bugs
14:34:02 <gmann> no critical one
14:34:48 <gmann> any bug we want to discuss today otherwise I will close office hour and go for breakfast :)
14:35:15 <yoctozepto> oh no, office hours before breakfast, how could they
14:35:24 <yoctozepto> enjoy your meal :-)
14:35:50 <gmann> I usually do during it when kopecmartin chair it :)
14:36:20 <yoctozepto> understood
14:36:26 <gmann> thanks everyone for joining. be safe and take care.
14:36:30 <gmann> #endmeeting