15:00:34 <kopecmartin> #startmeeting qa
15:00:34 <opendevmeet> Meeting started Tue Dec 10 15:00:34 2024 UTC and is due to finish in 60 minutes.  The chair is kopecmartin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:34 <opendevmeet> The meeting name has been set to 'qa'
15:00:41 <kopecmartin> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
15:00:48 <kopecmartin> agenda ^
15:00:57 <frickler> o/
15:02:20 <kopecmartin> \o
15:02:30 <gmann> o/
15:02:41 <opendevreview> Nathan proposed openstack/tempest master: Fixed encryption type methods to comply with documentation  https://review.opendev.org/c/openstack/tempest/+/935526
15:02:52 <kopecmartin> hey gmann isn't it too early for you?
15:03:00 <lpiwowar> o/
15:03:21 <gmann> kopecmartin: I am attending board meeting today so can join here too :)
15:03:26 <kopecmartin> :)
15:03:38 <kopecmartin> #topic Announcements and Action Items
15:04:04 <kopecmartin> this is the last office hour before the holidays which means the last office hour this year
15:04:38 <nperez> o/
15:04:39 <kopecmartin> as I mentioned last time, i won't be able to host these in the new year, so we'll need a new volunteer :)
15:04:44 <kopecmartin> hi nperez
15:05:23 <kopecmartin> one of the discussed options was that gmann would take over, however, in that case we'd shift the meeting for a later time to better accomodate his time zone
15:05:49 <kopecmartin> if that happens, it'll be shared on the ML as well
15:07:44 <kopecmartin> oh, one other update, i've got a volunteer for reviews (as my capacity for this kind of thing in the new year will be decreased)
15:08:06 <kopecmartin> tosky volunteered that he would like to help with reviews on tempest side
15:08:54 <kopecmartin> you may have seen his commits to cinder-tempest-plugin and a few related projects, e.g. cinder, glance and even tempest
15:09:17 <tosky> even though I don't know a lot of the internal bits, so I may not always be perfectly helpful
15:09:44 <tosky> (I do have some experience on devstack and grenade, though, to be refreshed a bit)
15:10:07 <kopecmartin> that is absolutely ok .. i'm sure tempest can benefit from that
15:10:08 <frickler> cool, yes, I remember you were around when I started digging into devstack
15:10:19 <gmann> perfect thanks tosky
15:10:32 <kopecmartin> luigi is everywhere ;)
15:10:33 <kopecmartin> https://review.opendev.org/q/from:ltoscano@redhat.com
15:12:12 <kopecmartin> #action so, one action item for me is to hand over the hosting of this office hour and find (if needed) a new time
15:13:01 <kopecmartin> that's all from announcements
15:13:26 <kopecmartin> #topic Epoxy Priority Items progress
15:13:26 <kopecmartin> #link https://etherpad.opendev.org/p/qa-epoxy-priority
15:13:33 * kopecmartin checking if there are any updates
15:14:00 * kopecmartin feeling a bit ashamed as he didn't get to a few action items there :/
15:15:16 <kopecmartin> the migration to noble went more or less fine
15:15:20 <kopecmartin> the email thread:
15:15:21 <kopecmartin> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/JOMDY26TCW7OX3NXRGOYQCIDXNNJ4E25/
15:15:50 <frickler> well still some cleanup happening, but nothing major that I'm aware of, yes
15:15:56 <gmann> one of the bug is in devstack-plugin-container CRI-O installation on noble failing
15:16:12 <kopecmartin> only 24 patches left open out of almost a hundred
15:16:14 <kopecmartin> #link https://review.opendev.org/q/topic:%22migrate-to-noble%22+status:open
15:16:17 <gmann> I pinged hongbin who is mainly maintaining this plugin and he will look into that
15:16:23 <kopecmartin> great
15:16:40 <gmann> yeah, I am trying to get those merged but they may take time
15:17:08 <gmann> CRI-O thing only impact k8s jobs
15:18:03 <gmann> and the doc job migration is still left
15:18:56 <kopecmartin> ack , thanks
15:19:22 <kopecmartin> let's move on
15:19:24 <kopecmartin> #topic Gate Status Checks
15:19:24 <kopecmartin> #link https://review.opendev.org/q/label:Review-Priority%253D%252B2+status:open+(project:openstack/tempest+OR+project:openstack/patrole+OR+project:openstack/devstack+OR+project:openstack/grenade)
15:19:35 <kopecmartin> 2 patches, both approved
15:19:50 <kopecmartin> #topic Sub Teams highlights
15:19:50 <kopecmartin> Changes with Review-Priority == +1
15:19:50 <kopecmartin> #link https://review.opendev.org/q/label:Review-Priority%253D%252B1+status:open+(project:openstack/tempest+OR+project:openstack/patrole+OR+project:openstack/devstack+OR+project:openstack/grenade)
15:20:06 <kopecmartin> 6 patches, most of them approved
15:20:30 <kopecmartin> i need a second opinion on
15:20:32 <kopecmartin> #link https://review.opendev.org/c/openstack/tempest/+/933308
15:20:36 <kopecmartin> and
15:20:37 <kopecmartin> #link https://review.opendev.org/c/openstack/tempest/+/935526
15:21:09 <nperez> hey you wanted me to fix the "closes bug" part of my commit message and fixed it
15:21:27 <kopecmartin> perfect, thank you
15:21:50 <nperez> https://review.opendev.org/c/openstack/tempest/+/935526
15:21:55 <nperez> thank you for reviewing it
15:22:33 <kopecmartin> thank you for working on it
15:23:23 <kopecmartin> i reviewed it, let's see what the automatic jobs think
15:23:48 <kopecmartin> #topic Periodic jobs Status Checks
15:23:48 <kopecmartin> Periodic stable full: https://zuul.openstack.org/builds?pipeline=periodic-stable&job_name=tempest-full-2023-1&job_name=tempest-full-2023-2&job_name=tempest-full-2024-1&job_name=tempest-full-2024-2
15:23:48 <kopecmartin> Periodic stable slow: https://zuul.openstack.org/builds?job_name=tempest-slow-2024-2&job_name=tempest-slow-2024-1&job_name=tempest-slow-2023-2&job_name=tempest-slow-2023-1
15:23:50 <kopecmartin> Periodic extra tests: https://zuul.openstack.org/builds?job_name=tempest-full-2024-2-extra-tests&job_name=tempest-full-2024-1-extra-tests&job_name=tempest-full-2023-2-extra-tests&job_name=tempest-full-2023-1-extra-tests
15:23:52 <kopecmartin> Periodic master: https://zuul.openstack.org/builds?project=openstack%2Ftempest&project=openstack%2Fdevstack&pipeline=periodic
15:24:36 <frickler> you can drop 2023.1 from those searches now
15:24:44 <frickler> that moved to unmaintained
15:24:47 <kopecmartin> oh, right, thanks frickler
15:26:15 <kopecmartin> all builds looks pretty standard
15:27:04 <kopecmartin> #topic Distros check
15:27:04 <kopecmartin> Centos 9: https://zuul.openstack.org/builds?job_name=tempest-full-centos-9-stream&job_name=devstack-platform-centos-9-stream&skip=0
15:27:04 <kopecmartin> Debian: https://zuul.openstack.org/builds?job_name=devstack-platform-debian-bookworm&skip=0
15:27:06 <kopecmartin> Rocky: https://zuul.openstack.org/builds?job_name=devstack-platform-rocky-blue-onyx
15:27:08 <kopecmartin> Jammy: https://zuul.opendev.org/t/openstack/builds?job_name=devstack-platform-ubuntu-jammy-ovn-source&job_name=devstack-platform-ubuntu-jammy-ovs&skip=0
15:27:10 <kopecmartin> Noble: https://zuul.opendev.org/t/openstack/builds?job_name=devstack-platform-ubuntu-noble&skip=0
15:27:59 <frickler> the latter two also need updates now I think. more noble less jammy
15:29:05 <kopecmartin> oh, right
15:29:53 <kopecmartin> hmm, the search filters based on the name only
15:30:14 <kopecmartin> .. on the other hand, it might be good to see the results on the unmaintained branch
15:30:24 <kopecmartin> hmm, but if there is something wrong, we can't fix that anyway
15:30:36 <kopecmartin> I'll try to limit the search
15:30:40 <frickler> yes, but devstack-platform-ubuntu-jammy-ovn-source was replaced by devstack-platform-ubuntu-noble-ovn-source for example on master
15:31:32 <kopecmartin> right .. ok, another action item then
15:31:34 <frickler> and devstack-platform-ubuntu-noble is replaced by tempest-full-py3 ;)
15:31:43 <kopecmartin> #action kopecmartin to update the above searches
15:32:00 <frickler> instead there is devstack-platform-ubuntu-jammy now. or so I think
15:33:27 <frickler> anyway, we can go on I think
15:33:52 <kopecmartin> ack
15:33:54 <kopecmartin> #topic Open Discussion
15:33:54 <kopecmartin> anything for the open discussion?
15:34:14 <clarkb> I wanted to call out https://bugs.launchpad.net/devstack/+bug/2082617 and less the specific issue and more the thing that made it difficult to debug
15:34:50 <clarkb> as noted in there I think the |default(omit) default module arguments may mask early detection of failures to render the config dicts
15:35:22 <clarkb> it would probably be a good idea for the qa team to investigate refactoring that in devstack so that we're less likely to pass a null default and wonder why the job isn't working as expected
15:36:13 <clarkb> The good news is I don't think jobs would pass if they have broken jinja in their localrc config so I don't think we have a bunch of jobs doing the wrong thing
15:36:19 <clarkb> but debugging is difficult as is
15:37:58 <kopecmartin> that's a good point
15:38:16 <frickler> ah, yes, that was a fancy issue. I just think the "qa team" is essentially near zero by now, so not sure who would take that up. except tosky maybe? :)
15:39:40 <kopecmartin> i'll check it
15:39:56 <clarkb> ya its an easy one to fix at a superficial level. Just update that CEPH ip address to the private ipv4 address and move on. My concern is more that debugging future issues may be more painful/ less obvious
15:40:14 <clarkb> and I suspect changing how defaults are handled may expose the issue more directly with a "jinja broke" error
15:41:29 <kopecmartin> right, that;s a good idea
15:42:06 <kopecmartin> cool, anything else/
15:42:08 <kopecmartin> ?
15:43:42 <kopecmartin> ok then, we're done
15:43:46 <kopecmartin> thank you all
15:43:52 <kopecmartin> see you around
15:44:01 <frickler> o/
15:44:04 <kopecmartin> #endmeeting