18:00:59 <gmaan> #startmeeting qa
18:00:59 <opendevmeet> Meeting started Wed May 14 18:00:59 2025 UTC and is due to finish in 60 minutes.  The chair is gmaan. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:59 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:59 <opendevmeet> The meeting name has been set to 'qa'
18:01:18 <gmaan> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
18:01:25 <gmaan> today agenda ^^
18:01:46 <gmaan> who all here today, will wait for 2min in case anyone join
18:04:00 <gmaan> let's start
18:04:17 <gmaan> #topic Priority Items progress
18:04:35 <gmaan> #link https://etherpad.opendev.org/p/qa-2025-2-priority
18:04:55 <gmaan> one update on RBAC, I started testing manager role and fixing some bugs related to that
18:05:04 <gmaan> #link https://bugs.launchpad.net/tempest/+bug/2110507
18:05:24 <gmaan> #topic Gate Status / Fix Checks
18:05:27 <gmaan> #link https://review.opendev.org/q/label:Review-Priority%253D%252B2+status:open+(project:openstack/tempest+OR+project:openstack/patrole+OR+project:openstack/devstack+OR+project:openstack/grenade)
18:06:46 <gmaan> #link https://review.opendev.org/c/openstack/tempest/+/945320
18:07:14 <gmaan> I reset priority for ^^ this, i do not think it is gate blocker or any urgent. at least not mentioned in comment
18:07:36 <gmaan> #topic Changes with Review-Priority == +1
18:07:38 <gmaan> #link https://review.opendev.org/q/label:Review-Priority%253D%252B1+status:open+(project:openstack/tempest+OR+project:openstack/patrole+OR+project:openstack/devstack+OR+project:openstack/grenade)
18:08:47 <gmaan> most of them are reviewed and waiting for author
18:09:17 <gmaan> 945320 - I will review after meeting, it seems some discussion happened there and need consensus
18:09:55 <gmaan> #topic Periodic jobs Status Checks
18:10:01 <gmaan> Periodic stable full
18:10:13 <gmaan> #link https://zuul.openstack.org/builds?job_name=tempest-full-2023-2&job_name=tempest-full-2024-1&job_name=tempest-full-2024-2&job_name=tempest-full-2025-1&pipeline=periodic-stable&skip=0
18:10:16 <gmaan> all green
18:10:25 <gmaan> Periodic stable slow
18:10:49 <gmaan> #link https://zuul.openstack.org/builds?job_name=tempest-slow-2024-2&job_name=tempest-slow-2024-1&job_name=tempest-slow-2023-2&job_name=tempest-slow-2025-1&skip=0
18:10:50 <gmaan> all ok
18:11:00 <gmaan> we might need to remove stable/2023.2 jobs?
18:12:07 <gmaan> it still not EOL yet but will be soon
18:12:09 <gmaan> #link https://review.opendev.org/q/topic:%22bobcat-eol%22
18:12:34 <gmaan> I will propose the changes to start the process to stop support of it in tempest
18:13:06 <gmaan> #action gmaan to start series to stop the support of stable/2023.2 in Tempest/QA
18:13:13 <gmaan> Periodic extra tests
18:13:21 <gmaan> #link https://zuul.openstack.org/builds?job_name=tempest-full-2024-2-extra-tests&job_name=tempest-full-2024-1-extra-tests&job_name=tempest-full-2023-2-extra-tests&job_name=tempest-full-2025-1-extra-tests&skip=0
18:13:34 <gmaan> all ok
18:13:34 <gmaan> Periodic master
18:13:48 <gmaan> https://zuul.openstack.org/builds?project=openstack%2Ftempest&project=openstack%2Fdevstack&pipeline=periodic
18:13:50 <gmaan> #link https://zuul.openstack.org/builds?project=openstack%2Ftempest&project=openstack%2Fdevstack&pipeline=periodic
18:13:56 <gmaan> it has some job failing, checking those
18:14:23 <gmaan> for c9s and rocky we had workaround,
18:14:42 <gmaan> #link https://review.opendev.org/c/openstack/devstack/+/948511
18:14:47 <gmaan> this is merged
18:15:43 <gmaan> but c9s job still failing after this fix merge
18:15:45 <gmaan> ERROR: Package 'nova' requires a different Python: 3.9.21 not in '>=3.10'
18:15:53 <gmaan> #link https://zuul.openstack.org/build/b107489a92b4419b9c521c075e5300b4
18:16:02 <gmaan> let me file a bug for this
18:16:31 <gmaan> same failure for c9s fips job #link https://zuul.openstack.org/build/f8d19e501edb44219db8704610f5da8c
18:16:53 <clarkb> Using python 3.9 to install /opt/stack/nova
18:17:03 <clarkb> maybe the fix was incomplete
18:18:10 <gmaan> #link https://bugs.launchpad.net/tempest/+bug/2110744
18:18:26 <gmaan> yeah, devstack change was to use py3.11 for c9s jobs
18:19:03 <gmaan> we might need to pin python version on tempest side job but not sure if we want to keep testing python 3.9 or can do until cs 10 is there
18:20:04 <gmaan> ykarel: ^^
18:20:29 <gmaan> tempest-full-test-account-no-admin-py3 is failing for known bug which i did not get time to look
18:20:42 <gmaan> not sure when I can check it but maybe next week
18:21:02 <opendevreview> Ivan Anfimov proposed openstack/devstack master: Remove temporary fix for problems with CSS styles  https://review.opendev.org/c/openstack/devstack/+/949066
18:21:22 <gmaan> another job failig 100% tempest-full-oslo-master
18:21:28 <gmaan> #link https://zuul.openstack.org/build/6b0ac80fa74d42ff8d4b5a66405989cb
18:21:59 <gmaan> I thought fix is merged for this error
18:22:01 <gmaan> "ImportError: cannot import name 'format_inspector' from 'oslo_utils.imageutils' (/usr/lib/python3/dist-packages/oslo_utils/imageutils.py)
18:22:01 <gmaan> "
18:24:26 <gmaan> cannot find. I konw we had some discussion about it among frickler sean-k-mooney
18:24:36 <gmaan> I will check it with them
18:25:30 <gmaan> #topic Distros check:
18:25:30 <gmaan> Centos 9
18:25:44 <gmaan> #link https://zuul.openstack.org/builds?job_name=tempest-full-centos-9-stream&job_name=devstack-platform-centos-9-stream&skip=0
18:26:34 <gmaan> devstack platform job pass but tempest c9s job failing as mentioned beforew
18:26:44 <gmaan> Debian
18:26:58 <gmaan> #link https://zuul.openstack.org/builds?job_name=devstack-platform-debian-bookworm&skip=0
18:27:41 <gmaan> green except failed once with ssh timeout in volume test
18:27:58 <gmaan> but nothing specific to distro side issue
18:28:00 <gmaan> Rocky
18:28:16 <gmaan> #link https://zuul.openstack.org/builds?job_name=devstack-platform-rocky-blue-onyx
18:28:21 <gmaan> green
18:29:02 <gmaan> but I think we should add tempest job also for rocky as that capture more issue than just platform job. similar to c9s job
18:29:24 <gmaan> #action gmaan to add rocky based tempest job and add it in periodic pipeline
18:29:59 <gmaan> nothing in Open Discussion
18:30:08 <gmaan> let's close the office hour
18:30:11 <gmaan> #endmeeting