18:01:24 <gmaan> #startmeeting qa
18:01:24 <opendevmeet> Meeting started Wed Jun 25 18:01:24 2025 UTC and is due to finish in 60 minutes.  The chair is gmaan. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:24 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:24 <opendevmeet> The meeting name has been set to 'qa'
18:01:52 <gmaan> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
18:02:01 <gmaan> today agenda ^^
18:03:00 <opendevreview> Merged openstack/devstack stable/2025.1: Remove libvirt apparmor workaround  https://review.opendev.org/c/openstack/devstack/+/950289
18:03:21 <gmaan> let's start
18:03:41 <gmaan> #topic Announcement and Action Item (Optional)
18:04:00 <gmaan> one action item - gmaan to start end of support for stable/2023.2 from Tempest
18:04:38 <gmaan> I proposed the changes for tempest new tag as well as for plugins
18:04:42 <gmaan> #link https://review.opendev.org/q/topic:%222023-2-last%22
18:05:22 <gmaan> a few plugins releases not merged yet but tempest tag is released to mark the end of support
18:05:55 <gmaan> and removed the stable/2023.2 testing from tempest master gate
18:05:57 <gmaan> #link https://review.opendev.org/c/openstack/tempest/+/952403
18:06:12 <gmaan> I will mark this done and remaining plugins releases changes can be tracked separatly
18:06:52 <gmaan> #topic Priority Items progress
18:07:02 <gmaan> #link https://etherpad.opendev.org/p/qa-2025-2-priority
18:07:26 <gmaan> some progress on 'Move tempest tests to new SRBAC defaults'
18:07:41 <gmaan> I started testing the project manager role on nova policy
18:07:56 <gmaan> also fixing the bug we have for project manager user creation
18:08:11 <gmaan> #link https://review.opendev.org/c/openstack/tempest/+/949534
18:09:10 <gmaan> Rocky Linux and Centos Stream testing: - this one is fixed now at least with workaround so marking it close in tracker
18:10:22 <gmaan> no updates on pre-provisioned  and fips testing item
18:10:38 <gmaan> #topic Gate Status / Fix Checks
18:10:45 <gmaan> Gate Blocker Fix / Urgent Change
18:10:57 <gmaan> #link https://review.opendev.org/q/label:Review-Priority%253D%252B2+status:open+(project:openstack/tempest+OR+project:openstack/patrole+OR+project:openstack/devstack+OR+project:openstack/grenade)
18:11:47 <gmaan> 2 are waiting for author and one new one is not reviewed
18:11:50 <gmaan> #link https://review.opendev.org/c/openstack/devstack/+/949066
18:12:10 <gmaan> I would like to see horixon core +1 here
18:13:08 <gmaan> #topic Changes with Review-Priority == +1
18:13:19 <gmaan> #link https://review.opendev.org/q/label:Review-Priority%253D%252B1+status:open+(project:openstack/tempest+OR+project:openstack/patrole+OR+project:openstack/devstack+OR+project:openstack/grenade)
18:14:39 <gmaan> reviewing those
18:22:35 <gmaan> I did review most of them, a few pending on author response or either zuul -1
18:22:38 <gmaan> #topic Periodic jobs Status Checks
18:22:44 <gmaan> Periodic stable full
18:23:00 <gmaan> #link https://zuul.openstack.org/builds?job_name=tempest-full-2023-2&job_name=tempest-full-2024-1&job_name=tempest-full-2024-2&job_name=tempest-full-2025-1&pipeline=periodic-stable&skip=0
18:23:23 <gmaan> last run of tempest-full-2024-1 failed
18:23:39 <gmaan> #link https://zuul.openstack.org/build/165695c796424530b8eaddd637717279
18:23:45 <gmaan> etcd issue
18:23:53 <gmaan> Periodic stable slow
18:24:09 <gmaan> #link https://zuul.openstack.org/builds?job_name=tempest-slow-2024-2&job_name=tempest-slow-2024-1&job_name=tempest-slow-2023-2&job_name=tempest-slow-2025-1&skip=0
18:24:29 <gmaan> last run of tempest-slow-2024-2 failed
18:24:43 <gmaan> #link https://zuul.openstack.org/build/89ac8284f86d42d1b7b503f6b41b2b6e
18:25:14 <gmaan> same issue
18:25:20 <gmaan> Periodic extra tests
18:25:32 <gmaan> #link https://zuul.openstack.org/builds?job_name=tempest-full-2024-2-extra-tests&job_name=tempest-full-2024-1-extra-tests&job_name=tempest-full-2023-2-extra-tests&job_name=tempest-full-2025-1-extra-tests&skip=0
18:25:35 <gmaan> all green
18:25:43 <gmaan> Periodic master
18:26:00 <gmaan> #link https://zuul.openstack.org/builds?project=openstack%2Ftempest&project=openstack%2Fdevstack&pipeline=periodic
18:26:06 <gmaan> last run for 3 jobs failing
18:26:43 <gmaan> tempest-full-test-account-no-admin-py3  is known issue which I did not get time to debug/fix
18:27:28 <gmaan> let me add action item to me so that it will remind me more closely than biweekly checks
18:27:38 <gmaan> #action gmaan to debug the tempest-full-test-account-no-admin-py3  failure
18:28:04 <gmaan> rocky linux also hitting etcd issue
18:28:23 <gmaan> same with devstack-no-tls-proxy  job
18:28:42 <gmaan> #topic Distros check:
18:28:49 <gmaan> Centos 9
18:29:04 <gmaan> #link https://zuul.openstack.org/builds?job_name=tempest-full-centos-9-stream&job_name=devstack-platform-centos-9-stream&skip=0
18:29:12 <gmaan> one failure in between but almost passing
18:29:18 <gmaan> Debian
18:29:33 <gmaan> #link https://zuul.openstack.org/builds?job_name=devstack-platform-debian-bookworm&skip=0
18:29:34 <gmaan> same
18:29:40 <gmaan> Rocky Linux
18:30:34 <gmaan> #link https://zuul.openstack.org/builds?job_name=devstack-platform-rocky-blue-onyx&job_name=tempest-full-rocky&skip=0
18:30:55 <gmaan> this also mix of passing and failing (some tests on volume status)
18:31:04 <gmaan> #topic Open Discussion
18:31:11 <gmaan> nothing here
18:31:15 <gmaan> closing the meeting
18:31:21 <gmaan> #endmeeting