18:00:53 <gmaan> #startmeeting qa
18:00:53 <opendevmeet> Meeting started Wed Aug 20 18:00:53 2025 UTC and is due to finish in 60 minutes.  The chair is gmaan. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:53 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:53 <opendevmeet> The meeting name has been set to 'qa'
18:01:26 <gmaan> meeting time, I am in middle of something else but try to do checks on periodic stuff and if anything else in topic
18:01:38 <gmaan> #link https://wiki.openstack.org/wiki/Meetings/QATeamMeeting#Agenda_for_next_Office_hours
18:01:48 <gmaan> today agenda^^
18:02:06 <gmaan> #topic Announcement and Action Item (Optional)
18:02:51 <gmaan> one update, I added my nomination to continue PTL for QA but note, I am continuing bcz no one else there. ping me if any volunteer to take this role in this or next cycle
18:03:11 <gmaan> so QA is not leaderless project list at least for this cycle
18:03:33 <gmaan> #topic Priority Items progress
18:03:35 <gmaan> #link https://etherpad.opendev.org/p/qa-2025-2-priority
18:04:38 <gmaan> I am continuing on RBAC testing. Manager role for nova is done, fixed a one bug for tempest manager user which should help or unhide the other service manager role testing
18:04:58 <gmaan> I started the service role setup in tempest (sending the serviec token along with user token)
18:05:05 <gmaan> #link https://review.opendev.org/c/openstack/tempest/+/892639
18:05:30 <gmaan> still testing it with nova change but this is direction of service-to-service API tetsing in tempest.
18:06:05 <gmaan> I saw some project/tests used a user with service role to test those API which is not the way how service communicate to other sercvice
18:06:52 <gmaan> it should be a user token but have service token embedded inline to request and keystyone middleware populate the request context with service token data
18:07:15 <gmaan> anyways once done, I will will send this proper way of testing to ML also
18:08:37 <gmaan> #topic OpenStack Events Updates and Planning (Optional)
18:08:57 <gmaan> no update on this.
18:09:09 <gmaan> #topic Gate Status / Fix Checks
18:09:20 <gmaan> #link https://review.opendev.org/q/label:Review-Priority%253D%252B2+status:open+(project:openstack/tempest+OR+project:openstack/patrole+OR+project:openstack/devstack+OR+project:openstack/grenade)
18:10:31 <gmaan> it seems there are two new changes, one in review for CVE
18:11:33 <gmaan> I +w other one
18:11:36 <gmaan> #topic Changes with Review-Priority == +1
18:11:45 <gmaan> #link https://review.opendev.org/q/label:Review-Priority%253D%252B1+status:open+(project:openstack/tempest+OR+project:openstack/patrole+OR+project:openstack/devstack+OR+project:openstack/grenade)
18:12:47 <gmaan> I am not sure a few of them are really priority or just tagged as priority.
18:12:57 <gmaan> but most of them under review
18:13:12 <gmaan> #topic Periodic jobs Status Checks
18:13:53 <gmaan> Periodic Master jobs: OK except know bug in account job
18:13:55 <gmaan> #link https://zuul.openstack.org/builds?project=openstack%2Ftempest&project=openstack%2Fdevstack&pipeline=periodic
18:14:02 <gmaan> Periodic Stable jobs:
18:14:21 <gmaan> #LINK https://zuul.openstack.org/builds?job_name=tempest-full-2023-2&job_name=tempest-full-2024-1&job_name=tempest-full-2024-2&job_name=tempest-full-2025-1&pipeline=periodic-stable&skip=0
18:14:33 <gmaan> #link https://zuul.openstack.org/builds?job_name=tempest-slow-2024-2&job_name=tempest-slow-2024-1&job_name=tempest-slow-2025-1&skip=0
18:14:41 <gmaan> #link https://zuul.openstack.org/builds?job_name=tempest-multinode-2025-1&job_name=tempest-multinode-2024-1&job_name=tempest-multinode-2024-2&skip=0
18:14:49 <gmaan> #link https://zuul.openstack.org/builds?job_name=tempest-full-2024-2-extra-tests&job_name=tempest-full-2024-1-extra-tests&job_name=tempest-full-2023-2-extra-tests&job_name=tempest-full-2025-1-extra-tests&skip=0
18:15:00 <gmaan> all looks green
18:15:04 <gmaan> #topic Distros check:
18:15:20 <gmaan> Centos 9: OK
18:15:22 <gmaan> #link https://zuul.openstack.org/builds?job_name=tempest-full-centos-9-stream&job_name=devstack-platform-centos-9-stream&skip=0
18:15:41 <gmaan> we should add cs10 job here, I will do after meeting
18:16:07 <gmaan> #action gmaan to add cs10 job in periodic distro testing checks
18:16:50 <gmaan> Rocky Linux: ok, at least latest run are passing though there are some failure in between
18:16:52 <gmaan> #link https://zuul.openstack.org/builds?job_name=devstack-platform-rocky-blue-onyx&job_name=tempest-full-rocky&skip=0
18:17:14 <gmaan> Ubuntu: ok
18:17:16 <gmaan> #link https://zuul.openstack.org/builds?job_name=devstack-platform-ubuntu-noble-ovn-source&job_name=devstack-platform-ubuntu-noble-ovs&job_name=devstack-platform-ubuntu-jammy&skip=0
18:17:31 <gmaan> nothing in Open Discussion
18:17:52 <gmaan> still I will wait for couple of min if any topic to be discussed
18:20:42 <gmaan> #endmeeting