21:00:33 <danwent> #startmeeting quantum
21:00:33 <openstack> Meeting started Mon Jan 14 21:00:33 2013 UTC. The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:36 <gongysh> hel
21:00:37 <openstack> The meeting name has been set to 'quantum'
21:00:43 <arosen> hi
21:00:47 <mlavalle> hi
21:00:48 <nati_ueno> hi
21:00:49 <danwent> #link agenda: http://wiki.openstack.org/Network/Meetings
21:01:00 <zyluo> hi
21:01:02 <danwent> ok, welcome to the grizzly-3 milestone!
21:01:06 <danwent> #topic announcements
21:01:14 <danwent> #info Now in Grizzly-3, the final milestone for Grizzly. Branch date is Feb 19th (http://wiki.openstack.org/GrizzlyReleaseSchedule)
21:01:16 <mestery> o/
21:01:22 <danwent> #info Summit Announced: http://www.openstack.org/summit/portland-2013/
21:01:43 <danwent> if you are an active developer and have not gotten a summit invite, please ping thierry and CC me.
21:01:57 <danwent> #info Foundation individual member elections are open: http://www.openstack.org/election/2013-board-election/CandidateList/
21:02:16 <danwent> I think we have at least one quantum team member on the list of those running, right kyle?
21:02:33 <danwent> any other announcements before we get started?
21:02:34 <mestery> danwent: Correct! I'm in the running.
21:03:11 <gongysh> mestery: u should tell me earlier.
21:03:22 <gongysh> haha
21:03:26 <mestery> gongysh: :)
21:03:30 <danwent> #topic quantum documentation
21:03:53 <danwent> At this point, we're at the same place on docs as we were two weeks agog.
21:03:57 <danwent> https://bugs.launchpad.net/openstack-manuals/+bugs?field.tag=quantum
21:04:20 <annegentle_itsme> I'd like more eyes on this one: https://review.openstack.org/#/c/18650/
21:04:20 <danwent> gongysh, arosen, we should probably take out references to the nova handler for quantum security groups, no?
21:04:38 <mestery> danwent: I'd like to help with some of these docs bugs, I'll see what I can do this week.
21:04:50 <danwent> annegentle_itsme: that code hasn't merged yet and is still under discussion, so probably not yet to to merge it.
21:04:51 <gongysh> arosen: what does u think of?
21:04:55 <arosen> danwent: I agree since we should hopefully get that integration directly into nova soon.
21:04:59 <annegentle_itsme> danwent: ah that makes sense
21:05:17 <gongysh> ok.
21:05:18 <danwent> gongysh: should that schedule review be marked WIP?
21:05:32 <danwent> gongysh: until the code is merged?
21:05:41 <gongysh> sure
21:05:47 <danwent> arosen: is there nova BP for the proxy? if so, who is assigned?
21:05:59 <arosen> There is. I'm currently assigned.
21:06:02 <danwent> arosen: i don't want the same thing to happen with security groups as happened to floating IPs.
21:06:18 <danwent> arosen: ok, can you send out a pointer?
21:06:38 <danwent> arosen: i guess we can discuss in G-3 section, as its not really docs. sorry
21:06:39 <arosen> https://blueprints.launchpad.net/nova/+spec/nova-quantum-security-group-proxy
21:06:45 <arosen> k
21:06:52 <danwent> https://bugs.launchpad.net/openstack-api-site/+bugs?field.tag=netconn-api
21:07:09 <danwent> looks like we are good there.
21:07:27 <danwent> So my big ask to people on the docs side is to start filing bugs for G-1 and G-2 items that have merged, but are not documented.
21:07:30 <gongysh> there is a section misssing about provider ex.
21:07:36 <gongysh> on netconn-api.
21:07:59 <danwent> gongysh: ok, can you file a bug and make it 'high' so we have it on our radar?
21:08:09 <gongysh> ok.
21:08:21 <danwent> perhaps mestery can handle that, if he is so inclined :)
21:08:40 <mestery> danwent, gongysh: I can do that.
21:09:12 <mestery> danwent: I noticed also that the guide here doesn't appear to be complete near the end http://docs.openstack.org/trunk/openstack-network/admin/content/app_demo_routers_with_private_networks.html
21:09:13 <danwent> ok, and in terms of new bugs that need to be filed.
21:09:29 <mestery> Planning to file a bug on that one too. Seems like it stops in the middle of explaining the deployment scenarioi.
21:09:47 <mestery> Anywys, FYI
21:09:59 <danwent> mestery: thanks for pointing that out.
21:10:14 <danwent> DB upgrade
21:10:14 <mestery> danwent: Just noticed it today while looking for something else actually.
21:10:32 <danwent> we have security groups documented already, is that right arosen ?
21:10:53 <gongysh> mestery: that is done by me. I stopped in middle? maybe
21:11:17 <mestery> gongysh: Seems maybe that is the case. :)
21:11:20 <danwent> markmcclain: can you file a bug for what is needed to document the user (not developer) part of DB upgrade?
21:11:27 <amotoki> danwent: we have already secgroup docs in admin guide.
21:11:32 <gongysh> mestery: welcome to file a bug and fix it.
21:11:36 <danwent> amotoki: thanks for the confirm
21:11:43 <mestery> gongysh: Will do, thanks!
21:11:46 <danwent> markmcclain: or do you expect packaging to handle that?
21:11:52 <markmcclain> danwent: sure
21:12:09 <markmcclain> I'll document since not everyone will use packaging
21:12:35 <danwent> salv-orlando: can you make sure we have bugs filed for each new API extension + mechanism?
21:12:57 <salv-orlando> danwent: sure. Can you clarify what you mean by 'mechanism'?
21:13:05 <danwent> i am thinking lbaas, service-type
21:13:10 <salv-orlando> ok gotcha
21:13:24 <danwent> sorry, what I mean to say is one bug for API doc, one for admin doc.
21:13:55 <salv-orlando> #action salv-orlando to file doc bugs for new undocumented API extensions (both netconn-api and openstack-manuals)
21:13:56 <salv-orlando> )
21:14:10 <danwent> moving forward, it would be great if during code reviews, we make sure all appropriate documentation bugs are filed if the change is user-visiible.
21:14:29 <danwent> markmcclain: can you also file one for running the metadata service?
21:14:47 <markmcclain> will do
21:14:58 <danwent> ok, anything else on docs front?
21:15:17 <danwent> #topic grizzly-3 milestone
21:15:40 <danwent> ok, time goes by so fast. we are now to the third and final milestone in the grizzly cycle
21:15:52 <gongysh> time flies.
21:16:04 <danwent> #info we already have 31 blueprints assigned to G-3, which is way more than will be completed.
21:16:24 <danwent> #info please make sure we focus on what we think we can complete with a high probability
21:17:15 <danwent> #info I want to try and rely on the sub-team leads more moving forward. So if you are a sub-team lead, please look through items currently assigned to g-3, and assign yourself as the approver if it is work for your team https://launchpad.net/quantum/+milestone/grizzly-3)
21:17:51 <danwent> I will be asking the sub-team leads to help create the agenda for team meetings moving forward, as they identify items from their sub-teams that need wider attention.
21:18:32 <danwent> With G-3 starting, I wanted to call attention to a couple discussions around existing items that I think its important that the team tackle in G-3
21:18:51 <danwent> first off, the discussion aroudn improving vif-plugging (this is across both nova + quantu): https://blueprints.launchpad.net/quantum/+spec/vif-plugging-improvements and https://blueprints.launchpad.net/nova/+spec/libvirt-vif-driver
21:19:29 <danwent> garyk has been driving this from a quantum side, working with Daniel Berrange from RH on the nova side
21:19:33 <garyk> danwent: i think that the vif improvement can be closed. danpb is working on the nova side. akihiro added in some additional goodies
21:19:57 <danwent> garyk: I still think this is very libvirt specific
21:20:07 <garyk> danwent: true.
21:20:31 <danwent> garyk: and I have some concerns around how things work as more fields are added to extension over time, or to how libvirt configured networking
21:20:56 <garyk> danwent: understood.
21:21:07 <amotoki> garyk: we need to figure out what information should be passed to nova and how to add an attribute.
21:21:09 <mestery> danwent: See Daniel's reply he just sent, FYI.
21:21:15 <danwent> garyk: I am nervous about additional fields just be added to this dictionary over time, making it a hode-podge. anyway, I sent a note to the list, which I expect other daniel will flame :)
21:21:23 <danwent> haha, i figured.
21:21:37 <garyk> danwent: :)
21:22:02 <mestery> danwent: I think Daniel's response was fairly pragmatic, given his involvement with libvirt. :)
21:22:02 <garyk> danwent: let me do a little homework and we can syc next week. sound reasonable?
21:22:14 <danwent> garyk: i appreciate it. thanks.
21:22:45 <danwent> mestery: i haven't seen it yet, i was just basing my comments off previous replies on a private thread. I think daniel and I actually agree on 90%+ of things.
21:23:10 <danwent> mestery: this might be a good area for you to be getting involved in as well
21:23:29 <danwent> mestery: that's why i wanted to open up the discussion more. in hindsight, should have done that much earlier.
21:23:59 <mestery> danwent: Agreed. Thanks for opening it up, and I agree with you.
21:24:23 <danwent> #info please check out ML thread on vif-plugging.
21:24:38 <danwent> next area I wanted to highlight was https://blueprints.launchpad.net/quantum/+spec/quantum-scheduler
21:24:58 <gongysh> haha, scheduler time
21:25:01 <danwent> i think we as a community need to be sure to execute on something in G-3 that provides ha/scale-out properties for dhcp + l3
21:25:35 <gongysh> yes. that is the of of tenets of Openstack.
21:25:36 <danwent> so I want to make sure we get good design discussion attention on this early, as the actual code changes may be substantial, so we need plenty of time for review as well
21:26:22 <danwent> #info quantum scheduler design doc is here: https://docs.google.com/a/nicira.com/document/d/1TJlW0_tMpeENA_ia38fvRu7ioKRt9fsWXBjivwd1mMw/edit
21:26:47 <danwent> please give your attention to commenting on this very early in G-3 (i..e, start this week)
21:27:08 <danwent> gongysh: looks like the spec has expanded since I last looked at it. will give it another read.
21:27:24 <gongysh> thanks
21:27:30 <danwent> gongysh: anything else to comment on this, other than that the docs are already available as well?
21:27:53 <gongysh> codes are in review too.
21:28:17 <danwent> https://review.openstack.org/#/c/18650/ (docs)
21:28:19 <gongysh> plus admin doc, cli command.
21:28:39 <danwent> https://review.openstack.org/#/c/18216/ (code)
21:28:51 <danwent> gongysh: ah, can you send pointer to admin docs review?
21:28:52 <gongysh> pdf admin guide was sent out one month ago to mail list.
21:29:33 <gongysh> https://review.openstack.org/#/c/18650/
21:29:38 <danwent> gongysh: thx.
21:29:59 <danwent> ok, next item is the hyper-v plugin https://blueprints.launchpad.net/quantum/+spec/quantum-plugin-hyper-v
21:30:13 <alexpilotti> hi there! :-)
21:30:33 <danwent> review now has two +2's from garyk and gongysh : https://review.openstack.org/#/c/18989/
21:31:01 <gongysh> thanks for alexpilotti's efforts.
21:31:07 <danwent> we were blocking merger, since this is a new plugin, it needed a core dev to agree to be the maintainer, and I wanted to general team discussion to see if there were any other concerns with the plugin being added.
21:31:25 <danwent> my understanding is that we have a core dev who has volunteered to be the maintainer? gongysh ?
21:31:32 <gongysh> yes.
21:31:54 <alexpilotti> I have to add that gongysh did an impressive work in testing and reviewing the plugin
21:32:08 <danwent> gongysh has a lot of cycles devoted to quantum, and is not the maintainer of any other plugins, so I don't see a resource issue there.
21:32:28 <danwent> alexpilotti: is the long-term goal for you or someone on your team to try and become a core dev, or to have gongysh maintain?
21:33:00 <alexpilotti> danwent: I'd gladly like to become a core dev to mantain the plugin
21:33:23 <danwent> alexpilotti: ok, would be great to have you working toward that goal.
21:33:34 <alexpilotti> as you know we as a company are very serious in mantaining the code and providing new features
21:33:42 <danwent> in the mean time, I wanted to see if anyone has any concerns around gongysh being the maintainer and this plugin merging?
21:34:17 <danwent> given the number of plugins I expect to have proposed soon, I wanted to have a bit more of a discussion around each new plugin, but I personally don't have concerns with this plugin in particular… everything seems pretty ship-shape.
21:34:28 <alexpilotti> from our pint of view, I couldn't see a better choice than gongysh
21:35:00 <danwent> ok, if there are no other concerns, I'll remove my -2 from the review, now that we have a core maintainer.
21:35:28 <danwent> alexpilotti, gongysh please file the appropriate doc bugs associated with the plugin.
21:35:37 <gongysh> sure
21:35:48 <alexpilotti> sure, tx danwent, gongysh!
21:36:17 <danwent> gongysh, garyk, one of you two can click approve :)
21:36:17 <mestery> Welcome to Quantum Hyper-V!
21:36:35 <danwent> :)
21:36:39 <alexpilotti> :-)
21:36:43 <gongysh> ok
21:36:47 <danwent> i want a screenshot of quantum running on windows :)
21:37:02 <gongysh> we will have.
21:37:02 <sthakkar> :)
21:37:06 <garyk> danwent: i'll let yong have the honor
21:37:10 <alexpilotti> danwent: you'll have an entire session in Portland ;-)
21:37:17 <danwent> ok, next topic: lbaas
21:37:33 <danwent> in G-2, we made good progress. the API merged, as did the DB CRUD operations.
21:37:49 <danwent> in G-3, I feel we need to merge at least one open source plugin/driver
21:38:07 <danwent> we currently have the following bp, which I believe is tracking this: https://blueprints.launchpad.net/quantum/+spec/lbaas-agent-and-rpc
21:38:17 <sthakkar> i believe Eugene & team have started some work here, right?
21:38:32 <danwent> sthakkar: yes, I believe so. was looking for an update from them.
21:39:15 <danwent> is anyone from the mirantis team at the meeting?
21:39:35 <danwent> my understanding is that he was working with leon, and testing leon's DB patch with their internal driver code.
21:39:35 <sthakkar> Oleg / Eugene are you guys on?
21:39:46 <sthakkar> danwent: yep i think so
21:40:02 <sthakkar> danwent: If they aren't on right now, I can drop them a note to follow up
21:40:04 <danwent> #todo sthakkar, can you check up on status there and report next meeting?
21:40:07 <danwent> haha
21:40:10 <danwent> yes, please
21:40:26 <sthakkar> will do
21:41:00 <danwent> ok, next up: python client + CLI discussions: https://etherpad.openstack.org/grizzly-quantum-cli-client, https://bugs.launchpad.net/python-quantumclient/+bug/1094713
21:41:02 <uvirtbot> Launchpad bug 1094713 in python-quantumclient "extension commands and options should be marked" [Wishlist,New]
21:41:32 <danwent> we had a lot of discussion around python client + CLI at the summit
21:41:44 <danwent> I wanted to make sure we circle back and discuss this before grizzly is over :)
21:42:07 <danwent> markmcclain: now that namespace + DB upgrade stuff is wrapped up, is this on the docket for G-3?
21:42:13 <markmcclain> yes
21:42:26 <markmcclain> also since I've got a few volunteers to help with a few other bp's too
21:43:04 <danwent> great. gongysh, markmcclain, can we clean up https://blueprints.launchpad.net/python-quantumclient a bit?
21:43:31 <danwent> we should talk about how to number the python-quantumclient release that we do around the grizzly release
21:43:32 <markmcclain> yes
21:44:26 <gongysh> 3.0 for Grizzly?
21:44:29 <danwent> basically, we'll need to create a release that we can assign bugs/blueprints to.
21:44:50 <danwent> and be able to track progress toward exactly what we think will be released
21:45:15 <danwent> gongysh: the changes at the python layer seem significant enough to merit a major version change, but up to you all :)
21:45:15 <markmcclain> I think 3.0 makes sense
21:45:37 <gongysh> ok, 3.0 for grizzly.
21:46:09 <gongysh> But I don't know how to make a milestone for it. markmcclain, do u know how to do it?
21:46:23 <danwent> ok, 15 minutes left
21:46:26 <amotoki> I also want to mark adddressed bugs as "Fix released" at some timing to cleanup bugs.
21:46:28 <gongysh> I mean on the launchpad.net
21:46:28 <markmcclain> no.. but I'll figure out after mtg
21:46:32 <danwent> wanted to move on pretty quickly to remaining items.
21:46:35 <gongysh> ok.
21:46:52 <gongysh> next, please.
21:46:52 <danwent> but please make any work you're planning to do in G-3 proposed in launchpad by next week's meeting.
21:46:59 <danwent> #topic quantums table
21:47:05 <danwent> #topic quantum stable
21:47:06 <danwent> :)
21:47:24 <danwent> garyk: do we have final date for stable release at end of month?
21:47:25 <gongysh> :) table
21:47:38 <danwent> yes, its quantum's table :)
21:47:40 <garyk> danwent: as far as i know 31st of the montj
21:47:55 <garyk> sorry month.
21:48:48 <danwent> garyk: ok. seems like there are a fair number of stable reviews out right now.
21:49:07 <danwent> but seems manageble.
21:49:20 <garyk> danwent: yes. there are 2 or 3 pending back porting. i'd like to do these once he current list is thourgh.
21:49:22 <danwent> at next meeting, if there is still a stable backlog, we'll review.
21:49:50 <danwent> garyk: yup. next meeting we can call out any high priority items still languishing
21:49:57 <danwent> #topic quantum system test
21:49:58 <garyk> ok. basically i need a stable core to give thumbs up. the majority have had good reviews from quantum reviewers
21:50:35 <danwent> any update on quantum system test?
21:50:53 <mlavalle> danwent: I am developing https://blueprints.launchpad.net/tempest/+spec/quantum-basic-api
21:51:03 <nati_ueno> I'm investigating why quantum-gating sometimes fails
21:51:11 <mlavalle> targeting G-3
21:51:20 <danwent> nati_ueno: great, was just in process of asking :)
21:51:32 <danwent> mlavalle: ok, so sounds like we've de-dupped efforts, great.
21:51:39 <danwent> #topic quantum + horizon
21:51:53 <danwent> amotoki, nati_ueno. did items merge for G-2 as expected?
21:52:02 <nati_ueno> danwent: yes
21:52:02 <amotoki> yes.
21:52:10 <danwent> sweet, great work guys!
21:52:24 <danwent> ok, can you send out pointers to work items for G-3?
21:52:30 <amotoki> L3 router and additional operations are available.
21:52:35 <amotoki> danwent: i updated the wiki.
21:52:43 <danwent> at this point, I don't believe anyone is working on lbaas + horizon, are they?
21:52:51 <garyk> danwent: amotoki: are we going to have provider network support?
21:52:56 <danwent> amotoki: ah, you are sly :)
21:53:02 <danwent> https://blueprints.launchpad.net/horizon/+spec/quantum-floating-ip
21:53:02 <danwent> https://blueprints.launchpad.net/horizon/+spec/quantum-network-topology
21:53:03 <danwent> https://blueprints.launchpad.net/horizon/+spec/quantum-vnic-ordering
21:53:04 <danwent> https://blueprints.launchpad.net/horizon/+spec/quantum-security-group
21:53:21 <danwent> lbaas + horizon might be a cool thing for someone looking for a project.
21:53:30 <amotoki> garyk: provider network information is displayed in detail.
21:53:32 <danwent> as having a gui makes it much easier to demo a capability
21:53:38 <garyk> amotoki: thanks
21:54:01 <amotoki> the first one can be uploaded to review this week.
21:54:25 <danwent> ok, great work on this guys.
21:54:30 <danwent> anything else on quantum/horizon?
21:54:45 <danwent> #topic open discussion
21:55:05 <danwent> vishy pinged me about https://blueprints.launchpad.net/nova/+spec/network-adapter-hotplug. the corresponding review seems abandoned.
21:55:44 <danwent> having hotplug seems useful in a lot of circumstances though, so i'll be fishing around for someone interested in working on this.
21:55:59 <danwent> any other open discussion? up to 5 minutes left in the meeting
21:56:22 <danwent> (but no need to take it up if no one has anything....)
21:56:23 <danwent> (but no need to take it up if no one has anything….)
21:56:35 <mestery> danwent: An early end to a Quantum meeting? :)
21:56:38 <danwent> ok, that's all folks!
21:56:45 <danwent> #endmeeting