21:00:28 <danwent> #startmeeting quantum
21:00:29 <openstack> Meeting started Mon Feb 11 21:00:28 2013 UTC.  The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:30 <shiv> Hi all
21:00:33 <openstack> The meeting name has been set to 'quantum'
21:00:39 <danwent> #info agenda: http://wiki.openstack.org/Network/Meetings
21:01:05 <danwent> #info ok folks, take a deep breath and get ready for a week of crazy reviewing.  We're one week out from G-3!
21:01:51 <danwent> #info all BPs must be in for review by tomorrow.  core devs, don't be afraid to call BS on something that is "in review" in name only
21:01:58 <salv-orlando> aloha
21:02:25 <garyk> hi
21:02:34 <SumitNaiksatam> hello!
21:02:35 <danwent> #info good news is that we're seeing more green on https://launchpad.net/quantum/+milestone/grizzly-3
21:03:01 <danwent> #info bad news i that there's still a ton to review, likely more than we can do a good job on reviewing.
21:03:24 <danwent> so be sure to prioritize things well, and focus cycles on things that stand a good chance of making it all the way through the pipeline
21:03:41 <danwent> #info we still have 20 items outstanding for G-3
21:03:54 <danwent> #info We will not be giving feature freeze exceptions for non high/critical issues.
21:04:02 <danwent> #info Remember to file doc bugs as we merge in G-3 features.
21:04:06 <danwent> any other announcements?
21:04:55 <danwent> ok, we're adding a new segment to our meeting, as markmcclain has started triaging and tagging all incoming bugs to make sure nothing is lost as we near the critical release period
21:05:05 <danwent> #topic important bug review (markmcclain )
21:05:23 <garyk> markmcclain: great work on this
21:05:38 <danwent> markmcclain: are any of those bugs unassigned?
21:05:52 <markmcclain> Yes about half are unassigned
21:06:05 <danwent> might be a good thing to highlight, as at this point in the cycle, any high/critical bug should be assigned or we should be working on finding someone
21:06:43 <markmcclain> https://bugs.launchpad.net/quantum/+bug/1080846
21:06:46 <uvirtbot> Launchpad bug 1080846 in quantum "rootwrap error in devstack w/quantum from quantum-dhcp" [High,Confirmed]
21:06:53 <markmcclain> is unassigned
21:07:18 <danwent> btw, we need to decide if we want to change this or not.  i have the code, but its not clear we want to change it.  feel free to comment.: https://bugs.launchpad.net/quantum/+bug/1111572
21:07:20 <uvirtbot> Launchpad bug 1111572 in quantum "quantum subnet-update can't update allocation-pool " [High,Confirmed]
21:08:09 <salv-orlando> I have a comment on this bug
21:08:12 <danwent> ok, i can take a look at the rootwrap one.
21:08:15 <salv-orlando> https://bugs.launchpad.net/quantum/+bug/1076179
21:08:16 <uvirtbot> Launchpad bug 1076179 in quantum "400 should be returned when invalid attributes are passed to Quantum API" [High,In progress]
21:08:39 <garyk> i can also take a bug or 2
21:08:49 <salv-orlando> isn't the same? The scope of 1076179 has been changed. The assignee says he will file a patch soon.
21:09:30 <danwent> salv-orlando: which are the same?
21:09:58 <salv-orlando> 1111572 & 1076179 (you have to read the description and comments, it's not evident from the bug title)
21:10:17 <salv-orlando> both basically are going to address the issue of returning 400 on unknown attributes
21:10:56 <danwent> salv-orlando: ah, but the question on 1111572 is whether we actually want it to be permissible to update allocation_pools after creating a subnet
21:11:09 <danwent> anyway, let's take this offline
21:11:20 <danwent> ok markmcclain any other unassigned on your list?
21:11:48 <markmcclain> not now
21:12:03 <danwent> ok, thanks again for doing this.
21:12:11 <danwent> #topic api team (salv-orlando)
21:12:36 <salv-orlando> things are pretty calm on the API side.
21:12:53 <salv-orlando> XML patch is merged (possibly just some clean up needed for unused methods)
21:12:58 <danwent> woohoo
21:12:59 <salv-orlando> We should merge pagination this week.
21:13:27 <danwent> ok, sound like api stuff is looking good.  anything else?
21:13:30 <salv-orlando> Alex Xu has done a great job on it. It's totally bw compatible and won't disrupt any plugin.
21:13:38 <salv-orlando> just minor outstanding bugs
21:13:44 <markmcclain> yeah the pagination is looking good
21:13:45 <nati_ueno> +1 for Alex
21:13:58 <danwent> awesome, great work alex
21:14:12 <danwent> #topic l3/ipam/dhcp
21:14:14 <amotoki> client side for XML is still under review.
21:14:16 <danwent> (markmcclain )
21:14:27 <markmcclain> we have 1 high item left
21:14:32 <salv-orlando> amotoki: I approved it :/
21:14:42 <markmcclain> Yong split multi L3/DHCP into 3 reviews
21:14:50 <amotoki> salv-orlando: thanks
21:15:18 <markmcclain> the reviews recevied light traffic, so I encourage everyone to check them out
21:15:19 <danwent> markmcclain: i owe reviews there
21:15:31 <danwent> markmcclain: will be reviewing later today, i promise :)
21:15:38 <markmcclain> since the review are stacked
21:15:44 <markmcclain> start with this one
21:15:44 <markmcclain> https://review.openstack.org/#/c/21049/
21:16:14 <danwent> we should get yong to abandon the other one: https://review.openstack.org/#/c/18216/
21:16:26 <danwent> rather than just -2 it
21:16:45 <markmcclain> yeah.. that should help avoid confusion
21:17:04 <markmcclain> he's on holiday so we will have to wait until he returns to remove it
21:17:27 <markmcclain> moving onto our doc item
21:17:40 <markmcclain> we have one high priority item that needs an author
21:17:57 <danwent> btw, on the topic of docs, salv-orlando are there doc plans for XML API?
21:18:09 <danwent> we should at least file an issue to track it
21:18:18 <danwent> (as each major item merges)
21:18:34 <annegentle> danwent: with samples provided, ladquin could work on XML integration into the WADL API doccs
21:18:43 <salv-orlando> danwent: A manually generated WADL for XML is in progress already I think
21:19:00 <zyluo> Almost done
21:19:06 <zyluo> some minor bugs left
21:19:08 <nati_ueno> annegentle: cool
21:19:11 <salv-orlando> and zyluo has more on WADL too
21:19:15 <danwent> annegentle: that would be great.  please work with salv-orlando and alex (not sure of his nick)
21:19:25 <salv-orlando> zyluo is the WADL guy
21:19:47 <danwent> salv-orlando: ah, isn't alex the one who did XML work?
21:19:54 <danwent> ah that was yong
21:19:57 <danwent> alex is pagination
21:19:59 <salv-orlando> alex did pagination, gongysh XML
21:20:12 <danwent> phew… too many features to keep track of :)
21:20:25 <danwent> ok, but back to the doc issue that mark was pointing out
21:20:32 <garyk> they work together :)
21:20:43 <markmcclain> https://bugs.launchpad.net/openstack-manuals/+bug/1099837
21:20:45 <uvirtbot> Launchpad bug 1099837 in openstack-manuals "dhcp-agent and l3-agent should not run without namespace" [High,Triaged]
21:20:48 <danwent> would be good if someone who uses and tests the non-namespace code take up the doc bug
21:21:07 <danwent> as anyone who runs without namespaces may not understand the consquences.
21:21:26 <garyk> please assign it to me.
21:21:29 <amotoki> when is the limit of that bug? i can take it after G-3
21:21:40 <danwent> garyk: thanks… you just beat me :P
21:22:12 <markmcclain> moving to Other L3/DHCP/IPAM items
21:22:33 <markmcclain> https://blueprints.launchpad.net/openstack/?searchtext=quantum-l3-routing-plugin
21:22:37 <markmcclain> is moving H
21:22:47 <markmcclain> https://blueprints.launchpad.net/quantum/+spec/quantum-l3-routing-plugin
21:23:12 <danwent> markmcclain: yeah, i think that makes sense
21:23:38 <markmcclain> the code is in good shape, but there are few design considerations
21:23:45 <markmcclain> that need to be explored
21:23:52 <amotoki> Do we mark -2 for these reviews to avoid confusions?
21:23:56 <garyk> markmcclain: danwent: agreed. best to
21:24:15 <garyk> best to resolve all open issues and not be pressurized with the timelimit that we have
21:24:18 <markmcclain> I'll see if I can Bob to change it to Work in Progress
21:24:41 <PopeAdolfTheFirs> Undoing the laccesssss
21:24:49 * PopeAdolfTheFirs plucks his bass drunkenly
21:25:03 <danwent> ?
21:25:06 <danwent> anyway...
21:25:20 <nati_ueno> spam?
21:25:25 <PopeAdolfTheFirs> me?
21:25:33 <PopeAdolfTheFirs> can you understand me baby don't you hand me a line
21:25:33 <danwent> go ahead markmcclain
21:25:38 <PopeAdolfTheFirs> although it doesnt matter you and me got plenty of time
21:25:45 <PopeAdolfTheFirs> there's nobody in the future so b aby let me hand you my love
21:25:52 <markmcclain> the Routes on Router might still make the G3 cut, but it depends on another review to land which means it might miss
21:25:53 <PopeAdolfTheFirs> no step for you to dance to so slip your hand inside my glooove
21:25:59 <PopeAdolfTheFirs> hold onto me hold on to me hold onto meeeee
21:26:08 <danwent> markmcclain: is this the extensions of extensions review?
21:26:45 <markmcclain> oh that merged… after I added this agenda
21:26:49 <danwent> markmcclain: i don't actually see it stacked on anything
21:26:58 <nati_ueno> really?
21:27:17 <amotoki> danwent: this is not the extension of extension review.
21:27:30 <nati_ueno> https://review.openstack.org/#/c/21265/
21:27:48 <nati_ueno> I'm going to rebase routes on route code with 21265
21:28:00 <danwent> nati_ueno: ah, ok, that is what I was wondering
21:28:05 <danwent> seems like a much cleaner way to do it.
21:28:14 <nati_ueno> Lbaas also depends on this patch, so this patch looks have higher priority
21:28:15 <emagana> nati_ueno: sign me in as reviewer
21:28:21 <nati_ueno> emagana: Thanks!
21:28:42 <danwent> nati_ueno: lbass depends on 21265?
21:28:51 <nati_ueno> danwent: ah sorry mistake
21:29:08 <nati_ueno> danwent: https://review.openstack.org/#/c/21208/
21:29:11 <danwent> ok, let's hand the ball back to markmcclain
21:29:27 <danwent> nati_ueno: yup
21:29:31 <markmcclain> ok.. last items is deferring https://review.openstack.org/#/c/21067/
21:29:44 <markmcclain> Pluggable IP Allocation until Havana
21:30:15 <markmcclain> that is it for me
21:30:29 <danwent> markmcclain: yeah, it seems like that review is only a partial step, so that makes sense.
21:30:57 <danwent> yamahata: can you move that to WIP?
21:31:04 <yamahata> Yes.
21:31:07 <danwent> thx
21:31:19 <danwent> ok, next up
21:31:28 <danwent> #topic nova-quantum integration (garyk)
21:31:48 <garyk> danwent: nova vif plugin has been approved and is now in
21:31:54 <danwent> cool
21:32:07 <garyk> danwent: there i one open bug with linux bridge and the aforementioned changes
21:32:33 <garyk> danwent: in the quanum api file there are some functions that are not implemented. i am looking into them
21:33:00 <danwent> garyk: which ones?  or would you rather take this offline and file a bug?
21:33:04 <danwent> nati_ueno: https://bugs.launchpad.net/quantum/+bug/1112912
21:33:05 <uvirtbot> Launchpad bug 1112912 in nova "get_firewall_required should use VIF parameter from quantum" [Undecided,Confirmed]
21:33:13 <Shree-HP> garyk++ : We are implementing some functions too at HP
21:33:17 <garyk> danwent: i think that offline is better. i'll write a mail to the list
21:33:24 <danwent> garyk: k, thanks
21:33:34 <danwent> nati_ueno: are you planning on posting a patch for that, or is someone else?
21:33:39 <nati_ueno> danwent: I can start working on this today. However I wanna discuss how to fix it
21:33:49 <nati_ueno> danwent: I read akihiro's mail and replied
21:34:13 <nati_ueno> danwent: We are going to support hybrid driver in future or it is temporary until we have ovs openflow version?
21:34:37 <nati_ueno> danwent: If the hybrid one is temporary, we should not add it on api
21:34:57 <danwent> nati_ueno: when you say API, do you mean as a vif-type?
21:35:11 <danwent> maybe better to take this offlist if there's already an email thread.
21:35:20 <nati_ueno> danwent: gotcha
21:35:25 <danwent> nati_ueno: for some reason, i can't assign the nova part of the bug to you...
21:35:31 <danwent> please try to assign it to yourself.
21:35:37 <nati_ueno> danwent: Sure
21:35:38 <danwent> and get it targeted for G-3
21:35:55 <nati_ueno> danwent: I havn't permission for nova
21:35:56 <danwent> anything else on nova/quantum?
21:36:06 <danwent> nati_ueno: to set milestone, or to assign yourself?
21:36:08 <nati_ueno> danwent: How about sec group integration?
21:36:20 <nati_ueno> danwent: I have assigned me just now. For milestone
21:36:20 <danwent> nati_ueno: we'll talk about that in next section on sec-groups
21:36:30 <danwent> nati_ueno: yeah, i can't change milestone either.
21:36:31 <nati_ueno> danwent: gotcha
21:36:45 <nati_ueno> danwent: I'll ping nova core guys
21:36:49 <danwent> at this point, not a huge deal.  will only become important if it doesn't merge my g-3
21:36:52 <danwent> nati_ueno: thx
21:37:04 <danwent> #topic security /firewalling (arosen)
21:37:41 <danwent> arosen: ?
21:37:44 <amotoki> ovs secgroup patch has been merged.
21:37:49 <danwent> nati_ueno: yes, congrats
21:37:55 <nati_ueno> danwent: Thanks
21:38:02 <amotoki> but it is not enabled by default.
21:38:09 <arosen> I'm working on the nova quantum proxy which is up as a wip
21:38:22 <arosen> hopefully, i'll be able to remove the wip later today
21:38:31 <danwent> want to send out a link to the review, as people don't usually perose the nova review boards
21:38:42 <arosen> https://review.openstack.org/#/c/21041/
21:39:25 <arosen> That's all on my front.
21:40:01 <danwent> arosen: ok, let's keep an eye on whether you get nova review eyeballs in the next few days once the WIP it taken off
21:40:23 <danwent> otherwise, we'll need to ask vish to get some help on reviewers, as this is an important community feature for grizzly
21:40:38 <amotoki> arosen: please ping me or core ML. i would like to review it
21:40:47 <danwent> looks like NEC plugin security groups also needs reviewer eyeballs
21:41:22 <danwent> or take that back, garyk and markmcclain seem to have it covered
21:41:28 <danwent> ok, moving on
21:41:39 <danwent> #topic lbaas team (danwent)
21:42:05 <danwent> we have a discussion with the main folks working on the haproxy lbaas stuff earlier this morning on irc
21:42:24 <danwent> given the time constraints, we're going to simplfy the patches a bit and focus on the haproxy in VM use case
21:42:41 <danwent> so expect to see that the branches will go into WIP for the next day or so, then come back.
21:43:09 <danwent> this is a 'high' community priority… I will be reviewing and testing, as will others.
21:43:24 <danwent> markmcclain, garyk , salv-orlando all of you have been active on reviewing at least some of these patches.
21:43:48 <danwent> we'll need at least one more core dev other than me, but I suspect we'll have that covered between the three of you, and more :)
21:44:01 <salv-orlando> It should be ok.
21:44:08 <danwent> enikanorov and ilyashakhat have been doing a great job working with us on the patch
21:44:13 <salv-orlando> I can do my first turn in 12 hours.
21:44:17 <markmcclain> yeah… I can be other core
21:44:19 <danwent> enikanorov, ilyashakhat, anything to add on your end?
21:44:44 <ilyashakhat> nop
21:44:46 <enikanorov> well, I'd say that it worth looking at the next patches
21:44:52 <enikanorov> e.g. not currentones
21:44:56 <danwent> enikanorov: up
21:45:13 <danwent> #topic quantumclient / cli (markmcclain, yong is out)
21:45:17 <enikanorov> which we plan to update tomorrow
21:45:19 <enikanorov> ok
21:45:48 <danwent> #info python-quantumclient release status for 3.0: https://launchpad.net/python-quantumclient/+milestone/3.0.0
21:46:13 <danwent> markmcclain: did we ever finish discussion on versioning for the client?  I think that thread just died
21:46:24 <markmcclain> pythonic api client is still in development.. still trying to resolve backwards compatibility issues
21:46:42 <markmcclain> otherwise nothing additional to add for cli
21:46:45 <garyk> danwent: there are also a lot of client reviews open. can people also look at those
21:46:53 <danwent> markmcclain: ok, please update Delivery field to something other than Unknown
21:47:14 <markmcclain> danwent: will do
21:47:16 <danwent> garyk: indeed there are.  https://review.openstack.org/#/q/status:open+project:openstack/python-quantumclient,n,z
21:47:41 <danwent> looks like xml support is about to merge, great.
21:47:42 <markmcclain> garyk: a few of the reviews require features to land in the main server first
21:47:56 <garyk> markmcclain: that is correct
21:47:58 <markmcclain> that is why there are a more than the usual open reviews
21:48:00 <danwent> markmcclain: ok, we should probably have people put such CLI branches in WIP
21:48:09 <markmcclain> danwent: +1
21:48:30 <danwent> also, markmcclain and yong will need to decide what the freeze policy should be for python-quantumclient
21:48:45 <danwent> it makes sense to have some kind of a lag after the server, but probably not too long
21:48:57 <markmcclain> #action markmcclain and yong to decide freeze policy
21:49:18 <danwent> #action: markmcclain and yong to drive discussion on pythonquantumclient versioning
21:49:20 <danwent> as well :)
21:49:46 <danwent> discussion on clearing fields continues on ML?  is that near resolution?
21:49:54 <danwent> sounds like we need an answer for grizzly?
21:50:04 <danwent> we're running low on time though, so let's take that offline.
21:50:15 <danwent> #topic quantum stable (garyk)
21:50:30 <danwent> #info quantum stable reviews: https://review.openstack.org/#/q/status:open+project:openstack/quantum+branch:stable/folsom,n,z
21:50:36 <garyk> danwent: same as last week - https://review.openstack.org/#/q/status:open+project:openstack/quantum+branch:stable/folsom,n,z
21:50:39 <danwent> garyk: anything to call out specifically?
21:50:46 <garyk> we can take it offline - nothing urgent
21:50:58 <danwent> garyk: thx
21:51:10 <danwent> any progress on system test, or should we skip due to time?
21:51:11 <garyk> short and sweet
21:51:16 <danwent> (we have several plugins to discuss)
21:51:23 <mlavalle> making good progress
21:51:27 <mlavalle> on testing
21:51:38 <mlavalle> no need to spend more time on this today
21:51:44 <danwent> mlavalle: ok, thanks
21:51:51 <danwent> #topic quantum + horizon
21:51:57 <danwent> amotoki + nati_ueno
21:52:09 <amotoki> floating IP support is merged.
21:52:15 <danwent> great work getting the two BPs merged
21:52:29 <amotoki> two bp are on review.
21:52:32 <danwent> and I saw KC has posted lbaas code
21:52:42 <amotoki> initial patch of lbaas support is available.
21:52:52 <danwent> have you two talked to gabriel about the two BPs that haven't been posted yet?
21:53:05 <amotoki> one
21:53:06 <danwent> do you have a sense of whether they will have time to review them in G-3?
21:53:18 <amotoki> my one will be uploade by tommorow.
21:53:26 <amotoki> nati_ueno: do you have any progress?
21:53:35 <nati_ueno> amotoki: I'll push the code until tommorow
21:53:41 <danwent> ok, let's make sure we talk to him about both, or postpone them.  don't want to be dropping code on them last minute
21:53:41 <nati_ueno> for network-topology one
21:53:52 <danwent> ok, moving to other team reports, specifically plugin discussions.
21:53:58 <danwent> #topic new proposed plugins
21:54:24 <danwent> ok, I sent an email to the core team about this, but since we discuss each new plugin before it is added, there are three plugins to talk about today.
21:54:51 <danwent> the first is one that was discussed at the summit and has been part of the G-3 plan for a while, but i neglected to raise it in a meeting until today: https://blueprints.launchpad.net/quantum/+spec/modular-l2
21:55:01 <danwent> rkukura: you are planning on being the core on this one?
21:55:06 <rkukura> yes
21:55:18 <danwent> do we have two other core reviewers working to get it into Grizzly?
21:55:39 <rkukura> not yet
21:56:17 <emagana> rkukura: I really liked what you presented during the summit, I can review this code
21:56:19 <danwent> mmm… is the whole patch posted already?  looks pretty managable if so.
21:56:29 <danwent> just over 1k LOC
21:56:39 <rkukura> the remainder should be posted tomorrow, about double in size
21:57:03 <rkukura> it is fairly small - uses the existing agents for now
21:57:04 <garyk> rkukura: does it support the security groups now?
21:57:12 <rkukura> tomorrow
21:57:12 <danwent> ok.  rkukura please follow-up with me about who the core devs are on this, ok?
21:57:18 <rkukura> ok
21:57:33 <danwent> any concerns about this plugin?
21:57:45 <danwent> as I mentioned, i feel bad, as this is one I should have brought up a while ago
21:58:27 <danwent> i generally feel like there's good community value in this plugin.  I don't think we should rip either OVS or LB out for grizzly, but long-term I think this has potential to handle much of the overlap between them.
21:58:33 <danwent> ok, moving on.
21:58:59 <danwent> #info ml2 plugin good to go in grizzly, pending core dev reviews
21:59:11 <danwent> next up is plumgrid
21:59:18 <danwent> emagana: this is you?
21:59:22 <emagana> yes, it is
21:59:34 <danwent> do we already have core devs on it?
21:59:43 <emagana> danwent: garyk is one of them
22:00:01 <danwent> emagana: can you link gerrit link to BP on lp?
22:00:09 <rkukura> I'll review it (after getting ml2 submitted)
22:00:11 <emagana> danwent: i need one more, any volunteers?  :-)
22:00:22 <emagana> rkukura: Thanks!
22:00:30 <emagana> danwent: Yes, I will
22:00:49 <danwent> ok… i must admit, I was pretty nervous seeing two new plugins proposed right at the end of G-3.
22:01:08 <danwent> but if we have the reviewing cycles to do a good job, I'm ok with it.
22:01:18 <danwent> do others have a concern?
22:01:42 <mestery> danwent: As long as the committed community stuff doesn't lose out on reviews to the plugins, I'm ok.
22:01:48 <garyk> if i understand correctly the end of g-3 is 21st
22:01:49 <danwent> we're unforunately out of time… so I will stay here and cover the last plugin.  If people need to run and have concerns around the plugins, please contact me or the ML in the next 24 hours.
22:01:57 <garyk> it is cutting it fine with changes
22:02:21 <danwent> garyk: and more realistically, the freeze is the 19th, in exactly one week.
22:02:28 <garyk> i am going to call it a day and as they say in hill street blues "be careful out there"
22:02:42 <garyk> danwent: yup - that is just around the corner
22:02:42 <danwent> I'm ok approving this as a low priority BP, as it came in late.
22:03:07 <danwent> but if there are core devs who can find the cycles without losing focus on key community priorities, i'm fine with that.
22:03:13 <danwent> last one, the midonet plugin
22:03:31 <danwent> anyone from that team here?  I don't think it has a core dev behind it, so we'll need a volunteer
22:03:51 <markmcclain> I've talked with the midonet folks
22:04:05 <markmcclain> I'll be core if the code gets proposed in time
22:04:29 <danwent> markmcclain: oh, it is not up for review?
22:04:31 <danwent> mmmm...
22:04:37 <danwent> ok, well, they have another day
22:04:39 <danwent> :)
22:05:07 <danwent> #info plumgride plugin ok to post for review in grizzly, will merge subject to core team reviews.  emagana is core dev.
22:05:47 <danwent> #info mido net plugin ok for posting review by EOD tomorrow for grizzly, will merge subjec to core team reviews.  markmcclain wiill be core dev if code is posted.
22:05:53 <danwent> #topic open discussion
22:06:02 <danwent> anything else urgent to discuss?
22:06:10 <danwent> I had a few things, but since we're over time, I will send out emails instead
22:06:15 <shiv> danwent: can you please see if brocade plugin needs status update (approval etc.)?
22:06:55 <emagana> shiv: I reviewed it this morning, I think some unit tests are missing
22:06:59 <danwent> shiv: brocade plugin was already approved for posting a review
22:07:15 <danwent> shiv: now its just up to getting the core dev approvals
22:07:29 <danwent> sorry folks, i need to run to another meeting (am already late).  have a good afternoon evening!
22:07:31 <danwent> #endmeeting