21:04:06 <nikhil> #startmeeting quotas-wg
21:04:06 <openstack> Meeting started Mon Mar 21 21:04:06 2016 UTC and is due to finish in 60 minutes.  The chair is nikhil. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:04:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:04:10 <openstack> The meeting name has been set to 'quotas_wg'
21:04:20 <nikhil> #topic roll call
21:04:34 <ninag> o/
21:04:42 <mc_nair> hello
21:04:44 <nikhil> Vilobh isn't here today as he's unwell.
21:05:11 <nikhil> that's a quorum
21:05:13 <nikhil> :)
21:05:23 <nikhil> Let's get started and see if people show up later.
21:05:26 <nikhil> #topic agenda
21:05:40 <nikhil> #link https://etherpad.openstack.org/p/quotas-wg-meeting-agenda
21:05:56 <nikhil> So, we've a few items to discuss today
21:06:09 <nikhil> but since Vilobh isn't here I'm not sure if we can go over all of them
21:06:24 <nikhil> Although, let's discuss a bit on the direction
21:06:38 <nikhil> #topic Follow up on the thread input
21:06:44 <nikhil> #link http://lists.openstack.org/pipermail/openstack-dev/2016-March/thread.html#89453
21:07:12 <nikhil> If you're aware already, I sent one email out last week to get more feedback on "where" to impl quotas in Openstack
21:07:27 <nikhil> There has been good amount of feedback.
21:07:55 <nikhil> Please follow links to some of the prior discussions too (from previous summits, meetups, etc.)
21:08:20 <nikhil> I looked at Vilobh's updated spec patch and it contains fair amount of stuff related to this.
21:08:36 <nikhil> But we need to extract more info out from Blazar etc efforts
21:08:55 <nikhil> be more explicit on how & what different this will be
21:09:13 <nikhil> Any general comments here?
21:09:36 <nikhil> I was also looking for some more feedback from the WG before I start replying to individual emails in that thread
21:10:02 <nikhil> (I've mostly waited as I myself wasn't well last week)
21:10:19 <nikhil> but it's good to get some more consensus around here
21:10:26 <nikhil> anything?
21:10:34 <ninag> I agree there were some good comments in the email threads...
21:10:49 <mc_nair> I don't have anything - will finish catching up the thread
21:10:55 <mc_nair> lot of comments :)
21:11:24 <nikhil> yeah
21:11:46 <nikhil> ok, I have some stuff to add but will go over that in the following topics
21:11:59 <nikhil> moving on
21:12:01 <nikhil> #topic Spec updates
21:12:14 <nikhil> #action all: review latest PS
21:12:27 <nikhil> #link https://review.openstack.org/#/c/284454/
21:12:56 <nikhil> We're mostly waiting on Vilobh for more input on where he's taking the spec.
21:13:17 <nikhil> But my feeling is that (basedon ML input)
21:13:30 <nikhil> we need to get the proposed solution out of the spec
21:13:48 <nikhil> preferably in a wiki or in the prj repo (once that's decided)
21:14:15 <ninag> So this spec focusses on use cases and interfaces/APIs?
21:14:16 <nikhil> cross project specs are considered as guidelines and we should have a better picture of the same in tomorrow's CPL meeting
21:15:04 <nikhil> ninag: right, we need to be clear on what to put in the spec. I will have that info in tomorrow's meeting.
21:15:20 <nikhil> but for this spec, the guidelines can be something like
21:15:42 <nikhil> for example: a common library with DB model builtin
21:16:25 <nikhil> pull this in your repo and add more resource related info to model, add wrapper to the quota drivers etc.
21:17:15 <nikhil> Another thing that Shamail mentioned to me was the PWG wants to bring in the user stories in a more cross prj spec-friendly manner
21:17:32 <nikhil> so, that will go in this spec (more clarity tomorrow)
21:18:13 <nikhil> But that has been my idea too, instead of going into implementation details we need to build the right concepts around what Quotas really mean for Openstack
21:18:18 <ninag> Sounds good
21:18:43 <nikhil> This sort of thing ties in with where+how (ie direction) and the trade-offs for the approaches.
21:18:58 <nikhil> more of a eagle eye view first
21:19:17 <nikhil> but let's see how things unfold by next week
21:19:49 <nikhil> Also, we need to bring this up in a CPL meeting. That may not happen until next week.
21:20:11 <nikhil> Meaning we need to push back on the video sync too.
21:20:24 <nikhil> Until then let's keep our feedback on the spec.
21:20:35 <nikhil> (and of course on the ML as well)
21:20:49 <nikhil> moving on
21:20:56 <nikhil> #topic Previous attempts (discussions, etherpads, projects, etc.)
21:21:21 <nikhil> Again, we just need to update the spec on this. These things for sure go in a CP spec.
21:21:45 <nikhil> let's have action item for all to review the ML links and do some searching
21:22:03 <nikhil> #action all: review ML discussion and suggest links to go in the spec
21:22:18 <nikhil> We'd discuss this again, next week.
21:22:26 <nikhil> moving on
21:22:47 <nikhil> #topic Documenting implementations in other projects explicitly (see update on the spec, do we need more?)
21:23:27 <nikhil> #info This will be confirmed in the CPL meeting of Tues March 22nd, 2016 (if not cancelled)
21:23:37 <nikhil> moving on
21:23:54 <nikhil> #topic Writing tradeoffs in the alternatives? Describing direction in the process, steps towards larger goal of inter-project quota awareness?
21:24:27 <nikhil> I wanted to discuss something here
21:24:49 <nikhil> My perspective is that we need to get started on something more tangible for one cycle (Newton)
21:25:33 <nikhil> And build the quotas effort on that, vs. trying a complete circus in one attempt and failing miserably.
21:25:56 <mc_nair> +1
21:26:06 <ninag> +1
21:26:37 <nikhil> My proposal is that we build the right DNA for quotas, implement it in 1-3 projects in Newton, discuss more with community in Ocata (Barcelona)
21:27:17 <nikhil> Based on the lessons learnt and as more information becomes available, evolve this effort.
21:27:18 <ninag> +1 again
21:27:39 <mc_nair> sounds like a good plan
21:27:53 <nikhil> So, please expect a response for orchestration-like quotas proposal (on ML) to be something around:
21:28:16 <nikhil> 1. Let's get the DNA for quotas right. Build it from single cell to multicellular organism.
21:29:08 <nikhil> 2. Focus on Newton on the right foundation for flat, nested and nested with overcommit quotas to ensure concurrency, coherency etc.
21:29:40 <nikhil> 3. Keep the long term partners involved in the discussion to ensure that we are not going off track (possibly once a month in this meeting)
21:30:31 <nikhil> 4. Collaborate with DefCore and different interested WGs to keep this compliant with Openstack standards.
21:31:04 <nikhil> I missed on the tradeoff about the UX aspect of this but that's somewhat covered in the WG collaboration aspect.
21:31:13 <nikhil> It's one thing to be really careful about,
21:31:23 <nikhil> my email did not mention it and a lot of folks want it,
21:31:45 <nikhil> but taking the library approach will make it difficult for UX folks to begin with,
21:31:55 <nikhil> hopefully we can incrementally improve that experience.
21:32:17 <nikhil> that's it from me on this topic
21:32:26 <nikhil> any comments, suggestions, concerns?
21:32:56 <mc_nair> sounds good to me. The big thing seems to be that we don't have a single really good implementation of quotas yet
21:33:08 <mc_nair> so I like the idea of that being a first step and push the goodness from there
21:33:50 <nikhil> cool
21:34:06 <nikhil> let's see if there's anything/anyone for open discussion
21:34:13 <nikhil> #topic Open Discussion
21:34:32 <ninag> is there a cross-project session on quotas at the summit?
21:34:57 <nikhil> I was looking for the proposal etherpad/google sheet but couldn't find it yet
21:35:24 <ninag> ok
21:35:43 <ninag> you can bring it up at the meeting tomorrow..?
21:35:47 <nikhil> sure
21:35:56 <nikhil> basically, this page should have been up
21:36:00 <nikhil> #link https://wiki.openstack.org/wiki/Design_Summit/Newton
21:36:04 <nikhil> that's not related to CP
21:36:09 <nikhil> but in general
21:36:44 <nikhil> #action nikhil to get the CP summit session proposal pad link
21:36:50 <nikhil> anything else?
21:38:10 <nikhil> Thanks ninag and mc_nair for joining today!
21:38:22 <nikhil> Let's catch up again next week.
21:38:27 <ninag> thanks, bye
21:38:29 <nikhil> #endmeeting