17:00:03 <boris-42> #startmeeting Rally
17:00:03 <openstack> Meeting started Tue Jun 24 17:00:03 2014 UTC and is due to finish in 60 minutes.  The chair is boris-42. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:07 <openstack> The meeting name has been set to 'rally'
17:00:25 <boris-42> msdubov hughsaunders marcoemorais ping
17:01:23 <marcoemorais> boris-42: heya
17:01:29 <meteorfox> boris-42: hi
17:01:42 <coolsvap> heya
17:01:57 <k4n0> I am here for rally meeting
17:02:04 <k4n0> o/
17:02:07 <boris-42> =)
17:02:12 * jtaleric lurking
17:02:14 <boris-42> Hi all
17:02:18 <oanufriev> hi
17:02:52 <tzabal> hi
17:03:04 <boris-42> let's just wait a couple of minutes
17:03:52 <olkonami> hi
17:04:50 <boris-42> so let's start=)
17:05:16 <boris-42> #topic we should do something with our unit test coverage
17:05:30 <boris-42> Okay recently (today) I added new job in Jenkins
17:05:41 <boris-42> that will create cover report on every patch
17:06:02 <boris-42> job is called rally-coverage
17:06:12 <boris-42> and if you click on it you'll see pretty html report
17:06:26 <boris-42> (red lines means that code is not covered by unit tests)
17:06:28 <redixin> sorry i late -_-
17:06:32 <boris-42> We should have 100% coverage
17:06:37 <boris-42> Any questions?
17:06:57 <k4n0> boris-42, 100% should be enforced on gates
17:07:03 <boris-42> k4n0 99^
17:07:36 <boris-42> k4n0 +1 for that to have some kind of 98% as a lower border for coverage
17:07:40 <boris-42> k4n0 otherwise just -1
17:07:51 <k4n0> +1
17:07:57 <boris-42> but first of all we need to cover everything tests=)
17:08:28 <boris-42> okay next topic
17:08:28 <k4n0> We can split up modules and start writing tests , maybe do this on a google doc or something
17:08:41 <boris-42> k4n0 probably we should make some kind of blueprint
17:08:44 <boris-42> k4n0 and workitems
17:08:45 <boris-42> ?
17:08:55 <redixin> +1 for blueprint
17:09:03 <k4n0> boris-42, blueprint is also good, ill make one after meeting
17:09:10 <boris-42> k4n0 thanks
17:09:25 <boris-42> so we will be able to split work
17:09:30 <boris-42> and work together
17:09:36 <boris-42> okay next topic
17:09:42 <k4n0> ok
17:09:49 <boris-42> #topic osprofiler
17:09:59 <k4n0> #action make blueprint for unit test coverage
17:10:01 <boris-42> Okay guys I made a last changes in API
17:10:14 <boris-42> and cover it 100% by unit tests
17:10:32 <boris-42> Going to launch devstack with it
17:10:39 <boris-42> and if there is no issues I will cut release
17:10:45 <boris-42> Any questions?)
17:11:31 <boris-42> https://github.com/stackforge/osprofiler this is library if somebody doesn't know =)
17:11:43 <boris-42> Okay moving to next topc
17:12:01 <boris-42> #topic Rally SLA
17:12:10 <boris-42> redixin plsss be more verbose
17:12:11 <boris-42> =)
17:12:19 <k4n0> what is Rally SLA ?
17:12:21 <boris-42> redixin and tell us what is it and status
17:13:01 <redixin> rally sla is just one more section in the task config file
17:13:18 <redixin> it is possible to specify criterios
17:13:28 <redixin> like maximum error rate
17:13:34 <redixin> or time limits
17:13:52 <k4n0> that is great
17:14:01 <redixin> task is going as usual, but there is special command to check if task was successful or not
17:14:16 <redixin> according to criterios
17:14:41 <redixin> here is the patch https://review.openstack.org/#/c/98158/
17:14:45 <boris-42> redixin btw we will need to add it to HTML
17:15:01 <boris-42> redixin somehow (e.g. does it pass or not criteria) and details
17:15:08 <boris-42> redixin I'll think about it
17:15:20 <redixin> yes, we can add one more table to html results
17:15:33 <redixin> and one more table to task detailed outpu
17:15:39 <boris-42> redixin yep
17:16:34 <boris-42> So as well our jobs check-rally-dsvm-rally and check-rally-dsvm-neutron-rally
17:16:43 <boris-42> will be able to check more carefully
17:16:47 <boris-42> benchmarks
17:17:04 <boris-42> e.g. we can setup for most of them that there is no failures
17:17:18 <boris-42> so we won't need to go and take a look every time on all tasks
17:17:27 <boris-42> any questions?
17:20:53 <boris-42> #topic stress runner
17:21:01 <boris-42> olkonami pls could you introduce us?
17:22:19 <olkonami> it is runner which increase concurrency stepwise
17:22:42 <olkonami> https://review.openstack.org/#/c/94806/
17:22:56 <boris-42> olkonami is it ready?
17:23:56 <olkonami> boris-42: not yet
17:24:06 <boris-42> olkonami ok any questions about it?
17:24:54 <k4n0> olkonami, when does it stop increasing concurrency?
17:25:20 <k4n0> olkonami, i mean if lots of api errors start coming up due to increased load, does it still keep increasing concurrency?
17:26:37 <olkonami> k4n0: we have max_failure_rate parameter for that, if it is exceeded, it will stop increasing
17:26:59 <k4n0> olkonami, ok so that is max failure for atomic action ?
17:27:45 <k4n0> olkonami, I will check the patch in detail, we  can move on for now :)
17:28:07 <olkonami> k4n0, sorry, don't understand question
17:28:16 <boris-42> k4n0 nope for atomic action
17:28:19 <boris-42> k4n0 for whole iteration
17:28:26 <k4n0> boris-42, got it
17:28:36 <boris-42> k4n0 so it will run with some constant load
17:28:39 <boris-42> k4n0 for some period
17:28:48 <boris-42> k4n0 before increasing load it will check
17:29:01 <boris-42> k4n0 that success / all is > then some parameter
17:29:21 <k4n0> boris-42, cool , got it
17:29:23 <boris-42> #topic RPS runner (or refactored periodic)
17:29:36 <boris-42> oanufriev hey could you share updates ?
17:29:59 <olkonami> also now parameter for regular stop incrasing is named "growth_count", do someone have better proposes?
17:30:30 <redixin> start, step, stop
17:30:31 <oanufriev> sorry, i can share them in 1.5 haur. Thereis a bug in unit test that causes memory leak
17:31:03 <oanufriev> if it's about code
17:31:13 <oanufriev> and about works
17:32:35 <oanufriev> periodic runner has been redesigned to check rps parameter instead period
17:33:01 <oanufriev> so now it should be understanded as N runs per second
17:34:35 <oanufriev> also i made extensible pool of multiprocessing.Process instances instead of using fixed lenght list of pools
17:34:58 <oanufriev> that was made to decrease memory usage and related failures
17:35:47 <oanufriev> questions
17:35:52 <oanufriev> ?
17:36:33 <boris-42> oanufriev when can we see any patches related to this?
17:36:54 <oanufriev> in 1.5 hour at gerrit ^)
17:36:58 <oanufriev> in 1.5 hour at gerrit :)
17:37:00 <boris-42> oanufriev great
17:37:10 <boris-42> any questions from anybody?
17:37:22 <boris-42> marcoemorais hughsaunders rediskin k4n0 olkonami ?
17:37:36 <rediskin> nope
17:37:39 <k4n0> nope
17:38:31 <olkonami> no patchs - no questions :)
17:39:12 <boris-42> lol=)
17:39:16 <boris-42> #topic rally & tempest
17:39:29 <boris-42> k4n0 any news?)
17:39:44 <k4n0> no updates, I am working on fixing review comments on latest patch
17:39:54 <k4n0> I am generating html from json stored in DB
17:40:05 <k4n0> json is coming from tempest subunit logs
17:40:33 <k4n0> Now i need to refactor the code such that we have a command like this "rally verify result -type html -out file.html "
17:41:55 <k4n0> https://review.openstack.org/101917
17:44:31 <boris-42> k4n0 ok great
17:44:40 <boris-42> #topic Open Discussion
17:44:49 <boris-42> Anybody would like to discuss anything?
17:46:05 <boris-42> hey hey hey?)
17:46:21 <k4n0> nothing from my end. I am not feeling well today
17:46:32 <k4n0> I have to get my wisdom tooth removed tomorrow :)
17:46:46 <boris-42> =)
17:46:55 <boris-42> k4n0 tomorrow?
17:47:00 <boris-42> k4n0 or yestardsy?)
17:47:06 <k4n0> tomorrow afternoon
17:48:30 <olkonami> k4n0, get well soon!
17:48:47 <k4n0> thanks
17:48:58 <boris-42> k4n0 oh
17:49:22 <boris-42> k4n0 have the same experience on previous friday=)
17:49:49 <boris-42> I would like to try to avid such stuff in future=)
17:49:58 <k4n0> boris-42, you also removed wisdom tooth?
17:50:05 <boris-42> k4n0 yep
17:50:08 <boris-42> k4n0 4 days ago
17:50:20 <k4n0> boris-42, haha, conincidence
17:50:32 <k4n0> boris-42, anyways, lets talk after meeting :)
17:50:44 <boris-42> k4n0 okay
17:50:51 <boris-42> I think we can end this meeting
17:51:10 <boris-42> thank you all guys=)
17:51:13 <oanufriev> boris-42 that's why you so angry =)
17:51:20 <boris-42> oanufriev yep =)
17:51:20 <k4n0> thanks all
17:51:26 <k4n0> oanufriev, haha
17:51:33 <boris-42> #endmeeting