17:10:23 <k4n0> #startmeeting Rally
17:10:23 <openstack> Meeting started Tue Jul 8 17:10:23 2014 UTC and is due to finish in 60 minutes. The chair is k4n0. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:10:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:10:26 <openstack> The meeting name has been set to 'rally'
17:10:40 <k4n0> Lets start the Rally meeting
17:10:47 <coolsvap> hello
17:10:48 <olkonami> hi!
17:10:56 <k4n0> boris-42 wont be in meeting today
17:11:54 <k4n0> who wants to start first?
17:12:05 <k4n0> #topic Rally review updates
17:12:36 <coolsvap> k4n0, i have started working on https://blueprints.launchpad.net/rally/+spec/improve-unit-test-coverage-rally
17:12:52 <coolsvap> submitted 3 patchsets for unit test coverage where its missing
17:13:44 <k4n0> great, thanks
17:14:01 <k4n0> olkonami, do you have any updates for the Stress runners ?
17:14:57 <k4n0> ok, moving on
17:15:08 <k4n0> oanufriev, Any updates since last meeting?
17:15:47 <olkonami> about stress runner, boris-42 asked me to modify ScenarioRunnerResult to store information about 1) failure_precent on iteration of scenario 2) was failure_precent > stop_on_failure_precent (at was what that level)
17:16:08 <olkonami> now I think how to do it
17:16:53 <k4n0> olkonami, any more blockers ?
17:18:03 <k4n0> rediskin, do you have any updates since last meeting?
17:18:10 <olkonami> k4n0, no, I hope it last problem with stress runner
17:18:54 <rediskin> k4n0: i start work around reducing number of points in generated html charts
17:19:06 <rediskin> there is too much points sometimes
17:19:16 <rediskin> also plot.py need some refactoring
17:19:42 <rediskin> patch is coming soon
17:20:04 <k4n0_> sorry, got disconnected
17:20:50 <rediskin> [20:18:55] <rediskin> k4n0: i start work around reducing number of points in generated html charts
17:20:50 <rediskin> [20:19:07] <rediskin> there is too much points sometimes
17:20:50 <rediskin> [20:19:17] <rediskin> also plot.py need some refactoring
17:20:50 <rediskin> [20:19:42] <rediskin> patch is coming soon
17:20:50 <k4n0_> rediskin, do you have updates since last meeting?
17:21:01 <k4n0_> rediskin, ahh , got it
17:21:14 <k4n0_> rediskin, any blockers?
17:21:42 <rediskin> k4n0_ no
17:22:19 <k4n0_> rediskin, any update on functional tests that we discussed last week?
17:23:36 <rediskin> about functional tests: there is one tiny problem: html results are generated, but not published
17:24:09 <k4n0> rediskin, not published by the jenkins job?
17:24:13 <rediskin> i believe i fix it today
17:24:58 <rediskin> by jenkins publisher. wrong path or something similar
17:25:07 <k4n0> rediskin, ok cool, let us know if any blockers
17:25:16 <rediskin> ok
17:25:40 <k4n0> I have been working on finishing unit tests for the final review in the rally-tempest integration patches
17:25:53 <k4n0> Will complete it by tonite
17:26:12 <k4n0> I am also working on increasing unit test coverage https://blueprints.launchpad.net/rally/+spec/improve-unit-test-coverage-rally
17:26:51 <k4n0> I have to start working on this blueprint as well https://blueprints.launchpad.net/rally/+spec/collect-runtime-duration
17:27:13 <k4n0> oanufriev is also working on first part of this blueprint https://blueprints.launchpad.net/rally/+spec/collect-runtime-duration
17:27:37 <coolsvap> k4n0, I also noticed the centos gate is failing due to dependency issue, guys please let know if anyone else facing similar issues
17:27:59 <k4n0> coolsvap, where is that?
17:28:11 <coolsvap> https://review.openstack.org/#/c/105511/
17:28:28 <coolsvap> i did recheck no bug, but still same issue persists
17:28:44 <k4n0> coolsvap, ok thanks for heads up
17:29:02 <k4n0> #action Check failing gate-rally-install-bare-centos6
17:29:08 <rediskin> it is not dependency issue, ist more looks like temporary network issues
17:29:48 <rediskin> i saw the patch adding retries to apt-get/yum in devstack
17:30:01 <k4n0> #info gate-rally-install-bare-centos6 failing due to temporary network issues (maybe)
17:30:04 <rediskin> so mb we should add retries to install_rally.sh
17:30:25 <coolsvap> rediskin, yes, recheck no bug failed with connection reset to peer
17:30:26 <rediskin> it is somewhere in yum configuration
17:30:44 <k4n0> #info Try adding retries for apt-get/yum to solve failng centos6 gate
17:30:52 <k4n0> rediskin, ok thanks, can you do that?
17:30:59 <rediskin> 2014-07-08 16:34:36.532 | Downloading/unpacking netaddr>=0.7.6
17:30:59 <rediskin> ...
17:30:59 <rediskin> 2014-07-08 16:34:51.829 | SSLError: The read operation timed out
17:31:00 <coolsvap> okay I will check in my patch
17:31:26 <k4n0> #topic open discussion
17:31:35 <k4n0> anything else left to discuss?
17:31:44 <rediskin> recently i heard about asynchronous collecting results
17:32:21 <k4n0> yes, Artem Borzilov is working on them
17:32:31 <k4n0> https://review.openstack.org/104518
17:32:53 <rediskin> oh, yes
17:32:55 <rediskin> thank
17:33:00 <rediskin> we need to review it =)
17:33:11 <rediskin> more eyes -- less errors
17:33:18 <k4n0> #action review https://review.openstack.org/104518
17:33:24 <k4n0> rediskin, got it
17:33:54 <k4n0> Anything else to discuss ?
17:34:08 <olkonami> I have a patch for plugins improvement
17:34:17 <olkonami> https://review.openstack.org/#/c/103145/
17:34:37 <olkonami> it makes possible to load plugins not only for scenarios, but also for runners and contexts
17:34:49 <rediskin> nice
17:34:50 <k4n0> #link https://review.openstack.org/#/c/103145
17:34:52 <olkonami> and plugins can be loaded from any subdirectories of plugins directories
17:35:08 <k4n0> sounds great
17:35:35 <k4n0> #action review https://review.openstack.org/#/c/103145/
17:35:58 <k4n0> olkonami, nice work with the docs
17:36:37 <k4n0> Anything else to discuss?
17:36:38 <olkonami> k4n0, thanks
17:37:52 <k4n0> ok , it seems we can end the meeting :)
17:38:27 <rediskin> https://github.com/openstack-dev/devstack/commit/9ad8f9890198de0a3c124cea06d993c9f1939ea8
17:38:36 <rediskin> only for apt
17:38:39 <rediskin> >_<
17:39:23 <k4n0> rediskin, can you send patch to our ci job script?
17:39:36 <k4n0> #link https://github.com/openstack-dev/devstack/commit/9ad8f9890198de0a3c124cea06d993c9f1939ea8
17:39:51 <rediskin> we should make patch for install_rally.sh
17:40:01 <rediskin> and it should be for yum,not apt
17:40:06 <k4n0> rediskin, Yes, correct
17:40:36 <k4n0> rediskin, since only centos6 is failing, but do you think we should put same change for ubuntu? So that it doesnt fail in future
17:40:41 <rediskin> ok, i gonna make patch soon
17:41:05 <k4n0> rediskin, can you make for both gates, centos and ubuntu ?
17:41:22 <coolsvap> k4n0, for ubuntu its there
17:41:28 <k4n0> #action rediskin will make patch for fixing yum retry issue
17:41:31 <coolsvap> we need it for yum only
17:41:34 <rediskin> this change in install_rally.sh, so it automatically aplly for all gates
17:41:39 <k4n0> coolsvap, ok thanks
17:41:42 <k4n0> rediskin, thanks
17:42:12 <k4n0> Shall we end the meeting?
17:43:16 <rediskin> lets do it. there is #openstack-rally if anyone wants to continue
17:43:19 <k4n0> ok, seems we dont have anything else to discuss, ending meeting
17:43:25 <k4n0> Thanks everyone. We did meeting without boris-42 today :)
17:43:40 <k4n0> #endmeeting