17:05:24 <boris-42> #startmeeting Rally
17:05:25 <openstack> Meeting started Tue Aug 19 17:05:24 2014 UTC and is due to finish in 60 minutes.  The chair is boris-42. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:05:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:05:29 <openstack> The meeting name has been set to 'rally'
17:05:47 <boris-42> k4n0 rediskin ping
17:07:11 <coolsvap> hello
17:08:50 <boris-42> Hi all
17:08:59 <temujin> hi
17:09:14 <rook> Hey
17:09:32 <RainbowBastion> Hi
17:10:38 <boris-42> Okay let's start
17:11:19 <boris-42> #topic Making a small virtual summit
17:11:35 <boris-42> guys what do you think if we make in hangout mini summit?
17:11:50 <boris-42> e.g. 2 days where we can discuss interesting stuff
17:13:03 <coolsvap> boris-42, +1, when are we planning this, I am okay with sometime around mid-sept
17:13:23 <boris-42> coolsvap probably mid-august?
17:13:38 <boris-42> coolsvap mid september will be quite close to openstack summit
17:14:39 <coolsvap> boris-42, its already Aug 19 maybe around second week of sept 9,10
17:15:00 <boris-42> coolsvap oh shii
17:15:02 <boris-42> =)
17:15:22 <boris-42> coolsvap okay 9,10 september seems ok
17:15:43 <boris-42> coolsvap we wil have time to prepare docs for discussion
17:15:52 <coolsvap> boris-42, yup
17:16:10 <boris-42> olkonami temujin rook what do you think ?
17:16:41 <olkonami> sept 9,10 is ok for me
17:16:49 <rook> is this a virtual event?
17:17:07 <boris-42> rook yep
17:17:18 <boris-42> rook just a hangout that can be join by everybody
17:17:34 <rook> boris-42 I am good with the September dates.
17:18:33 <boris-42> marcoemorais harlowja ^
17:18:44 <temujin> think, that's all right for such event
17:18:45 <harlowja> boris-42 cool
17:19:19 <harlowja> boris-42 coasterz  i think i'm fine with sept 9,10
17:19:26 <harlowja> oops, should be coolsvap
17:19:37 <boris-42> harlowja ok great
17:19:49 <boris-42> it will be great opportunity to collect user expireicne
17:19:55 <boris-42> and to dicuss how to cover more use cases
17:20:02 <boris-42> okay let's move to next topic
17:20:16 <boris-42> #topic "rally info" command
17:20:35 <boris-42> #link https://review.openstack.org/#/c/102853/
17:20:42 <boris-42> ^ This is the start of long road
17:21:04 <boris-42> where you will be able by running CLI commands to get all interesting infromation
17:21:13 <boris-42> so this is first step
17:21:31 <boris-42> "rally info find NovaServers" will print it's docstring
17:21:48 <boris-42> as well I think that in future it should print available benchmarks
17:22:22 <boris-42> ally info find  NovaServers.boot_and_delete_server will print detailed info about benchmark and what arguments it accepts (if this info is presented in code)
17:22:42 <boris-42> so we should improve quality of some doc strings
17:22:49 <boris-42> and work on usability of this comamnd
17:23:32 <boris-42> e.g. listing stuff, and find that supports regexp and so on
17:24:12 <boris-42> rook coolsvap k4n0 harlowja olkonami temujin ^
17:24:18 <boris-42> any thoughts?
17:24:44 <coolsvap> boris-42, agreed we need to work on doc strings if we want to increase its usability
17:25:10 <boris-42> coolsvap yep so probably we need to add blueprint
17:25:15 <boris-42> coolsvap like we have for tests
17:25:29 <boris-42> #action add blueprint for improving doc strings in benchmarks
17:25:33 <coolsvap> boris-42, yup
17:27:42 <boris-42> okay let's move to next topic
17:27:57 <boris-42> #topic generic cleanup
17:28:04 <boris-42> Okay we are still fighting
17:28:15 <boris-42> to get clean up work in every case in any case
17:28:32 <boris-42> so to do that rediskin is refactoring current cleanup context
17:28:37 <boris-42> rediskin are you here?
17:30:09 <boris-42> okay I'll try to cover most important points
17:30:41 <boris-42> Split admin & user (cleanup) already done. This is required case we are going to support benchmarking withou admin access
17:30:56 <boris-42> cause*
17:31:10 <boris-42> And it's already done
17:31:31 <boris-42> The second thing is to create and extensible framework for adding new resources to cleanup
17:31:46 <boris-42> So users will just specify some class and implement 1-2 methods
17:31:53 <boris-42> that cleanup single resource
17:32:18 <boris-42> and cleanup context will know how to use these mini-resource cleanup's
17:32:43 <boris-42> and do all logic with limiting speed of resource deletion
17:32:48 <boris-42> and repeat in case of failuers
17:33:07 <boris-42> https://review.openstack.org/#/c/113536/
17:33:19 <boris-42> there is already patch that remove part of crap ^
17:33:49 <boris-42> And as well there is third point that should be done
17:33:51 <boris-42> it will be quite big
17:34:08 <boris-42> it's finish unification of resource names & implement command
17:34:18 <boris-42> that will delete all resources with this specifc pattern
17:34:34 <boris-42> e.g. rally_<task_uuid>_<uuid> will be the name of resource
17:34:43 <boris-42> so we can list all resources and delete one by one
17:35:04 <boris-42> (in any case even if something went wrong with server that is running rally)
17:35:25 <boris-42> coolsvap rook harlowja olkonami temujin ^
17:35:52 <harlowja> i'm still a fan of writing a file that has all the things rally created ;)
17:36:02 <harlowja> or multiple files...
17:36:14 <boris-42> harlowja it will create a big overhead imho
17:36:23 <harlowja> meh
17:36:30 <boris-42> harlowja plus what if something happen with that file
17:36:36 <harlowja> like aliens take it?
17:36:41 <harlowja> or comets hit it?
17:36:44 <temujin> that's grate idea to rollback changes the benchmark made
17:36:45 <harlowja> space aliens
17:37:27 <boris-42> harlowja yep
17:37:30 <olkonami> I prefer approach from boris-42
17:37:38 <harlowja> ok dokie, up to u guys
17:37:46 <harlowja> i like AOF for this kind of stuff :-P
17:38:01 <boris-42> harlowja making file in case of distributed load
17:38:02 <harlowja> *append only files
17:38:05 <boris-42> harlowja maybe dangours=)
17:38:08 <harlowja> meh
17:38:17 <harlowja> life is dangerous
17:38:21 <harlowja> i drove my car in today, that was dangerous
17:38:22 <harlowja> lol
17:39:29 <boris-42> harlowja lol
17:39:31 <boris-42> harlowja yep
17:39:33 <harlowja> :)
17:39:45 <harlowja> but u know what, i did it!
17:39:48 <harlowja> amzing, i know
17:39:52 <boris-42> harlowja I really don't know we can provide this way with creating resources =)
17:40:04 <boris-42> harlowja and putting them to file
17:40:15 <boris-42> harlowja but really not sure that it's better then just don't have file=)
17:40:26 <harlowja> easier to view when just a bunch of files
17:40:40 <harlowja> easier to make non-monolothic cleanup scripts
17:40:40 <harlowja> :-P
17:40:48 <harlowja> i heard rally is monolothic, lol
17:40:53 <boris-42> harlowja me too
17:40:59 <boris-42> harlowja too monolothic
17:41:02 <harlowja> :)
17:41:15 <rook> lol
17:41:24 <rook> it is just a bunch of scripts
17:41:31 <boris-42> rook rally?
17:41:34 <harlowja> monolothic godamnit
17:42:00 <boris-42> rook actually it's in one directory so it's monolithic..
17:42:12 <harlowja> omg
17:42:14 <harlowja> crazy
17:42:15 <rook> lol
17:42:28 <rook> I spent most of my lunch reading through that thread
17:42:34 <boris-42> rook ahaha=)
17:42:42 <boris-42> rook I eat already tons of popcorn=)
17:43:43 <rook> I don't have a dog in the fight... Just interesting to read the different opinions
17:44:41 <boris-42> rook so i really dislike of splitting rally to separated repositories in the way that QA wants
17:44:49 <boris-42> it will make development and usage harder
17:44:58 <lordd_> well I heard it is unstable and will break your cloud and kill rook's dog
17:45:24 <rook> lordd_ you assholes! that is why my dogs keep dying!
17:45:40 <lordd_> :D
17:45:43 <rook> boris-42 can you explain what this split is?
17:45:43 <boris-42> lol
17:46:01 <boris-42> rook so they would like to move in separated repository load generators from rally
17:46:08 <boris-42> rook scenarios as well in separated
17:46:21 <boris-42> rook and script that save data to DB in separeted
17:46:39 <boris-42> rook and stuff that generates html with results in separate
17:46:44 <harlowja> is there then a script that combines all these back together to form rally, lol
17:46:55 <boris-42> harlowja yep
17:46:58 <boris-42> harlowja in gates
17:47:16 <rook> wtf
17:47:22 <rook> is Tempest handled in this way?
17:47:22 <boris-42> rook so and all this to be able to consume these scripts with tempest
17:47:32 <boris-42> rook they would like
17:47:33 <harlowja> thats like captain planet right, where u combine all the rings and stuff
17:47:43 <rook> harlowja: hahaha
17:47:55 <boris-42> harlowja lol
17:48:03 <lordd_> lol indeed
17:48:18 <boris-42> so I really don't know how to convince people
17:48:22 <boris-42> just to left rally as is
17:48:37 <harlowja> https://www.youtube.com/watch?v=kbW5sxyu9bU (captain planet, for those who have no idea wtf i am referring to)
17:49:26 <boris-42> harlowja ahaha
17:49:34 <lordd_> well, I don't want to be unpopular, but I would like to have an installation method similar to other openstack projects
17:49:54 <lordd_> but I suppose this will come with time
17:49:57 <harlowja> instead of captain planet, it can be captain boris
17:50:11 <lordd_> in any case, with Ubuntu, the install script works perfectly
17:50:42 <boris-42> lordd_ installation for what?
17:50:50 <boris-42> lordd_ you mean be able to do pip install rally?
17:51:00 <boris-42> lordd_ someday someday we will make first rally version
17:51:24 <lordd_> either pip, or OS packaging
17:51:42 <lordd_> but I totally understand why this isn't happening now, and shouldn't be a priority at all
17:51:43 <boris-42> lordd_ so yep someday
17:52:23 <lordd_> this rant was only related to the monolithic, scripting, etc..
17:52:40 <lordd_> somebody mentioned because of the installation method
17:52:50 <boris-42> lol
17:52:53 <lordd_> in any case, please ignore this comments and continue
17:53:10 <boris-42> lordd_ will de if you say=)
17:53:12 <boris-42> do*
17:53:21 <boris-42> #topic open discussion
17:53:31 <boris-42> okay probably somebody want to put some input?
17:53:55 <lordd_> I have a question concerning network testing
17:54:37 <lordd_> I saw a script example mentioning neutron networks, but that didn't work
17:54:52 <boris-42> lordd_ hm what one?
17:55:08 <lordd_> sorry, the idea would be to associate nova vms to neutron networks
17:55:10 <lordd_> this:
17:56:21 <lordd_> "neutron_network": {
17:56:21 <lordd_> "network_cidr": "10.%s.0.0/16",
17:56:36 <lordd_> this in theory is context for boot_and_delete_server
17:56:41 <lordd_> from NovaServers
17:56:52 <boris-42> context?
17:57:01 <lordd_> "context": {
17:57:07 <boris-42> ah
17:57:15 <boris-42> heh there are 2 patches related to this
17:57:35 <boris-42> https://review.openstack.org/#/c/103306/
17:58:03 <lordd_> thanks, I will check on that
17:58:12 <boris-42> lordd_ it hold work actually
17:58:16 <boris-42> lordd_ not sure I didn't test it
17:58:19 <boris-42> lordd_ but I'll
17:58:54 <lordd_> ok, next one is to create actual load from benchmarking
17:59:14 <boris-42> lordd_ lets' move to rally chat
17:59:22 <lordd_> ok, np
17:59:24 <boris-42> cause we need to finish meeting
17:59:30 <boris-42> #endmeeting