17:05:58 <k4n0> #startmeeting Rally
17:05:59 <openstack> Meeting started Tue Sep 30 17:05:58 2014 UTC and is due to finish in 60 minutes. The chair is k4n0. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:06:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:06:03 <openstack> The meeting name has been set to 'rally'
17:06:53 <k4n0> So seems like boris-42 is offline, lets do a short update sync
17:07:07 <k4n0> #topic Plugins
17:07:20 <rook> k4n0: sure.. do you happen to know the RPC/HTTP work he has spoken to me about?
17:07:24 <rook> he being boris-42
17:07:45 <k4n0> rook, Nope, me and boris-42 couldnt sync up after our chat
17:07:52 <rook> k4n0: ok
17:08:04 <k4n0> Anyone has any updates on plugins?
17:08:19 <k4n0> oanufriev, ?
17:08:51 <rook> none from my end
17:09:00 <k4n0> ok, moving on
17:09:01 <k4n0> #topic CLI improvements
17:09:12 <k4n0> https://docs.google.com/a/mirantis.com/document/d/1iZa9V8C3Z09JTC3x2MGpBq-FEszwRmVCYoxCbN1zHgo/edit#heading=h.cd7fv0p8e3fk
17:09:27 <k4n0> Anyone has updates on the CLI improvements we have been doing?
17:09:52 <rook> No CLI improvements, I would like to talk about any progress on the API work... (sorry for the offtopic)
17:10:03 <k4n0> rook, sure, let me finish old topics
17:10:10 <msdubov_> So so oanufrief has taken the 2nd task
17:10:21 <msdubov_> it's on review
17:10:28 <temujin> yes
17:10:41 <temujin> but it's in progress now
17:10:55 <k4n0> temujin, can you link to the review?
17:10:59 <k4n0> I have started working on unit tests for CLI code, will be done in 1-2 days
17:11:39 <msdubov_> k4n0 great, I'll be doing some improvements for "rally info" this week
17:11:45 <oanufriev_> https://review.openstack.org/#/c/124910
17:11:49 <k4n0> oanufriev_, thanks
17:11:49 <msdubov_> like misspelings handling etc
17:11:56 <k4n0> msdubov_, great !
17:12:23 <k4n0> ok moving on
17:12:25 <k4n0> #topic Docs
17:12:39 <k4n0> oanufriev_, any updates?
17:13:32 <k4n0> msdubov_, Any doc related updates, pending reviews ?
17:13:42 <oanufriev_> k4n0: no. deep discussion needed. i'm waiting till Boris back
17:13:59 <k4n0> oanufriev_, ok, any pending reviews for doc related work?
17:14:29 <msdubov_> k4n0 not finished my work yet... will make an update this week
17:14:40 <k4n0> msdubov_, cool
17:15:07 <k4n0> Alright, moving on
17:15:19 <k4n0> #topic Summit preparation?
17:15:41 <k4n0> I know boris-42 is not online, but is there anything we are to discuss in Paris summit?
17:15:58 <k4n0> maybe we can start a etherpad for collaborating on that
17:16:50 <msdubov_> Well I've forgotten the topis of talks Boris is going to give in Paris, but he definitely will have a couple of them
17:16:50 <k4n0> msdubov_, any comments about this ^
17:17:50 <k4n0> msdubov_, Yea, me and boris-42 will give a talk as well
17:18:11 <k4n0> https://openstacksummitnovember2014paris.sched.org/event/02c2d667ba3d46e3aa6a7e8f5f4a0dd9
17:18:14 <msdubov_> k4n0 Whar are you going to speak about?
17:18:45 <k4n0> msdubov_, We will try to evaluate openstack vendors (Neutron/Cinder) using rally + osprofiler
17:18:59 <msdubov_> So you have a joint session? That's nice
17:19:10 <k4n0> msdubov_, Yes :)
17:19:34 <k4n0> Ok, lets move ahead then
17:19:40 <k4n0> #topic Free discussion
17:19:45 <k4n0> rook, ^
17:20:29 <rook> k4n0 nothing, i wish boris was eh
17:20:31 <rook> here =)
17:20:41 <rook> i wanted to get more details around the RPC/http work!
17:20:45 <k4n0> rook, hehe, yea, he must be very busy.
17:20:52 <k4n0> maybe msdubov_, can help?
17:21:03 <k4n0> rook, can you point to the blueprint ?
17:21:12 <rook> k4n0: that is the problem, he didn't have one
17:21:20 <k4n0> rook, ahh, yes
17:21:23 <rook> lol
17:21:27 <rook> super secret project
17:21:31 <k4n0> rook, you can still give others bit context
17:22:17 <rook> I wanted a way to launch all the guests, then run a workload in concert. Currently this cannot be done with Rally... Boris mentioned the RPC/HTTP work will help this.
17:23:03 <msdubov_> rook, k4n0, well this work definitely was initiated some time ago, and I even remember a blueprint, but can't find it right now
17:23:04 <rook> so, obviously I cannot run 1200 guests all at once, I would need to have a concurrency of 20-30, and work up to the # of guests i can support.
17:23:17 <msdubov_> we have an 'aas' module in Rally
17:24:02 <rook> AAS ?
17:24:31 <k4n0> rook, Hehe, yes, can you take a look here https://github.com/stackforge/rally/tree/master/rally/aas
17:24:53 <msdubov_> rook 'As-a-service' :)
17:25:17 <k4n0> msdubov_, I have a review request https://review.openstack.org/#/c/125012/
17:26:07 <msdubov_> k4n0 will do! I have one for you as well: https://review.openstack.org/119297
17:26:18 <k4n0> #action msdubov_ to review https://review.openstack.org/#/c/125012/
17:26:27 <k4n0> #action k4n0 to review https://review.openstack.org/#/c/125012/
17:26:47 <rook> ah, nice k4n0 thanks
17:27:02 <rook> What does RaaS get me? ;)
17:27:21 <k4n0> rook, I need to sync up with boris-42 , cannot comment now :)
17:27:24 <k4n0> msdubov_, ^ ?
17:27:30 <msdubov_> Me either
17:27:33 <rook> lol
17:27:35 <rook> aight
17:27:47 <k4n0> ok, it seems we can wrap this meeting :)
17:27:53 <k4n0> any more discussion items?
17:27:53 <rook> sure, thanks k4n0
17:28:04 <k4n0> sorry rook , will get back to you soon
17:28:23 <msdubov_> No from me, k4n0 thanks for chairing!
17:28:35 <k4n0> Thanks for attending this short meeting guys :)
17:28:36 <k4n0> #endmeeting