17:07:30 <boris-42> #startmeeting rally
17:07:31 <openstack> Meeting started Tue Oct 7 17:07:30 2014 UTC and is due to finish in 60 minutes. The chair is boris-42. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:07:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:07:34 <openstack> The meeting name has been set to 'rally'
17:07:36 <openstack> boris-42: Error: Can't start another meeting, one is in progress. Use #endmeeting first.
17:07:40 <boris-42> k4n0 around?
17:07:42 <boris-42> msdubov ping
17:08:03 <k4n0_> yes
17:08:07 <k4n0_> o/
17:10:31 <boris-42> k4n0_ so let's wait a bit for other=)
17:10:37 <k4n0_> boris-42, sure :)
17:10:44 <olkonami> hi all!
17:10:51 <boris-42> k4n0_ lazy really team ^_
17:10:53 <boris-42> k4n0_ ^_^
17:11:02 <k4n0_> boris-42, haha
17:11:29 <boris-42> olkonami welcome back =)
17:14:14 <boris-42> k4n0_ so let's start
17:14:19 <k4n0_> sure
17:14:56 <boris-42> #topic tests refactoring
17:15:44 <boris-42> so recently we merged quite huge patch
17:16:13 <boris-42> so now we have all tests (unit, functional, hackings and ci scripts together)
17:16:14 <boris-42> https://github.com/stackforge/rally/tree/master/tests
17:16:21 <boris-42> as well we add Readme file for it
17:17:30 <boris-42> so I hope it's nice now=)
17:17:34 * k4n0_ checks
17:17:35 <boris-42> k4n0_ what do you think?)
17:17:50 <boris-42> k4n0_ a lot of merge conflicts=)
17:18:00 <k4n0_> boris-42, looks good !
17:18:39 <boris-42> k4n0_ hehe where are all others=)
17:19:08 <boris-42> k4n0_ btw as well we added it to readthedocs
17:19:13 <boris-42> k4n0_ https://rally.readthedocs.org/en/latest/testing.html so now we have this page
17:19:33 <k4n0_> boris-42, thats nice, google search for rally would give good links
17:19:48 <boris-42> yep I hope so=)
17:20:49 <boris-42> #topic remove run_tests.sh
17:21:09 <boris-42> Recently I removed run_tests.sh
17:21:10 <boris-42> https://github.com/stackforge/rally/commit/b11235b83ea421eb0da5922391953e6ac9656810
17:21:28 <boris-42> there are few reasons why I did it
17:21:35 <boris-42> 1) It removes 1k lines of code=)
17:21:43 <boris-42> 2) This code is not tested in gates
17:22:03 <boris-42> 3) This can have different results from what we are running in gates with "tox"
17:22:13 <k4n0_> people still use run_tests.sh? :D
17:22:20 <boris-42> k4n0_ some of them
17:22:25 <boris-42> k4n0_ =)
17:22:37 <boris-42> k4n0_ but I don't think that they will use it in feature=)
17:23:31 <rediskin> hey
17:24:04 <boris-42> rediskin hey there
17:24:08 <boris-42> Okay next topic
17:24:13 <boris-42> #topic versioning
17:24:32 <boris-42> Okay finally I am happy to say that we are starting versioning stuff
17:24:42 <boris-42> every month we will make 2 versions
17:24:44 <rediskin> is database schema ready enough?
17:25:01 <boris-42> rediskin it's not about database and upgrades between versions
17:25:01 <rediskin> stable enough *
17:25:19 <boris-42> rediskin it's about making https://pypi.python.org/pypi
17:25:49 <k4n0_> boris-42, how are we approaching versioning , any document?
17:25:51 <boris-42> rediskin no backward compability at this moment
17:25:59 <boris-42> k4n0_ I am going to make a document
17:26:01 <rediskin> i crying every time when database schema is old, and no migration tools, and i need to run rally-manage db recreate
17:26:14 <boris-42> rediskin yep yep
17:26:25 <boris-42> rediskin it's sad but we won't address it at this moment
17:26:29 <boris-42> rediskin step by step
17:26:43 <boris-42> so versioning will be next
17:27:04 <rediskin> lets do not change database shema =)
17:27:50 <boris-42> 0.n.m -> 0.n.m+1 means that we it's backward compatible and it's enough to run "python setup.py install"
17:28:28 <boris-42> o.n.m -> 0.n+1.0 means that something is not backward compatible and it *may* require flushing DB
17:28:52 <boris-42> rediskin k4n0_ so we will have statistics about how often we break everything=)
17:29:02 <k4n0_> boris-42, sounds good
17:30:08 <boris-42> k4n0_ rediskin so this will be basic step in direction
17:30:18 <boris-42> of versioning everything
17:30:46 <boris-42> we will need to make versions of results, plugins and DB
17:30:56 <boris-42> so a lot of work to do=)
17:31:28 <k4n0_> boris-42, wow , thats lot of work
17:31:34 <boris-42> k4n0_ yep as usually
17:31:44 <k4n0_> boris-42, ok how are we tracking all this work?
17:31:58 <boris-42> k4n0_ hm I don't know=)
17:32:30 <boris-42> k4n0_ I hope to finish some key feature request that change a lot of this stuff
17:32:44 <k4n0_> boris-42, ok add me to this tasks
17:32:58 <boris-42> k4n0_ sure but you have already a lot of tasks? ;)
17:33:15 <k4n0_> boris-42, Yes, i want to help out, I am just doing the unit tests task for now
17:33:46 <boris-42> k4n0_ oyep a lot of work there
17:33:56 <boris-42> k4n0_ btw where is coolsvap|afk ?)
17:34:12 <boris-42> k4n0_ haven't seen him for a while
17:34:17 <k4n0_> boris-42, I dont know, ill give him these updates in office tomorrow
17:34:35 <boris-42> k4n0_ ok
17:35:05 <boris-42> #topic work on gates
17:35:14 <boris-42> Okay there were 2 related things to gates
17:35:33 <boris-42> We fixed cli function testing job
17:35:34 <boris-42> https://github.com/stackforge/rally/commit/543a7900f5ec6ce5b858d51f97e046940cefcb2a
17:35:39 <boris-42> so now it's always green=)
17:35:55 <boris-42> and we add 2 experimental jobs
17:36:00 <boris-42> Designate + Zaqar
17:36:06 <boris-42> https://github.com/stackforge/rally/commit/ad8ee24c882a7566a77da6785e4571551c674c98 designate even work
17:36:16 <boris-42> if you type "check experimental" it should be green
17:39:03 <boris-42> #topic some issues with installation of Rally in ubuntu 12.04 LTS
17:39:17 <boris-42> https://answers.launchpad.net/rally/+question/255406
17:39:24 <boris-42> rediskin k4n0_ ^ could you guys as well take a look
17:39:46 <k4n0_> boris-42, sure, ill spin a 1204 vm in morning
17:40:00 <k4n0_> #action check https://answers.launchpad.net/rally/+question/255406
17:40:14 <rediskin> hm
17:40:15 <boris-42> k4n0_ seems like we need to remove that page in WIKI
17:40:27 <rediskin> there is a job for install rally on 12.04
17:44:30 <boris-42> rediskin I am going to remove manual installation page
17:46:34 <andreykurilin_> boris-42, i'm late, sorry
17:47:12 <andreykurilin_> boris-42, why you are want to remove manual installation page?
17:48:48 <boris-42> andreykurilin_ cause people is trying to use it
17:48:56 <boris-42> andreykurilin_ already 3 person https://answers.launchpad.net/rally/+question/255406
17:49:00 <boris-42> andreykurilin_ faced this
17:50:00 <andreykurilin_> boris-42, maybe we should update this manual?
17:50:04 <boris-42> andreykurilin_ https://wiki.openstack.org/wiki/Rally/installation/manual
17:50:08 <boris-42> andreykurilin_ I like this more
17:51:00 <andreykurilin_> boris-42: yes, automated installation is better...
17:51:05 <boris-42> andreykurilin_ yep
17:53:24 <boris-42> so
17:53:39 <boris-42> #topic future cool things
17:53:57 <boris-42> A lot of improvements in rally info command
17:54:11 <boris-42> https://review.openstack.org/#/c/126421/
17:54:30 <boris-42> New report html page https://review.openstack.org/#/c/125119/
17:54:52 <boris-42> Better generic cleanup https://review.openstack.org/#/c/116269/
17:55:30 <boris-42> and as well I am working on some changes in the way how we are storing results
17:55:56 <boris-42> plus refactoring of validation stuff to unify validation in case of scenario and context
17:56:25 <andreykurilin_> boris-42, about cleanup: why rediskin put -2 for it?
17:56:26 <boris-42> And cunning results https://review.openstack.org/#/c/125245/ this will make Rally super scalable. So we will be able to run benchmarks for days and weeks
17:56:32 <boris-42> andreykurilin_ I don't know
17:56:34 <boris-42> =)
17:58:00 <andreykurilin_> boris-42, do we plan finish all this patches before next mini-release?
17:58:07 <boris-42> andreykurilin_ I hope so
17:58:15 <andreykurilin_> :)
17:58:21 <boris-42> andreykurilin_ I mean they are all almost finisehd
17:58:48 <andreykurilin_> boris-42, https://review.openstack.org/#/c/125245 needs changing code from oslo-incubator
18:00:23 <boris-42> andreykurilin_ heh
18:00:36 <boris-42> andreykurilin_ I think that can be removed
18:00:41 <ayoung> Everone out of the pool. Here comes
18:00:42 <boris-42> andreykurilin_ or done in proper way
18:00:44 <ayoung> KEYSTONE!
18:00:51 <boris-42> ayoung NO! =)
18:00:52 <morganfainberg> lol
18:00:57 <morganfainberg> boris-42, yes! :P
18:00:58 <ayoung> CANNONBALL!
18:01:08 <boris-42> ayoung https://encrypted-tbn3.gstatic.com/images?q=tbn:ANd9GcTD9r24UjMH-5UAb1i49yf-F99o1jYzZ1sK1GPH3bgqqXsVZbr4fA9P3g
18:01:13 <boris-42> ayoung =)
18:01:17 <boris-42> #endmeeting