17:07:53 <msdubov_> #startmeeting Rally
17:07:54 <openstack> Meeting started Tue Apr 14 17:07:53 2015 UTC and is due to finish in 60 minutes.  The chair is msdubov_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:07:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:07:57 <openstack> The meeting name has been set to 'rally'
17:08:15 <msdubov_> rvasilets, yfried, andreykurilin1 Hi
17:08:21 <rvasilets> Hi
17:09:26 <yfried> msdubov_: hi. I'm partially here...
17:09:32 <msdubov_> yfried, Ok :)
17:11:07 <msdubov_> pradeep Hi!
17:12:07 <msdubov_> Okay seems like the today's meeting is going to be not very long since many people are missing
17:12:10 <msdubov_> But let's start
17:12:18 <msdubov_> #topic Rally accepted to Openstack
17:12:40 <yfried> msdubov_: yey
17:12:59 <msdubov_> After 1.5 years of development Rally has got accepted to OpenStack as an official OpenStack project!
17:13:06 <msdubov_> #link https://review.openstack.org/#/c/169357/
17:13:20 <msdubov_> Nice job, guys, and congratulations
17:13:57 <msdubov_> #topic Release 0.0.3
17:14:08 <meteorfox> msdubov_: what are the next steps? does Rally moves to github OpenStack
17:14:13 <meteorfox> oops to late
17:14:18 <pradeep> msdubov_: Hi
17:14:34 <msdubov_> meteorfox, nevermind :) Yep, as far as I know we will move to OpenStack
17:14:42 <pradeep> msdubov_: kool  :)
17:15:00 <meteorfox> cool
17:15:05 * yfried gonna have to change all automation scripts...
17:15:15 <msdubov_> meteorfox, and the next steps are to deal somehow with the increasing interest from the community :)
17:15:38 <msdubov_> meteorfox, there will be more and more developers involved
17:15:46 <meteorfox> msdubov_: I think having a very clear roadmap should help focus that interest
17:15:47 <pradeep> msdubov_:  yfried: Good news. Any major code changes expected  due to this?
17:15:59 <msdubov_> meteorfox, yep, that's true
17:16:16 <msdubov_> pradeep, don't think so, we're just following our Roadmap as before
17:16:22 <pradeep> ok
17:16:26 <msdubov_> So another important news is that we are about to have the 0.0.3 release
17:16:45 <msdubov_> Oh we actually already have it :)
17:16:47 <msdubov_> #link https://review.openstack.org/173134
17:17:13 <msdubov_> This release cycle took us 33 days, but we're striving towards a 2-weeks release cycle
17:17:34 <msdubov_> The 0.0.3 release brings 53 commits
17:17:53 <msdubov_> Among them - 11 new plugins (benchmark scenarios/runners/sla stuff) and 14 bugfixes
17:18:16 <msdubov_> 0.0.3 also includes some changes in the docs and the spec on the new input task format
17:18:30 <msdubov_> Any questions on this?
17:19:16 <yfried> msdubov_: re spec - have we started working on it?
17:19:34 <pradeep> msdubov_:   2 week cycle would be bit challenging?
17:19:43 <pradeep> msdubov_: how do other projects follow?
17:20:16 <yfried> pradeep: milestones (~3 for each version, AFAIK)
17:20:53 <pradeep> ok
17:21:53 <msdubov_> yfried: Seems like not yet, there are some blockers that have to be implemented first
17:22:09 <msdubov_> pradeep, Yep, this is going to be challenging, the next topic is going to be about that
17:23:05 <msdubov_> So let's move to it
17:23:09 <msdubov_> #topic Release management
17:23:56 <msdubov_> So, indeed, to have a successful 2-weeks release cycle, we have to be a bit more organized
17:24:26 <msdubov_> And there should be a mechanism of notifying the reviewers of what should be reviewed first to get to the next release
17:24:38 <msdubov_> The idea is to use a special blueprint for that
17:24:47 <msdubov_> #link https://blueprints.launchpad.net/rally/+spec/important-for-next-release
17:24:53 <msdubov_> This blueprint has to be mentioned in the corresponding patches on Gerrit, which will make it simpler for the reviewers to find out the patches that are of the highest importance
17:25:16 <yfried> msdubov_: openstack projects can create special gerrit dashboards with priorities and such
17:25:50 <msdubov_> yfried, interesting, I personally didn't take a llok at them
17:26:04 <msdubov_> yfried, but anyway, we're always trying to make everything as simple as possible
17:26:24 <msdubov_> yfried, A blueprint makes it simple to make just a list of patches that have to be merged in 0.0.x
17:26:26 <yfried> https://review.openstack.org/Documentation/user-dashboards.html
17:26:31 <msdubov_> yfried, thanks
17:26:31 <yfried> https://github.com/sdague/gerrit-dash-creator
17:26:41 <yfried> https://github.com/stackforge/gerrit-dash-creator
17:27:21 <msdubov_> yfried, Thank you one more time
17:27:42 <msdubov_> #action to look at the gerrit dashboards
17:27:58 <yfried> msdubov_: that's unrelated to tracking patches with bp
17:28:05 <msdubov_> yfried, I see
17:28:09 <yfried> msdubov_: which should be done regardlessly
17:28:18 <msdubov_> yfried, ok
17:28:22 <msdubov_> So along with that...
17:28:23 <msdubov_> We will also presumably have a special IRC meeting at #openstack-meeting for release discussions
17:28:29 <msdubov_> every week
17:28:54 <yfried> msdubov_: could we do it in more reasonable times?
17:29:06 <pradeep> msdubov_: was about to ask that
17:29:07 <msdubov_> yfried, aren't you ok with the time of this meeting?
17:29:10 <pradeep> yfried:  ^
17:29:31 <yfried> it's 20:30 for me
17:29:44 <msdubov_> yfried, for me too :)
17:30:01 <aswadr> folks- which timezone is it?
17:30:05 <pradeep> msdubov_:  23:00  in india now. :)
17:30:11 <yfried> msdubov_: my daughter here is wating for her bath ... :(
17:30:14 <aswadr> is is*
17:30:19 <msdubov_> yfried, ah
17:30:28 <yfried> ~5hrs earlier?
17:31:03 <msdubov_> aswadr, UTC+3 for me
17:31:10 <msdubov_> yfried, Will talk to boris-42!
17:31:24 <yfried> msdubov_: maybe alternating weeks?
17:31:37 <aswadr> @msdubov_ thanks! and is the day decidec too?
17:31:42 <msdubov_> yfried, I think we have the meeting in the evening to make it possible for people overseas to participate
17:31:51 <msdubov_> aswadr, Not yet
17:32:06 <aswadr> o
17:32:11 <aswadr> ok*
17:32:19 <msdubov_> yfried, alternating weeks? what do you mean?
17:32:54 <yfried> msdubov_: 1 week this time, 1week earlier
17:33:08 <msdubov_> yfried, Not sure this is the best solution...
17:33:29 <msdubov_> yfried, Ok, will discuss that with Boris
17:33:39 <msdubov_> So, as for the release management
17:33:40 <msdubov_> I will be responsible for this process
17:33:51 <msdubov_> (chairing meetings, writing release notes etc.)
17:34:03 <msdubov_> Are there any questions left on this?
17:36:40 <msdubov_> yfried, Do you have a couple of minutes?
17:36:57 <yfried> msdubov_: yes
17:37:09 <msdubov_> #topic Refactoring scenario utils
17:37:17 <msdubov_> #link https://review.openstack.org/#/c/172831/
17:37:26 <msdubov_> yfried, Could you please tell us a bit about this?
17:37:27 <yfried> msdubov_: great
17:37:42 <yfried> so this was asked for by boris-42
17:38:06 * yfried looking for links
17:38:22 <yfried> we worked on https://review.openstack.org/#/q/status:open+project:stackforge/rally+branch:master+topic:IPv6_Tests,n,z
17:39:52 <yfried> and it intorduces complicated changes that are required in ctx as well as wrapper and would be handy in Neutron utils and other scenario down the road
17:41:16 <yfried> so the idea is to have all service utils in one place that is accesible for all plugins
17:42:04 <yfried> and while at it, move away from the inheritance relationship between utils and scenarios, towards compositions
17:42:40 <yfried> meaning: scenarios will have utils as attributes
17:42:52 <yfried> clear enough?
17:43:43 <msdubov_> yfried, yep, thanks!
17:43:47 <msdubov_> yfried, Will review
17:44:24 <yfried> msdubov_: also
17:44:50 <yfried> having all utils in a single place will make the wrapper (net, keystone) part of that tree and simpler to handle
17:45:25 <msdubov_> yfried, Won't it be a kind of too much for a single place?
17:46:10 <yfried> msdubov_: having the wrapper there as well?
17:46:15 <yfried> msdubov_: IMO no
17:46:33 <msdubov_> yfried, ok
17:47:02 <yfried> msdubov_: becuase they would be integrated in this tree and would hold only the necessary code (less code in wrapper)
17:48:19 <msdubov_> yfried, ok
17:48:19 <msdubov_> #topic Free discussion
17:48:47 <yfried> msdubov_: what about meeting agenda?
17:48:49 <pradeep> msdubov_: i see some patches posted long long before.
17:49:13 <msdubov_> yfried, ?
17:49:16 <msdubov_> pradeep, Which ones?
17:49:30 <pradeep> https://review.openstack.org/#/c/97030/
17:49:39 <pradeep> msdubov_:  some one working on those?
17:50:41 <pradeep> msdubov_: for ex: ironic.
17:50:48 <pradeep> msdubov_:  https://review.openstack.org/#/c/117705/
17:50:50 <msdubov_> pradeep, As for that patch, it seems like it should have been abandoned
17:51:06 <msdubov_> pradeep, There is a similar work in another chain of patches https://review.openstack.org/#/c/141671/
17:51:18 <msdubov_> pradeep, But some patches are just low priority
17:51:36 <msdubov_> pradeep, or people get tired of working on them :)
17:52:17 <yfried> pradeep: I guess you could post a comment asking about them, and if no response in ~1wk, just take over
17:52:29 <pradeep> msdubov_:  :) ok
17:52:32 <pradeep> yfried: sure
17:52:33 <yfried> pradeep: if that's what you are asking
17:52:39 <yfried> msdubov_: re agenda
17:52:40 <pradeep> yes
17:53:48 <yfried> msdubov_: boris suggested we publish an editable agenda prior to the meetings, so ppl can add stuff, and prepare in advance, or maybe cancle a meeting if nothing is on the agenda?
17:54:23 <msdubov_> yfried, hm, that makes sense
17:54:31 <msdubov_> yfried, he didn't tell me that today :)
17:54:42 <yfried> msdubov_: if we had an agenda...
17:54:59 <yfried> msdubov_: also, do we have some automatic logging of meetings?
17:55:01 <msdubov_> msdubov_, It just turned out a couple of hours back that I'll chair it
17:55:08 <msdubov_> yfried, yes
17:55:23 <msdubov_> When I'll finish the meeting there will be links
17:55:30 <msdubov_> yfried, Can I do that? :)
17:56:43 <tosky> yfried: you can use the wiki, as other projects do: https://wiki.openstack.org/wiki/Meetings/Rally
17:56:46 * yfried going to wash my kid
17:56:53 <yfried> msdubov_: sure
17:57:15 <msdubov_> yfried, You can also always find the link to the meeting logs here http://rally.readthedocs.org/en/latest/project_info.html
17:57:18 <msdubov_> #endmeeting