14:00:49 <boris-42> #startmeeting Rally
14:00:49 <openstack> Meeting started Mon Jul  6 14:00:49 2015 UTC and is due to finish in 60 minutes.  The chair is boris-42. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:53 <openstack> The meeting name has been set to 'rally'
14:01:12 <boris-42> yfried: stpierre ping
14:01:17 <stpierre> pong
14:01:33 <yfried> boris-42: hi
14:02:04 <skraynev> hi all
14:02:30 <boris-42> skraynev: hi there
14:02:40 <boris-42> e0ne: hi
14:02:44 <temujin> hi all
14:02:50 <andreykurilin> o/
14:02:56 <andreykurilin> \o
14:02:57 <skraynev> boris-42: try to split mind on two sync-ups :)
14:03:06 <boris-42> amaretskiy: ping
14:03:08 <yingjun> hi
14:03:15 <kun_huang> \o
14:03:15 <boris-42> yingjun: hi hi
14:03:23 <amaretskiy> hi
14:03:38 <andreykurilin> temujin: o////////
14:03:47 <temujin> pffff
14:04:10 <rvasilets> Hi
14:04:31 <e0ne> boris-42: hi
14:04:53 <boris-42> okay let's get start)
14:05:14 <boris-42> #topic Rally Meeting Agenda (finally we did it)
14:05:32 <boris-42> rvasilets: Thank you for you hard work on this not so interesting task
14:05:49 <e0ne> boris-42: please post a link
14:05:52 <boris-42> rvasilets: could you explain how it is organized ? and what you did
14:06:13 <rvasilets> boris-42, sure
14:06:31 * yfried will be back in 10min
14:06:46 <rvasilets> We could find a link in priject info in wiki Rally page
14:06:48 <rvasilets> https://wiki.openstack.org/wiki/Rally#Project_Info
14:06:59 <rvasilets> there is Project meetings
14:07:04 <rvasilets> https://wiki.openstack.org/wiki/Meetings/Rally
14:07:36 <e0ne> #link https://wiki.openstack.org/wiki/Meetings/Rally
14:08:05 <rvasilets> Before every weekly meeting we should post our suggestion to agenda. After a meeting I will briefly summarize our meeting in Previous Meetings
14:08:26 <rvasilets> eom
14:08:47 <boris-42> rvasilets: as well we should add that meeting manager will be changed each 2 weeks
14:09:11 <boris-42> rvasilets: so nobody will get to tired from doing this work
14:09:17 <e0ne> rvasilets: why you don't use meeting notes for summary?
14:09:29 <boris-42> e0ne: because it's not human written
14:09:35 <e0ne> :)
14:09:48 <boris-42> e0ne: the same why we don't use release notes that are auto generated
14:10:12 <e0ne> good point:)
14:10:24 <andreykurilin> e0ne: the same why we don't use tempest for testing rally
14:11:03 <boris-42> andreykurilin: LOL
14:11:10 <boris-42> okay so the idea is next
14:11:25 <boris-42> if you want to discuss something you should add it to agenda
14:11:51 <boris-42> in such way we will have more organized and useful meeting
14:12:08 <e0ne> boris-42: +!
14:12:10 <e0ne> boris-42: +1
14:12:27 <boris-42> skraynev: yingjun stpierre redixin ^
14:12:53 <skraynev> boris-42: ok. currently is nothing from me
14:13:06 <yingjun> looks good
14:13:21 <redixin> I thought it is already like that ^
14:14:03 <boris-42> redixin: hehe
14:14:48 <redixin> btw, IMO we should try to use all this meetbot stuff, and not bother people with making meeting summary by hand
14:15:45 <andreykurilin> redixin: something like:
14:15:47 <boris-42> redixin: this is good point to have better logs of meeting (but I would still prefer to have human written summaries)
14:15:50 <andreykurilin> #idea we should try to use all this meetbot stuff, and not bother people with making meeting summary by hand
14:15:54 <andreykurilin> ?
14:16:05 <redixin> andreykurilin, yep
14:16:15 <rvasilets> #help
14:16:25 <redixin> https://wiki.debian.org/MeetBot
14:16:31 <redixin> #link https://wiki.debian.org/MeetBot
14:17:41 <rvasilets> yhis bot is very limited
14:17:51 <rvasilets> bounded
14:18:15 <rvasilets> I don't now what tag to use when I whant to summerazi the topic
14:18:18 <rvasilets> for example
14:18:28 <rvasilets> * now=>know
14:18:47 <rvasilets> *summarize
14:18:50 <redixin> #agreed?
14:19:07 <rvasilets> )
14:19:17 <boris-42> #agreed We should use https://wiki.debian.org/MeetBot tags
14:19:27 <rvasilets> ok its good idea
14:19:39 <rvasilets> don;t forget to use them then!
14:19:41 <boris-42> #agreed We should write summaries by hand
14:19:57 <boris-42> #agreed we should rotate each 2 weeks meeting manager
14:20:14 <boris-42> #action We should create list of people who would like to help with task
14:20:28 <boris-42> okay let's move to the first topic
14:20:30 <e0ne> 40 minutes reminder :)
14:20:40 <boris-42> #topic Ironic benchmarks
14:20:50 <boris-42> rvasilets: so?
14:21:59 <rvasilets> okey. I tried to add first Ironic benchmark https://review.openstack.org/#/c/186064/ and I thought that its done, but...
14:22:30 <rvasilets> I found some problem  that I cant solve
14:22:38 <rvasilets> http://logs.openstack.org/64/186064/14/experimental/gate-rally-dsvm-ironic-rally/9b0a8d7/console.html#_2015-06-30_14_39_09_363
14:23:00 <rvasilets> I got recursion and I don't know why!
14:23:16 <rvasilets> Need help
14:23:32 <rvasilets> This patch is desired for Ironic team to enable Rally job in Ironic tests
14:23:36 <boris-42> rvasilets: wrong link
14:23:37 <rvasilets> eom
14:23:52 <boris-42> http://logs.openstack.org/64/186064/14/experimental/gate-rally-dsvm-ironic-rally/9b0a8d7/console.html.gz#_2015-06-30_14_39_09_363 rvasilets this one shoudl work
14:23:57 <boris-42> btw you should use
14:23:59 <boris-42> #link http://logs.openstack.org/64/186064/14/experimental/gate-rally-dsvm-ironic-rally/9b0a8d7/console.html.gz#_2015-06-30_14_39_09_363
14:24:43 <boris-42> rvasilets: btw you forgot to send link to the patch actually*
14:24:46 <rvasilets> okey. Sorry for that. The link is #link https://review.openstack.org/#/c/186064/ for the patch that need help
14:25:44 <rvasilets> Is there someone who can help me with that?
14:26:06 <rvasilets> #help Is there someone who can help me with that?
14:26:19 <boris-42> rvasilets: so did you take a look at the code of python ironic client?
14:26:28 <boris-42> rvasilets: did you try to run by hands this commands and so on?
14:26:35 <rvasilets> yes
14:26:42 <boris-42> rvasilets: and they work?
14:27:08 <rvasilets> cli of Ironic is working
14:27:30 <boris-42> rvasilets: not CLI
14:27:40 <boris-42> rvasilets: did you use it as python client (lib)
14:27:53 <boris-42> rvasilets: in exactly the same way as rally use it
14:28:25 <rvasilets> no
14:28:45 <boris-42> rvasilets: so try it firstly (to repeat the same commands)
14:29:20 <boris-42> rvasilets: if they work then there is some difference between what you did in rally and by hand
14:29:38 <boris-42> rvasilets: if they doesn't work there is difference between CLI and what you are doing
14:29:45 <boris-42> rvasilets: in any case I will try to take a look at this
14:30:08 <rvasilets> But there is one more step to find that difference!
14:30:24 <boris-42> #action rvasilets will try to understand why Ironic benchmarks doesn't work and why CLI of ironic works
14:30:44 <boris-42> #action boris-42 will review Ironic patch https://review.openstack.org/#/c/186064/
14:30:50 <boris-42> okay let's move to next topic
14:31:11 <boris-42> #topic Use DDT framework in tests
14:31:28 <boris-42> Okay guys let's use DDT framework for testing and rewrite all the tests on it
14:31:41 <boris-42> This framework is really nice
14:31:47 <rvasilets> #idea tag?)
14:31:53 <amaretskiy> we can not use ddt in all tests - only where that is usefult
14:31:57 <boris-42> rvasilets: nope because it's topic
14:32:13 <boris-42> amaretskiy: yep but there is a lot of places where it is useful =)
14:32:20 <andreykurilin> vponomaryov: ^
14:32:30 <amaretskiy> boris-42: ok :)
14:32:30 <boris-42> amaretskiy: part of group of tests can be rewritten on it
14:32:33 <yfried> boris-42: what is DDT? what's its adv?
14:32:40 <stpierre> this http://ddt.readthedocs.org/en/latest/ ?
14:32:41 <boris-42> yfried: let me show the sample
14:33:20 <boris-42> yfried: https://github.com/openstack/rally/blob/master/tests/unit/plugins/openstack/scenarios/manila/test_utils.py#L117-L133
14:33:30 <boris-42> #link sample of DDT way to test https://github.com/openstack/rally/blob/master/tests/unit/plugins/openstack/scenarios/manila/test_utils.py#L117-L133
14:34:08 <boris-42> so?)
14:34:43 <boris-42> this module btw can be replaced with DDT https://github.com/openstack/rally/blob/97c520c828fe7d44fb6b0ce3011bc23eefba1bb1/tests/unit/plugins/openstack/scenarios/neutron/test_loadbalancer_v1.py#L100-L127
14:35:13 <amaretskiy> boris-42: 100%
14:35:14 <stpierre> seems like in some cases it'd be very useful, and in others can provide some marginal benefit by easily multiplying test cases (and thus hopefully increasing edge-case coverage)
14:35:35 <stpierre> but i don't think we need to be quite so dogmatic as rewriting *all* the tests with ddt :)
14:35:57 * yfried agrees with stpierre
14:36:13 <stpierre> but it'd certainly simplify any of the cases where we have a _test_foo() function, and that's called from test_foo() and test_foo_failure() and test_foo_with_bar() and ....
14:36:15 <boris-42> stpierre: yfried rewritting *all* the tests that should be rewriten
14:36:22 <yfried> we have enough on our plate without rewriting existing tests
14:36:36 <yfried> boris-42: rally coverage seems excellent already
14:36:48 <boris-42> yfried: house keeping is very important task
14:37:03 <boris-42> yfried: I mean it looks like not important task, but it's actually curcial
14:37:06 <yfried> boris-42: I don't disagree, it's just priorities...
14:37:16 <stpierre> we should definitely keep ddt in mind for code reviews, and it'd be nice to rewrite obvious low-hanging fruit so that we have examples to point at
14:37:26 <boris-42> stpierre: yep
14:37:36 <boris-42> stpierre: these tasks are quite good for newbies
14:37:46 <boris-42> stpierre: what we need is just set of bugs
14:37:47 <stpierre> and some of us seem to have a particular masochistic bent for working on unit tests
14:37:59 <boris-42> stpierre: LOL
14:38:16 <yfried> boris-42: stpierre: I guess if someone volunteered to flag all refactor candidates and tag them as low-hanging fruits we can pick it up later
14:38:52 <boris-42> #info yfried: so what we need for now is to block intorducing new cases where DDT should be used
14:39:00 <yingjun> #agree using ddt for newly added tests, low priority to rewite
14:39:26 <boris-42> everybody agree ^ ?
14:39:32 <amaretskiy> #agree
14:39:38 <yfried> boris-42: I'll have to look into DDT to know this for blocking new patches. could you please provide a good link?
14:40:01 <boris-42> yfried: so this thing is quite simple
14:40:16 <boris-42> it's just decorator that creates N times the same method with different arguments
14:40:30 <boris-42> I belive the best sample is to take a look at manila plugins tests
14:41:41 <yfried> boris-42: ack
14:42:16 <stpierre> why don't we try to get a couple of existing tests converted as well, then we'll have a larger body of examples
14:42:37 <yfried> stpierre: good #idea
14:42:44 <stpierre> we don't need to do them all right now, but a couple more would be nice
14:43:10 <boris-42> stpierre: yfried btw kiran can refactor
14:43:17 <boris-42> stpierre: yfried own tests to use DDT
14:43:42 <boris-42> and we will have a sample of patch that refactors part of tests
14:43:44 <yfried> boris-42: if kiran is willing to be the guinee pig :)
14:43:45 <boris-42> that we can show to other
14:44:11 <boris-42> yfried: I think he likes to learn new stuff
14:45:29 <boris-42> okay let's move to next topic
14:45:58 <boris-42> #topic Optimize Rally imports
14:46:07 <boris-42> Okay guys I did everything that was possible
14:46:16 <boris-42> (without changing other libs)
14:46:32 <boris-42> #link https://review.openstack.org/#/c/196493/ and here is the result of my work
14:47:08 <boris-42> yfried: ^
14:47:50 <yfried> boris-42: +2
14:48:18 <yfried> boris-42: it's a good patch
14:48:31 <boris-42> The only thing that I am worried is that we are able to introduce regression in future
14:48:55 <boris-42> but there are part of really good changes e.g. lazy db that saves most of the time=)
14:49:29 <boris-42> okay let's move to next topic
14:49:37 <boris-42> #agree That patch should be merged =)
14:49:43 <boris-42> #agreed That patch should be merged =)
14:49:52 <boris-42> #topic Some review work update
14:49:54 <boris-42> kun_huang: ping
14:50:04 <kun_huang> boris-42: pong
14:50:14 <kun_huang> there some patches need to track
14:50:21 <kun_huang> https://etherpad.openstack.org/p/rally_review_work
14:51:05 <kun_huang> the one who submit sahara related patches seems leaving
14:51:06 <yfried> kun_huang: why do we need this? https://review.openstack.org/#/dashboard/?foreach=%28project%3Aopenstack%2Frally%29+status%3Aopen&title=Rally+Dashboard&Critical+for+next+release=%28starredby%3A%22mdubov%40mirantis.com%22+AND+starredby%3A%22boris%40pavlovic.me%22%29+AND+status%3Aopen&Waiting+for+final+approve=label%3AVerified%3E%3D1%252cjenkins+label%3AVerified%3E%3D1%252crally%252Dci+NOT+owner%3Aself+label%3ACode%252DReview%
14:51:07 <yfried> 3E%3D2+NOT+label%3ACode%252DReview%252D1+NOT+label%3AWorkflow%3E%3D1+NOT+label%3AWorkflow%3C%3D%252D1+NOT+owner%3Aself+label%3ACode%252DReview%3E%3D2+NOT+label%3ACode%252DReview%252D1+NOT+label%3AWorkflow%3E%3D1+NOT+label%3AWorkflow%3C%3D%252D1+NOT+%28starredby%3A%22amaretskiy%40mirantis.com%22+OR+starredby%3A%22akurilin%40mirantis.com%22+OR+starredby%3A%22boris%40pavlovic.me%22+OR+starredby%3A%22yingjun.li%40kylin%252Dcloud.
14:51:07 <yfried> com%22+OR+starredby%3A%22mdubov%40mirantis.com%22+OR+starredby%3A%22sskripnick%40mirantis.com%22+OR+starredby%3A%22yfried%40redhat.com%22%29&Bug+fixes=topic%3A%22%5Ebug%2F.%2A%22+AND+status%3Aopen&Proposed+specs=%28message%3A%22%5Bspec%5D%22+file%3A%22%5E.%2Aspecs.%2A%22%29&Important+patches=%28starredby%3A%22boris%40pavlovic.me%22+OR+starredby%3A%22mdubov%40mirantis.com%22%29+NOT+%28starredby%3A%22mdubov%40mirantis.com%
14:51:07 <yfried> 22+AND+starredby%3A%22boris%40pavlovic.me%22%29+AND+status%3Aopen&Ready+for+review=label%3AVerified%3E%3D1%252cjenkins+label%3AVerified%3E%3D1%252crally%252Dci+NOT+label%3ACode%252DReview%252D1+NOT+label%3AWorkflow%3E%3D1+NOT+label%3AWorkflow%3C%3D%252D1+NOT+label%3ACode%252DReview%3E%3D2+NOT+%28starredby%3A%22amaretskiy%40mirantis.com%22+OR+starredby%3A%22akurilin%40mirantis.com%22+OR+starredby%3A%22boris%40pavlovic.me%
14:51:07 <yfried> 22+OR+starredby%3A%22yingjun.li%40kylin%252Dcloud.com%22+OR+starredby%3A%22mdubov%40mirantis.com%22+OR+starredby%3A%22sskripnick%40mirantis.com%22+OR+starredby%3A%22yfried%40redhat.com%22%29&Has+%252D1+but+passed+tests=label%3AVerified%3E%3D1%252cjenkins+label%3AVerified%3E%3D1%252crally%252Dci+label%3ACode%252DReview%252D1+NOT+label%3AWorkflow%3E%3D1+NOT+label%3AWorkflow%3C%3D%252D1+NOT+label%3ACode%252DReview%3E%3D2
14:51:08 <yfried> sorry
14:51:20 <boris-42> yfried: uh oh=)
14:51:36 <kun_huang> yfried: I know this, it not 100% enough
14:51:37 <boris-42> goo.gl/04aT6p
14:51:43 <yfried> boris-42: kun_huang: tried to post the link to boris-42's nice board
14:51:56 <boris-42> yfried: here is google short url goo.gl/04aT6p
14:52:15 <boris-42> kun_huang: so maybe we can extend that dashboard?
14:52:31 <kun_huang> boris-42: yep, I will try it
14:52:36 <boris-42> kun_huang: .e.g. if I mark patch with star it will become important one
14:52:52 <boris-42> kun_huang: if it has +2 it is close to merge (e.g. in separated column)
14:53:03 <boris-42> kun_huang: we can add you to the people who can manage important patches
14:53:19 <boris-42> kun_huang: if you would like to maintain this kind of work
14:53:27 <kun_huang> boris-42: :-)
14:54:10 <boris-42> kun_huang: so what do you think?
14:54:38 <kun_huang> boris-42: “people who can manage important patches” means core?
14:54:50 <boris-42> kun_huang: nope it's all by hand ...
14:55:02 <boris-42> kun_huang: btw I belive we can put acl group
14:55:10 <boris-42> kun_huang: or create new one specially for this
14:55:17 <boris-42> kun_huang: I will try to play with it
14:55:38 <kun_huang> boris-42: me too, I would love to have a try on it
14:56:31 <kun_huang> let's go back to my topic it self first
14:56:33 <boris-42> #action Do the changes with rally dashboard to fit kun_huang requirments)
14:56:42 <kun_huang> some came to rally and contribute their patches
14:56:44 <boris-42> kun_huang: we have only 4 minute s=)
14:56:51 <boris-42> kun_huang: so be fast=)
14:57:08 <kun_huang> some of patches seems be ignored and they are leaving
14:57:57 <kun_huang> (my network broken just now)
14:58:28 <boris-42> kun_huang: so we are trying not to ignore stuff
14:58:31 <boris-42> kun_huang: at least me...
14:59:05 <boris-42> kun_huang: so in any case we should add new rule
14:59:20 <boris-42> #idea e.g. review the oldest patches firstly *
14:59:21 <yfried> boris-42: kun_huang: I believe the dashboard should be able to show verifed patches that haven't been reivewd for a long while
14:59:32 <boris-42> yfried: yep exactly
14:59:43 <kun_huang> good idea
14:59:48 <amaretskiy> #agree - review the oldest patches firstly
14:59:54 <boris-42> kun_huang: we will try to add some kind of sort
15:00:00 <amaretskiy> fifo
15:00:02 <boris-42> like latest review from core
15:00:05 <boris-42> #endmeeting