14:03:05 <boris-42> #startmeeting Rally
14:03:06 <openstack> Meeting started Mon Nov 23 14:03:05 2015 UTC and is due to finish in 60 minutes. The chair is boris-42. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:10 <openstack> The meeting name has been set to 'rally'
14:03:11 <boris-42> Meeeeeeeting time
14:03:20 <boris-42> #topic ping everybody
14:03:25 <ikhudoshyn> o/
14:03:27 <amaretskiy> hi
14:03:28 <chenli> o/
14:03:30 <boris-42> andreykurilin: ping
14:03:39 <andreykurilin> boris-42: pong
14:03:43 <ylobankov> hi
14:03:48 <boris-42> oanufriev: ping
14:04:57 <boris-42> #topic Todays agenda
14:04:59 <boris-42> https://wiki.openstack.org/wiki/Meetings/Rally#Agenda
14:05:07 <redixin> ni hao
14:05:15 <boris-42> #topic [amaretskiy] do we need a hacking check with `topy' tool?
14:05:26 <boris-42> #link https://pypi.python.org/pypi/topy
14:05:37 <amaretskiy> there is an interesting tool
14:05:41 <boris-42> Okay I am ok with this tool
14:05:42 <amaretskiy> named topy
14:06:06 <amaretskiy> it rather effective in finding typos in docstrings and comments
14:06:09 <boris-42> amaretskiy: maybe we can try to add it to OpenStack infra
14:06:15 <oanufriev> hi all
14:06:15 <rvasilets> hi
14:06:22 <amaretskiy> yes, sure
14:06:28 <boris-42> amaretskiy: so we will need to add it first to global requiremnts
14:06:33 <boris-42> amaretskiy: which is not so easy
14:06:49 <amaretskiy> yes, but after we agreed that we will use it in hacking
14:06:56 <amaretskiy> correct
14:07:11 <amaretskiy> so this is not possible, right?
14:07:12 <boris-42> amaretskiy: I am ok with using it
14:07:21 <boris-42> amaretskiy: what is not possible?
14:07:36 <amaretskiy> adding topy to requirements
14:07:51 <boris-42> amaretskiy: you must add it first to global requirments
14:07:58 <redixin> we can add it to optional-requirements, and create a conditional test
14:08:08 <boris-42> redixin: bad idea
14:08:21 <boris-42> redixin: why not just add it to the global requriments?
14:08:37 <amaretskiy> i'm in doubts - so what will we actually do?
14:08:41 <redixin> im not saying we should not add it to global requirements
14:09:03 <redixin> im saying we can add it to optional-requirements. it will take few minutes to go
14:09:04 <boris-42> amaretskiy: you don't know about global requirements project?
14:09:10 <redixin> not few weeks
14:09:11 <amaretskiy> i know
14:09:26 <boris-42> amaretskiy: so why it's problem to make patch that adds this lib
14:09:36 <boris-42> amaretskiy: then it adds to test-requriments.txt in rally
14:09:51 <boris-42> amaretskiy: and make a test that is grammarnazi
14:11:04 <amaretskiy> okay, so I guess we have a disicion: 1) propose update for test-requriments.txt (add topy) and 2) add hacking for checking typos
14:11:06 <amaretskiy> right?
14:11:58 <LiuNanke> this toolkit is nice ,i use it got my first commit and have merged
14:12:10 <andreykurilin> :)
14:12:21 <redixin> we should add this to TC meeting
14:12:31 <redixin> then create a CR in global-requiements
14:12:52 <LiuNanke> this is my first time join in the meeting nice to meet you all :)
14:13:17 <ikhudoshyn> hi LiuNanke, welcome
14:13:30 <boris-42> redixin: amaretskiy why not just add it to global requriments
14:13:37 <boris-42> redixin: amaretskiy without any big disucssion
14:13:41 <LiuNanke> hi~
14:13:49 <boris-42> LiuNanke: hi
14:13:54 <LiuNanke> hi
14:14:02 <boris-42> redixin: amaretskiy and then we can even create seperated job that checks grammar
14:14:11 <boris-42> redixin: amaretskiy in infra
14:14:12 <redixin> im just kidding
14:15:11 <amaretskiy> okay, so... do we have a desicion? if yes then I'm making a patch to global-requirements
14:15:24 <boris-42> amaretskiy: go and make patches
14:15:31 <amaretskiy> great
14:15:33 <amaretskiy> eom
14:15:34 <boris-42> #agreed make grammar nazi job
14:15:50 <LiuNanke> global-requirements is better i think
14:16:01 <rvasilets> And what if I need to add to docstring name of project. For example monasca, that is grammar typo
14:16:16 <boris-42> rvasilets: I believe this job can be non voting
14:16:31 <boris-42> rvasilets: and it is possible to ignore some lines
14:16:32 <rvasilets> Or, ok
14:16:39 <boris-42> rvasilets: or add ignoring list
14:16:43 <boris-42> rvasilets: of words
14:16:58 <rvasilets> greate
14:17:04 <rvasilets> *great
14:17:20 <boris-42> okay next topic
14:17:22 <boris-42> #topic [andreykurilin] Rally 0.1.2 will be the last release with py26 support?
14:17:39 <boris-42> #link https://review.openstack.org/#/c/247477/
14:17:51 <boris-42> so this is sad but true
14:17:58 <boris-42> we won't be able to support py26
14:18:06 <andreykurilin> boris-42: maybe, we will able to support py26
14:18:20 <LiuNanke> i agree it'time to say goodbye to py26
14:18:36 <boris-42> LiuNanke: so I don't agree much ...
14:18:44 <andreykurilin> https://github.com/openstack/requirements/blob/master/global-requirements.txt#L40
14:18:48 <boris-42> LiuNanke: it's quite wide used in enterprise world
14:19:04 <andreykurilin> requirements supports markers
14:19:26 <boris-42> andreykurilin: that is going to be hell
14:19:28 <andreykurilin> so, we will be able to use "old" releases of some libraries and continue to support py26 for some time
14:19:33 <andreykurilin> boris-42: yes
14:19:39 <andreykurilin> so I prefer to remove py26 support
14:19:54 <boris-42> #agreed removing support of py26
14:20:03 <amaretskiy> #agreed removing support of py26
14:20:06 <andreykurilin> nice)
14:20:09 <boris-42> #topic [rvasilets] Add monasca plugin to Rally. How we will add monasca into the gate. Should it be non-voting, separate job or experimental?
14:20:19 <boris-42> #link https://review.openstack.org/#/c/248298/2
14:20:33 <boris-42> rvasilets: so actually they are working on job
14:20:57 <boris-42> #link https://review.openstack.org/#/c/244893/
14:21:10 <boris-42> rvasilets: ^ here is the patch that should actually add job
14:21:17 <boris-42> rvasilets: but seems like it's not ready yet
14:21:37 <rvasilets> Is it would be separate job?
14:22:32 <rvasilets> As I understand if we create separate file then it should to be separate job
14:23:15 <boris-42> rvasilets: yes of course we are going to create seperated job for Monasca project
14:23:16 <rvasilets> I mean rally-jobs/monasca.yaml
14:24:07 <rvasilets> Will it be voting?
14:24:27 <boris-42> rvasilets: you are not first day in project=(
14:24:44 <boris-42> rvasilets: it will be add as a non voting job
14:24:51 <boris-42> rvasilets: and it will be non voting job
14:25:27 <rvasilets> Ok. I have no questions
14:25:48 <boris-42> #topic open discussion
14:26:03 <boris-42> Anybody wants to discuss anything?
14:26:08 <ylobankov> yep
14:26:20 <boris-42> ylobankov: where is the point in agenda?) hm?)
14:26:28 <boris-42> ylobankov: so what's up?
14:26:48 <ylobankov> https://review.openstack.org/#/c/235857/ please take a look at this
14:27:14 <boris-42> ylobankov: ok maybe if I find some time
14:27:15 <boris-42> =)
14:27:26 <ylobankov> and express your opinion abaut this
14:27:53 <boris-42> ylobankov: ok
14:28:13 <boris-42> anything else?
14:28:17 <ylobankov> I have -1 from redixin, but I would like to have opinions of other reviewers
14:29:37 <boris-42> ylobankov: ok
14:30:03 <boris-42> so we can end todays meeting?
14:30:19 <rvasilets> I don't like the name xfail
14:30:26 <rvasilets> its unclear
14:30:33 <rvasilets> I have wrote it previously
14:30:44 <rvasilets> and uxsuccess
14:32:46 <rvasilets> nothing from me else
14:33:52 <boris-42> okay seems like we can end meeting and continue discussion in rally chat
14:33:56 <boris-42> see you next week
14:33:59 <boris-42> #endmeeting