13:38:11 <msdubov_> #startmeeting RallyRelease
13:38:12 <openstack> Meeting started Wed May  6 13:38:11 2015 UTC and is due to finish in 60 minutes.  The chair is msdubov_. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:38:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:38:16 <openstack> The meeting name has been set to 'rallyrelease'
13:38:17 <msdubov_> So let's start
13:38:29 <msdubov_> #topic Release 0.0.4
13:39:24 <msdubov_> First, there is the first version of release notes: https://review.openstack.org/#/c/180498
13:39:46 <msdubov_> redixin, amaretskiy, andreykurilin, yfried Has anyone except for boris-42 seen it? Any further comments?
13:39:58 <yfried> msdubov_: why not start with the new dashboard?
13:40:05 <amaretskiy> I will review this soon
13:40:29 <andreykurilin> msdubov_: I started review it, but don't finish yet:)
13:40:47 <msdubov_> amaretskiy, andreykurilin Thanks!
13:41:02 <msdubov_> yfried, We will discuss it, but release notes and release 0.0.4 are a kind of urgent things
13:41:22 <openstackgerrit> Merged openstack/rally: [Clients] Add classmethod osclients.Clients.register  https://review.openstack.org/177884
13:44:33 <msdubov_> amaretskiy, andreykurilin, yfried, boris-42, redixin And let me remind you one more time that we still hope to have the following three patches in our 0.0.4 release:
13:44:36 <msdubov_> First, murano stuff
13:44:40 <msdubov_> #link https://review.openstack.org/#/c/137650/
13:44:45 <msdubov_> #link https://review.openstack.org/#/c/171625/
13:44:50 <msdubov_> #link https://review.openstack.org/#/c/162418/
13:45:04 <msdubov_> And also the installation script ^
13:45:11 <msdubov_> So please pay the most attention to them now.
13:45:20 <msdubov_> amaretskiy, andreykurilin yfried boris-42 redixin Any questions?
13:45:43 <amaretskiy> no questions
13:45:52 <amaretskiy> ok
13:45:58 <redixin> i have a question
13:46:04 <yfried> msdubov_: I have issues with installation script
13:46:13 <yfried> msdubov_: I was unable to review latest patchset
13:46:27 <yfried> msdubov_: but I have concerns with changing default behavior
13:46:31 <msdubov_> redixin Is now responsible for that script
13:46:52 <yfried> redixin: I didn't see and answer to my concerns
13:47:18 <redixin> we can finish install.sh but without removing psycopg2 from requirements
13:47:23 <yfried> redixin: making "venv" installation implicit is both a change of behavior and a bad idea
13:47:52 <msdubov_> yfried, redixin Can we maybe discuss the details later here, after the meeting finishes? We have very little time actually
13:48:04 <redixin> is installing system-wide by default if root
13:48:16 <redixin> and installing venv if non-root
13:48:31 <yfried> redixin: msdubov_ ok
13:48:41 <yfried> redixin: let's discuss this later.
13:48:41 <msdubov_> #topic Release 0.0.5
13:49:16 <msdubov_> amaretskiy, andreykurilin redixin boris-42 yfried I'd like to ask you to propose patches "critical" for the next release, namely 0.0.5
13:49:31 <msdubov_> I'll collect them then in our release doc
13:49:40 <msdubov_> #link https://docs.google.com/document/d/1TX5zpYcTX8AXm-K_h1lzUNVCMvbRgsjUKU-dEYNWLY8/edit
13:49:49 <amaretskiy> I propose patches related to reports
13:50:30 <yfried> msdubov_: not sure what critical means
13:50:36 <amaretskiy> oh, they already there
13:50:49 <msdubov_> amaretskiy, Seems like already there :)
13:50:53 <rvasilets_> [Swift] Add objects context class?
13:51:19 <rvasilets_> Rally verify support for any in-tree Openstack project functional tests&
13:51:48 <msdubov_> yfried, "Critical" means that we really want to have them in the release 0.0.5, without these patches a release will make little sense
13:51:48 <msdubov_> yfried, so "critical" patches should be reviewed asap
13:52:16 <redixin> yfried, maybe it is "patches that someone waiting and suffering" =)))
13:52:29 <msdubov_> rvasilets_, yep, thanks, we already had some swift stuff in 0.0.4, so let's continue having it as top priority for 0.0.5
13:52:54 <redixin> what about murano?
13:52:57 <rvasilets_> also I think we don't merge murano bench)
13:53:33 <yfried> msdubov_: redixin: ack
13:53:42 <msdubov_> redixin, rvasilets_ That would be sad :(
13:53:58 <rvasilets_> yes
13:54:29 <msdubov_> Actually the same about plugin base because boris-42 said we should have 0.0.4 without it...
13:54:30 <andreykurilin> msdubov_: I want to see removement of psycong2 package from requirements in 0.0.5. Also, it would be nice if installation script will be able to install packages based on selected db backend
13:54:39 <rvasilets_> Maybe some plugins patches?
13:55:02 <msdubov_> andreykurilin, thanks, agreed
13:55:27 <msdubov_> rvasilets_, So swift/murano benchmarks are already plugins?
13:55:33 <msdubov_> rvasilets_, What do you mean?
13:56:02 <rvasilets_> Boris patches about plugins
13:56:15 <rvasilets_> https://review.openstack.org/#/c/150647/
13:56:23 <rvasilets_> https://review.openstack.org/#/c/160142/
13:56:59 <msdubov_> rvasilets_, Yes, boris-42 said he wouldn't be able to update them very quickly, so we should have 0.0.4 without it
13:57:23 <msdubov_> Okay, thanks for all this information, I will put it to the doc later
13:57:28 <msdubov_> Now the last topic
13:57:36 <msdubov_> #topic Rally dashboard
13:57:46 <msdubov_> #link goo.gl/04aT6p
13:57:54 <msdubov_> Many thanks to rvasilets_  for this nice dashboard
13:58:28 <msdubov_> yfried, So you can see the list of patches "Critical for next release" there
13:58:42 <msdubov_> They are for now actually just the patches starred by boris-42 and me
13:59:02 <yfried> msdubov_: yeah. I'm already using it. it's a great tool
13:59:12 <msdubov_> rvasilets_, I just have one question, what is "Important patches"? How do we define them?
13:59:53 <rvasilets_> As I remember its patches starred by you or boris
14:00:09 <msdubov_> rvasilets_, Ok, clear
14:00:23 <yfried> rvasilets_: msdubov_: boris set them to "stared by core team"
14:00:31 <msdubov_> rvasilets_, But I dislike the idea a bit, what about patches starred by other cores?..
14:00:37 <msdubov_> yfried, Ah ok
14:00:47 <yfried> msdubov_: "stared by msdubov_" means release-patches
14:01:05 <rvasilets_> msdubov_, it was like so first. But Boris ask me to do like now
14:01:13 <msdubov_> yfried, release patches are those stared by both me and boris-42
14:01:35 <msdubov_> rvasilets_, So I personally think the opinion of all the cores should be reflected in this dashboard
14:01:43 <msdubov_> rvasilets_, So let's discuss that with boris-42
14:01:48 <rvasilets_> Ok
14:02:32 <yfried> msdubov_: ^ any core can make patch important. only msdubov_+ boris-42 can make it "release critical " AFAIK
14:03:20 <rvasilets_> In other projects is so.  ^ any core can make patch important.
14:03:27 <rvasilets_> As I saw
14:03:44 <rvasilets_> *its
14:04:42 <redixin> important == starred?
14:05:51 <msdubov_> redixin, as far as I have understood yes
14:06:57 <redixin> Critical+for+next+release=%28starredby%3A%22mdubov%40mirantis.com%22+AND+starredby%3A%22boris%40pavlovic.me%22%29
14:07:01 <redixin> i see
14:07:16 <rvasilets_> starred means to push star under title of commit message
14:07:39 <rvasilets_> )
14:08:24 <openstackgerrit> Andrey Kurilin proposed openstack/rally: DO NOT MERGE: get subunit output  https://review.openstack.org/180556
14:08:25 <openstackgerrit> Sergey Skripnick proposed openstack/rally: Improve installation script  https://review.openstack.org/162418
14:08:42 <redixin> ^ I just added --system/-s for backward compat
14:09:04 <yingjun> how about add ‘Your are a reviewer, but haven't voted in the current revision’ like this url do: http://dwz.cn/IQklE
14:09:53 <msdubov_> yingjun, I think that would be a nice thing to add!
14:09:56 <msdubov_> rvasilets_, ^
14:10:06 <redixin> +1
14:10:10 <yfried> +1
14:10:26 <msdubov_> rvasilets_, Please add that!
14:10:35 <msdubov_> #action Add �Your are a reviewer, but haven't voted in the current revision� to Rally dashboart
14:10:45 <msdubov_> Okay guys let's finish the meeting
14:10:47 <msdubov_> #endmeeting