14:00:18 <spotz> #startmeeting RDO Meeting 2021-06-30
14:00:18 <opendevmeet> Meeting started Wed Jun 30 14:00:18 2021 UTC and is due to finish in 60 minutes.  The chair is spotz. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:18 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:18 <opendevmeet> The meeting name has been set to 'rdo_meeting_2021_06_30'
14:00:55 <spotz> #topic Roll Call
14:01:16 <amoralej> o/
14:01:37 <jcapitao> o/
14:01:51 <jlabarre-rh> q/
14:03:11 <spotz> #chair amoralej jcapitao jlabarre-rh
14:03:11 <opendevmeet> Current chairs: amoralej jcapitao jlabarre-rh spotz
14:03:40 <spotz> Our one agenda item doesn't have a name if someone wants to claim it while we wait a few minutes
14:04:07 <amoralej> i think it refers to adding devel repo to our buildroot in cloudsig
14:04:20 <amoralej> i think jcapitao proposed to discuss in this mtg?
14:04:31 <spotz> not surre who is lime green:)
14:04:38 <ykarel> o/
14:04:46 <jcapitao> yeah that's me
14:04:50 <spotz> #chair amoralej jcapitao jlabarre-rh ykarel
14:04:50 <opendevmeet> Current chairs: amoralej jcapitao jlabarre-rh spotz ykarel
14:05:17 <spotz> #topic Enable integration of CentOS 8 buildroots to our CBS builder
14:05:46 <jcapitao> so, CentOS guys proposed a new CBS/koji feature
14:06:00 <jcapitao> #link https://lists.centos.org/pipermail/centos-devel/2021-June/077081.html
14:06:14 <jcapitao> all info in the mail
14:06:25 <spotz> jcapitao: Thatnks for the link I was having cut and paste issues:)
14:06:51 <amoralej> i think we must enable missing devel repo
14:07:03 <amoralej> that will fix our issue with openssl-static in c8
14:07:18 <amoralej> and potentially others missing devel pkgs
14:07:40 <ykarel> +1
14:07:43 <spotz> +1
14:08:12 <ykarel> btw apevec had raised a concern yesterday, of including some packages during build which might be missing in runtime if needed by package
14:08:14 <jcapitao> apevec had concerns at run-time
14:08:26 <amoralej> no need at runtime
14:08:26 <jcapitao> yeah
14:08:32 <amoralej> only at build time
14:08:44 <ykarel> but i think we test promotions and if something missing for runtime will get caught
14:08:45 <jcapitao> the devel packages won't be needed at runtime
14:08:53 <jcapitao> but others ?
14:09:10 <amoralej> there should be nothing else
14:09:20 <amoralej> that buildtime requirements
14:10:00 <jcapitao> okk
14:10:02 <amoralej> also, as ykarel said, if something is needed we'll catch it in promotion gate
14:10:08 <jcapitao> the only package blocked is octavia-tempest-plugin ?
14:10:13 <amoralej> i think so
14:10:22 <amoralej> for others, we did rebuild packages in cbs
14:10:33 <amoralej> and tagged them
14:10:37 <amoralej> as libuv iirc
14:12:59 <amoralej> #action amoralej to reply https://pagure.io/centos-infra/issue/315 to enable missing devel
14:13:06 <jcapitao> ok
14:14:05 <apevec> +1 for complete BR in CBS
14:14:19 <apevec> amoralej, openssl-static was fixed by latest change in .spec
14:14:27 <apevec> in octavia tests
14:14:28 <spotz> Any thing else on this? Sounds like we need to innclude the repo but possibly buiuld out own packages?
14:14:34 <amoralej> was it finally merged?
14:14:41 <apevec> I think it was
14:14:58 <apevec> https://review.rdoproject.org/r/c/openstack/octavia-tempest-plugin-distgit/+/33352
14:15:31 <amoralej> right
14:15:33 <amoralej> in master
14:16:23 <amoralej> i'm not sure if we can backport to stable releases
14:16:44 <amoralej> ah, i remember now
14:17:25 <amoralej> with those options it can be built statically without openssl iirc
14:18:37 <rdogerrit> Alfredo Moralejo created openstack/octavia-tempest-plugin-distgit wallaby-rdo: Drop *-static BR for golang binary  https://review.rdoproject.org/r/c/openstack/octavia-tempest-plugin-distgit/+/34140
14:18:37 <apevec> yes
14:19:26 <amoralej> i'll squash that with new-release
14:22:04 <ykarel> ack +1
14:22:13 <amoralej> spotz, i think that's it about this topic
14:22:33 <spotz> Thanks amoralej
14:22:43 <spotz> #ttopic RDO Social at the PTG
14:22:53 <spotz> #topic RDO Social at the PTG
14:23:35 <spotz> So starting to plan early this time around! Looking for ideas of what we should do. We did trivia last time so was thinnking we should do something else
14:23:42 <rdogerrit> Alfredo Moralejo proposed openstack/octavia-tempest-plugin-distgit wallaby-rdo: Drop *-static BR for golang binary  https://review.rdoproject.org/r/c/openstack/octavia-tempest-plugin-distgit/+/34140
14:24:42 <spotz> When it gets closer I'll doodle to figure out time and date but feedback apprecciated on whether doing it during the break in the day's schedule was good or bad
14:25:31 <amoralej> when is next ptg?
14:25:33 <ykarel> iirc we did next week of PTG last time
14:25:52 <ykarel> October 18-22, 2021!
14:26:03 <spotz> Octoberr  18-22
14:26:17 <ykarel> #link https://www.openstack.org/ptg/
14:26:27 <spotz> ykarel: That was the one 2 PTGs ago, last PTG we had a trivia night during the PTG
14:26:43 <amoralej> still virtual event
14:26:45 <amoralej> right
14:26:46 <ykarel> okk possibly i forgot :)
14:26:48 <spotz> PTG is virtual and free again yep
14:27:10 <spotz> The Foundation is talking rreturn to events in 2022
14:27:33 <spotz> Vancouver and/or Berlin
14:28:13 <amoralej> i hope 2022 will be the back-to-physical world :)
14:29:20 <spotz> We're crossing fingers for Open Source Summit(Seattle in Sept) and Kubecon NA(LSA in October the week before PTG)
14:29:24 <amoralej> spotz, i'll think about ideas for next social thing
14:29:57 <spotz> Cool thanks amoralej. Getting everyone together for trivia worked well so I'd definitely like to get folks together again
14:30:12 <amoralej> yes, it was good
14:30:19 <spotz> If nothing else on this
14:30:29 <spotz> #topic NNext Week's Chair
14:30:42 <spotz> And that is the video call:)
14:31:34 <jlabarre-rh> I don't know.  I heard one observation that once the "social distancing" was over, could we just keep doing it anyway
14:32:08 <amoralej> jlabarre-rh, you mean keep doing virtual-only events?
14:32:26 <spotz> jlabarre-rh: The PTG? I tthink there are some advantages of the remote being more people can attend. I think we have better cross project collaboration in person
14:32:47 <amoralej> i agree
14:32:57 <jlabarre-rh> I think they meant not having to hang out with other people <g>
14:33:14 <amoralej> maybe one physical, one virtual every year may be good
14:33:17 <spotz> I know some teams inn the past have streamed their sessions when in person or atleast tried. Networking at the venue can prohobot that
14:33:22 <amoralej> or mix virtual-physical
14:33:40 <spotz> I so need a new keyboard!
14:34:18 <amoralej> :)
14:34:47 <spotz> jlabarre-rh: I won't lie a full week OpenStacking requires downtime after:) But there are definite advantages to everyone getting together to plan and just to socialize
14:35:41 <jlabarre-rh> I just miss Lunacon (but that didn't die due to COVID)
14:35:48 <spotz> I think seeing how Ope Source Summit goes as a hybrid event will tell us a lot as to whether that model will work and what it will take to do
14:36:33 * amoralej searchs lunacon... :)
14:37:06 <spotz> That does look like it was fun:)
14:37:32 <amoralej> spotz, yes, i think there will be some effort to get the best from both worlds in future, we'll see...
14:37:47 <amoralej> yeah, looks fun :)
14:37:58 <spotz> Ok back to next week's chair?:)
14:38:42 <ykarel> i can take it
14:38:50 <spotz> Thannk ykarel!
14:39:02 <spotz> $topic Open Discussion
14:39:06 <spotz> grr
14:39:12 <spotz> #topic Open Discussion
14:39:31 <amoralej> in case you didn't see it https://lists.centos.org/pipermail/centos-devel/2021-June/077084.html
14:39:38 <amoralej> after discussions about epel in CBS
14:39:48 <amoralej> it's all or nothing
14:39:56 <amoralej> so, nothing changes for us
14:40:03 <apevec> yep
14:40:15 <amoralej> we'll keep rebuilding packages
14:40:15 <apevec> and that's fine, SIGs can choose
14:40:36 <sshnaidm> amoralej, hi, I've created a pr to collection rpm: https://src.fedoraproject.org/rpms/ansible-collection-community-general/pull-request/1
14:40:37 <amoralej> well, SIGs can choose if be compatible with epel or not
14:40:38 <ykarel> amoralej, we will not cross tag?
14:40:47 <sshnaidm> amoralej, should I ping someone?
14:40:48 <ykarel> and build alwasy
14:40:49 <amoralej> but we can't choose to include specific epel builds
14:41:05 <amoralej> ykarel, we can't cross tag epel
14:41:11 <amoralej> as packages will not be imported
14:41:39 <apevec> ykarel, cross-tagging epel is not an option
14:42:02 <apevec> idea to import epel builds into CBS was discussed but discarded
14:42:08 <ykarel> ahkk got it that was ruled out
14:42:15 <amoralej> yep
14:42:19 <amoralej> that option was discarded
14:43:34 <amoralej> sshnaidm, you created that PR 5 minutes ago!, give them some time... :)
14:44:12 <amoralej> maintainers will receive a notification about the PR
14:44:17 <sshnaidm> amoralej, ok :) can you take a look if it's ok?
14:45:21 <spotz> heheh
14:47:35 <amoralej> sshnaidm, but those scripts still exist in 3.2.0
14:47:39 <amoralej> and even in 3.3.0
14:47:46 <amoralej> and fedora is 3.2.0
14:47:58 <amoralej> so i think you'll need to wait for next release
14:48:16 <amoralej> note fedora specs are for a specific release not for main branch
14:49:02 <sshnaidm> amoralej, ok, so to hold it for now?
14:49:05 <amoralej> sshnaidm, i guess you are building master?
14:49:08 <amoralej> with the spec?
14:49:11 <sshnaidm> amoralej, yep
14:49:21 <amoralej> then you need to make it compatible with both
14:49:29 <amoralej> maybe check if the directories exist
14:49:47 <amoralej> before doing the sed or something like that
14:50:16 <spotz> Do we want to end the meeting and then continue this or is this good to be in the logs?
14:50:40 <amoralej> yeah, sorry spotz, this is out of the scope for meeting
14:50:50 <spotz> #endmeeting