15:02:13 <amoralej> #startmeeting RDO meeting - 2016-09-28
15:02:14 <zodbot> Meeting started Wed Sep 28 15:02:13 2016 UTC.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:14 <zodbot> The meeting name has been set to 'rdo_meeting_-_2016-09-28'
15:02:14 <openstack> Meeting started Wed Sep 28 15:02:13 2016 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:18 <openstack> The meeting name has been set to 'rdo_meeting___2016_09_28'
15:02:34 <rbowen> Oh, hi.
15:02:40 <chandankumar> \o/
15:02:46 <number80> o/
15:02:53 <amoralej> #chair chandankumar rbowen number80
15:02:53 <zodbot> Current chairs: amoralej chandankumar number80 rbowen
15:02:54 <openstack> Current chairs: amoralej chandankumar number80 rbowen
15:02:55 <dmsimard> \o
15:03:02 <jpena> o/
15:03:06 <gchamoul> o/
15:03:08 <imcsk8> o/
15:03:17 <amoralej> #chair dmsimard jpena gchamoul imcsk8
15:03:18 <zodbot> Current chairs: amoralej chandankumar dmsimard gchamoul imcsk8 jpena number80 rbowen
15:03:18 <openstack> Current chairs: amoralej chandankumar dmsimard gchamoul imcsk8 jpena number80 rbowen
15:03:24 <trown> o/
15:03:26 <jschlueter> o/
15:03:38 <amoralej> #chair trown jschlueter
15:03:38 <zodbot> Current chairs: amoralej chandankumar dmsimard gchamoul imcsk8 jpena jschlueter number80 rbowen trown
15:03:43 <openstack> Current chairs: amoralej chandankumar dmsimard gchamoul imcsk8 jpena jschlueter number80 rbowen trown
15:03:54 <amoralej> let's start with the first topic
15:04:04 <amoralej> #topic DLRN Ocata branch preparation
15:04:11 <amoralej> who added that?
15:04:11 <jpena> I added this one
15:04:24 <amoralej> go for it then!
15:04:26 <amoralej> :)
15:05:04 <jpena> We're preparing for Ocata -> https://trello.com/c/sl4Xs6wy/353-recreate-centos-master-worker-on-newton-rc
15:05:17 <Duck> coin
15:05:22 <jpena> The puppet-dlrn and rdoinfo reviews are in progress
15:05:50 <jpena> My only doubt is: will we open Ocata before or after Newton GA? That could affect the rdoinfo review -> https://review.rdoproject.org/r/2765
15:07:06 <jpena> number80, any proposal?
15:07:39 <myoung> o/
15:07:49 <amoralej> #chair myoung
15:07:49 <zodbot> Current chairs: amoralej chandankumar dmsimard gchamoul imcsk8 jpena jschlueter myoung number80 rbowen trown
15:07:51 <openstack> Current chairs: amoralej chandankumar dmsimard gchamoul imcsk8 jpena jschlueter myoung number80 rbowen trown
15:09:42 <amoralej> jpena, "open ocata" means starting new centos-ocata work using ocata-uc and centos-master for master-head?
15:10:14 <jpena> amoralej: yes. Also, it means no more newton-uc, and centos-newton would be "newton" now
15:10:21 <amoralej> and centos-newton for stable/newton with or without uc as we prefer
15:10:35 <jpena> correct
15:11:29 <amoralej> ok, as said in the review, imho, for all projects we pin there shouldn't be much difference between HEAD and u-c in stable/newton at this point
15:12:00 <number80> jpena we can
15:12:27 <rdogerrit> Merged openstack/tripleo-ui-distgit: Bump tripleo-ui-deps version  http://review.rdoproject.org/r/2783
15:12:40 <amoralej> but if we want to be a bit more conservative we can use uc and unpin after GA, no much work is required, right?
15:13:05 <jpena> amoralej: the only post-GA change would be to remove the pins
15:13:07 <jpena> for newton
15:13:49 <dmsimard> need to afk momentarily, my only agenda item is mostly explained in-line -- sorry
15:13:51 <amoralej> then, we can open ocata and let u-c pins for newton
15:13:53 <amoralej> ok?
15:14:04 <jpena> ok for me
15:14:43 <amoralej> #info ocata will be open and u-c pins will be maintained in newton tag until newton GA
15:14:48 <amoralej> ^ is this correct?
15:14:58 <jpena> +1
15:15:37 <amoralej> anything to say about buildlogs.centos.org/centos/7/cloud/x86_64/openstack-ocata/ ?
15:16:10 <amoralej> we'll start using buildlogs.centos.org/centos/7/cloud/x86_64/openstack-newton for dlrn builds?
15:16:21 <amoralej> or we need buildlogs.centos.org/centos/7/cloud/x86_64/openstack-ocata/ from the very beginning for ocata worker?
15:16:27 <jpena> openstack-ocata is still 404. number80 was going to check if this was caused by having no packages tagged
15:16:37 <jpena> for the ocata worker, we need openstack-ocata from the beginning
15:17:00 <amoralej> ok
15:17:15 <amoralej> number80, are tags already created for ocata?
15:17:57 <amoralej> yes they are
15:18:41 <amoralej> #action number80 to check if openstack-ocata directory in buildlogs is missing because there are not packages tagged yet
15:18:45 <amoralej> ok, let's move on
15:19:04 <number80> amoralej: I tagged a package earlier, no changes, I may ping Arrfab about it
15:19:13 <amoralej> #undo
15:19:14 <zodbot> Removing item from minutes: ACTION by amoralej at 15:18:41 : number80 to check if openstack-ocata directory in buildlogs is missing because there are not packages tagged yet
15:19:15 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7f66f4fe7490>
15:19:45 <amoralej> #action number80 will check with centos team about why openstack-ocata doesn't exist yet in buildlogs
15:19:56 <amoralej> #topic Announcements
15:20:10 <rbowen> Please come help us test the RC tomorrow - https://www.rdoproject.org/testday/newton/rc/
15:20:15 <amoralej> #topic Test day, tomorrow and Friday - https://www.rdoproject.org/testday/newton/rc/
15:20:25 <amoralej> let's see if we can get a promotion today...
15:20:32 <rbowen> Yep. That'd be nice. :-)
15:20:39 <amoralej> hopefully
15:20:57 <trown> ya I am pretty hopeful
15:21:00 <amoralej> trown disabled tempest tests in minimal job, which has been the only problem in the last executions
15:22:02 <rbowen> Other announcements?
15:22:21 <rbowen> chandankumar has a new blog post about running Tempest on RDO. That should be useful for test day.
15:22:38 <chandankumar> Tempest now provides script to install tempest plugin test packages automatically:
15:22:43 <chandankumar> https://raw.githubusercontent.com/redhat-openstack/tempest/master/tools/install_test_packages.py
15:22:56 <chandankumar> tempest blog link https://www.rdoproject.org/blog/2016/09/running-tempest-on-rdo-openstack-newton/
15:23:18 <EmilienM> chandankumar: is it upstream?
15:23:27 <EmilienM> I don't see it in https://github.com/openstack/tempest/tree/master/tools
15:23:38 <amoralej> #chair EmilienM
15:23:38 <zodbot> Current chairs: EmilienM amoralej chandankumar dmsimard gchamoul imcsk8 jpena jschlueter myoung number80 rbowen trown
15:23:39 <openstack> Current chairs: EmilienM amoralej chandankumar dmsimard gchamoul imcsk8 jpena jschlueter myoung number80 rbowen trown
15:23:41 <chandankumar> EmilienM: it is in rh-openstack/tempest repo
15:24:06 <chandankumar> EmilienM: we will move this script under tempest config tool(which is still in progress)
15:24:11 <EmilienM> I figured. My question is why it's not upstream.
15:24:38 <chandankumar> EmilienM: but anyone can use it as standalone script
15:25:00 <chandankumar> </eof>
15:25:18 <amoralej> EmilienM, maybe you can check with dmellado
15:25:29 <amoralej> the plans to include the config tool upstream
15:25:51 <amoralej> anything else about announcements?
15:26:02 <chandankumar> EmilienM: https://github.com/redhat-openstack/python-tempestconf
15:26:38 <amoralej> next topic
15:26:43 <rbowen> It looks like dmsimard's items are mostly announcements, rather than discussion topics.
15:26:44 <EmilienM> I'm still confused by we contribute to tempest downstream repo first and then upstream
15:26:50 <amoralej> #topic Important dates
15:26:51 <EmilienM> but maybe it's me :-)
15:27:22 <amoralej> #info CentOS outage October 10th: https://lists.centos.org/pipermail/ci-users/2016-September/000392.html
15:27:33 <chandankumar> EmilienM: we are switching to upstream tempest from ocata release once tempest config tool seperation is done.
15:27:44 <dmsimard> Yup, no discussion, just highlighting important dates that are coming
15:27:58 <amoralej> #info rcip-dev (review.rdoproject.org) outage >= October 15th (not announced yet)
15:28:15 <amoralej> #info review.rdoproject.org maintenance 2016-10-10 13:00 UTC: https://www.redhat.com/archives/rdo-list/2016-September/msg00095.html
15:28:29 <amoralej> #info Newton release: October 6th: https://releases.openstack.org/newton/index.html
15:28:32 <rbowen> for the Ceph/RDO meetup in Barcelona, we still could have another speaker/topic.
15:28:46 <amoralej> rbowen, i'd like to participate
15:29:03 <rbowen> https://etherpad.openstack.org/p/rdo-barcelona-meetup-schedule
15:29:13 <amoralej> but i'm not sure about the topic
15:29:33 <amoralej> topic 1, "RDO release status (aarch64, repos, workflow)" covers everithing :)
15:29:57 <dmsimard> It's a RDO+Ceph meetup
15:30:03 <dmsimard> so anything about the two are good IMO
15:30:09 <dmsimard> but 5-10 minutes is damn short :)
15:30:44 <amoralej> ok, i'll think something
15:31:01 <rbowen> Yes, it is indeed very short.
15:31:02 <amoralej> and discuss in the channel
15:31:19 <rbowen> But we'll have snacks and beers afterwards for extended discussion.
15:31:41 <number80> amoralej: it's a general status of the project, not in-depth for each topic
15:31:50 <number80> we have few minutes only
15:32:06 <amoralej> ok, number80
15:32:22 <rbowen> I need to leave a little early anyways.
15:32:24 <bandini> number80: are the updated builds for erlang/rabbit ready? do you know what is left to do roughly? ;)
15:32:26 <amoralej> i'll focuse on something more specific
15:32:28 <bandini> EmilienM: ^
15:32:32 <rbowen> Lunch with my daughter today. :-)
15:32:45 <number80> bandini: they're in -pending repo
15:33:19 <bandini> number80: thanks. do they get moved after some time or does something specific need to happen?
15:33:48 <amoralej> i think we covered topics in the etherpad
15:34:08 <amoralej> #topic open floor
15:34:14 <amoralej> we still have 25 minutes
15:34:36 <dmsimard> Noteworthy perhaps
15:34:53 <jpena> one topic about DLRN: we're working on the dlrn+nodepool functionality, the DLRN part of it should be implemented by https://review.rdoproject.org/r/2498
15:35:05 <jpena> be aware that there's a long list of patches leading to it :)
15:35:26 <dmsimard> We're hopefully about to merge Designate+BIND testing coverage in puppet-openstack-integration (WIP since early July) so that'll be one more project in the RDO CI testing pipeline
15:36:22 <amoralej> it'd be nice to add it to packstack too
15:36:51 <panda> jpena: where is that functionality tracked ?
15:36:52 <dmsimard> I don't have the bandwidth to do that but someone can probably pick it up fairly easily, I've already done all the hard work :)
15:37:19 <amoralej> sure dmsimard, i was not thinking in you but in myself :)
15:37:20 <dmsimard> otherwise I can probably do it sometime during ocata
15:37:22 <amoralej> for ocata
15:37:27 <chandankumar> rbowen: since RDO newton release is coming, we might need to update your documentation to caters RDO newton.
15:37:37 <dmsimard> amoralej: the review is here: https://review.openstack.org/#/c/337860/
15:37:45 <jpena> panda: https://review.rdoproject.org/etherpad/p/dlrn-on-nodepool . Trying to find a trello card (can't remember if we opened it=
15:37:47 <amoralej> thanks dmsimard
15:38:25 <panda> jpena: thanks.
15:38:53 * number80 good
15:38:57 <number80> chandankumar: rbowen left
15:40:41 <amoralej> anything else for open floor?
15:42:31 <amoralej> we still have some time but if there are not more topics i'll close the meeting and give you back 20 minutes, :)
15:43:33 <amoralej> #endmeeting