15:01:04 <jruzicka> #startmeeting RDO meeting - 2016-10-19
15:01:04 <openstack> Meeting started Wed Oct 19 15:01:04 2016 UTC and is due to finish in 60 minutes. The chair is jruzicka. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:04 <zodbot> Meeting started Wed Oct 19 15:01:04 2016 UTC. The chair is jruzicka. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:04 <zodbot> The meeting name has been set to 'rdo_meeting_-_2016-10-19'
15:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:08 <openstack> The meeting name has been set to 'rdo_meeting___2016_10_19'
15:01:13 <rbowen> Geez. Already?
15:01:29 <dmsimard> I know right, three meetings in a row for me today. Productive.
15:01:31 <jruzicka> #topic roll call
15:01:40 <rbowen> Yo
15:01:41 <jruzicka> oh hello o/
15:01:47 <flepied> o/
15:01:47 <jpena> o/
15:01:48 <chandankumar> \o/
15:01:54 <jjoyce> o/
15:02:03 <dmsimard> \o
15:02:19 <jschlueter> o/
15:02:41 <jruzicka> #chair flepied jpena chandankumar jjoyce dmsimard jschlueter
15:02:41 <openstack> Current chairs: chandankumar dmsimard flepied jjoyce jpena jruzicka jschlueter
15:02:41 <zodbot> Current chairs: chandankumar dmsimard flepied jjoyce jpena jruzicka jschlueter
15:03:11 <rdogerrit> Merged rdopkg: Update to 0.41 http://review.rdoproject.org/r/3387
15:03:11 <mengxd> o/
15:03:55 <dmellado> o/
15:04:15 <apevec> o/
15:04:16 <dmellado> dmsimard: maybe we can have a meeting later to speak about the meetings
15:04:20 <dmellado> meta-meeting, sorta
15:04:23 <dmellado> xD
15:04:32 <jruzicka> #chair mengxd dmellado apevec number80
15:04:32 <openstack> Current chairs: apevec chandankumar dmellado dmsimard flepied jjoyce jpena jruzicka jschlueter mengxd number80
15:04:32 <zodbot> Current chairs: apevec chandankumar dmellado dmsimard flepied jjoyce jpena jruzicka jschlueter mengxd number80
15:04:44 <trown> o/
15:05:01 <jruzicka> #chair trown
15:05:01 <zodbot> Current chairs: apevec chandankumar dmellado dmsimard flepied jjoyce jpena jruzicka jschlueter mengxd number80 trown
15:05:02 <openstack> Current chairs: apevec chandankumar dmellado dmsimard flepied jjoyce jpena jruzicka jschlueter mengxd number80 trown
15:05:06 <rdogerrit> Merged DLRN: Allow to test a packaging fix for an upcoming upstream change http://review.rdoproject.org/r/3356
15:05:10 <jruzicka> #topic unresponsive maintainer procedure in case of FTBFS or unreliable upstream release model
15:05:13 <trown> dmsimard: but how many meetings did you schedule during the meetings
15:05:21 <trown> that is the true measure of productivity
15:05:35 <jruzicka> #link https://review.rdoproject.org/r/#/q/topic:rdo-FTBFS
15:05:43 <jruzicka> #link https://review.rdoproject.org/r/#/q/topic:rdo-FTBFS-newton
15:05:49 <apevec> o/ I propose this topic
15:05:52 <dmsimard> Do we have any of those right now ? I think cisco was addressed, there was arista as well ?
15:05:56 <jruzicka> apevec, stage is yours ;)
15:06:05 <dmsimard> We probably need to formalize a process/policy around it, yes
15:06:06 <apevec> we need to formalize the policy and document it
15:06:09 <apevec> yep
15:06:16 <amoralej> o/
15:06:22 <amoralej> sorry
15:06:24 <number80> o/
15:06:35 <apevec> so unresponsivenes on FTBFS which blocks "consistent" is one thing
15:06:52 <apevec> but maintainer should also talk to respecitve upstream
15:07:16 <apevec> and if they don't have usable release model, we'll not be able to package them
15:07:35 <apevec> networking-vmware is current example
15:08:00 <apevec> I'd propose we start with Fedora
15:08:11 <apevec> 's unresponsiveness procedure and refine it
15:08:26 <apevec> e.g. timeouts in Fedora might be too long for us
15:08:32 <rbowen> That always seems like a good place to start.
15:08:39 <apevec> any other suggestions ?
15:09:40 <apevec> it's a balance, we don't want this to be hall of shame list but with move to more build automation, we need to have predictable packaging and upstream releases
15:09:56 <number80> +1 for that proposal
15:10:00 <jruzicka> +1
15:10:12 <amoralej> +1
15:10:23 <trown> +1
15:10:26 <jruzicka> I'm also +1 for explicitly documenting rogue projects that break automation in some public shame list
15:10:39 <jruzicka> but that's offtopic here
15:10:41 <jpena> +1
15:10:53 <dmsimard> +1
15:11:14 <rdogerrit> chkumar246 proposed openstack/rally-distgit: Fixed config-generated, missing dependency and cleaned up unnecessary files. http://review.rdoproject.org/r/3190
15:11:28 * apevec apevec to send formal unresponsive procedure proposal to rdo-list
15:11:45 <dmsimard> you probably meant #action
15:11:47 <jruzicka> #action apevec to send formal unresponsive procedure proposal to rdo-list
15:11:52 <apevec> err yes
15:12:14 <jruzicka> #topic Test day stats
15:12:45 <jruzicka> #info 4 tickets, 53 IRC participants
15:12:48 <jruzicka> #info 1680 messages (roughly twice the chatter as last time, and much of it actually about testing)
15:12:59 <jruzicka> #link http://rdoproject.org/testday/
15:13:38 <trown> remix_tj++ helped file a bug and a patch against tripleo!
15:13:57 <trown> that has since made it into stable/newton
15:14:52 <remix_tj> does exists a beer bank of tripleo? i have debts with trown and amoralej :-)
15:15:18 <jruzicka> if it doesn't it's a serious bug ;)
15:15:26 <amoralej> :)
15:15:51 <jruzicka> ok, moving on
15:15:53 <rbowen> Oh, test day. I just wanted to report the stats. It was very encouraging,a fter the last one.
15:15:58 <rbowen> Sorry, I was momentarily distracted.
15:16:13 <rbowen> We had a lot of actual discussion on IRC by people that were obviously testing stuff.
15:16:26 <trown> ya +1 was one of the better ones
15:16:38 <dmsimard> Next one will be even better :D
15:16:51 <dmsimard> We had some last minute issues here and there
15:17:00 <jruzicka> #info test day was very encouraging, one of the better testing days
15:17:14 <myoung> o/
15:17:15 <jruzicka> #info next test day will be even better :D
15:17:21 <jruzicka> #chair amoralej myoung
15:17:21 <zodbot> Current chairs: amoralej apevec chandankumar dmellado dmsimard flepied jjoyce jpena jruzicka jschlueter mengxd myoung number80 trown
15:17:22 <openstack> Current chairs: amoralej apevec chandankumar dmellado dmsimard flepied jjoyce jpena jruzicka jschlueter mengxd myoung number80 trown
15:17:36 <jruzicka> #topic We are running a survey on how the community is using RDO
15:17:47 <rbowen> We have 19 responses so far to the survey
15:17:48 <jruzicka> #link https://goo.gl/forms/ZolZdgrfREHUs3Vt1
15:18:02 <rbowen> I will be posting an anonymized summary to the RDO blog in a few weeks.
15:18:35 <dmsimard> 19 responses already, yay
15:18:36 <rbowen> So far, 58% of respondents are running production clouds on RDO, while 21% are using it to as a Proof of Concept for their org.
15:18:44 <jruzicka> nice!
15:19:07 <rbowen> And the packstack/tripleo split is 30/25
15:19:17 <dmsimard> I think it may have been worth adding an option "I'm considering RDO" or "Looking to learn more about RDO" but it's too late now :p
15:19:21 <rbowen> Still a very small sample size, but I think we'll get some useful info out of it.
15:19:39 <rbowen> Writing surveys is hard. :-)
15:19:47 <jruzicka> doing surveys is hard :-p
15:20:04 <jruzicka> looking forward to results
15:20:07 <rbowen> So, yeah, spread the word, and we'll hopefully get some folks at Summit filling it out, too.
15:20:17 <rbowen> I'll come up with an easier shortURL for it.
15:20:57 <jruzicka> #topic aarch64
15:21:05 <jruzicka> number80, please enlighten us
15:21:43 <apevec> he's busy doing it? :)
15:22:16 <apevec> let's paste as info what is in agenda?
15:22:18 <jruzicka> quite likely :)
15:22:19 <jruzicka> ok
15:22:42 <jruzicka> #info enabling arch in CBS build targets
15:22:45 <rdogerrit> Jon Schlueter proposed openstack/rally-distgit: Fixed BR for oslo-config-generator http://review.rdoproject.org/r/3386
15:22:48 <jpena> Are we just doing it in CBS, or will we have a DLRN instance?
15:22:53 <jruzicka> #info do not build openstack-tripleo-ui until new order (it will break until bootstrapping is finished)
15:22:57 <apevec> jpena, just CBS
15:23:08 <apevec> for now
15:23:17 * jruzicka just almost pasted his top secret rdopkg copr credentials
15:23:29 <number80> yes
15:24:44 <number80> it's the only arch-dependent package in newton tag, os it'll break before we finish, so do not push update until we're done
15:24:49 * number80 has keyboard issue
15:26:22 <number80> jruzicka: having a DLRN instance for one package won't be useful :)
15:26:33 <jruzicka> serious keyboard issues... shall we move on?
15:26:40 <jruzicka> :-p
15:27:17 <jruzicka> #topic Skip RDO meeting next week yay/nay?
15:27:30 <trown> yay
15:27:37 <rbowen> Next week's meeting is Tuesday evening in Barcelona, and will be streamed on YouTube
15:27:46 <rbowen> https://www.youtube.com/watch?v=ji-WqEXZRTY
15:27:47 <rbowen> :D
15:27:49 <trown> fancy
15:27:58 <jruzicka> live RDO meeting omg
15:28:06 <apevec> so chair is rbowen !
15:28:14 <jpena> wow, I'll have to cut my hair so I look fine on youtube :P
15:28:41 <chandankumar> i will watch everybody on youtube :P
15:29:05 <apevec> #info Next week's meeting is Tuesday evening in Barcelona, and will be streamed https://www.youtube.com/watch?v=ji-WqEXZRTY
15:29:11 <number80> \o/
15:29:14 <rbowen> So, here's hoping the network isn't awful there.
15:29:25 * number80 will just repeat same bet as last time
15:29:32 <jruzicka> we will see about that :)
15:29:34 <number80> until it gets reality
15:29:35 <apevec> 1 or 2h ?
15:29:51 <number80> 2h
15:29:56 <apevec> we had 10h delay after upstream GA for newton
15:30:02 <rbowen> I expect the actual meeting part to be only 1 hour.
15:30:13 <rbowen> But we have the room until 21:00
15:30:23 <rbowen> Or until the beer runs out. :-)
15:30:30 <apevec> ok, so 500% improvement, good goal :)
15:30:35 <dmsimard> This is probably going to be jam packed
15:30:35 <jruzicka> I like the sound of that.
15:30:36 <number80> yep, but this time, we'll get repo prepared ahead of time
15:30:41 <dmsimard> Lots of interest in the event
15:30:52 <rbowen> We have sold out the EventBrite tickets (150) but we held back some secret ones, so you won't be turned away.
15:31:04 <number80> if it's not challenging, it's not a real goal
15:32:41 <jruzicka> #info we aim at 500% improvement
15:32:47 <apevec> alright, we're out of agenda
15:32:49 <jruzicka> with that we move to Annoucements
15:32:52 <jruzicka> no, sry
15:32:58 <jruzicka> I went out of order
15:33:08 <apevec> ah
15:33:12 <apevec> get in order!
15:33:22 <jruzicka> apevec, no, you let me chair!
15:33:26 <jruzicka> :-p
15:33:38 <jruzicka> #topic Announcements
15:33:44 <rbowen> Mostly same announcements as every week, from me. If you're going to be at OpenStack Summit, please drop by the booth between talks to help answer questions.
15:33:48 <jruzicka> rbowen, please go ahead
15:33:54 <rbowen> #link https://etherpad.openstack.org/p/rdo-barcelona-summit-booth
15:34:07 <rbowen> And, we already mentioned the RDO/Ceph gathering.
15:34:10 <rbowen> Free Beer
15:34:12 <rbowen> :)
15:34:22 <rbowen> I hope to see many of you in a few days in Barcelona.
15:34:27 <rbowen> Then we can start working on FOSDEM.
15:34:31 <dmsimard> rbowen: still no all-you-can-ask session ?
15:34:46 <dmsimard> so you just need general coverage here and there ?
15:35:05 <rbowen> Well, I'm not sure when these people are actuallya vailable.
15:35:13 <rbowen> If you want to claim a time slot, we'll promote an all-you-can-ask
15:35:18 <rbowen> put up signs and whatnot.
15:35:26 <apevec> ah there was realy "free beer " in the evenbrite that's why it sold out so fast :)
15:35:36 <dmsimard> apevec: lol
15:35:37 <rbowen> But I need to know what day/time you are available for that.
15:35:53 <dmsimard> rbowen: ok I haven't finished my summit schedule yet.. it's on my todo by friday :(
15:36:06 <rbowen> So, let me know by Tuesday morning, and we'll be fine. :-)
15:36:07 <apevec> yeah, I didn't work out my sched either
15:36:21 <rbowen> We'll have the schedule posted up at the booth.
15:36:23 <jruzicka> schedule... haha.
15:36:26 <apevec> let's just update etherpad when we know our free slots
15:36:29 <rbowen> Yes.
15:36:32 <rbowen> Yes please.
15:36:38 <jpena> rbowen: so we just assign slots to ourselves in the etherpad?
15:36:42 <rbowen> Yes please.
15:36:46 <jpena> ack
15:36:51 <rbowen> https://etherpad.openstack.org/p/rdo-barcelona-summit-booth
15:37:16 <apevec> #action everyone signup your slots in https://etherpad.openstack.org/p/rdo-barcelona-summit-booth
15:37:29 <rbowen> If we get enough people signed up, I can just spend the week on the beach.
15:37:35 <rbowen> :D
15:37:52 <apevec> well, temp 15-20something degC max
15:37:59 <rbowen> Yeah, there is that.
15:38:09 <jpena> cloudy all week, meh
15:38:10 <rbowen> anyways, that's all the announcements, I believe.
15:38:12 <dmsimard> pff, that's okay by Canadian standards
15:38:20 <dmsimard> still beach-able
15:39:04 <dmsimard> remember, I live in an igloo with my pet moose and beaver
15:39:50 <apevec> yeah there's always something worse :)
15:41:02 <apevec> any other announcements?
15:41:06 <jruzicka> oh yes, sry
15:41:09 <jruzicka> distraction
15:41:31 <jruzicka> #info rodpkg-0.41 release right now
15:41:50 <rdogerrit> David Moreau Simard created config: Revert "Temporarily disable TryStack" http://review.rdoproject.org/r/3388
15:42:21 <jruzicka> it contains critical `rdopkg patch` fix, new tag-patches command by ktdreyer, massive refactoring and fixes
15:42:34 <jruzicka> please upgrade and test
15:43:07 <apevec> jschlueter, ^ you reported patch issue
15:43:19 <jruzicka> jschlueter, yes, that one should be fixed
15:44:01 <jruzicka> aaand that's it
15:44:04 <jruzicka> #topic open floor
15:45:02 <remix_tj> i'll try to come to the rdo booth, but only as visitor to thank you all
15:45:17 <dmsimard> completely random but just sharing
15:45:32 <dmsimard> I created this card almost a year ago when I joined Red Hat: https://trello.com/c/1YzosHkU/134-idea-create-a-tool-to-follow-release-notes
15:45:40 <rbowen> remix_tj: See you there!
15:45:51 <dmsimard> tl;dr when something breaks, upstream tells us to read the release notes but there are so many release notes it's impossible to keep up with them
15:46:06 <misc> dmsimard: that's the idea
15:46:16 <rbowen> I spent a day reading the release notes from the various projects. It was soul-crushing.
15:46:17 <dmsimard> so I just talked with Doug about this and he's open to adding something like rss or some other means of subscribing to release notes updates
15:46:18 <misc> like saying to open a ticket when there is 5 bug tracker :)
15:46:31 <dmsimard> adding something like rss on the condition that I do it, of course
15:46:34 <jruzicka> soul-crushing release notes :D
15:46:42 <dmsimard> so that'll be a stretch goal for ocata for me on downtime
15:46:59 <rbowen> Also, most of the projects do a really poor job of talking about what is actually *interesting* about a particular release, in a way that anyone outside of the project will actually care about.
15:47:16 <dmsimard> rbowen: yeah, some notes are developer oriented, others are user oriented
15:48:12 <jruzicka> you could sort that through neural network and only filter user oriented ones :-p
15:48:19 <dmsimard> that was it for me, just sharing an interesting improvement coming eventually
15:48:43 <rbowen> Oh, I had one other thing.
15:49:10 <rbowen> If you worked on something cool in Newton, or are planning something cool for ocata (dmsimard!) I will be doing the "what did you work on" interviews like I did last time around.
15:49:25 <rbowen> Podcast, or blog post, or whatever. Either in person in Barcelona, or on Hangouts later.
15:49:30 <rbowen> SO let me know if you like to talk.
15:50:02 <dmsimard> rbowen: pff, like 75% of the stuff I wanted to do in newton that was recorded in the interview didn't make the cut :p
15:50:16 * dmsimard wants to do too many things
15:50:25 <jruzicka> great ambitions make great progress
15:50:50 <dmsimard> oh, yeah, progress was had -- just not on the things I thought
15:51:19 <jruzicka> same here ;)
15:51:30 <jruzicka> and with that
15:51:47 <jruzicka> #topic next chair
15:51:57 <jruzicka> #info rbowen because we meet in Barcelona
15:52:02 <rbowen> :D
15:52:23 <jruzicka> #endmeeting