15:00:02 <jruzicka> #startmeeting RDO meeting - 2017-06-14
15:00:03 <openstack> Meeting started Wed Jun 14 15:00:02 2017 UTC and is due to finish in 60 minutes.  The chair is jruzicka. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:06 <openstack> The meeting name has been set to 'rdo_meeting___2017_06_14'
15:00:17 <amoralej> o/
15:00:38 <jruzicka> o/
15:00:54 <jpena> o/
15:01:11 <rdogerrit> Merged config master: Ensure there is no master branch in distgit repos  https://review.rdoproject.org/r/6857
15:01:19 <jruzicka> do we still need to do explicit #chair or not?
15:01:49 <amoralej> i think someone said it was not needed
15:02:01 <jruzicka> let's see what happens when we don't :)
15:02:13 <jruzicka> #topic Migration of www.rdoproject.org to RDO Cloud
15:02:21 <amoralej> number80, apevec, chandankumar, ykarel, meeting time
15:02:32 <amoralej> friendly reminder :)
15:02:34 <chandankumar> \o/
15:02:48 <jruzicka> #undo
15:02:49 <openstack> Removing item from minutes: #topic Migration of www.rdoproject.org to RDO Cloud
15:02:54 <apevec> o/
15:02:55 <number80> o/
15:03:32 <apevec> I guess you cannot set topics/undo if not chair?
15:03:35 <apevec> #undo
15:03:41 <apevec> which is fine
15:04:00 <jruzicka> sounds fine, let's see
15:04:30 <jruzicka> So let's start.
15:04:31 <Duck> quack o/
15:04:49 <jruzicka> #topic Migration of www.rdoproject.org to RDO Cloud
15:05:06 <jpena> this is mine
15:05:28 <jpena> so the cloud where our current www is running is going to be shut down soon (before the end of July)
15:05:51 <jpena> we have a tenant in the RDO Cloud ready for this, so it's just a heads up and a shout out to Duck and misc for coordination
15:06:17 <apevec> we also should plan review.rdo migration after that
15:06:38 <Duck> jpena: so we just need to publish the site on a new place then?
15:07:11 <Duck> and so RDO Cloud is also ready for production then
15:07:25 <jpena> Duck: yes. Do you want to have credentials on the RDO Cloud tenant, or just want a VM to deploy on?
15:07:39 <jpena> the RDO Cloud is mostly ready, but in any case in a better shape than OS1
15:08:26 <Duck> I guess it's mostly a matter of involvement, if we have more access we can help on other areas
15:09:01 <misc> also may help in case of panic
15:09:14 <jpena> Duck, misc: sure, then let's ask for access. Do you have an account in the RDO Cloud already?
15:09:30 <Duck> no Sir, where do I get it?
15:10:22 <jpena> I'll send you the details
15:10:58 <Duck> jpena: on a side matter, I was going to ask about what kind of projects are acceptable to host (on a possible separate tenant), so if we could talk about it too :-)
15:11:37 <jpena> Duck: it's meant for RDO/OpenStack development, so anything related should be acceptable
15:13:02 <misc> good, so we can host gluster here, that can be used with openstack :)
15:13:23 <jpena> :)
15:14:20 <jpena> so that's it for the topic. We are now in sync
15:14:23 <jruzicka> #topic Plan to prevent DLRN from falling back to master when future EOL branches are created
15:15:49 <jpena> this topic came up today. When a release goes EOL, their stable branches get deleted, and we get branch-eol instead
15:16:01 <jpena> this confuses DLRN, which falls back to master
15:16:37 <jpena> and that creates havoc in our repos, because we have mixed master and stable/mitaka packages (in this case)
15:17:41 <jpena> after some  discussions, I think the best idea is to add a new option for DLRN, to avoid the fallback behavior for workers running on the stable branches
15:18:36 <jpena> the only side-effect is that, for some packages that are currently using master on older releases (for example python-hacking), we'll have to set some source-branch for them in rdoinfo
15:18:42 <misc> why not disable the fallback ?
15:18:46 <apevec> to clarify one thing above: tag $branch-eol
15:19:16 <apevec> but that's openstack project specific
15:19:37 <apevec> misc, we use fallback before stable branches are created
15:19:48 <apevec> also some project are master branch only
15:20:07 <jpena> for example: during pike branching, we'll have a mix of stable/pike and master for a few weeks
15:20:24 <apevec> yeah, not all branch at the same time
15:20:36 <jpena> after GA, we can flip the switch and prevent fallback
15:20:45 <apevec> and we start new DLRN instance in advance
15:20:51 <apevec> to bootstrap it on time
15:21:06 <apevec> jpena, some project are branching after GA
15:21:21 <jpena> apevec: ok, then when all projects have branches
15:21:28 <jpena> s/branches/branched
15:21:51 <apevec> ack, we need to check that for each cycle there won't be fixed date
15:22:37 <amoralej> apevec, in the worst case, if we want to follow master trunk for a specific project
15:22:43 <amoralej> we can use source-branch: master
15:22:45 <amoralej> in rdoinfo
15:22:53 <rdogerrit> chkumar246 proposed rdoinfo master: Remove under-review tag from patrole  https://review.rdoproject.org/r/7059
15:22:57 <apevec> right
15:23:05 <apevec> now, the option naming! :)
15:23:11 <apevec> source-branch-lock  ?
15:23:51 <jpena> apevec: oh, it's just an option in projects.ini, not in rdoinfo
15:23:53 <amoralej> will it disable fallback both for distgits and project repos, right?
15:24:00 <jpena> amoralej: yes
15:24:09 <apevec> jpena, still needs a name
15:24:10 <jpena> that's not a big deal, since we do not do lazy branching anymore
15:24:11 <amoralej> disable_repo_fallback
15:24:30 <jpena> in my test implementation, it's fallback_to_master
15:24:36 <jpena> enabled by default
15:24:36 <apevec> hm, it's branch fallback not repo
15:24:59 <apevec> +1 for fallback_to_master
15:25:08 <apevec> and default
15:25:11 <jruzicka> fallback_to_master sounds self-explainatory
15:25:17 <amoralej> sounds good
15:25:18 <amoralej> +1
15:25:30 <jpena> good, then I don't have to change my patch :D
15:25:38 <jruzicka> :D
15:27:21 <jruzicka> #info DLRN to contain fallback_to_master option to prevent unwanted fallback to master branch for stable releases
15:27:24 <amoralej> jpena, when disabling fallback, we should announce to maintainers, as they should manage them for projects without stable branch
15:27:37 <jpena> amoralej: ok
15:28:37 <jruzicka> #topic Mitaka EOL
15:28:46 <apevec> yes finally!
15:28:49 <amoralej> i added that
15:28:56 <jruzicka> #info Current stable builds in -testing passed CI in https://ci.centos.org/view/rdo/view/cbs-promote-pipelines/job/rdo-promote-cloudsig-testing-mitaka/
15:28:57 <apevec> I'm tagging the builds to -release as we type
15:29:04 <amoralej> yeah, finally it passed CI
15:29:12 <amoralej> ok, can i remove the jobs in ci.centos already?
15:29:53 <amoralej> apevec ^ do you want to run CI on -release?
15:30:32 <apevec> amoralej, we could do that only once synced to mirror.c.o
15:30:36 <apevec> so tomorrow
15:30:48 <apevec> so yes, let's wait with removing jobs until tomorrow
15:30:59 <amoralej> it will be synced today?, nice, i though we would have to wait for some window
15:31:11 <apevec> it will be tomorrow morning
15:31:13 <amoralej> moving them to vault is after sync to mirror.c.o?
15:31:18 <apevec> window is Mon-Thu
15:31:33 <amoralej> ok, good to know
15:31:34 <apevec> amoralej, yes, I'll send request to centos-devel
15:32:02 <apevec> I think this will be first SIG report to move to vault.c.o so we'll need to figure out the process
15:32:07 <apevec> and document for other sigs
15:32:17 <amoralej> didn't we do it for previous releases?
15:32:18 <apevec> s/report/repository/ !
15:32:41 <apevec> amoralej, no, we'll do it now for all old releases
15:33:06 <amoralej> ok
15:33:38 <amoralej> #action amoralej to run CI jobs on mitaka-release tags and remove all mitaka jobs from ci.centos once they pass
15:34:10 <amoralej> that's it from my side
15:34:18 <apevec> #action apevec to request move <= Mitaka repos to valut.centos.org
15:34:25 <apevec> #undo
15:34:39 <jruzicka> #undo
15:34:40 <openstack> Removing item from minutes: #action apevec to request move <= Mitaka repos to valut.centos.org
15:34:44 <apevec> thanks :)
15:34:53 <apevec> #action apevec to request move <= Mitaka repos to vault.centos.org
15:36:07 <jruzicka> #topic open floor
15:37:17 <apevec> Reminder: test day(s) tomorrow and Friday!
15:37:21 <amoralej> apevec, number80, could you review https://review.rdoproject.org/r/#/c/7060/ and https://review.rdoproject.org/r/#/c/7071/ when you have a chance?
15:37:30 <apevec> we now have passed-ci just in time!
15:37:48 <apevec> amoralej, will do
15:38:15 <amoralej> we have another upstream promotion today for master, promotion pipeline is running now
15:38:17 <apevec> #info Test Day Pike2 this week! https://www.rdoproject.org/testday/pike/milestone2/
15:38:28 <amoralej> maybe we can have even something newer for tomorrow
15:38:40 <apevec> amoralej, if it works, sure
15:39:57 <number80> amoralej: ack
15:40:32 <jruzicka> #topic next chair
15:40:34 <chandankumar> test day is tomorrow
15:40:44 <chandankumar> jruzicka: i can do thatr
15:40:51 <jruzicka> #action chandankumar to chair next meeting
15:41:23 <jruzicka> #endmeeting