15:00:42 <jpena> #startmeeting RDO meeting - 2017-08-16
15:00:43 <openstack> Meeting started Wed Aug 16 15:00:42 2017 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:47 <openstack> The meeting name has been set to 'rdo_meeting___2017_08_16'
15:00:57 <jpena> #topic roll call
15:01:08 <myoung> o/
15:01:09 <ykarel> \o
15:01:10 <snecklifter> o/
15:01:15 <jruzicka> \0/
15:01:20 <jpena> #chair myoung ykarel snecklifter jruzicka
15:01:21 <openstack> Current chairs: jpena jruzicka myoung snecklifter ykarel
15:01:24 <PagliaccisCloud> o/
15:01:31 <jpena> #chair PagliaccisCloud
15:01:33 <openstack> Current chairs: PagliaccisCloud jpena jruzicka myoung snecklifter ykarel
15:01:44 <number80> o/
15:01:49 <amoralej> o/
15:01:54 <jpena> #chair amoralej numans
15:01:54 <openstack> Current chairs: PagliaccisCloud amoralej jpena jruzicka myoung numans snecklifter ykarel
15:01:57 <jpena> #undo
15:01:58 <openstack> Removing item from minutes: #topic roll call
15:02:08 <jpena> it looks like I can't remove chairs :)
15:02:11 <jpena> #topic roll call
15:02:15 <jpena> #chair number80
15:02:16 <openstack> Current chairs: PagliaccisCloud amoralej jpena jruzicka myoung numans number80 snecklifter ykarel
15:02:36 <number80> use #unchair for that
15:02:42 <jpena> oh
15:02:46 <jpena> #unchair numans
15:02:47 <openstack> Current chairs: PagliaccisCloud amoralej jpena jruzicka myoung number80 snecklifter ykarel
15:02:58 <jpena> thx number80
15:03:06 <number80> (undo is only for items that appears in the final report)
15:03:32 <jpena> let's start with the agenda
15:03:34 <rdogerrit> Merged openstack/vmware-nsx-distgit rpm-master: Remove python-networking-vmware-nsx-tests-tempest subpackage.  https://review.rdoproject.org/r/8579
15:03:44 <jpena> #topic (Follow up from last week) We still haven't done any work towards shipping stable release of containers
15:04:12 <jpena> this topic was proposed by dmsimard|off, who is off... Has anyone taken it over?
15:04:40 <jruzicka> so probably, that still stands :D
15:04:45 <rbowen> present
15:04:52 <jpena> #chair rbowen
15:04:53 <openstack> Current chairs: PagliaccisCloud amoralej jpena jruzicka myoung number80 rbowen snecklifter ykarel
15:05:13 <amoralej> main issue is that DoD is not clear with regards to container i think
15:06:03 <amoralej> do RDO has to provide containers images for tripleo or will tripleo itself provides them?
15:06:10 <amoralej> it's unclear to me
15:09:04 <rdogerrit> trown proposed config master: Add additional containerized multinode jobs to pipelines  https://review.rdoproject.org/r/8586
15:09:22 <number80> To me is means changing RDO Definition of Done
15:09:48 <number80> https://www.rdoproject.org/blog/2016/05/technical-definition-of-done/
15:09:59 <rbowen> It does seem to be, yes.
15:10:15 <number80> It implies that we are to provide those images
15:10:21 <snecklifter> phew, I was wondering what the heck the Dept of Defense had to do with this
15:10:40 <trown> it is even a bit trickier I think
15:10:45 <number80> snecklifter: common acronym if you read agile litterature
15:10:52 <snecklifter> i dont :/
15:11:06 <trown> because tripleo will build/host images using rdo infra (but upstream code)
15:11:11 <number80> snecklifter: I can share few recommendation after the meeting if you like :)
15:11:20 <trown> is that good enough for rdo dod?
15:11:37 <snecklifter> number80: sure
15:11:38 <number80> trown: what do you mean by upstream code?
15:11:56 <trown> number80: the job runs using tripleo-ci repo
15:12:13 <rbowen> Do we need to explicitly add this to the dod article?
15:12:25 <trown> number80: so changing what happens involves changing tripleo-ci repo
15:12:39 <amoralej> we are already providing images based on RDO Trunk (dlrn builds)
15:12:55 <amoralej> the point, IMO, is if we need to provide images based on CloudSIG ones
15:12:59 <number80> trown: I'm fine with code from upstream but the artefact should be published by our infra at some point
15:13:00 <trown> ah, right
15:13:09 <trown> sorry mixed the two
15:13:21 <amoralej> and providing them via official centos registry
15:13:24 <trown> tripleo is responsible for trunk builds
15:13:27 <number80> amoralej: I think we should at some point
15:13:41 <trown> to me RDO would be responsible for stable builds
15:14:07 <number80> trown: we also have to make sure that 3o works with those images
15:14:19 <trown> I think the question then is whether to provide vanilla stable builds or tripleo stable builds for containers
15:14:51 <trown> my opinion is that vanilla stable builds will not be very useful to the community given we dont provide any deployment tool for them
15:15:01 <rdogerrit> Yatin Karel proposed openstack/designate-distgit rpm-master: Requirement sync for pike  https://review.rdoproject.org/r/8589
15:15:14 <amoralej> trown, i agree with that
15:15:19 <trown> but I know dmsimard has a different opinion
15:15:52 <amoralej> yeah, the point is that publishing something that we don't test at all
15:16:33 <number80> well, we can fix this if we agree on that :)
15:16:51 <trown> in a world with infinite resources it would probably make sense to test and publish both the vanilla and tripleo containers
15:16:52 <number80> But I suggest that we move this topic to the mailing list so every stakeholder gets a chance to share their PoV
15:16:55 <rdogerrit> Yatin Karel proposed openstack/heat-distgit rpm-master: Requirement sync for pike  https://review.rdoproject.org/r/8590
15:17:10 <jpena> +1 to complete the discussion on the mailing list
15:17:24 <trown> ya, +1 to ML
15:17:31 <ykarel> +1 to ML
15:17:46 <number80> trown: if we need resources then we'll go ask our sponsors to help :)
15:18:02 <rbowen> Who's going to start that thread?
15:18:07 <number80> first is to define what we want to do
15:18:52 <number80> trown: ?
15:19:01 * number80 has not the full background of that question
15:19:36 <trown> I dont really have bandwidth to lead that discussion atm
15:20:02 <trown> I can chime in with my opinion from tripleo perspective, but not really herd the cats on it
15:20:38 <jpena> dmsimard will be back next week, we can "assign" the task to him, but we'll lose a couple days
15:20:49 <rdogerrit> Ronelle Landy proposed config master: Add OVB jobs and all periodic pipelines  https://review.rdoproject.org/r/7754
15:20:52 <number80> if nobody will take it, I'll kickstart the discussion
15:21:03 <trown> ya, not sure it is that pressing tbh
15:21:19 <number80> trown: decision can wait but let's have people start discussing
15:21:37 <trown> number80: sure
15:21:54 <rdogerrit> Yatin Karel proposed openstack/gnocchiclient-distgit rpm-master: Requirement sync for pike  https://review.rdoproject.org/r/8591
15:22:17 <number80> #action number80 start discussion on containers image/RDO
15:22:43 <jpena> next topic?
15:22:48 <number80> *nods*
15:23:08 <jpena> #topic coverage removal as build requirement -> https://github.com/redhat-openstack/easyfix/issues/11
15:23:19 <jpena> this topic was raised by snecklifter
15:23:28 <snecklifter> hello
15:23:37 <snecklifter> Quick summary?
15:23:41 <number80> yes
15:23:54 <snecklifter> So I mostly did the patches to remove this: https://review.rdoproject.org/r/#/q/topic:easyfix/11
15:24:12 <snecklifter> I think chandankumar raised it as a quick fix
15:24:25 <snecklifter> mrunge has mentioned he thinks coverage should stay
15:24:54 <snecklifter> I dont care hugely either way but it would be good to understand the rationale behind some of the fixes
15:25:12 <snecklifter> I'm enjoying doing the easy work but need to know its of some use
15:25:36 <snecklifter> So just need some guidance on whether it *should* be removed or not
15:25:38 <snecklifter> EOF
15:25:40 <number80> I think it was removed upstream, but it may not be the case for all projects
15:25:50 <jpena> so afaik, coverage is only used to report the number of lines covered by unit tests, is that right?
15:26:07 <number80> yeah
15:26:12 <amoralej> yes, and afaik is not used when running  unit tests from %check
15:26:17 <jpena> and we don't care about that in %check
15:26:35 <amoralej> so, IMO we can remove it
15:26:41 <jpena> unless we're using it in the %check command-line for some reason (that might be the case in a spec)
15:26:41 <snecklifter> mrunge believed there was some benefit to keeping it hence he -1 a couple of reviews
15:27:08 <snecklifter> unfortunately they could not make the meeting
15:27:47 <snecklifter> ok, jpena would you mind putting a comment about why this is happening in the github ticket?
15:27:54 <trown> if we dont ever use it in the build... it should not be in build-requires
15:28:17 <jpena> snecklifter: sure. We can also discuss it with mrunge when he's back, I think it's not needed
15:28:22 <snecklifter> trown: this is what I thought but again, I'm just doing the donkey work so needed to defer to experts :)
15:28:45 <trown> maybe mrunge missed that aspect, and is just commenting on the general usefulness of coverage as a metric (which I agree with)
15:28:57 <jpena> #action jpena to add more clarification about coverage removal at https://github.com/redhyepat-openstack/easyfix/issues/11
15:29:02 <snecklifter> trown: I think that is the case
15:29:08 <jpena> #undo
15:29:09 <openstack> Removing item from minutes: #action jpena to add more clarification about coverage removal at https://github.com/redhyepat-openstack/easyfix/issues/11
15:29:13 <jpena> #action jpena to add more clarification about coverage removal at https://github.com/redhat-openstack/easyfix/issues/11
15:29:40 <jpena> let's move on, we have several topics to cover
15:29:42 <trown> thanks for tackling that snecklifter
15:29:46 <snecklifter> also, there are still a good few reviews waiting +2/W so it would be great if they could be done, they are just trivial one-liners
15:29:57 <snecklifter> thanks
15:30:06 <jpena> #topic DLRN builder migration to RDO Cloud: status update
15:30:43 <jpena> About the migration: the fedora, centos-newton and centos-ocata builders are now working on the new node, running in RDO Cloud
15:30:50 <rdogerrit> Yatin Karel proposed openstack/openstacksdk-distgit rpm-master: Requirement sync for pike  https://review.rdoproject.org/r/8592
15:31:12 <jpena> I'm currently syncing all data for the centos-pike, centos-master and centos-master-head workers, they'll all be active later today
15:31:25 <jpena> Once it's done, I'll switch DNS entries
15:31:40 <jpena> if anything is broken after that, I'm the person to yell at :)
15:31:47 <trown> ha
15:32:12 <rdogerrit> Yatin Karel proposed openstack/gnocchiclient-distgit rpm-master: Requirement sync for pike  https://review.rdoproject.org/r/8591
15:32:31 <jpena> any questions?
15:33:12 <jpena> #info DLRN builder being migrated to the new system on the RDO Cloud. DNS switch will happen later today
15:33:32 <jruzicka> so RDO Cloud is stable so far?
15:34:15 <jpena> jruzicka: yes, it's stable enough. review.rdo is running without issues, and having the instance closer to the DB is a good thing
15:34:31 <jruzicka> great
15:36:16 <jpena> ok, let's move on
15:36:25 <jpena> #topic rdophase2 (pike) CI pipeline is stood up and running
15:36:29 <jpena> myoung ^^
15:36:56 <myoung> just a general FYI, $title was put in place recently
15:37:42 <jruzicka> myoung, what does that mean in a short summary? :)
15:37:46 <myoung> details are in etherpad, RH Release Delivery is now importing from stable/pike vs. master for new osp12 puddles, so these jobs are now what we're looking at (vs. rdophase2: master)
15:38:43 <myoung> TLDR: rdophase2 := CI pipeline that runs after RDO pipelines in ci.centos promote hashes.  Runs on internal RH hardware, and we look for those jobs to pass prior to importing changes from RDO --> OSP.
15:39:10 <jruzicka> myoung, nice, thanks for tl;dr :)
15:39:35 <jpena> cool
15:39:57 <myoung> wanted to update #rdo with status, questions, more an announce vs. ask/need :)
15:40:10 <jpena> this time, the transition to stable/ branch is being smoother than usual :)
15:40:26 * myoung nods
15:40:48 <jpena> next topic, then?
15:40:57 <myoung> I think the one thing to make a note of is
15:41:17 <amoralej> myoung, just as a note, upstream promotion for pike is still based in a single job
15:41:18 <myoung> we still don't have container jobs in rdophase2, would like to add them soon once things stabilize in rdophase1
15:41:33 <amoralej> while master uses 6 jobs
15:41:47 <amoralej> but that's being fixed as we talk
15:41:59 <amoralej> https://review.rdoproject.org/r/#/c/7754/
15:42:01 <myoung> amoralej, ack, we're looking at both master+pike during transition.  Is there an ETA for when pike promotion will have full compliment of jobs?
15:42:21 <amoralej> hopefully soon
15:42:34 <myoung> jschlueter, tvignaud, weshay ^^
15:43:31 <myoung> amoralej, thx for update - will look @7754 and watch
15:43:59 <jpena> #topic Test day report?
15:44:09 <jpena> rbowen, did you add this topic?
15:44:27 <rbowen> Yeah. I was on the beach on test day. I wondered if anything useful happened.
15:45:09 <rbowen> If not, we can move on. But it would be worth figuring out how to make test days more profitable.
15:45:39 <amoralej> rbowen, i didn't see much activity, tbh
15:45:45 <number80> Yep
15:46:01 <rbowen> Ok. That's a shame.
15:46:14 <rdogerrit> Merged openstack/ironic-python-agent-distgit rpm-master: Requirement sync for pike  https://review.rdoproject.org/r/8611
15:46:20 <rbowen> We'll try to promote it more broadly for the Pike release, and give scenarios of suggested testing and so on.
15:46:21 <trown> it does feel a bit like as CI has become more stable test day participation has gone down
15:46:28 <trown> which does make some sense
15:46:28 <rbowen> Yes, that's definitely the case.
15:46:46 <rbowen> So identifying the scenarios that CI doesn't/can't test might be worthwhile.
15:46:46 <flaper87> number80: amoralej: http://logs.openstack.org/59/471759/59/experimental/gate-tripleo-ci-centos-7-scenario006-multinode-oooq-nv/b0410fc/logs/subnode-2/rpm-qa.txt.gz :(
15:46:53 <trown> we need to find a way to make test days .. ya that ^
15:46:58 <flaper87> number80: amoralej still python-jinja2-2.7.2-2.el7.noarch
15:47:00 <rbowen> Anyways, next topic I guess.
15:47:10 <number80> flaper87: I'll look into after we close the meeting
15:47:19 <flaper87> woops, didn't notice the meeting. so sorry :(
15:47:30 <jpena> #topic Release checklist - https://www.rdoproject.org/rdo/release-checklist/ - leading up to Pike release
15:47:37 <rbowen> Pike is scheduled for Aug 30. https://www.rdoproject.org/rdo/release-checklist/ is a list of things that I try to do to promote the RDO part of the release.
15:47:50 <rbowen> So I'll be working through that over the coming week, and asking for help with many of the items.
15:48:14 <rbowen> I'll be drafting the release messaging based on the last one we did, and then asking for input
15:48:24 <rbowen> We did an AWESOME job of this for Ocata.
15:48:54 <rbowen> But do look through that list, and see if there's any part of it that you'd like to participate in writing.
15:49:02 <rbowen> I'll be posting to the list about this as soon as I have the initial draft.
15:49:16 <rbowen> That's all.
15:49:47 <jpena> #action everyone help rbowen with Pike release messaging
15:50:15 <jpena> #topic chair for next meeting
15:50:15 <rbowen> Thanks.
15:50:27 <jpena> any volunteer to chair the next meeting?
15:50:44 <jruzicka> thanks for taking care of the dirty community work as always, rbowen ❤
15:50:49 <jruzicka> yeah, I can chair
15:51:17 <jpena> #action jruzicka to chair the next meeting
15:51:25 <jpena> #topic open floor
15:51:55 <jruzicka> rdopkg to have full python3 support in next release ;)
15:52:20 <jruzicka> mostly thanks to jpena anyway :)
15:55:50 <jpena> I think we're done, so let's get 5 minutes back!
15:55:54 <jpena> #endmeeting