15:00:26 <jpena> #startmeeting RDO meeting - 2018-10-17
15:00:27 <openstack> Meeting started Wed Oct 17 15:00:26 2018 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:28 <number80> o/
15:00:30 <openstack> The meeting name has been set to 'rdo_meeting___2018_10_17'
15:00:38 <jpena> remember to add last-minute topics to the agenda at https://etherpad.openstack.org/p/RDO-Meeting
15:00:41 <jpena> #topic roll call
15:00:45 <jpena> #chair number80
15:00:46 <openstack> Current chairs: jpena number80
15:00:51 <PagliaccisCloud> \o
15:01:05 <jpena> #chair PagliaccisCloud
15:01:06 <openstack> Current chairs: PagliaccisCloud jpena number80
15:03:30 <ykarel> o/
15:03:35 <jpena> #chair ykarel
15:03:36 <openstack> Current chairs: PagliaccisCloud jpena number80 ykarel
15:04:15 <amoralej> ykarel, we got a promotion!!!
15:04:24 <ykarel> amoralej, cool
15:04:25 <jpena> #chair amoralej
15:04:25 <openstack> Current chairs: PagliaccisCloud amoralej jpena number80 ykarel
15:04:30 <jpena> ok, let's start with the agenda
15:04:33 <amoralej> i'm about to leave, sorry
15:04:39 <jpena> #topic reserve rdo-* namespaces on gitlab?
15:04:42 <jpena> apevec ^^
15:05:43 <number80> +1 even if we don't use them but I'd like to hear more context
15:09:07 <mjturek> o/
15:09:12 <jpena> #chair mjturek
15:09:13 <openstack> Current chairs: PagliaccisCloud amoralej jpena mjturek number80 ykarel
15:12:15 <number80> ?
15:12:27 <jpena> shall we move on to the next topic until apevec arrives?
15:14:31 <number80> I guess so
15:14:48 <jpena> #topic drop newton tags from rdoinfo
15:14:56 <number80> +1
15:15:01 <jpena> apevec proposed this topic, too, but I think I have some more context
15:15:05 <number80> no arguments against it
15:15:25 <ykarel> +1
15:15:27 <jpena> newton is already EOL, so the RDO Trunk builder is basically idle or building some branchless project
15:15:42 <jpena> I'm +1 to it, too
15:15:55 <jpena> so we'll need 3 things:
15:16:11 <jpena> 1- stop newton DLRN builder (but keep repos around)
15:16:22 <jpena> 2- Remove newton tags from rdoinfo
15:16:28 <jpena> 3- Cleanup Newton ci jobs
15:16:58 <jpena> since the first item is related to DLRN, I'll take care of the coordination (unless someone else volunteers)
15:17:54 <jpena> #action jpena to coordinate newton removal
15:17:56 <ykarel> iirc we removed newton jobs, but can check again
15:18:08 <ykarel> may be some are pending
15:18:11 <jpena> good, let's move on then
15:18:17 <jpena> #topic next week's chair
15:18:21 <jpena> volunteers?
15:18:24 <number80> I can do it
15:18:32 <jpena> #action number80 to chair the next meeting
15:18:34 <jpena> thanks number80
15:18:53 <jpena> #topic open floor
15:19:17 <jpena> what else do we have to discuss?
15:19:25 <openstackgerrit> yatin proposed openstack/packstack master: [Fedora] Use tested repo for deployment  https://review.openstack.org/611355
15:20:01 <PagliaccisCloud> um, I think the magnum installer for packstack-rocky has a bug :/
15:20:13 <PagliaccisCloud> or 10
15:21:18 <jpena> PagliaccisCloud: that seems... feasible. I see we are not testing magnum in any of the CI scenarios
15:21:49 <ykarel> jpena, in scenario003
15:21:57 <ykarel> ?
15:22:10 <ykarel> --os-magnum-install=y
15:22:11 <jpena> ykarel: oh! I was checking the table at https://github.com/openstack/packstack/blob/master/README.md
15:22:17 <jpena> and it wasn't there
15:22:23 <ykarel> may be doc missed
15:22:29 <PagliaccisCloud> ah h*ck. it was throwing up random auth errors until i added lock_path to magnum.conf & bounced apache & memcached
15:23:00 <PagliaccisCloud> but i'm not sure if adding lock_path or just restarting apache fixed whatever was going on. I'm still working through build timeouts :/
15:23:41 <jpena> PagliaccisCloud: can you open a bug with the details you have so far? We'll work it out
15:23:48 <ykarel> hmm possible looks like no tests are running for magnum
15:24:05 <ykarel> --run-tempest-tests="smoke TelemetryAlarming"
15:24:09 <PagliaccisCloud> sure, i'll get one started. ktenzer anything to add?
15:25:11 <ktenzer> no I think rocky is working really well so RDO has done a great job getting it so solid. Only issues are magnum but we can open some bugzillas and work with you offline
15:25:40 <ktenzer> oh one thing is Octavia integrated or will it be?
15:26:00 <jpena> it's not integrated yet
15:26:29 <jpena> we had some chats with ajo, but never came up to a conclusion
15:26:39 <ktenzer> ok if you need someone to test...i have a really good test for it using openshift or okd which has a quite complex loadbalancer setup so happy to test anything
15:26:59 <ktenzer> and wrote the heat templates etc that deploy load balancers
15:30:15 <mjturek> I have something to bring up! We (baha Vorrtex and I) are going to start looking into building images (overcloud/undercloud/ipa) for ppc64le. Can anyone point us to relevant jobs? I assume said jobs are in rdo zuul?
15:30:20 <rdogerrit> Yatin Karel created rdo-jobs master: [Fedora] Use tested repo for deployment  https://review.rdoproject.org/r/17005
15:33:09 <ykarel> mjturek, -upload jobs build and publish images, for example: periodic-tripleo-ci-centos-7-ovb-1ctlr_1comp-featureset002-master-upload
15:33:51 <mjturek> got it
15:33:55 <mjturek> thanks ykarel
15:34:04 <mjturek> so it only happens after validation jobs?
15:34:38 <ykarel> validation jobs?
15:36:07 <mjturek> ykarel - sorry, I mean like how container builds happen in a separate job without testing. There's nothing analogous to that for images
15:36:12 <ykarel> jobs with dependencies https://github.com/rdo-infra/review.rdoproject.org-config/blob/master/zuul.d/tripleo.yaml#L39
15:36:23 <mjturek> will take a look
15:36:51 <ykarel> ack
15:42:02 <jpena> if there's nothing else to discuss, we can enjoy some 15+ extra minutes :)
15:43:22 <jpena> going once, going twice...
15:44:21 <jpena> #endmeeting