15:01:02 <jcapitao> #startmeeting RDO meeting - 2019-10-16
15:01:03 <openstack> Meeting started Wed Oct 16 15:01:02 2019 UTC and is due to finish in 60 minutes.  The chair is jcapitao. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:07 <openstack> The meeting name has been set to 'rdo_meeting___2019_10_16'
15:01:18 <jcapitao> #topic roll call
15:01:42 <amoralej> o/
15:01:57 <leanderthal> o/
15:02:03 <jcapitao> still have time to add any last-minute topic to the agenda at https://etherpad.openstack.org/p/RDO-Meeting
15:02:17 <jcapitao> #chair amoralej leanderthal
15:02:18 <openstack> Current chairs: amoralej jcapitao leanderthal
15:04:02 <jpena> o/
15:04:19 <jcapitao> #chair jpena
15:04:19 <openstack> Current chairs: amoralej jcapitao jpena leanderthal
15:06:30 <jcapitao> so let's start with the agenda
15:06:40 <jcapitao> #topic Train Release
15:07:11 <jcapitao> amoralej: all yours
15:07:12 <amoralej> #info OpenStack Train has been released upstream http://lists.openstack.org/pipermail/openstack-announce/2019-October/002024.html
15:07:18 <amoralej> \o/
15:07:29 <jcapitao> \m/
15:07:34 <leanderthal> \o/
15:07:47 <amoralej> we are building GA releases just published
15:07:58 <amoralej> then we need to promote to -testing and -release
15:08:44 <amoralej> note that trailing-cycle packages, specially kolla and tripleo have not release RC yet
15:09:12 <leanderthal> do we have an ETA on both of those and any others that are particularly vita to RDO?
15:09:22 <amoralej> so i'm proposing to wait for them to provide release candidates before doing RDO Train official GA
15:09:37 <amoralej> it should be a matter of one or two weeks the most
15:09:41 <leanderthal> before doing the announcement?
15:09:44 <amoralej> yes
15:09:52 <amoralej> before doing the announcement
15:09:56 <leanderthal> it can wait a week or so
15:09:57 <amoralej> wdyt?
15:10:05 <leanderthal> but not more
15:10:10 <amoralej> ok
15:10:22 <amoralej> let's see if we can get them ready by then
15:10:26 <leanderthal> hard deadline is the ois
15:10:38 <amoralej> let's review the status on next weekly meeting
15:10:43 <leanderthal> ok
15:11:22 <leanderthal> i'm going to do a blog post about it to buy us time
15:11:52 <leanderthal> it'll be talk about trailing cycle packages and that the core packages are available, but not be a formal release announcement
15:11:58 <amoralej> otherwise we make do an announcement and make people aware that tripleo and kolla will be published later
15:12:11 <amoralej> leanderthal, ack
15:12:17 <leanderthal> i think a blog post with the official announcement later is fine
15:12:17 <jcapitao> where do we (RDO) announce GA ?
15:12:28 <amoralej> anyway, to get the rest of packages we need to promote and push to mirrors
15:12:39 <leanderthal> on the lists (dev@ users@ centos-devel@), the blog, and social media
15:13:00 <amoralej> and given that tomorrow morning (9:00 UTC) is the last push for this week I'm not sure if they will be before monday
15:13:16 <jcapitao> leanderthal: ack
15:13:49 <leanderthal> jcapitao, https://www.rdoproject.org/rdo/release-checklist/
15:13:53 <leanderthal> and anyone else keen
15:14:46 <rdogerrit> Alan Bishop created rdoinfo master: Update puppet-etcd's upstream location  https://review.rdoproject.org/r/23214
15:15:09 <amoralej> btw announcment text is being worked in https://etherpad.openstack.org/p/rdo-train-release-announcement
15:15:24 <leanderthal> #action leanderthal write a post re: trailing cycle packages / rdo core packages are available / announcement will come later
15:15:53 <amoralej> leanderthal, i added the line about RDO Train being centos7 only and being the last one on centos7.
15:16:04 <leanderthal> yeah, that's solid amoralej
15:16:07 <leanderthal> i saw that.
15:16:07 <amoralej> feel free to rephrase if needed
15:16:50 <amoralej> also we'll try to produce packages for train on centos8 but i don't want to commit to much because of external dependencies
15:17:01 <amoralej> so i didn't mention it
15:17:12 <leanderthal> totally - we can do that MONTHS down the road; there's no rush there
15:17:17 <amoralej> we can announce it later when we are sure
15:17:18 <amoralej> ok
15:17:45 <Ramereth> it'll be great to have train for both centos7/8 for migration purposes FWIW
15:18:00 <leanderthal> totally
15:18:03 <amoralej> yes
15:18:17 <amoralej> we'll try to, but let's see
15:18:37 <Ramereth> I'd be willing to help if you run out of people resources too :)
15:18:45 <leanderthal> thx Ramereth
15:19:17 <amoralej> thanks Ramereth, we'll keep sharing updates on weekly meetings
15:19:20 <amoralej> stay tuned
15:20:01 <amoralej> Ramereth, the overall plan is in https://review.rdoproject.org/etherpad/p/moving-rdo-to-centos8
15:21:11 <amoralej> and i think that's it about train release
15:21:19 <Ramereth> thx
15:21:50 <leanderthal> well.
15:21:54 <leanderthal> except i'm also talking about it
15:23:31 <jcapitao> about what ?
15:23:49 <amoralej> btw, other thing that i almost forgot
15:23:56 <leanderthal> the train release announcement
15:24:00 * leanderthal points to the etherpad
15:24:09 <amoralej> #info altarch repos have some issue, reported https://bugs.centos.org/view.php?id=16590
15:24:23 <amoralej> leanderthal, that would also be a blocker for announcement?
15:24:37 <amoralej> there are issues with repos for non x86_64 arch
15:24:49 <leanderthal> not necessarily
15:25:00 <leanderthal> but i'll keep it in mind
15:25:19 <leanderthal> jcapitao, next topic?
15:25:29 <jcapitao> let's move on
15:25:44 <jcapitao> #topic Train Release Announcement
15:25:59 <leanderthal> #link https://etherpad.openstack.org/p/rdo-train-release-announcement
15:26:15 <leanderthal> altho amoralej already mentioned it; we're writing the announcement
15:26:52 <leanderthal> we normally use #link https://releases.openstack.org/train/highlights.html as our reference point for highlights, but i wanted to ask officially in the meeting
15:27:08 <leanderthal> What projects did *RDO* contribute to within the OpenStack project for the Train cycle in particular?
15:27:41 <leanderthal> i saw tobiko (thanks anonymous person!)
15:27:45 <leanderthal> but was there anything else?
15:28:04 <amoralej> that was me )
15:28:09 <amoralej> :)
15:28:30 <amoralej> so, the only new relevant package added to RDO in this cycle was tobiko
15:28:58 <amoralej> also puppet-rsyslog but i think it's not worthy to mention in the announcement
15:29:43 <raukadah> amoralej: we can mention about tobiko it will give some exposure a new testing tool
15:30:01 <leanderthal> amoralej++
15:30:03 <amoralej> yes, that's why i added tobiko
15:30:15 <raukadah> amoralej: we added ansible-config_template
15:30:15 <leanderthal> we didn't contribute to ironic or openstack ansible?
15:30:18 <leanderthal> for example?
15:30:49 <amoralej> you mean contributing code?
15:31:08 <leanderthal> yes
15:31:16 <raukadah> leanderthal: yes we contribute
15:31:43 <amoralej> but mostly occasionally, i'd say
15:31:53 <raukadah> leanderthal: on openstack-ansible-os_tempest, ansible-role-python_venv_buid and ansible-config_template project
15:32:02 <leanderthal> raukadah, awesomeness; thank you
15:32:09 <jpena> we also contributed to the puppet modules
15:32:12 <amoralej> i think the big contribution from RDO is providing packages to develop and test several projects
15:32:18 <leanderthal> jpena, awesomeness; thank you
15:32:29 <amoralej> puppet openstack, kolla, tripleo and osa
15:32:32 <raukadah> amoralej: https://review.rdoproject.org/r/#/c/21524/
15:32:34 <leanderthal> amoralej, perfect; thank you
15:33:14 <amoralej> and right, probably puppet modules is probably the one of the ones we contribute more
15:33:18 <leanderthal> raukadah++
15:33:23 <amoralej> and packstack which is maintained as part of RDO
15:33:23 <leanderthal> jpena++
15:33:53 <raukadah> leanderthal: we are also using os_tempest project in tripleo ci job but not sure it is a part of mentioning it
15:34:07 <leanderthal> that's it for me; i need to run at *:30 so i can't chair, but if someone wants to co-chair with me, i'm happy to start a meeting if someone else is willing to end it
15:34:29 <amoralej> jpena we should mention something about rpm-packaging?
15:34:38 <amoralej> rdo also contributes to it
15:34:57 <jcapitao> *RDO is everywhere*
15:34:58 <leanderthal> i'll read the meeting notes if someone thinks of anything else
15:35:10 <jpena> yes, although we barely use its output (just openstack-macros)
15:35:37 <amoralej> it uses rdo deps repo
15:35:44 <amoralej> and iirc uses dlrn
15:35:51 <amoralej> or am i wrong?
15:35:52 <jpena> yep
15:36:06 <amoralej> so, that's some contribution from our side :)
15:36:34 <raukadah> amoralej: this release we collaborated a lot among different deployment tool
15:37:25 <amoralej> yes, i think that's our big contribution part
15:37:31 <amoralej> deployment tools
15:37:41 <amoralej> also tempestconf etc...
15:38:22 <raukadah> amoralej: Do we want to mention about RHEL8?
15:38:29 <raukadah> ci
15:38:59 <amoralej> nop
15:39:07 <raukadah> ok
15:39:14 <amoralej> specially because that's a ci-only thing
15:39:37 <amoralej> not conceived to be supported nor used for operators
15:40:07 <raukadah> amoralej: python3 movement is one of the biggest thing happened in this release
15:40:30 <amoralej> yes, but we don't have centos8 so
15:40:48 <amoralej> it's actually not available for users
15:40:50 <amoralej> althoug...
15:40:59 <jcapitao> yes we can announce that when suporting c8
15:41:01 <amoralej> we can include a sentence about it somehow
15:41:43 <amoralej> although i don't want to add noise and make clear we only support centos7 so far
15:42:27 <jcapitao> +1
15:42:39 <raukadah> ++
15:42:48 <jpena> +1 to not adding noise
15:45:38 <jcapitao> looks like we catched all (at least allmost) the contributions during this cycle
15:45:57 <jcapitao> any other suggestions ?
15:47:40 <jcapitao> we can move on the the next topic
15:47:45 <jcapitao> #topic chair for the next meeting
15:47:59 <jcapitao> any volunteers ?
15:48:14 <amoralej> i can co-chair with leanderthal as she suggested
15:49:15 <jcapitao> #topic amoralej and leanderthal to chair the next meeting
15:49:56 <jcapitao> #undo
15:49:57 <openstack> Removing item from minutes: #topic amoralej and leanderthal to chair the next meeting
15:50:08 <jcapitao> #action amoralej and leanderthal to chair the next meeting
15:50:20 <jcapitao> thank you amoralej
15:50:40 <jcapitao> #topic open floor
15:51:21 <jcapitao> any additional topic you would like to discuss ?
15:52:09 <amoralej> just to mention
15:52:26 <raukadah> jcapitao: if one some have time, please reboot this http://github.com/redhat-openstack/easyfix
15:52:28 <amoralej> we will clean usage of common CBS tags
15:52:31 <raukadah> project
15:52:58 <amoralej> #info common CBS tags are being cleaned https://trello.com/c/J4eMr91Z/719-clean-usage-from-common-tags
15:53:48 <jcapitao> indeed, good to mention
15:55:35 <amoralej> wrt easyfix, let's add to next meeting topics and look for ideas of new easyfixe
15:55:40 <jcapitao> amoralej: wrt rdo project easyfix, I think it's a good idea i can work on
15:55:49 <amoralej> ok
15:55:49 <jcapitao> yes
15:56:18 <raukadah> jcapitao: great, let me know if any help needed
15:56:59 <jcapitao> #action jcapitao looks for ideas of new rdo easyfix
15:59:05 <jcapitao> so if nothing else to discuss, we can close just in time
16:00:33 <jcapitao> let's close then
16:00:38 <jcapitao> #endmeeting