14:01:59 <ykarel> #startmeeting RDO meeting - 2020-01-08
14:02:00 <openstack> Meeting started Wed Jan  8 14:01:59 2020 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:03 <openstack> The meeting name has been set to 'rdo_meeting___2020_01_08'
14:02:28 <ykarel> @all please add last minute topics to agenda https://etherpad.openstack.org/p/RDO-Meeting
14:02:34 <ykarel> #topic roll call
14:02:41 <jpena> o/
14:03:05 <jcapitao> o/
14:03:41 <rh-jelabarre> o/
14:04:20 <dpawlik> o/
14:04:24 <ykarel> #chair jpena jcapitao rh-jelabarre dpawlik
14:04:24 <openstack> Current chairs: dpawlik jcapitao jpena rh-jelabarre ykarel
14:07:08 <ykarel> Ok let's start
14:07:21 <ykarel> So welcome all to the very first meeting of 2020 \o/
14:08:07 <ykarel> #topic CentOS8 updates
14:08:13 <jcapitao> \m/
14:08:23 <ykarel> So we have couple of updates for CentOS8
14:08:33 <ykarel> #info RDO trunk centos8 master component based repo available at https://trunk.rdoproject.org/centos8-master/consistent/delorean.repo
14:08:43 <ykarel> #info RDO deps repo for centos8 master available at https://trunk.rdoproject.org/centos8-master/delorean-deps.repo
14:08:54 <ykarel> #info CentOS8 jobs are running fine against rdoinfo, weirdo, packstack and puppet projects
14:09:04 <ykarel> #info CentOS8 dependencies sync from copr to rdo deps repo is being worked with https://review.rdoproject.org/r/#/c/24274/
14:09:33 <ykarel> So we have some working bits for CentOS8 and jobs are running with these
14:10:01 <ykarel> Though we have couple of known issues, which we need to address
14:10:40 <ykarel> We have dependencies on other SIGs from where we consume packages
14:10:48 <ykarel> like opstools, ceph, etc
14:11:19 <leanderthal> o/
14:11:23 <ykarel> and all of them are stuck at availability of CBS for CentOS8
14:11:55 <ykarel> and we have not heard any plan from those SIGs to have a alternative like we did with copr
14:11:59 <ykarel> #chair leanderthal
14:12:00 <openstack> Current chairs: dpawlik jcapitao jpena leanderthal rh-jelabarre ykarel
14:12:30 <ykarel> Other issue is missing HA packages which used to be there in CentOS7 but missing in CentOS8
14:12:50 <ykarel> but those are expected to be available with CentOS8.1
14:12:58 <ykarel> but we don't have ETA for that yet
14:13:00 <jcapitao> do we have more visibility on CBS for c8 ?
14:13:29 <ykarel> jcapitao, it will be available only after CentOS8.1 get's release
14:13:39 <ykarel> for both we don't have an ETA
14:14:27 <jcapitao> crap
14:14:56 <ykarel> may be leanderthal have some more insight around CentOS8.1 and CBS?
14:15:06 <ykarel> leanderthal, by chance u have more info ^^?
14:15:10 <leanderthal> I don't, sadly.
14:15:16 <leanderthal> :-\
14:15:27 * jcapitao checking the next milestone for ussuri
14:15:36 <leanderthal> february
14:15:37 <ykarel> jcapitao, it's in Feb
14:15:46 <ykarel> i guess 10th
14:15:57 <jcapitao> exactly
14:16:03 <ykarel> leanderthal, ack
14:16:15 <ykarel> let's see if we can get a positive update from CentOS guys
14:16:22 <ykarel> we need to reach rbowen too
14:17:11 <ykarel> So with approaching next milestone we have another issue, upstream is dropping python2 support
14:17:26 <ykarel> and by milestone2 they are planning to drop it from libraries and clients
14:18:04 <ykarel> we have already seen breakages due to it and we were forced to pin to working commit for py2 https://review.rdoproject.org/r/#/q/topic:pin-py2
14:18:08 <ykarel> #link https://review.rdoproject.org/r/#/q/topic:pin-py2
14:18:44 <ykarel> and as the time passes and if we don't have working CentOS8 completely we would be forced to pin more projects
14:19:04 <ykarel> or we have to look for alternative, like pin for CentOS7 and not for CentOS8
14:19:15 <ykarel> but that would need an additional tag in rdoinfo
14:19:32 <ykarel> which we wanted to avoid if can get CentOS8 ready soon
14:20:14 <ykarel> that's it from CentOS8 current updates, any queries/suggestion on CentOS8 till now?
14:20:31 <ykarel> #chair amoralej
14:20:32 <openstack> Current chairs: amoralej dpawlik jcapitao jpena leanderthal rh-jelabarre ykarel
14:21:23 <ykarel> amoralej, would u like to add something on ^^
14:22:00 <amoralej> not
14:22:02 <amoralej> just about etcd
14:22:08 <amoralej> i'd like to understand what needs it
14:23:21 <jcapitao> what's the issue with etcd ?
14:23:55 <ykarel> from codesearch i see it's needed for some dcn-hci and networking-ml2-vvp agent
14:24:06 <ykarel> but don't know what exactly needs it
14:24:18 <amoralej> jcapitao, centos7 had etcd
14:24:22 <amoralej> centos8 doesn't
14:24:33 <amoralej> so we need to include it in deps or get from other sig
14:24:51 <jcapitao> okk
14:24:55 <ykarel> We can ask TripleO guys about it's usage, they may have idea about it
14:25:19 <ykarel> EmilienM, mwhahaha do you know what needs etcd?
14:25:44 <mwhahaha> cinder?
14:25:55 <mwhahaha> something does now
14:25:59 * mwhahaha checks
14:26:18 <mwhahaha> yea cinder
14:26:20 <EmilienM> something else with NFV
14:26:23 <mwhahaha> for A/A
14:26:28 <EmilienM> but i think we never used that
14:26:46 <EmilienM> mwhahaha: wasn't it redis?
14:26:49 <mwhahaha> no
14:26:56 <mwhahaha> cinder-volume
14:26:56 <EmilienM> is it for coordination?
14:27:06 <mwhahaha> deployment/cinder/cinder-volume-container-puppet.yaml:    description: When running Cinder A/A, whether to connect to Etcd
14:27:11 <EmilienM> ok
14:28:25 <rdogerrit> Javier Peña created openstack/vmware-nsxlib-distgit rpm-master: Use stestr for unit test execution  https://review.rdoproject.org/r/24418
14:29:33 <amoralej> ok, thanks mwhahaha
14:29:45 <rdogerrit> User mjturek proposed rdo-infra/ci-config master: ppc64le: Export dlrnapi vars on cico node  https://review.rdoproject.org/r/24398
14:29:55 <ykarel> Thanks mwhahaha EmilienM
14:30:35 <ykarel> so moving ahead
14:30:49 <ykarel> we have couple of items to be done as a Next step
14:31:02 <ykarel> Setup puppet promotion pipeline for CentOS8
14:31:35 <ykarel> we started it with https://review.rdoproject.org/r/#/c/24263/
14:32:04 <ykarel> we need to get it work with component promotion, i am working on it, and will push patch today on it
14:32:37 <ykarel> Also we need to get TripleO jobs to be ready with CentOS8
14:33:08 <ykarel> weshay_ can u provide some update wrt it ^^?
14:33:18 <ykarel> may be u missed my yesterdays message
14:34:55 <ykarel> seems he is out, we can get it off meeting and have some more updates by next week
14:35:06 <ykarel> any queries on it? else we move to next topic
14:35:54 <ykarel> #link https://review.rdoproject.org/r/#/c/24263/
14:36:30 <ykarel> ok let's move
14:36:33 <ykarel> #topic [jcapitao] Requirements improvment plan
14:36:42 <ykarel> jcapitao, yours ^^
14:37:04 <jcapitao> I'm planning to move the job rdopkg-reqcheck from rdo-jobs to config project in order to be able to submit review automatically
14:37:30 <amoralej> jcapitao, automatically how?
14:37:34 <amoralej> periodically?
14:37:41 <amoralej> or based on events?
14:37:54 <jcapitao> based on events
14:38:12 <jcapitao> a change of req file upstream
14:38:48 <jcapitao> and to submit a review with the error
14:39:06 <jcapitao> good or bad idea ?
14:39:23 <amoralej> good
14:39:28 <amoralej> but need a different job
14:39:39 <amoralej> not rdopkg-reqcheck as is
14:39:51 <amoralej> what i'd do is, on every requirements.txt change
14:40:04 <amoralej> run reqchec, and if a change is needed propose a review updating it
14:40:09 <amoralej> as needed
14:40:18 <amoralej> i'd keep current job as is
14:40:20 <ykarel> jcapitao, what u mean by to submit a review with the error?
14:40:22 <amoralej> and create a new one in config
14:40:29 <ykarel> review like rdo-FTBFS?
14:41:08 <jcapitao> amoralej: ack so, two jobs
14:41:15 <amoralej> yes
14:41:18 <jcapitao> ykarel: yes
14:41:33 <amoralej> current is one to check reqcheck on each spec change
14:41:39 <jcapitao> ack this was the sub-question
14:43:01 <ykarel> jcapitao, ack
14:43:48 <ykarel> with this we again have challenge like to fix requirements error patch like we have to do fix FTBFS
14:43:59 <ykarel> instead of maintainers, though this will be low priority
14:44:42 <ykarel> jcapitao, so u planning to propose patch on what cases?
14:44:49 <jcapitao> perfect, so I will keep the current one as-is and create another one in config project
14:44:52 <ykarel> new requirements, or updates in existing requirement
14:45:16 <ykarel> jcapitao, so u will be running that job in each project?
14:45:31 <ykarel> as requirements.txt live in projects itself upstream
14:45:45 <ykarel> as a third party post job?
14:45:59 <jcapitao> the new one, on each project upstream
14:46:26 <jcapitao> when requirements.txt file has been edited
14:46:28 <amoralej> ykarel, they could be ran in openstack-post
14:46:33 <amoralej> for all projects
14:46:37 <ykarel> amoralej, yes i meant that
14:46:39 <amoralej> on requirements.txt only
14:46:41 <amoralej> yeap
14:46:50 <amoralej> or maybe only the more important
14:47:08 <amoralej> i'm not sure if all projects would be a problem for sf zuul
14:47:13 <amoralej> but i guess it's doable
14:47:23 <ykarel> hmm as like u-c pinned ones not sure needed
14:47:33 <ykarel> may be for those run when we get u-c updated
14:47:37 <ykarel> or tag get's released
14:48:18 <ykarel> hmm considering job is small it's not be a problem
14:48:22 <jcapitao> +1
14:49:30 <ykarel> ok we can start with some projects and then expand
14:49:35 <ykarel> and improve as we go
14:49:40 <amoralej> i think as soon as we can run it only for requirements.txt
14:49:42 <amoralej> should be fine
14:50:12 <jcapitao> ack i'll do this
14:50:31 <ykarel> ack +1
14:50:36 <jcapitao> last thing
14:50:49 <jcapitao> need some review https://softwarefactory-project.io/r/#/q/project:rdopkg
14:51:12 <jcapitao> plzz
14:51:28 <jcapitao> when you have spare time
14:51:38 <jcapitao> that's all for me
14:52:07 <ykarel> ok thanks jcapitao
14:52:22 <ykarel> #topic Chair for the next meeting
14:52:26 <ykarel> any volunteer?
14:52:37 <leanderthal> i can do it
14:52:50 <ykarel> #action leanderthal to chair next week
14:52:52 <ykarel> Thanks leanderthal
14:52:58 <leanderthal> no worries ykarel
14:53:03 <ykarel> #topic open floor
14:53:15 <ykarel> bring any topic now which got missed
14:57:44 <ykarel> If nothing is there we can close a little early :)
14:58:42 <ykarel> Ok Thanks all
14:58:45 <ykarel> #endmeeting