14:04:24 <jpena> #startmeeting RDO meeting - 2020-01-15
14:04:25 <openstack> Meeting started Wed Jan 15 14:04:24 2020 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:04:28 <openstack> The meeting name has been set to 'rdo_meeting___2020_01_15'
14:04:35 <jpena> remember to add last-minute topics to the agenda at https://etherpad.openstack.org/p/RDO-Meeting
14:04:39 <jpena> #topic roll call
14:04:47 <jcapitao> o/
14:05:38 <jpena> #chair jcapitao
14:05:39 <openstack> Current chairs: jcapitao jpena
14:06:03 <amoralej> o/
14:06:12 <jpena> #chair amoralej
14:06:12 <openstack> Current chairs: amoralej jcapitao jpena
14:08:09 <jpena> let's start with the agenda
14:08:15 <jpena> #topic Removing fedora stabilized repos and jobs
14:09:04 <jpena> amoralej: ^^
14:10:00 <amoralej> fedora stabilized repos and jobs where created as preparation for centos8
14:10:26 <amoralej> now that we have DLRN-rpmbuild and weirdo jobs with centos8 it doesn't make sense to keep it
14:11:02 <amoralej> we have already removed the fedora-stable based jobs both upstream and in rdo repos
14:11:21 <amoralej> so i think it's time to remove the repos
14:12:07 <amoralej> #info Fedora Stabilize repos in https://trunk.rdoproject.org/fedora/stable-base/ will be removed
14:12:14 <rdogerrit> Spyros Trigazis proposed openstack/magnumclient-distgit train-rdo: python-magnumclient-2.16.0-1  https://review.rdoproject.org/r/24553
14:12:37 <amoralej> #info anyone using them, please let us know
14:12:45 <jpena> so there are no jobs using the fedora repos anymore, either in RDO or opendev.org?
14:12:58 <amoralej> nop afaik
14:13:02 <jpena> we are still using it in the rpm-packaging project, until the CentOS 8-based builder is finished
14:13:06 <amoralej> jpena and we can stop https://trunk.rdoproject.org/fedora/report.html
14:13:13 <amoralej> mm
14:13:13 <amoralej> ok
14:13:27 <jpena> so we could still remove the trunk-fedora VM, but keep the repos until then
14:13:27 <amoralej> jpena, is there much work missing to move to centos8?
14:14:16 <amoralej> we can do it
14:14:27 <amoralej> but i'll remove all tooling around
14:14:29 <jpena> since python2 packages are not available, we need to convert all remaining packages to be python3-only. It's WIP at the moment, but should take a couple weeks before it's completed
14:15:57 <amoralej> #info rpm-packaging is still using f28 jobs
14:16:16 <amoralej> jpena, and wouldn't it make sense to add a centos8 non-voting job upstream and remove f28
14:16:29 <amoralej> to gate py3 patches using centos8 instead of fedora?
14:16:45 <jpena> amoralej: that will make sense as soon as we can bootstrap a minimum number of packages
14:17:10 <jpena> right now, most are failing because they depend on some lower-level package that allow both python2 and python3
14:17:21 <jpena> e.g. stevedore, cliff and friends
14:17:43 <amoralej> ok
14:17:59 <amoralej> jpena, you agree with stopping dlrn builder for fedora?
14:18:04 <amoralej> and keep just repos as-is?
14:18:20 <jpena> amoralej: yes, that's fine for me. We can even delete the trunk-fedora VM, it is not affecting us
14:18:27 <amoralej> ok
14:18:48 <amoralej> #info DLRN builder https://trunk.rdoproject.org/fedora/report.html will be stopped and removed
14:19:24 <amoralej> #info repos under https://trunk.rdoproject.org/fedora/ will be maintained as current status while rpm-packaging project moves to python3 only
14:20:06 <amoralej> #info repo https://review.rdoproject.org/r/#/admin/projects/rdo-infra/fedora-stable-confighttps://review.rdoproject.org/r/#/admin/projects/rdo-infra/fedora-stable-confighttps://review.rdoproject.org/r/#/admin/projects/rdo-infra/fedora-stable-confighttps://review.rdoproject.org/r/#/admin/projects/rdo-infra/fedora-stable-confighttps://review.rdoproject.org/r/#/admin/projects/rdo-infra/fedora-stable-config will be closed
14:20:17 <amoralej> #undo
14:20:17 <openstack> Removing item from minutes: #info repo https://review.rdoproject.org/r/#/admin/projects/rdo-infra/fedora-stable-confighttps://review.rdoproject.org/r/#/admin/projects/rdo-infra/fedora-stable-confighttps://review.rdoproject.org/r/#/admin/projects/rdo-infra/fedora-stable-confighttps://review.rdoproject.org/r/#/admin/projects/rdo-infra/fedora-stable-confighttps://review.rdoproject.org/r/#/admin/projects/rdo-infra/fedora-stable-config will be closed
14:20:27 <amoralej> #info repo https://review.rdoproject.org/r/#/admin/projects/rdo-infra/fedora-stable-config will be closed
14:21:08 <amoralej> #info copr project https://copr.fedorainfracloud.org/coprs/g/openstack-sig/fedora-overrides/ will be removed
14:21:21 <amoralej> #info any update in deps for fedora will be done manually
14:21:28 <amoralej> jpena, ^ is that fine?
14:21:33 <jpena> perfect for me
14:21:48 <amoralej> ok
14:21:51 <amoralej> thanks
14:21:59 <amoralej> we can move to next topic
14:22:15 <jpena> #topic Update about CentOS 8
14:23:14 <amoralej> #info Update about centos8 and cbs from centos team https://lists.centos.org/pipermail/centos-devel/2020-January/036477.html
14:23:31 <amoralej> apparently centos 8.1 is close
14:23:56 <jcapitao> \o/
14:24:22 <amoralej> according to the mail, once 8.1 is released "work will begin on bringing this new codebase, along with CentOS Stream, in to CBS"
14:24:53 <amoralej> #info     Puppet promotion pipeline running and promoting https://ci.centos.org/view/rdo/view/weirdo-pipelines/view/weirdo-promote-test-puppet-centos8/
14:25:56 <amoralej> #info high availability packages for 8.0 have been uploaded to https://trunk.rdoproject.org/centos8-master/deps/advvirt/8.0/ha/
14:26:17 <amoralej> note that 8.1 will have ha packages, so no more rebuilds will be needed
14:27:30 <amoralej> oooq team is also working to get centos8 jobs based running
14:27:39 <amoralej> there is already a build container jobs running periodically
14:27:40 <amoralej> https://review.rdoproject.org/zuul/builds?job_name=periodic-tripleo-centos-8-master-containers-build-push
14:27:57 <amoralej> they are working to push all required fixes in tooling
14:28:07 <amoralej> i think that's it from me
14:28:32 <jpena> nice, let's hope that CBS job is quick :)
14:29:34 <jpena> next topic, then
14:30:27 <jpena> #topic chair for next meeting
14:30:31 <jpena> any volunteer around?
14:30:52 <jcapitao> i can take it
14:31:36 <jpena> thanks jcapitao
14:31:43 <jpena> #action jcapitao to chair the next meeting
14:31:52 <jpena> #topic open floor
14:32:08 <jpena> if there's any other topic you would like to discuss, now is the right time!
14:33:51 <tosky> just thanks for all the work; the centos 8 migration is not easy
14:41:17 <jpena> no more topics. Let's put the extra 20 minutes to good use ;)
14:41:20 <jpena> #endmeeting