14:00:48 <jpena> #startmeeting RDO meeting - 2020-02-05
14:00:49 <openstack> Meeting started Wed Feb  5 14:00:48 2020 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:53 <openstack> The meeting name has been set to 'rdo_meeting___2020_02_05'
14:00:58 <mjturek> o/
14:01:02 <zbr> o/
14:01:10 <jpena> Remember that you can add any last-minute topic to the agenda at https://etherpad.openstack.org/p/RDO-Meeting
14:01:13 <jpena> #topic roll call
14:01:18 <jpena> #chair mjturek zbr
14:01:19 <openstack> Current chairs: jpena mjturek zbr
14:01:28 <amoralej> oooooo/
14:01:46 <jpena> #chair amoralej
14:01:47 <openstack> Current chairs: amoralej jpena mjturek zbr
14:01:53 <baha> o/
14:01:59 <jcapitao> o/
14:02:05 <jpena> #chair baha jcapitao
14:02:06 <openstack> Current chairs: amoralej baha jcapitao jpena mjturek zbr
14:03:25 <leanderthal> o/
14:03:41 <jpena> #chair leanderthal
14:03:42 <openstack> Current chairs: amoralej baha jcapitao jpena leanderthal mjturek zbr
14:04:15 <rh-jelabarre> o/
14:04:44 <jpena> #chair rh-jelabarre
14:04:45 <openstack> Current chairs: amoralej baha jcapitao jpena leanderthal mjturek rh-jelabarre zbr
14:05:36 <jpena> let's start with the agenda
14:05:46 <jpena> #topic Log uploads for ppc64le containers job is failing
14:05:52 <mjturek> heyyy
14:06:16 <mjturek> so there's a paste there. Seems like the credentials don't work anymore?
14:07:45 <jpena> hm, we were migrating the log server to vexxhost, and maybe the credentials were not updaated here
14:07:59 <jpena> dpawlik, did you update the credentials in zuul? We may need to do the same in another repo
14:08:17 <mjturek> ahhh
14:08:19 <mjturek> jpena just a reminder this job is on cico nodes
14:08:40 <mjturek> oh wait, we may be back
14:08:45 <dpawlik> jpena, which creds?
14:08:46 <mjturek> baha just linked me to a recent log
14:09:04 <dpawlik> jpena, ssh-key for uploader is just added for zuul secret
14:09:18 <jpena> mjturek: right, but we have some other jobs running on ci.centos.org
14:09:23 <mjturek> jpena: we can move on, looks like it's working again :)
14:09:24 <jpena> which may not be updated
14:09:28 <baha> There was a period where uploads were failing, but it looks to me like we may be back, yeah
14:09:28 <jpena> aha
14:09:49 <baha> Between the time of the topic being created and the meeting this morning it got sorted out =)
14:09:53 <jpena> right, it is related to a similar issue we had with the other RDO jobs running on ci.centos
14:10:22 <mjturek> cool cool
14:10:24 <mjturek> thanks!
14:10:24 <jpena> dpawlik: just curious, does the uploader user in the new logserver accept the same ssh keys?
14:14:55 <jpena> ok, shall we move on?
14:15:53 <tristanC> jpena: it's a new loguser, logserver.rdorpoject.org is setup with a new secret that contains the new key
14:16:30 <jpena> tristanC: ack. Then we'll need to update the configuration in rdo-infra/ci-config to have jobs in ci.centos.org send the logs there, right?
14:16:40 <jpena> thirdpartylogs.rdoproject.org
14:17:26 <dpawlik> jpena, thats why ci.centos.org is still using old log server
14:18:05 <jpena> ok then. So it's not lost from our radar, that's what I wanted to ensure
14:19:17 <jpena> alright, let's move on
14:19:25 <jpena> #topic Manually test uploading a container to registry.rdoproject.org
14:19:31 <mjturek> me again!
14:20:12 <ykarel|away> o/
14:20:15 <mjturek> tripleo team is having trouble with pulling ppc64le containers from registry.rdoproject.org
14:20:32 <mjturek> so in an attempt to identify the issue
14:20:55 <mjturek> we'd like to have permission to upload a container or two to see if that's where the problem starts
14:21:06 <mjturek> rfolco has offered to help here and we'd tread lightly
14:21:37 <mjturek> would this be okay?
14:24:18 <mjturek> questions? concerns?
14:25:00 <jpena> You could already kill the registry via a CI job anyway, so I don't see an issue :)
14:25:43 <mjturek> awesome!
14:25:58 <mjturek> jpena we will work with rfolco here and again, we'll be careful
14:26:20 <jpena> mjturek: ok. I'll send you the creds
14:26:34 <jpena> #action jpena to send mjturek credentials to upload images to the RDO registry
14:27:54 <jpena> #topic CentOS 8 update
14:28:00 <jpena> amoralej: ^^
14:28:20 <amoralej> so, we are still in the process of deps building
14:28:28 <amoralej> main issue is still the erlang
14:28:37 <amoralej> #info erlang stack blocked by https://bugs.centos.org/view.php?id=16968
14:28:53 <amoralej> other than that, we are just fixing some minor issues
14:29:00 <amoralej> ykarel is working on them
14:29:22 <amoralej> mostly unit tests failing because of cbs specific infra issues
14:30:01 <amoralej> and i think that's it
14:30:42 <ykarel> hmm other than that we are testing CBS builds with puppet-openstack-integration with https://review.opendev.org/#/c/705934/
14:31:04 <ykarel> 2 jobs passed, 2 failed, reason is missing python3-botocore
14:31:24 <ykarel> python3-botocore comes from HA repo, which is not enabled in those jobs
14:31:39 <amoralej> let's enable it in separated review
14:31:51 <ykarel> yes sure
14:32:17 <amoralej> mmm
14:32:31 <amoralej> i think os repos are coming from some base jobs
14:32:49 <amoralej> it could be good to add them there instead of in p-o-i
14:33:20 <amoralej> LOOP [configure-mirrors : Install CentOS 8 repository files]
14:33:26 <ykarel> amoralej, yes https://opendev.org/zuul/zuul-jobs/src/branch/master/roles/configure-mirrors/tasks/mirror/CentOS-8.yaml
14:33:35 <amoralej> yeah, that
14:34:04 <ykarel> ok let's try that
14:34:22 <ykarel> not sure that will be accepted as HA is not a general repo
14:34:31 <ykarel> contains specific packages
14:34:57 <amoralej> it has powertools
14:35:09 <amoralej> i don't see a reason to not accept ha
14:35:24 <amoralej> but if that's the case, we can always add it in p-o-i, no problem
14:35:35 <ykarel> ok will propose a patch and see
14:40:35 <jpena> should we move on?
14:40:52 <ykarel> yes
14:41:03 <jpena> #topic Chair for next meeting
14:41:06 <jpena> any volunteers?
14:42:11 <jcapitao> I can take it
14:42:34 <jpena> thanks jcapitao
14:42:41 <jpena> #action jcapitao to chair the next meeting
14:43:17 <jpena> #topic open floor
14:43:30 <jpena> If there's any other topic to discuss, now is the right time
14:49:20 <jpena> ok, let's get those 10 minutes back!
14:49:23 <jpena> #endmeeting