14:03:53 <amoralej> #startmeeting RDO meeting - 2020-05-20
14:03:53 <openstack> Meeting started Wed May 20 14:03:53 2020 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:56 <amoralej> oh
14:03:57 <openstack> The meeting name has been set to 'rdo_meeting___2020_05_20'
14:03:58 <ykarel> amoralej, Thanks
14:04:00 <amoralej> all yours then
14:04:22 <ykarel> ack
14:04:32 * jbrooks lurks
14:04:43 <ykarel> Please add topic to agenda https://etherpad.openstack.org/p/RDO-Meeting
14:04:47 <ykarel> #topic roll call
14:05:00 <amoralej> o/
14:05:05 <spotz> o/
14:05:05 <jcapitao> o/
14:05:32 <ykarel> #chair amoralej spotz jcapitao
14:06:31 <amoralej> #chair ykarel
14:06:32 <openstack> Current chairs: amoralej ykarel
14:06:44 <ykarel> #chair amoralej spotz jcapitao
14:06:45 <openstack> Current chairs: amoralej jcapitao spotz ykarel
14:08:15 <ykarel> Let's start with topics
14:08:29 <ykarel> #topic Ussuri GA status update
14:08:32 <ykarel> amoralej, ^
14:08:41 <amoralej> i think you have all the details
14:08:57 <ykarel> Ok /me will add
14:09:04 <amoralej> #info waiting for new releases for tripleo and ansible
14:09:09 <amoralej> #undo
14:09:10 <openstack> Removing item from minutes: #info waiting for new releases for tripleo and ansible
14:09:14 <amoralej> #info waiting for new releases for tripleo and ansible roles
14:09:42 <ykarel> So we are waiting for tripleo release https://review.opendev.org/#/q/topic:tripleo-ussuri-release
14:09:44 <amoralej> #info tripleo expects to do their releases between 21st and 27th may
14:10:45 <ykarel> #link https://review.opendev.org/#/q/topic:tripleo-ussuri-release
14:10:53 <spotz> And we have the 28th the drop dead for the release announcement
14:10:55 <amoralej> #info we need a new release of puppet pacemaker https://review.opendev.org/#/c/729606/ and https://review.opendev.org/#/c/729537/
14:11:26 <jcapitao> do we have an issue with it ?
14:11:37 <jcapitao> puppet-pacemaker i mean
14:11:49 <amoralej> ykarel, jcapitao if we have issues with some specific puppet module or ansible role needed we can create it from commit snap
14:11:57 * iurygregory a bit late =)
14:12:10 <amoralej> jcapitao, last tag is 0.8.0 and we need some newer patches
14:12:44 <amoralej> ykarel, have you identified any other issue wrt tripleo jobs?
14:12:55 <amoralej> we already have networking-mlnx and networking-ansible
14:12:59 <ykarel> amoralej, yes also puppet-tripleo needs update
14:12:59 <jcapitao> amoralej: ok, it's a bit old
14:13:03 <ykarel> I was testing standalone scenario001 with some hacks
14:13:11 <ykarel> i am tracking all steps in https://review.rdoproject.org/etherpad/p/tripleo-ussuri-standalone-cloudsig-centos8
14:13:14 <amoralej> ykarel, but that's not comming in tripleo GA?
14:13:27 <ykarel> amoralej, i see metadata updated to 12.3.0
14:13:36 <ykarel> so should come with GA, need to check release patch also
14:13:45 <ykarel> #link https://review.rdoproject.org/etherpad/p/tripleo-ussuri-standalone-cloudsig-centos8
14:13:56 <ykarel> if anyone want to try can check with ^^
14:14:00 <amoralej> ykarel, https://review.opendev.org/#/c/728537/
14:14:05 <amoralej> that has puppet-tripleo
14:14:17 <ykarel> okk good
14:15:09 <ykarel> #info we also need centos-release-openstack-ussuri rpm to build and published in centos8 extras repo
14:15:11 <amoralej> ykarel, you think we may have a tripleo job in check pipeline building container images and deploying standalone?
14:15:12 <ykarel> #link https://git.centos.org/rpms/centos-release-openstack/tree/c8-sig-cloud-openstack-ussuri
14:15:31 <amoralej> we can add it already even if it's non-voting
14:15:41 <ykarel> amoralej, with all the hacks?
14:15:45 <ykarel> if yes we can do
14:15:48 <amoralej> no
14:15:50 <amoralej> well
14:15:52 <amoralej> which hacks
14:16:07 <ykarel> using delorean-current
14:16:14 <amoralej> no
14:16:15 <ykarel> for kolla and tripleo packages
14:16:20 <amoralej> let's keep it failing
14:16:31 <amoralej> until we have the repo with everything we need
14:16:42 <amoralej> and let's keep it non-voting
14:16:57 <amoralej> we can add delorean-current in DNM to test the job or something like that
14:17:05 <ykarel> ohhk, will do like test with all workarounds in CI and once it works, will remove all hack and get it merged
14:17:31 <amoralej> wfm
14:17:41 <ykarel> ack will do in my morning tomorrow
14:18:48 <ykarel> locally i am able to deploy scenario001 with the steps in etherpad with cloudsig builds
14:18:58 <ykarel> need to do some tests still
14:19:36 <ykarel> any thing else in this topic, or shall we move?
14:20:06 <amoralej> i think that's it
14:20:18 <ykarel> ok let's move to next
14:20:42 <ykarel> #topic Next Week's Chair?
14:21:10 <amoralej> i can take it
14:21:16 <ykarel> amoralej Thanks
14:21:23 <ykarel> #action amoralej to chair next week
14:21:36 <ykarel> #topic open floor
14:21:45 <ykarel> Feel free to bring any topic now
14:23:06 <spotz> None from me
14:23:48 <amoralej> who will be sending the ussuri announcement to the ML?
14:25:03 <spotz> Yeah we have the announcement ready we're just waiting for the trailing projects. It sounds like tripleo by the 27th which means we can send it on the drop dead date of the 28th
14:25:14 <iurygregory> yeah
14:25:17 <spotz> Either myself or iurygregory
14:25:23 <spotz> or jbrooks
14:25:28 <amoralej> spotz, ok, i'll keep you in the loop
14:25:31 <amoralej> with any progress
14:25:42 <spotz> Rain finished it so it's good to go
14:25:49 <iurygregory> amoralej, also me pls =)
14:25:59 <amoralej> 27th is latest timeline for tripleo, hopefully we have something before
14:26:07 <spotz> +1
14:27:06 <jbrooks> Do we have enough highlights in the announcement draft now?
14:27:31 <iurygregory> jbrooks, I think we do have enough =)
14:27:47 <jbrooks> cool, yeah, it looks interesting enough to me :)
14:27:50 <iurygregory> at least it's following the pattern we had in the past =)
14:27:59 <jbrooks> +1
14:28:11 <spotz> And we can use it as a template going forward
14:28:25 <iurygregory> yeah
14:29:57 <amoralej> we also will coordinate with centos guys to make sure they push
14:31:21 <amoralej> spotz, jbrooks i'll add a couple of more lines in other improvements
14:31:52 <spotz> Sounds good amoralej thanks
14:32:59 <ykarel> An update wrt testing cloudsing builds with tripleo standalone scenario001, there are some known bug which happens randomly, i too hit during my testing
14:33:18 <ykarel> one is https://bugs.launchpad.net/tripleo/+bug/1878405/
14:33:18 <openstack> Launchpad bug 1878405 in tripleo "tripleo ansible sometimes does not run certain containers" [High,In progress] - Assigned to Emilien Macchi (emilienm)
14:33:52 <ykarel> ^ is being investigated currently
14:34:10 <EmilienM> ykarel: i found issue and proposed a fix
14:34:10 <ykarel> and other is misconfig of retries, should be fixed with https://review.opendev.org/#/c/729560/
14:34:32 <ykarel> EmilienM, cool
14:35:11 <amoralej> spotz, added
14:35:41 <spotz> Thanks
14:39:41 <ykarel> Any thing else needs to be bringed up, or we close early and every one gets 20 minutes back
14:41:04 <radez> amoralej: I'm not sure how to fix that, looks like there are two missing?
14:41:18 <radez> amoralej: would I just need to tag a new version?
14:41:42 <amoralej> radez, i think you need to add some job
14:42:01 <radez> amoralej: ok, I'll see what I can do to figure it out
14:42:33 <ykarel> #chair radez
14:42:34 <openstack> Current chairs: amoralej jcapitao radez spotz ykarel
14:43:10 <amoralej> radez, https://github.com/redhat-openstack/packstack/blob/master/.zuul.yaml#L189-L191
14:43:15 <amoralej> i think something like that?
14:43:27 <amoralej> well, that's for packstack
14:43:29 <amoralej> but similar
14:43:38 <amoralej> no, sorry, that's for the github mirror
14:44:25 <amoralej> radez, there is a thread about the topic in http://lists.openstack.org/pipermail/openstack-discuss/2020-May/014941.html
14:46:03 <radez> amoralej: hm, they seem to conclude that there was just a missing brach?
14:46:13 <radez> net-ansible has those branches
14:47:17 <radez> amoralej: here they are: https://tarballs.opendev.org/openstack/networking-ansible/
14:47:57 <amoralej> but only until it was moved to x namespace
14:47:57 <radez> is there a way to consolidate those locations?
14:47:58 <amoralej> right?
14:48:07 <amoralej> 4.0.0 is missing
14:48:22 <amoralej> for RDO we've finally pulled from pypi
14:48:26 <amoralej> which has 4.0.0
14:48:29 <radez> yes 4.0.0 is missing
14:49:11 <radez> we may have messed up that push becasue we pushed manually to pypi
14:53:22 <amoralej> i'd say it should be in tarballs.opendev.org even if you push manually the tag
14:56:17 <ykarel> Ok Thanks all, let's close
14:56:19 <ykarel> #endmeeting