14:01:06 <jcapitao> #startmeeting RDO meeting - 2020-06-10
14:01:06 <openstack> Meeting started Wed Jun 10 14:01:06 2020 UTC and is due to finish in 60 minutes.  The chair is jcapitao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:10 <openstack> The meeting name has been set to 'rdo_meeting___2020_06_10'
14:01:49 <jcapitao> #topic roll call
14:02:04 <amoralej> o/
14:02:31 <jcapitao> there is still time to add topic to the agenda at https://etherpad.openstack.org/p/RDO-Meeting
14:02:39 <jcapitao> #chair amoralej
14:02:40 <openstack> Current chairs: amoralej jcapitao
14:02:47 <ykarel> o/
14:03:05 <jcapitao> #chair ykarel
14:03:06 <openstack> Current chairs: amoralej jcapitao ykarel
14:05:43 <rdogerrit> Sorin Sbarnea (zbr) proposed rdo-infra/ci-config master: POC: Switch molecule promoter jobs to centos-8  https://review.rdoproject.org/r/28038
14:06:02 <jpena> o/
14:06:40 <jcapitao> #chair jpena
14:06:41 <openstack> Current chairs: amoralej jcapitao jpena ykarel
14:07:16 <jcapitao> let's start it
14:07:23 <jcapitao> #topic Openstack clients - Fedora sync
14:07:34 <jcapitao> #link https://review.rdoproject.org/etherpad/p/ussuri-fedora-sync
14:07:50 <jcapitao> so, almost all os clients are now sync in Fedora rawhide
14:08:04 <jcapitao> currently 2 missing due to unit tests failure
14:08:20 <jcapitao> debian folks hit the same issues, they filed the bug upstream
14:08:43 <amoralej> jcapitao, which ones?
14:08:58 <jcapitao> i put them in the pad
14:09:12 <jcapitao> i filed bz ticket just to track them on fedora side
14:09:33 <amoralej> the one about oslo-utils reings me a bell
14:09:57 <amoralej> could you check if we had to disable unit tests in previous builds in fedora?
14:11:03 <jcapitao> ok i will
14:11:19 <jcapitao> but it works with py37
14:11:40 <amoralej> jcapitao, in fedora?
14:11:49 <jcapitao> yep
14:12:16 <jcapitao> and fails since py38
14:13:13 <spotz> Hey all sorry I'm late
14:13:18 <amoralej> ok
14:13:19 <jcapitao> i tried to fix it, unsuccessfully
14:13:28 <amoralej> wrt the octaviaclient looks like legit issue
14:13:34 <amoralej> not sure if only affecting unit tests
14:13:45 <jcapitao> #chair spotz
14:13:46 <openstack> Current chairs: amoralej jcapitao jpena spotz ykarel
14:14:02 <jpena> jcapitao: https://bugs.launchpad.net/oslo.utils/+bug/1841072
14:14:02 <openstack> Launchpad bug 1841072 in oslo.utils "test_reflection.CallbackEqualityTest.test_different_instance_callbacks fails on Python 3.8" [Undecided,New]
14:14:51 <jpena> it's not fixed upstream yet, but I see there's some patch for ubuntu
14:14:52 <amoralej> ah, i remembered something about that
14:15:00 <jcapitao> jpena: ah !
14:15:07 <jpena> we could either skip that test or see if the Ubuntu fix is different
14:15:12 <ykarel> ohhk so it failing upstream too https://39770df410ace4902fc0-3eec3a080da8356877afe7c3a8a6cc53.ssl.cf5.rackcdn.com/734145/1/check/openstack-tox-py38/c65b8a1/testr_results.html
14:15:37 <jpena> I'd simply skip the test for now
14:15:47 <ykarel> +1
14:15:50 <amoralej> yep
14:16:33 <amoralej> cgoncalves, some unit tests in octaviaclient are failing since python 3.8 https://storyboard.openstack.org/#!/story/2007536
14:16:41 <amoralej> if you have a chance to take a look
14:17:14 <jcapitao> ok, i'll skip unit tests for oslo.utils
14:17:26 <ykarel> jpena, only the affected test
14:17:34 <ykarel> not all
14:17:36 <jpena> yes, just that test
14:17:36 <ykarel> sorry jcapitao
14:18:02 <jcapitao> ack
14:18:22 <spotz> +1
14:19:02 <jcapitao> last thing about virtualbmc
14:19:16 <jcapitao> it's not in @openstack-sig group
14:19:29 <jcapitao> should we ask ownership ?
14:19:57 <spotz> Is anyone else using it? IE should it be a SiG?
14:20:16 <amoralej> it has a maintainer
14:20:17 <spotz> And even if it's a SiG doesn't mean someone from here can't chair or co-chair
14:20:24 <amoralej> i would not request access
14:20:31 <amoralej> but i would propose PR
14:21:00 <amoralej> and as spotz said, you can ask about being co-maintainer
14:21:14 <jcapitao> yeah i proposed a PR
14:21:35 <amoralej> i just say you did :)
14:22:35 <amoralej> let's see what he says
14:23:07 <jcapitao> ok ;)
14:23:29 <jcapitao> next topic then
14:23:34 <jcapitao> #topic Override file for reqcheck job
14:23:47 <jcapitao> #link https://review.rdoproject.org/r/#/c/26167/
14:23:56 <jcapitao> i'm bringing back this topic as we are now post ussuri release
14:24:25 <jcapitao> so the .spec files are synced with the upstream requirements.txt files
14:24:54 <jcapitao> i've updated the override-file.yml
14:25:30 <jcapitao> so basically, this file contains all the reqcheck exception that should be overwritten or ignored in order to pass reqcheck successfully
14:26:10 <jcapitao> need some reviews :)
14:26:13 <amoralej> ok, i'll take a look later
14:26:22 <amoralej> i need to refresh the syntax of that file :)
14:27:10 <ykarel> me too :)
14:27:15 <jcapitao> if you see a more intuitive way, let me know
14:27:39 <jcapitao> i'm opened to suggestion
14:28:54 <ykarel> may be u can add some details how to manage and how it's generated
14:28:55 <amoralej> i will if i can figure out something better
14:29:25 <jcapitao> ykarel: in the commit message you mean ?
14:29:50 <ykarel> jcapitao, in file itself as a comment would be better
14:30:13 <ykarel> yaml has multi line comment ?
14:30:17 <jcapitao> ykarel: okk, good suggestion
14:30:43 <amoralej> or a README
14:31:08 <amoralej> i think it's better not to mess the file with comments that may break automation at some point
14:31:42 <ykarel> README also ok, main idea is to have better understanding for contributors
14:31:58 <ykarel> and initial reviewers too :)
14:32:17 <jcapitao> let's go for a README :)
14:33:40 <spotz> Poke and I'll review the README
14:33:47 <rdogerrit> Merged openstack/murano-tempest-plugin-distgit rpm-master: Remove congressclient as requirement  https://review.rdoproject.org/r/28007
14:34:11 <jcapitao> #action jcapitao to add a README about override file of reqcheck job
14:34:23 <jcapitao> let's continue
14:34:27 <jcapitao> #topic First jobs running validation of RDO Trunk Victoria on CentOS Stream
14:34:57 <ykarel> great \o/
14:35:00 <rdogerrit> Chandan Kumar created rdo-infra/ci-config master: Add fs038 jobs to queens, rocky and stein promotions  https://review.rdoproject.org/r/28042
14:35:14 <rdogerrit> Merged openstack/murano-distgit rpm-master: Remove congressclient as requirement  https://review.rdoproject.org/r/28006
14:35:28 <jcapitao> so we are taking advantage of CentOS Stream ?
14:35:28 <amoralej> so, according to the goal of using CentOS Stream to validate pre-release RHEL content i've created some periodic jobs
14:35:44 <amoralej> those deploy last promoted master content of centos-stream
14:36:01 <amoralej> i mean *on* centos-stream
14:36:10 <spotz> Nice
14:36:12 <amoralej> that runs daily in periodic pipeline
14:36:35 <amoralej> #info Jobs results in https://review.rdoproject.org/zuul/builds?project=rdoinfo&pipeline=periodic#
14:36:52 <amoralej> #info job names periodic-victoria-puppet-*-centos-stream and periodic-victoria-packstack-*-centos-stream
14:37:12 <amoralej> that's our first approach to centos-stream
14:37:19 <amoralej> running fine so far
14:38:07 <amoralej> note that we keep using standard centos8 to build packages and to run all the rest of the jobs
14:38:25 <amoralej> and there are no plans to switch to centos-stream to build packages in cludsig
14:38:45 <amoralej> i think that's it from my side
14:39:16 <spotz> Are we having any issues with 8 in regards to Networm Manager and no network service?
14:39:40 <amoralej> not so far but i saw a mail in rdo ML
14:39:49 <amoralej> didn't check yet
14:40:20 <amoralej> some of the network configurations in packstack are not persistent
14:40:32 <spotz> amoralej: Which list? Migt not be on all I should be if I'm going to help out here
14:40:37 <amoralej> that has been the case since long ago, as it was only created for CI usage
14:41:21 <amoralej> spotz, https://lists.rdoproject.org/pipermail/users/2020-June/000785.html
14:42:00 <spotz> amoralej: Ok I am on there just missed it:(
14:42:28 <amoralej> np
14:44:03 <jcapitao> ok, next topic
14:44:07 <jcapitao> #topic Congress retirement
14:44:30 <jcapitao> #link https://review.opendev.org/#/q/topic:retire-congress+(status:open+OR+status:merged)
14:44:42 <jcapitao> #link https://review.rdoproject.org/r/#/q/topic:retire-congress+(status:open+OR+status:merged)
14:44:45 <amoralej> #info congress project has been retired upstream
14:45:10 <amoralej> #info congress, congressclient, congress-test-tempest and puppet-congress will be retired from RDO in Victoria
14:45:45 <amoralej> #action anyone using congress packages from RDO should move out of it as packages will be removed soon
14:46:56 <rdogerrit> Sorin Sbarnea (zbr) proposed rdo-infra/ci-config master: POC: Switch molecule promoter jobs to centos-8  https://review.rdoproject.org/r/28038
14:48:23 <jcapitao> let's move to last topic
14:48:34 <jcapitao> #topic Removal of Pike and Ocata Trunk repos
14:49:15 <jcapitao> #link https://lists.rdoproject.org/pipermail/dev/2020-May/009380.html
14:49:30 <jcapitao> ykarel: ^ all yours
14:49:50 <ykarel> So we have notified more than 3 weeks ago about it and not received any objection on it
14:50:07 <ykarel> I think we can drop these repos
14:50:17 <ykarel> may be next week?
14:50:37 <ykarel> by doing a follow up mail that we dropping next week
14:51:15 <amoralej> lgtm
14:51:20 <jcapitao> +1
14:51:28 <amoralej> ykarel, before doing final removal
14:51:34 <amoralej> let's just rename those
14:51:36 <amoralej> for some days
14:51:47 <amoralej> or just remove the symlink and leaving the actual content
14:51:55 <amoralej> just in case
14:52:01 <ykarel> amoralej, okk +1
14:52:39 <ykarel> will notify on mail that we dropping next week
14:52:47 <spotz> +1, a little bit of a scream test but in all honestly sometimes folks need the older stuff
14:53:18 <ykarel> and as a backup we can keep it for some more days by renaming repos
14:54:22 <amoralej> ykarel, also we need to make sure those will not longer created
14:54:26 <amoralej> by automation
14:54:40 <amoralej> in case they are still in hiera files
14:54:49 <ykarel> amoralej, yes let's see how we can do that
14:55:06 <jcapitao> #action ykarel to notify on ML that RDO will drop Pike and Ocata Trunk repos next week
14:55:18 <amoralej> https://softwarefactory-project.io/r/#/c/18347/
14:55:23 <amoralej> that disabled it
14:55:29 <amoralej> now we need to remoe them
14:55:42 <amoralej> from there and also puppet-dlrn common.yml
14:55:54 <ykarel> yes
14:56:45 <ykarel> ok let's move, that's it for this topic
14:56:54 <jcapitao> #topic next week chair
14:57:02 <jcapitao> any volunteer ?
14:58:10 <amoralej> i can take it
14:58:26 <jcapitao> thank you amoralej :)
14:58:30 <jcapitao> #action amoralej to chair next week meeting
14:58:45 <jcapitao> we are running out of time, sorry
14:58:54 <jcapitao> #topic open floor
14:59:40 <jcapitao> if you have anything to bring out there
15:01:22 <jcapitao> let's close the meeting then
15:01:30 <jcapitao> thanks for joining
15:01:37 <jcapitao> #endmeeting