14:02:50 <ykarel> #startmeeting RDO meeting - 2020-07-08
14:02:51 <openstack> Meeting started Wed Jul  8 14:02:50 2020 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:54 <openstack> The meeting name has been set to 'rdo_meeting___2020_07_08'
14:03:20 <ykarel> Add last minute topics to agenda https://etherpad.opendev.org/p/RDO-Meeting
14:03:25 <ykarel> #topic roll call
14:03:31 <amoralej> o/
14:03:34 <spotz> o/
14:04:19 <jcapitao> o/
14:05:49 <ykarel> #chair amoralej spotz jcapitao
14:05:50 <openstack> Current chairs: amoralej jcapitao spotz ykarel
14:06:16 <ykarel> Ok let's start with topics
14:06:19 <ykarel> #topic Upcoming events
14:06:24 <ykarel> amoralej spotz ^^
14:07:51 <spotz> I looked into the hopin.to platform as a possibility for our future events. OpenShift COmmons is actually going to use it later this month so we can get an idea how it would work for us for the test days/hackfest
14:09:12 <spotz> We should make a decision on whether we want to stay with a Test Days this time around or changeover to more of a hackfest so we can start planning and then advertising
14:10:21 <amoralej> i'm in favor of investing the time in planning and organizing hackfest
14:10:58 <amoralej> if we can stay with test days with minimal effort
14:11:02 <amoralej> no problem from my side
14:11:06 <spotz> I know it's just usually the 4 of us in meetings, but maybe send something to the lists and see if we can't get a committee?
14:11:50 <spotz> I haven't done a test days so not sure what's involved there. Hackfest we could have a few use-cases to test and hack on, or pick some areas and potential bugs to work on
14:12:35 <amoralej> wrt test days
14:12:52 <amoralej> it's mainly give links for installation docs
14:13:09 <amoralej> and a etherpad to report who has been testing and what they  found
14:13:21 <amoralej> and some advertising on ML and maybe twitter account
14:13:26 <spotz> Ahh so I've been doing the test days on my own:)
14:14:13 <spotz> So not that far off from a use-case type of hackfest, we'd just be adding an interactive part to it perhaps by having a platform to unify people in a 'room'
14:14:37 <amoralej> usually, point of contact is #rdo
14:14:46 <jcapitao> +1 for the hackfest (if there is enough attendees)
14:15:41 <spotz> Ok so do we want to stick with IRC or make it visual with hopin.to?
14:15:54 <ykarel> +1 for hackfest
14:16:11 <amoralej> you mean for *this* test days?
14:16:46 <amoralej> sorry, i thought we were thinking in hackfest later
14:16:48 <amoralej> i got lost
14:16:58 <spotz> Yeah. So we have to questions do Test Day or Hackfest for RC1
14:17:23 <amoralej> ah
14:17:31 <amoralej> i was thinking the question was more
14:17:33 <spotz> And second do we want to move to a more formal platform like hopin.to
14:18:04 <amoralej> for hackfest on rc1, hopin.to
14:18:43 <spotz> Yep, and it's ok if we stick with what we know now and then move things for the next one
14:19:01 <spotz> Or even move back if we don't like the results
14:20:42 <spotz> To be honest it seems like the Test Days is similar to a Use Case hackfest, we could rename to hackfest and still do that plus have a list of bugs for people to work on as well
14:21:38 <amoralej> for me, test days is differnt
14:21:51 <amoralej> to hackfest, at least in my mind :)
14:22:00 <amoralej> but i may be wrong
14:22:10 <amoralej> test days is something more like
14:22:13 <spotz> I do test days any time I run through docs apparently so I'm a bad judge:)
14:23:01 <amoralej> "test deployment using docs by yourself and let us know if you find some issue. We'll be on irc if you need help"
14:23:09 <amoralej> those are test days
14:23:23 <amoralej> hackfest i understood we'd do something more guided
14:23:40 <amoralej> and with much more clear use cases
14:23:47 <spotz> That was actually how they just internally did the hackfests with provided use-cases
14:24:16 <amoralej> focus is no in testing as much as in helping people to do their first deployments
14:24:28 <spotz> For test days?
14:24:29 <amoralej> or deployment with some specific feature or configuration
14:24:33 <amoralej> hackfest
14:24:49 <spotz> Ok
14:25:25 <amoralej> I'm not sure if I'm explaining clear or messing it up :)
14:25:28 <spotz> Your Test days are a hackfest type to me and your hackfest is a workshop to me:)
14:25:37 <amoralej> :)
14:25:47 <amoralej> oook
14:25:51 <amoralej> names are important
14:26:05 <amoralej> let's agree on names for events
14:26:08 <spotz> Yep and it's worth the time spent to get everyone using the same words
14:26:13 <amoralej> yep
14:26:31 <spotz> ykarel and jcapitao - what words do you use?:)
14:27:47 <spotz> And while we wait I'll type something on doc days
14:27:48 <ykarel> For me it's like: Test Day which we used to do till now, follow docs and report/fix issues
14:28:30 <ykarel> workshop is guided deployments with some use cases
14:28:55 <ykarel> hackfest can be mixed of both
14:29:17 <ykarel> where we help live on issues
14:29:21 <spotz> I think after emailing with rbowen we should go ahead and email the lists and see what we get back. I may be able to tie it into Grace Hopper but may not be able to
14:29:58 <spotz> ykarel: And I think either way we should be there to help
14:30:20 <ykarel> yes right
14:31:25 <spotz> I'm hoping at least the basic upstream install docs for a keystone,glance,nova,neutron cluster will be fixed shortly
14:31:38 <jcapitao> tbh i have no strong opinion (as i haven't participated in test days yet), but imho hackfest includes "test days" as a chapter
14:32:29 <spotz> Maybe something we could do is do a how to install workshop before the hackfest which yeah would include test day runs through the docs?
14:33:00 <amoralej> sounds good
14:33:30 <spotz> Ok I'll try to put something together, then get buyin on details from the group before we send to the lists?
14:33:31 <ykarel> +1
14:33:47 <amoralej> +1
14:34:10 <jcapitao> +1
14:34:21 <spotz> I can atleast help install issues in the workshop if folks are on vacation:)
14:34:48 <spotz> And with the thought once I'm done with my install tests the docs should be pretty solid for a basic cluster
14:35:34 <spotz> #action spotz mail lists about doc holes
14:35:59 <spotz> @action spotz make a basic plan for workshop and hackfest to share with the group next week
14:36:28 <spotz> #action spotz make a basic plan for workshop and hackfest to share with the group next week
14:38:03 <spotz> Anything else on this?
14:38:35 <ykarel> nothing from me
14:39:24 <amoralej> nothing from my side
14:39:47 <jcapitao> ok for me
14:40:17 <spotz> next topic then:)
14:40:18 <ykarel> spotz, so next topic streaming and OpenShift COmmons AMA (7/27) seems covered already
14:40:48 <ykarel> or something more to discuss on that
14:40:53 <spotz> Well we're looking for volunteers to be on OpenStack and RDO related streams:)
14:41:05 <ykarel> #topic streaming and OpenShift COmmons AMA (7/27)
14:41:20 <ykarel> okk all yours ^
14:41:54 <spotz> We'll be part of OpenShift COmmons and there's the ADA scheduled for 7/27 with once we can get our own cadence have our own streaming slot for OpenStack/RDO
14:42:34 <spotz> SO if anyone is interested in getting involved and being on streams just let me know even if 7/27 doesn't work in your schedule
14:42:41 <spotz> ADA=AMA
14:43:18 <spotz> So tell your friends and we'll start to put together a list of people and topics
14:43:20 <amoralej> spotz, but that AMA is specific for openstack?
14:43:27 <spotz> amoralej: Yep
14:43:35 <amoralej> oh, nice
14:43:54 <amoralej> did you start recruiting already?
14:44:32 <spotz> And in the Commons streams we can be a little more community related like how to get your first patch. Where some of the other slots are generally more technical. I think we'll want a mix of community and technical eventually
14:44:49 <amoralej> i'd like to participate from the rdo side
14:44:50 <spotz> amoralej: I mentioned it this morning during the OpenStack Program meeting but that's it
14:45:05 <amoralej> it may be good to involve someone from tripleo i.e.
14:46:00 <spotz> My only concern is the OpenShift COmmons streams start in 1 hour and are an hour generally. Is that too late for you? Once we get our own show we'll be able to go with something earlier
14:46:52 <spotz> I can reach out to Wes for tripleo. And we can always have different people for different topics
14:47:05 <amoralej> i think i can join on 27 at that time
14:47:38 <amoralej> also someone more familiar with openshift on openstack
14:47:46 <amoralej> as i foresee questions about the topic
14:47:52 <spotz> I'll let Diane know
14:48:32 <spotz> Yeah thats definitely a hot topic, I know August can do that but it's definitely something I need to pick up as well as openstack and ceph
14:50:06 <spotz> ANy other thoughts on this besides?
14:50:22 <spotz> spreading the word:)
14:52:51 <spotz> #topic review needed
14:53:03 <spotz> #link  https://review.rdoproject.org/r/#/c/28218/
14:53:26 <spotz> That will fix an install issue with placement so folks won't need to hack it in themselves:)
14:53:41 <ykarel> spotz, is there any bug for it with some more details
14:53:53 <ykarel> like what step failed exactly, in which scenario etc
14:54:32 <spotz> Hrm we discussed it in channel, I don't think I bothered to bug it as I was patching it
14:54:58 <spotz> But when you get to the verification stage in the docs you error out
14:56:08 <ykarel> okk will check channel logs then later
14:56:24 <spotz> https://docs.openstack.org/placement/latest/install/verify.html is the page with the instructions
14:56:50 <spotz> fails on openstack --os-placement-api-version 1.2 resource class list --sort-column name and the next command
14:57:00 <ykarel> ack
14:57:22 <spotz> I still need to patch that page to use the rpm for python3-osc-placement
14:58:28 <spotz> And that isn't an RDO specific page FYI
14:58:49 <ykarel> ack
14:59:10 <ykarel> ok let's move to next
14:59:14 <ykarel> #topic Next Week's chair
14:59:19 <ykarel> any volunteer?
14:59:24 <amoralej> i can take it
14:59:49 <ykarel> Thanks amoralej
14:59:55 <ykarel> #action amoralej to chair next week
15:00:01 <ykarel> #topic Open Floor
15:00:14 <ykarel> so we are already out of time
15:00:22 <ykarel> so let's close
15:00:31 <ykarel> Thanks all
15:00:33 * spotz will be quieter next week?:)
15:00:34 <ykarel> #endmeeting