14:00:32 <ykarel> #startmeeting RDO meeting - 2020-08-12
14:00:33 <openstack> Meeting started Wed Aug 12 14:00:32 2020 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:36 <openstack> The meeting name has been set to 'rdo_meeting___2020_08_12'
14:00:43 <spotz> I'm here with net issues, glad I'm not leading today:)
14:00:58 <ykarel> Please add topic to the Agenda https://etherpad.opendev.org/p/RDO-Meeting
14:01:06 <ykarel> #chair spotz
14:01:07 <openstack> Current chairs: spotz ykarel
14:01:14 <ykarel> #topic roll call
14:01:27 <ykarel> Anyone else around?
14:01:54 <rh-jelabarre> as I get older I'm getting rounder, if that helps...
14:02:21 <spotz> rh-jelabarre: very true:)
14:02:54 <ykarel> #chair rh-jelabarre
14:02:55 <openstack> Current chairs: rh-jelabarre spotz ykarel
14:06:39 <ykarel> Ok let's start, It's a vacation month, some people are already on vacations
14:07:27 <ykarel> So there is no topic in today's agenda
14:07:54 <ykarel> anything you would like to bring up
14:08:12 <ykarel> can anyone access https://review.rdoproject.org/r ?
14:08:15 <ykarel> it's not loading for me
14:08:41 <tristanC> ykarel: it's missing a trailing `/`
14:08:58 <tristanC> ykarel: we recently updated the host, was this url working before?
14:09:44 <ykarel> tristanC, i guess yes
14:09:49 <ykarel> tristanC, recently means yesterday?
14:10:08 <danpawlik> ykarel: https://review.rdoproject.org/r/
14:10:10 <tristanC> ykarel: actually we did it today, yesterday was the zuul control plane
14:10:14 <ykarel> or today it was updated
14:10:15 <danpawlik> is working perfect
14:10:17 <ykarel> tristanC, okk
14:10:33 <tristanC> ykarel: ok let me see, it seems like a regression, we can fix that
14:11:07 * ykarel reconnects, seems some issue with my network
14:12:19 <spotz> Only thing I really have emailing with weshay about the tripleo related workshop, he's on PTO this week though
14:12:24 <rdogerrit> Merged rdo-infra/ci-config master: Fix typo in influxdb repo  https://review.rdoproject.org/r/28914
14:12:55 <spotz> I'm going back and forth on whether we'll do the manual install, will decide once we decide whether we're doing a full tripleo or a quickstart one
14:13:46 <ykarel_> danpawlik, tristanC now i can access after changing my local network
14:14:12 <ykarel_> wrt / in end, seems like / was there from browser auto complete
14:14:22 <ykarel_> but if it can be fixed that would also be good
14:14:41 <tristanC> ykarel: ok then it is not a regression, let me improve the rewrite rule none the less
14:15:00 <ykarel_> tristanC, Thanks
14:16:15 <ykarel> #topic openvswitch builds in NFV SIG
14:16:37 <ykarel> So with NFG SIG we have started doing builds for openvswitch, ovn etc
14:17:05 <ykarel> it's an attempt so different teams like ovirt, rdo etc and consume it from same source
14:17:21 <ykarel> The builds are rebuilds from rhel Fast DataPath
14:17:35 <ykarel> #link http://ftp.redhat.com/pub/redhat/linux/enterprise/8Base/en/Fast-Datapath/SRPMS/
14:18:15 <ykarel> #link https://cbs.centos.org/koji/builds?tagID=2120
14:18:37 <ykarel> We will share more details as we make progress
14:19:55 <rdogerrit> Yatin Karel created rdo-jobs master: Revert "Turn off ara-report"  https://review.rdoproject.org/r/28943
14:20:05 <rdogerrit> Rafael Folco created rdo-infra/ci-config master: Switch mol* jobs to centos-8 nodeset  https://review.rdoproject.org/r/28944
14:20:36 <ykarel> That's it in this topic, any thing to discuss on it
14:22:46 <rdogerrit> Yatin Karel proposed rdo-jobs master: Revert "Turn off ara-report"  https://review.rdoproject.org/r/28943
14:22:57 <tristanC> ykarel: https://review.rdoproject.org/r  should now work without a trailing '/'
14:23:31 <ykarel> tristanC++ that's great
14:23:51 <ykarel> Ok let' move to next topic
14:24:30 <ykarel> #topic Chair for next meeting
14:24:57 <spotz> I'm not committing to anything until my net is back!
14:25:24 <ykarel> :)
14:25:48 <ykarel> I can retake it if no one else
14:26:03 <ykarel> as we are sort of people in this month
14:26:11 <spotz> Also Kubecon next week
14:26:39 <ykarel> #action ykarel to chair next week
14:27:06 <spotz> Thanks ykarel
14:27:20 <ykarel> #topic open floor
14:27:26 <ykarel> Feel free to bring any topic  now
14:27:57 <spotz> Hopefully I'll have an events update
14:28:12 <elade> I can create a port without IP addresses (on L2 network) using CLI "openstack port create --disable-port-security --no-security-group --network NetworkName --no-fixed-ip porName" but I can't do this with heat template? I tried " fixed_ips:: []" (for OS::Neutron::Port ) but I constantly get "No more IP addresses available on network"
14:29:02 <spotz> elade: Been a while since I'de much Heat but double check you do have enough IPs in the block in your template if it was originally configured there
14:29:30 <spotz> I've done....
14:30:19 <elade> spotz: thank . i don't need any IP addresses. From the CLI I can do "openstack port create --disable-port-security --no-security-group --network NetworkName --no-fixed-ip porName" over and over again and it never fails.
14:31:13 <spotz> So what are you trying to do in the template, and make sure it's a function in the template version you're using
14:32:39 <elade> I'm trying to create a VM which is connected to a L2 network. I will get DHCP address from outside DHCP server. I can do this in CLI and it works:
14:33:04 <elade> openstack port create --disable-port-security --no-security-group --network networkname  --no-fixed-ip portName
14:33:36 <elade> openstack server add port vmName portName
14:34:17 <spotz> elade: Best suggestion is to verify that the template version you're using has the functionality you want. Not sure if $heat is active of not but they should know
14:34:44 <spotz> Template versions don't always make sense when picking one
14:37:28 <elade> ok i'll try in #heat thanks
14:37:31 <ykarel> Yes someone from heat could answer this quickly
14:39:44 <spotz> I'm better at running the service then using the templates but it's been a few years now since I was a Heat Engineer
14:39:57 <ykarel> elade, you have template handy that u using?
14:41:05 <elade> @ykarel http://paste.openstack.org/show/796778/
14:42:00 <elade> We want it to create a port with no fixed_ips. It's as if the default is 1 IP even if we specify []
14:45:49 <ykarel> elade, on a quick look seems it's happening due to https://opendev.org/openstack/heat/src/branch/master/heat/engine/resources/openstack/neutron/port.py#L497-L499
14:46:32 <ykarel> but some one from heat could confirm, or it's not your production system you could try changing that and see
14:46:42 <ykarel> s/it's/ if it's/
14:47:05 <ykarel> del props[self.FIXED_IPS] --> props[self.FIXED_IPS] = []
14:49:12 <elade> ooooh nasty. I think i'll try that.
14:50:17 <ykarel> ack
14:54:21 <spotz> heheh
14:55:22 <ykarel> Ok if nothing else, let's close the meeting
14:56:29 <spotz> +1
14:57:15 <ykarel> #endmeeting