14:01:42 <jcapitao> #startmeeting RDO meeting - 2021-06-09
14:01:43 <opendevmeet> Meeting started Wed Jun  9 14:01:42 2021 UTC and is due to finish in 60 minutes.  The chair is jcapitao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:44 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:46 <opendevmeet> The meeting name has been set to 'rdo_meeting___2021_06_09'
14:01:50 <spotz> o/
14:02:05 <jcapitao> #topic roll call
14:03:08 <jcapitao> #chair spotz
14:03:09 <opendevmeet> Current chairs: jcapitao spotz
14:03:21 <ykarel> o/
14:04:13 <jcapitao> #chair ykarel
14:04:15 <opendevmeet> Current chairs: jcapitao spotz ykarel
14:07:44 <spotz> amoralej: mighht be working on the email discussed before the meeting want me to gp?
14:09:14 <amoralej> o/
14:09:24 <amoralej> sorry
14:09:41 <jcapitao> spotz: gp ?
14:09:53 <jcapitao> #chair amoralej
14:09:54 <opendevmeet> Current chairs: amoralej jcapitao spotz ykarel
14:09:55 <spotz> #link - https://coolstuff.redhat.com/category/121/rdo
14:10:08 <jcapitao> #topic Sool Stuff Store!
14:10:24 <jcapitao> let's start with your topic spotz :)
14:11:00 <spotz> Sp we hhave a section in the new stuff store! Upcoming we will be having some non-release coozies and I'll be working on the Wallaby shirts shortly
14:11:20 <spotz> That's it so far:)
14:12:07 <amoralej> it's cool spotz !
14:12:08 <ykarel> s/Sool/Cool
14:12:09 <amoralej> nice work
14:12:26 <amoralej> we'll have wallaby t-shirts?
14:12:34 <amoralej> in the store, i mean
14:13:11 <spotz> Most likely shirrts unless tyherre's something else that looks cool but yeah I've got the updated Spencer for it already
14:13:29 <spotz> We'll have a code like last time and then afterr a bit they'll be for sale
14:14:16 <jcapitao> coool
14:15:20 <jcapitao> thanks spotz
14:15:23 <jcapitao> next topic
14:15:30 <jcapitao> #topic Status about CentOS Stream 9 adoption
14:16:06 <jcapitao> amoralej: I think you have the clearest vision on this topic
14:16:14 <amoralej> yes
14:16:31 <amoralej> let me summarize the progress we have done
14:17:34 <amoralej> #info we are running p-o-i scenarios on centos9 to identify gaps and issues
14:18:09 <amoralej> #info review https://review.opendev.org/c/openstack/puppet-openstack-integration/+/793462 documments the issues and hacks to get all passing
14:18:39 <amoralej> we've reported the known issues to the responsible teams, as puppet modules, ironic, etc...
14:19:36 <amoralej> #info creating packstack on CentOS jobs in RDO zuul so that we also identify issues and be able to run third party
14:20:16 <amoralej> #info https://review.rdoproject.org/r/c/rdo-jobs/+/33995 and https://review.opendev.org/c/x/packstack/+/795130
14:20:33 <amoralej> i think we are doing a good progress on it
14:20:53 <amoralej> ah, and finally
14:21:15 <amoralej> #info we have non-voting jobs DLRN-rpmbuild-centos9 running in rpm-master branches
14:21:30 <rdogerrit> Merged config master: Make it possible to set virtualenv_python  https://review.rdoproject.org/r/c/config/+/34034
14:21:51 <amoralej> while these are non voting, it's good to know if we may be breaking centos9 builds with changes
14:22:16 <ykarel> amoralej, so the plan is to run third party check non-voting jobs or starting with experimental ones
14:22:21 <amoralej> and let's keep it in mind while merging changes
14:22:24 <ykarel> just going through reviews
14:22:28 <amoralej> ykarel, first experimental
14:22:32 <ykarel> okk
14:22:34 <amoralej> you mean for packstack, right?=
14:22:37 <ykarel> yes
14:22:52 <ykarel> ok sounds good
14:23:23 <amoralej> yes, so first we will only run them when doing "check rdo experimental" comment
14:23:24 <amoralej> iirc
14:23:34 <ykarel> yes ^ correct
14:24:37 <jcapitao> yes
14:25:04 <jcapitao> and then as non-voting in main pipeline ?
14:25:21 <ykarel> yes openstack-check
14:25:37 <jcapitao> ok
14:25:45 <ykarel> and once c9 labels available upstream move jobs to upstream check
14:25:59 <ykarel> but wouldn't we have issues when we move jobs upstream with same name?
14:26:40 <amoralej> by then, we will be able to remove these jobs
14:26:42 <ykarel> i think we would be clearing third party check jobs once upstream ready, so shouldn't be an issue
14:26:44 <ykarel> yeap
14:26:48 <amoralej> tbh i think that's not a big problem
14:26:52 <ykarel> yes
14:27:10 <jcapitao> good
14:27:22 <jcapitao> and do we have update on CentOS Stream 9 GA ?
14:27:52 <amoralej> not yet
14:28:13 <amoralej> no idea when we'll have it
14:28:32 <amoralej> hopefully soon, but there is no a committed timeline
14:28:37 <spotz> I did give folks the heads up in the OpenStack Program inteernal meeting today just so they knew we're prerping but waiting and migght be late
14:30:37 <jcapitao> ok, at least we're almost ready
14:31:34 <jcapitao> any question on this topic ?
14:32:39 <jcapitao> let's move then
14:32:44 <jcapitao> #topic Chair for next week
14:33:03 <amoralej> i can take it
14:33:27 <jcapitao> #action amoralej to chair next week meeting
14:33:33 <jcapitao> thank you amoralej
14:33:42 <jcapitao> #topic open floor
14:35:36 <jcapitao> looks like the "Changing TripleO's release model" thread is trending topic
14:36:16 <amoralej> :)
14:36:51 <amoralej> we'll probably need some adjustments depending on the final decission
14:36:59 <amoralej> and how tripleo project implements it
14:37:43 <ykarel> so iiuc they are planning to skip cutting stable branches for some releases
14:37:51 <ykarel> and will just release tags
14:38:09 <rdogerrit> Alfredo Moralejo created rdo-website master: Adjust supported releases in the releases table  https://review.rdoproject.org/r/c/rdo-website/+/34045
14:38:16 <amoralej> ykarel, we will see
14:38:21 <amoralej> we may do that
14:38:28 <ykarel> so for RDO case, we will keep building from master for those skipped branches, right?
14:38:32 <amoralej> or just skip tripleo packages from some RDO releases
14:38:38 <ykarel> ahh
14:38:44 <ykarel> ok let's see
14:39:22 <amoralej> it will also depend on tripleo team, who maintains it
14:39:22 <amoralej> but in any case, we may need to adjust our definition of done
14:39:34 <ykarel> yes agree
14:40:05 <amoralej> and document the tripleo status on those releases, it's too early to decide, i think
14:40:42 <ykarel> yes would be much clear in coming weeks/months
14:40:52 <ykarel> so we can document before xena release
14:41:08 <amoralej> yes, sure
14:41:28 <amoralej> by then everything should be clear
14:42:18 <jcapitao> yes, we've got the time
14:44:26 <ykarel> btw noticed the link for upstream-id is wrong https://review.rdoproject.org/r/c/rdoinfo/+/34044
14:44:37 <ykarel> it's pointing to review.rdo instead of review.opendev
14:44:47 <amoralej> ah, the link
14:44:48 <ykarel> may be it's after gerrit upgrade?
14:44:48 <amoralej> right
14:45:13 <amoralej> i'm not sure where's that managed
14:45:19 <amoralej> as it's gerrit ui think?
14:45:23 <ykarel> https://github.com/rdo-infra/review.rdoproject.org-config/blob/master/gerrit/commentlinks.yaml#L4-L6 looks correct
14:45:31 <ykarel> in past ^ used to work
14:45:53 <amoralej> we'll need to ask SF team
14:46:18 <ykarel> yes, fbo jpena do you have idea ^
14:46:47 <amoralej> btw, the ones in openstack-sig in fedora are probably getting a bunch of mails from rebuild for 3.10
14:47:04 <amoralej> note that openstack builds are currently blocked by eventlet failures
14:47:31 <amoralej> but anyway, if you are assigned to bz, take a look just to make sure we are not blocking others
14:49:12 <ykarel> ack, i haven't looked at those yet
14:50:05 <jcapitao> ok I'll take a look
14:51:45 <jcapitao> I'll close the meeting in a few sec
14:51:47 <amoralej> as said before, i think eventlet is currently blocking openstack packages, but for other deps, we may own issues
14:53:35 <jcapitao> we've got this pad https://review.rdoproject.org/etherpad/p/fedora-python3.10-issues
14:54:00 <jcapitao> it might be outdated though
14:54:33 <amoralej> ah, right
14:54:45 <amoralej> that's from previous atempt
14:54:47 <amoralej> right?
14:54:54 <jcapitao> yes
14:56:18 <amoralej> https://bugzilla.redhat.com/show_bug.cgi?id=1913291 eventlet bz
14:56:19 <opendevmeet> bugzilla.redhat.com bug 1913291 in python-eventlet "python-eventlet fails to build with Python 3.10: TypeError: can't set attributes of built-in/extension type 'TimeoutError'" [Unspecified,New] - Assigned to kevin
14:56:21 <jcapitao> but iirc the python3.10 COPR was broken, and haven't take a look since then
14:56:36 <amoralej> now 3.10 is in the main f35 branch
14:56:47 <amoralej> so everything will be built with 3.10 in 35
14:57:32 <ykarel> jpena, seeing couple of network related issues in weirdo jobs, not sure if it's related to public network switch
14:57:40 <ykarel> couple of reds in https://review.rdoproject.org/zuul/status
14:57:58 <ykarel> failures like: Unable to download data from https://rubygems.org/ - timed out (https://api.rubygems.org/specs.4.8.gz)
14:58:23 <ykarel> Cannot find a valid baseurl for repo: rdo-qemu-ev/x86_64
14:58:38 <jcapitao> let's close
14:58:42 <jcapitao> #endmeeting