14:00:31 <amoralej> #startmeeting RDO meeting - 2021-06-16
14:00:31 <opendevmeet> Meeting started Wed Jun 16 14:00:31 2021 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:31 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:31 <opendevmeet> The meeting name has been set to 'rdo_meeting___2021_06_16'
14:00:39 <amoralej> #topic rollcall
14:00:55 <jcapitao> o/
14:01:38 <spotz> o/
14:02:04 <amoralej> #chair jcapitao spotz
14:02:04 <opendevmeet> Current chairs: amoralej jcapitao spotz
14:02:14 <ykarel> o/
14:02:21 <amoralej> remember you add your topics to https://etherpad.opendev.org/p/RDO-Meeting
14:03:18 <amoralej> #chair ykarel
14:03:18 <opendevmeet> Current chairs: amoralej jcapitao spotz ykarel
14:04:32 <amoralej> let's start with first topic
14:04:55 <amoralej> #topic migration of jobs in ci.centos.org to new jenkins instance
14:06:06 <amoralej> #link https://trello.com/c/c4jdnhio/758-migration-from-cicentosorg-to-new-openshift-centos-ci
14:07:02 <amoralej> #info all RDO jobs running on ci.centos.org must be moved to https://jenkins-cloudsig-ci.apps.ocp.ci.centos.org/
14:07:31 <amoralej> #info users are created, basic configuration is done
14:08:07 <amoralej> #info currently working on identify the needed jobs and to add them to a new jjb config dir
14:08:27 <amoralej> #link https://review.rdoproject.org/r/q/topic:jenkins-v2
14:09:19 <amoralej> ykarel has added the 1st level jobs that we need to add https://review.rdoproject.org/etherpad/p/jenkins-migration
14:09:43 <amoralej> jcapitao, i'd say to start adding jjb files for weirdo-promote-test-puppet-centos8-train and the nested jobs
14:09:56 <rdogerrit> Yatin Karel proposed config master: Adapt publish-cico job for jenkins-v2  https://review.rdoproject.org/r/c/config/+/34128
14:10:12 <jcapitao> ok
14:10:24 <amoralej> once we have one pipeline there, it should be easy to add the rest
14:10:40 <amoralej> btw, i think we can also use this migration to move weirdo jobs to cico nodes
14:10:57 <ykarel> +1
14:11:21 <amoralej> i tested cico nodes access in https://jenkins-cloudsig-ci.apps.ocp.ci.centos.org/job/test-amoralej/ and it works fine
14:11:33 <amoralej> so, we'll need to adapt that part
14:12:25 <amoralej> we must have some builder to get and free cico nodes
14:12:33 <amoralej> somewhere in ci-config project
14:12:56 <amoralej> just note we need to assign those jobs to "cico-workspace" label
14:14:28 <ykarel> yes, ppc jobs are using that builder
14:14:31 <ykarel> weirdo-get-node
14:14:49 <ykarel> and tripleo libvirts jobs also i think
14:15:06 <amoralej> in ppc oooq jobs?
14:15:16 <amoralej> i have doubts if the same job would be fine
14:15:57 <ykarel> in ppc container and image build job
14:16:12 <ykarel> they are using, tripleo libvirt jobs have there own script
14:16:17 <amoralej> mjturek, fyi ^ moving jobs in ci.centos to a new instance
14:16:32 <ykarel> https://github.com/openstack/tripleo-quickstart/blob/9c734b154a3516bba55209af0cdcb5daeb795d47/ci-scripts/get-node.sh
14:16:41 <ykarel> https://github.com/openstack/tripleo-quickstart/blob/9c734b154a3516bba55209af0cdcb5daeb795d47/ci-scripts/return-node.sh
14:17:17 <amoralej> mmm, but that's using quistart.sh for something
14:17:54 <rdogerrit> Merged rdo-infra/ci-config master: Add jjb validate job for jenkins-v2  https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/34126
14:19:12 <ykarel> yes just setting up venv
14:19:41 <ykarel> we would don't need that for weirdo jobs, was just a reference
14:19:49 <amoralej> yep
14:20:00 <amoralej> and some other adjustments will be neede
14:20:26 <amoralej> but yea, seems prety close to what we need
14:21:22 <ykarel> yeap
14:21:27 <amoralej> i think this is it about this topic
14:22:57 <amoralej> there are no more topics for today
14:23:06 <amoralej> #topic next week's chair
14:23:14 <amoralej> anyone willing to take it?
14:23:34 <jcapitao> I can take it
14:23:34 <ykarel> i can take it
14:23:42 <ykarel> jcapitao won :)
14:23:45 <amoralej> uh, jcapitao was faster :)
14:23:49 <amoralej> sorry ykarel
14:23:53 <jcapitao> :D
14:23:53 <ykarel> np
14:24:01 <amoralej> #action jcapita to chair next week
14:24:07 <amoralej> #topic open floor
14:24:20 <mjturek> thanks amoralej !
14:25:05 <amoralej> mjturek, check if the jobs you are interested in are included in the list  in https://review.rdoproject.org/etherpad/p/jenkins-migration
14:25:29 <amoralej> our plan is to migrate those as they are today
14:26:12 <mjturek> yes it's the two you have listed - will watch to make sure it went smoothly
14:26:32 <amoralej> i wonder if we'll hit some issue to push logs to logserver.rdoproject.org
14:27:05 <amoralej> i'm not sure if we rely in anything installed in the old slaves
14:27:10 <amoralej> ssh keys or something
14:27:30 <amoralej> we'll discover it soon
14:27:30 <ykarel> seems we would need to adapt, currently we inject keys in nodes itself
14:27:50 <ykarel> in images that we used to customize
14:28:38 <amoralej> you mean in the images used in vexxhost?
14:28:49 <ykarel> yes
14:29:13 <amoralej> but in ppc jobs we are gathering logs
14:29:21 <amoralej> so we can follow similar approach
14:29:29 <ykarel> yes
14:33:13 <amoralej> no more topics you'd like to share?
14:33:36 <amoralej> jcapitao, wrt python 3.10 in fedora
14:33:43 <amoralej> everything is under control, right?
14:33:50 <amoralej> mainly waiting for eventlet?
14:34:05 <jcapitao> yep, eventlet should be available in rawhide by tomorrow morning
14:34:16 <amoralej> is the patch merged upstream?
14:34:26 <jcapitao> and then we'll be able to rebuild our packages
14:35:03 <jcapitao> I don't think so but Fedora core maintainers decide to go w/o it being merged upstream
14:35:18 <amoralej> ahhh
14:35:23 <jcapitao> https://src.fedoraproject.org/rpms/python-eventlet/pull-request/7
14:36:33 <amoralej> ok, good, that should unblock us
14:37:05 <jcapitao> yeap, I haven't proposed the patch b/c I was waiting the upstream patch to be merged but they don't want to wait apparently
14:37:35 <amoralej> yes, it looks like so
14:37:45 <amoralej> well it's blocking quite many packages
14:37:53 <amoralej> i understand why they are pushing
14:38:19 <amoralej> ok, if that was it, i'm closing the meeting
14:38:25 <amoralej> and giving you some minutes back
14:38:50 <amoralej> thank you all for joining
14:38:51 <amoralej> #endmeeting