14:01:26 <jcapitao> #startmeeting RDO meeting - 2021-06-23
14:01:26 <opendevmeet> Meeting started Wed Jun 23 14:01:26 2021 UTC and is due to finish in 60 minutes.  The chair is jcapitao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:26 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:26 <opendevmeet> The meeting name has been set to 'rdo_meeting___2021_06_23'
14:03:23 <ykarel> o/
14:03:27 <jcapitao> sorry for the short notice, we'll wait a little bit for additional topics https://etherpad.openstack.org/p/RDO-Meeting
14:03:40 <spotz> o/
14:04:24 <jcapitao> #chair ykarel spotz
14:04:24 <opendevmeet> Current chairs: jcapitao spotz ykarel
14:08:54 <jcapitao> amoralej: around ?
14:09:31 <amoralej> oh
14:09:32 <amoralej> right
14:09:35 <amoralej> o/
14:10:25 <jcapitao> #chair amoralej
14:10:25 <opendevmeet> Current chairs: amoralej jcapitao spotz ykarel
14:10:38 <jcapitao> let's start with first topic
14:10:45 <jcapitao> #topic Gerrit Merge Strategy
14:10:54 <jcapitao> ykarel: ^
14:11:36 <ykarel> yes, so yesterday we discussed this, currently distgit patches goes to merge conflict even if there is no merge conflict
14:12:05 <ykarel> and this happens as we configure [submit]/mergeContent = false
14:12:33 <ykarel> so we are evaluating  [submit]/mergeContent = true now
14:12:51 <jcapitao> since https://review.rdoproject.org/r/c/config/+/34259
14:12:53 <ykarel> #link https://review.rdoproject.org/r/c/config/+/34259
14:13:05 <rdogerrit> mathieu bultel proposed openstack/validations-libs-distgit rpm-master: Add validation.cfg workaround  https://review.rdoproject.org/r/c/openstack/validations-libs-distgit/+/34241
14:13:25 <jcapitao> is it better ?
14:13:40 <ykarel> so we expecting with this change, that gerrit will auto rebase if there is no conflict at time of submit
14:13:46 <ykarel> jcapitao, haven't tested it
14:14:08 <amoralej> let's create some dommy patches in one of the puppet packages
14:14:12 <amoralej> dummy
14:14:18 <ykarel> patches are not merged since it https://review.rdoproject.org/r/q/project:%255Epuppet/puppet.*-distgit
14:14:29 <ykarel> amoralej, i rebased some patches ^
14:14:46 <jcapitao> what did change suddenly to have this issue ?
14:14:48 <ykarel> so with merge of puppet-tripleo patches it should be clear
14:15:03 <amoralej> ah
14:15:14 <amoralej> so all those are rebased on rpm-master right?
14:15:17 <ykarel> yes
14:15:45 <amoralej> let me check if we can merged them as they are
14:15:51 <ykarel> jcapitao, issue was there for long, but it get's more visible when multiple patches are posted together
14:16:11 <ykarel> yesterday tkajinam raised it and it lead to the discussion
14:16:20 <ykarel> we used to manually rebase always till now
14:16:41 <ykarel> now we are hoping to avoid manually rebases unless and until there are real conflicts
14:17:47 <jcapitao> ok good
14:18:01 <ykarel> for some projects we really need that option to be turned off
14:18:17 <ykarel> as we run different jobs in check and gate, like rdoinfo
14:18:46 <amoralej> in fact, it will also happen in distgits
14:18:52 <rdogerrit> User marios created rdo-infra/ci-config master: DNM testing try to set the dlrn_hash for dlrn reporting  https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/34275
14:19:04 <amoralej> i mean, different jobs in check and gate
14:19:23 <amoralej> so, some jobs will only be executed with the individual patches
14:19:31 <amoralej> but not with the rebases
14:19:31 <ykarel> yes true in some project we may have it
14:19:45 <amoralej> https://review.rdoproject.org/r/c/puppet/puppet-tripleo-distgit/+/33852
14:19:55 <amoralej> so, gate only has dlrn-rpmbuild-centos8
14:20:09 <amoralej> it doesn't run tripleo, centos9 or build-tripleo
14:20:16 <amoralej> probably it's fine
14:20:20 <amoralej> for distgits
14:21:05 <amoralej> because, iiuc the automatic rebase is done only before gate jobs, right?
14:21:15 <spotz> Woould anything from the Validate presentation yesterday help us?
14:21:36 <ykarel> i think it's at the time of merge after gate results
14:21:44 <amoralej> the one about validation framework?
14:21:54 <amoralej> after gate results?
14:21:59 <amoralej> that's weird, i think...
14:22:30 <amoralej> in that case the gate jobs run with a different commits stack that the one merged
14:22:53 <amoralej> if patches A and B are sent of top of commit XYZ
14:23:06 <amoralej> final situation is XYZ/A/B
14:23:20 <jpena> iirc, patches in the gate queue are always checked as if they were merged with the current repo contents (so gate jobs are running the "right" content)
14:23:21 <amoralej> so we should get that merge sequence at some point
14:23:22 <spotz> amoralej: yeah that one
14:23:46 <amoralej> yeah, that makes sense, thanks jpena
14:23:52 <ykarel> yes ^ seems true
14:24:07 <amoralej> spotz, i think it's unrelated with validation framework in this case
14:24:11 <ykarel> i meant specifically for those options, as the were in [submit] group
14:25:01 <amoralej> i think the point from gerrit perspective is that it does the submit *before* running gates, but in an internal repo
14:25:04 <amoralej> not the final one
14:25:07 <amoralej> or something like that
14:25:54 <rdogerrit> Merged puppet/puppet-tripleo-distgit rpm-master: puppet-sahara is no longer required  https://review.rdoproject.org/r/c/puppet/puppet-tripleo-distgit/+/34246
14:25:56 <amoralej> so 1. summit internal repo - 2. run gates - 3. pushes from the "internal tested repo" to the public one
14:26:12 <amoralej> ok, now let's see what happens with the other review in puppet-tripleo
14:26:27 <ykarel> yes let's see
14:26:30 <amoralej> so, https://review.rdoproject.org/r/c/puppet/puppet-tripleo-distgit/+/34247 can be merged
14:26:34 <amoralej> no conflict warning now
14:26:47 <ykarel> ok so it's good sign
14:26:52 <amoralej> yep
14:26:56 <amoralej> let's try to merge it
14:26:56 <ykarel> earlier it used to show conflict warning
14:27:23 <ykarel> ok +w
14:27:24 <amoralej> yes, i think so
14:29:07 <ykarel> https://review.rdoproject.org/r/gitweb?p=puppet/puppet-tripleo-distgit.git;a=log;h=refs/heads/rpm-master
14:29:34 <ykarel> https://github.com/rdo-packages/puppet-tripleo-distgit/commits/rpm-master
14:29:37 <amoralej> we can see the spec in the gate job if the spec had the puppet-sahura removed
14:30:01 <ykarel> yes
14:33:55 <jcapitao> there is no puppet-sahara
14:34:04 <ykarel> yeap
14:34:05 <amoralej> yep
14:34:26 <amoralej> so, i'd say it works as expected
14:34:37 <ykarel> yes
14:34:37 <amoralej> the only question is if current job definitions is fine
14:34:41 <rdogerrit> Merged puppet/puppet-tripleo-distgit rpm-master: Remove unused puppet-vcsrepo  https://review.rdoproject.org/r/c/puppet/puppet-tripleo-distgit/+/34247
14:35:38 <ykarel> commit history also looks fine
14:35:41 <ykarel> https://review.rdoproject.org/r/gitweb?p=puppet/puppet-tripleo-distgit.git;a=log;h=refs/heads/rpm-master
14:35:46 <amoralej> i'd say there's usually no big dependencies between patches in specs or complex stuff that is sensitive to this kind of issues
14:35:46 <ykarel> https://github.com/rdo-packages/puppet-tripleo-distgit/commits/rpm-master
14:36:04 <amoralej> so i think we can live with this
14:36:05 <amoralej> as is
14:36:15 <ykarel> yes agree
14:36:17 <amoralej> keep DLRN-rpmbuild-centos8 (and 9 in future)
14:36:21 <amoralej> in gate
14:36:42 <amoralej> in fact weirdo and oooq are non-voting
14:36:43 <amoralej> iirc
14:36:49 <amoralej> so no point in adding non-voting jobs in gate
14:37:08 <ykarel> yes those are non voting
14:38:44 <ykarel> now we see slightly different comment from zuul
14:38:45 <ykarel> Change has been successfully rebased and submitted as f13aa50e0459674f0d2280076d8697ad55e6638d by Zuul CI
14:39:11 <amoralej> right
14:39:22 <amoralej> in fact, it's a new PS
14:39:33 <amoralej> good to have visibility
14:39:37 <ykarel> yes
14:39:39 <ykarel> ok let's move to next topic
14:39:39 <rdogerrit> Merged rdo-infra/ci-config master: Set extended_hash value to None instead of 'None'  https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/34196
14:39:48 <amoralej> actually it creates a new PS with a new parent
14:40:00 <ykarel> PS or commit?
14:40:20 <ykarel> PS for patch set?
14:40:40 <amoralej> patchset
14:40:40 <jcapitao> yes PS3 in this case
14:40:54 <amoralej> yes
14:41:39 <ykarel> okk got it now
14:42:55 <jcapitao> good
14:43:07 <jcapitao> let's move to next topic then
14:43:22 <jcapitao> #topic Contributor shirt update
14:43:30 <jcapitao> from spotz
14:44:55 <spotz> So while we've had the new Wallaby release version for a while we just got the new store. I've been going through it and have narrowed it down to actually the original shirrt type I'd wanted. Just working on a color at this point. I'll note the new stoore isn't easy to tell what coloor you're looking at and the virtual preview doesn't uplooad for me to see
14:45:25 <spotz> But I hope to have something in the works end of this week or nexr
14:46:04 <ykarel> cool
14:46:34 <spotz> And there should be coozies up there soon to. For the contributor shirts we'll get codes again and include shipping
14:46:35 <ykarel> atleast i haven't seen new store yet
14:46:42 <jcapitao> what kind of orignality does this shirt have ? :)
14:47:49 <spotz> New color and Victoria replaced by Wallaby. I'm not sure we can change Spencer much each time beyond that but we have control of color for shirts and possibly we couldd change item but wanted to stick with shirrts until I get better at the store
14:48:41 <amoralej> what coozies mean? :)
14:49:00 <spotz> https://coolstuff.redhat.com/category/121/rdo
14:49:06 <spotz> https://coolstuff.redhat.com/category/121/rdo#link https://coolstuff.redhat.com/category/121/rdo
14:49:10 <spotz> bah!
14:49:27 <spotz> Coozies are little things you can put a can in and it helps keep them cold
14:49:36 <spotz> #link https://coolstuff.redhat.com/category/121/rdo
14:49:49 <spotz> But we have our own section of the store!
14:50:11 <amoralej> ahh i know now
14:50:48 <spotz> And that will be non-release Spencer on there
14:51:08 <amoralej> https://belusaweb.s3.amazonaws.com/product-images/gallery/623045_BS-Detail.jpg
14:51:14 <spotz> \yep
14:51:33 <amoralej> nice
14:51:33 <spotz> Ours are a grey from looking at the photo I was sent
14:51:46 <amoralej> it's cool to have our own section in the store!
14:51:49 <amoralej> spotz++
14:52:08 <jcapitao> yeah that rocks !
14:52:20 <spotz> Yep! Gives us more visibility:)
14:54:15 <jcapitao> ok, there is no more topic for today
14:54:30 <jcapitao> before open floor
14:54:34 <jcapitao> #topic Chair for next week
14:54:39 <spotz> I can take it
14:54:44 <spotz> I haven't done it in a bit
14:55:13 <jcapitao> thank you spotz
14:55:23 <jcapitao> #action spotz to chair next week
14:55:35 <jcapitao> #topic Open Floor
14:56:02 <ykarel> wrt migration to new jenkins https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/34226
14:56:19 <ykarel> any idea how we manage credentials in current ci.centos jenkins
14:56:25 <ykarel> like DLRNAPI_PASSWD
14:56:41 <ykarel> i was looking at credentials for rdo user, but couldn't find it
14:57:40 <amoralej> mmm
14:59:34 <amoralej> it uses credentials-bindings
15:00:13 <amoralej> https://github.com/rdo-infra/ci-config/blob/0ce33c32ecf54f4df2834e6e147989129d380b15/jenkins/jobs/weirdo-defaults.yml#L25-L28
15:00:46 <ykarel> yes, but where and how those creds are stored
15:00:58 <amoralej> i think we create them manually
15:01:02 <amoralej> in jenkins webui
15:01:18 <ykarel> for rdo user or some other?
15:01:26 <amoralej> checking
15:01:30 <ykarel> ack
15:02:38 <jcapitao> I'm going to close the meeting, we can continue to discuss on this topic off record
15:02:44 <ykarel> ack
15:02:46 <jcapitao> #endmeeting