14:01:22 <jcapitao> #startmeeting RDO meeting - 2021-08-11
14:01:22 <opendevmeet> Meeting started Wed Aug 11 14:01:22 2021 UTC and is due to finish in 60 minutes.  The chair is jcapitao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:22 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:22 <opendevmeet> The meeting name has been set to 'rdo_meeting___2021_08_11'
14:01:28 <jcapitao> #topic roll call
14:01:48 <spotz> weshay|ruck: marios|ruck - pinging in case you want to join the discussions
14:01:51 <spotz> o/
14:02:01 <jcapitao> #chair spotz
14:02:01 <opendevmeet> Current chairs: jcapitao spotz
14:02:06 <weshay|ruck> hola
14:02:35 <jcapitao> amoralej on PTO, and ykarel is not around
14:02:41 <apevec> o/
14:03:01 <jcapitao> #chair apevec
14:03:01 <opendevmeet> Current chairs: apevec jcapitao spotz
14:06:12 <marios|ruck> o/
14:06:32 <spotz> apevec: You about?
14:06:36 <spotz> NM:)
14:06:50 <jcapitao> #chair marios|ruck
14:06:50 <opendevmeet> Current chairs: apevec jcapitao marios|ruck spotz
14:07:01 <jcapitao> let's start with first topic
14:07:12 <jcapitao> #topic RDO Xena and release it on CS8 - plan B
14:07:48 <weshay|ruck> fun fun
14:07:56 <jcapitao> I guess spotz you added it ?
14:08:03 <jcapitao> #chair weshay|ruck
14:08:03 <opendevmeet> Current chairs: apevec jcapitao marios|ruck spotz weshay|ruck
14:08:22 <apevec> I asked about it
14:09:36 <jcapitao> so we won't go with plan A ?
14:09:47 <apevec> so current CS9 status is that most likely repos will not be ready this month or so
14:10:05 <apevec> and we'll have to publish RDO X with CS8
14:10:20 <apevec> then add CS9 later when it's available
14:10:57 <apevec> I don't think we have alternative so this is more public record
14:11:06 <spotz> I added it for apevec:)
14:11:09 <weshay|ruck> crystal ball for tripleo.. would be that tripleo skips xena.. releases yoga w/ cs9
14:11:10 <apevec> please summarize for minutes
14:11:18 * apevec in other call in ||
14:11:35 <jcapitao> fair enough
14:11:45 <weshay|ruck> crystal balls don't always work.. marios|ruck thoughts on that prediction?
14:11:49 <spotz> And yeah a little late was fine but we might be 2 months late if we wait
14:12:10 <marios|ruck> to clarify what weshay|ruck said depends if we merge https://review.opendev.org/c/openstack/tripleo-specs/+/801512 and decide to go ahead with it for xena
14:12:13 <marios|ruck> cutting it a bit close...
14:12:14 <marios|ruck> ;)
14:12:22 <marios|ruck> but as weshay|ruck said, we haven't had any big pushback yet
14:12:27 <marios|ruck> mostly +2 so that is likely to happen
14:13:08 <marios|ruck> (end of file)
14:16:11 <spotz> I haven't heard anyoone against it
14:16:26 <jcapitao> ok, when will be the final decision (i.e merged or abandoned) ?
14:16:27 <tkajinam> if Xena is released on CS8 first and then on CS9 later, are both release supported for long term ?
14:16:50 <tkajinam> previously we migrate from c7 to c8, train was a kind of "transition" release which is supported on both c7 and c8
14:16:52 <marios|ruck> jcapitao: "soon" i think there are some final discussions happening now latest comments on that spec
14:17:07 <marios|ruck> jcapitao: maybe we can make a decision at next week irc meeting on tuesday
14:18:27 <jcapitao> marios|ruck: ok good
14:19:02 <apevec> tkajinam, plan A was: X on CS9, then "backport" CS9 to W and have W as transition RDO release
14:19:12 <tkajinam> ah ok
14:19:37 <apevec> we'll see about transition release, maybe both X and W will be both CS8/9
14:19:54 <tkajinam> I agree that's plan A but if we take plan B then both X and W will be transition releases
14:19:58 <spotz> tkajinam: I cann't speak for tripleoo team but when we've done it for OSA yes the backport was supported
14:20:24 <spotz> If y'all need me to attend on Tuesday throw me an invite
14:20:34 <spotz> OOh tripleo meeting nnnever mind I have it:)
14:21:44 <tkajinam> I was curious of supported release + os combination in rdo mainly because we need corresponding jobs in puppet. I'll watch the discussion to see which plan (A/B) is likely to happen
14:21:54 <tkajinam> sorry for interrupts
14:22:12 <spotz> Nope we all do it:) Reading and typing takes time!
14:22:13 <marios|ruck> spotz: ack yes i meant tripleo irc meeting next tue
14:22:20 <jcapitao> #chair tkajinam
14:22:20 <opendevmeet> Current chairs: apevec jcapitao marios|ruck spotz tkajinam weshay|ruck
14:23:11 <jcapitao> #info RDO Xena will be first released on CS8
14:23:31 <jcapitao> #info RDO Xena will be released on CS9 later when it's available
14:23:36 <spotz> weshay|ruck and marios|ruck - Are you woorried about any perception problems if TripleO skips Xena?
14:28:32 <marios|ruck> yes of course this is a concern spotz
14:28:53 <marios|ruck> spotz: mentioned in the spec the main point is that 'tripleo doesn't support all openstack releases'
14:29:17 <marios|ruck> spotz: and some mitigation is considered around using tags to signal which versions of the tripleo repos are compatible with the branch when tripleo has not created that branch in their repo
14:30:31 <spotz> marios|ruck: Ok, I know y'all have a plan. Just been dealing with a lot of the usual perception issues with OpenStack lately so wanted to confirm
14:31:24 <marios|ruck> spotz: to be clear, even if we don't create a branch we will always continually test master with our ci
14:31:39 <marios|ruck> spotz: ack
14:31:52 <spotz> Thanks
14:32:03 <jcapitao> let's see how it goes
14:32:27 <jcapitao> we can switch to next topic
14:32:47 <jcapitao> #topic RDO Trunk repos for centos-[queens|rocky|stein] stopped
14:33:21 <jcapitao> as mentioned in last meetings, we planned to stop trunk repos for Queens, Rocky and Stein releases
14:33:50 <jcapitao> we removed the DLRN workers
14:34:00 <jcapitao> #link https://softwarefactory-project.io/r/c/software-factory/sf-infra/+/22460
14:37:56 <tosky> does it mean we can drop all open patches for those branches?
14:41:40 <jcapitao> tosky: yes those patches can be dropped
14:42:07 <tosky> thanks!
14:43:41 <jcapitao> next topic
14:43:42 <jcapitao> #topic chair for next week
14:43:57 <jcapitao> any volunteer ?
14:44:49 <spotz> It's you or me unless we volunteer ykarel:)
14:45:15 <spotz> I shoould be able to do it
14:45:51 <jcapitao> in fact ykarel told me a couple hours back he could propose himself if no volunteer :)
14:46:13 <spotz> Woot!
14:46:31 <jcapitao> #action ykarel to chair next week
14:46:45 <jcapitao> I'll ping him tomorrow ;)
14:47:02 <jcapitao> #topic Open floor
14:47:27 <jcapitao> if you want to bring something out of topic
14:53:23 <jcapitao> vim .
14:55:45 <spotz> hehe ok II think it's safe to endmeeting:)
14:55:52 <jcapitao> yes :)
14:56:04 <jcapitao> thank you all for joining !
14:56:07 <jcapitao> #endmeeting