14:01:10 <ykarel> #startmeeting RDO meeting - 2021-08-18
14:01:10 <opendevmeet> Meeting started Wed Aug 18 14:01:10 2021 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:10 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:10 <opendevmeet> The meeting name has been set to 'rdo_meeting___2021_08_18'
14:01:32 <spotz> o/
14:01:40 <ykarel> #topic roll call
14:01:45 <ykarel> #chair spotz
14:01:45 <opendevmeet> Current chairs: spotz ykarel
14:01:46 <rdogerrit> Merged openstack/tripleo-common-distgit ussuri-rdo: Apply Patch for redhat-release rpm cleanup in CentOS  https://review.rdoproject.org/r/c/openstack/tripleo-common-distgit/+/34993
14:02:23 <ykarel> Can add last minute topics to https://etherpad.opendev.org/p/RDO-Meeting
14:05:44 <ykarel> Ok let's start with topics, some people are on PTOs
14:05:59 <ykarel> #topic RDO xena release preparation
14:06:45 <ykarel> #info non client libraries release this week
14:06:49 <ykarel> #link https://releases.openstack.org/xena/schedule.html
14:07:24 <ykarel> So with this we need to start with release preparation, as a starter we create an etherpad and a trello card to track progress
14:07:45 <ykarel> i will get those created and probably from next week can start with requirement sync for non client libraries
14:08:06 <ykarel> #action ykarel to create xena release preparation trello card and etherpad
14:08:18 <spotz> ykarel: I'll prep an etherpad with the announcement
14:08:44 <ykarel> spotz, ok Thanks, with that we have much time so that can wait
14:09:13 <ykarel> we also need to deal with c8 and c9 stream xena handling in release announcement
14:09:37 <spotz> ykarel: Yeah cause it'd be said to get that done before the wallaby shirts get in!
14:09:42 <spotz> sad even
14:09:48 <rdogerrit> Merged rdo-infra/ci-config master: Update cockpit to new jenkins  https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/34895
14:09:49 <rdogerrit> Merged rdo-infra/ci-config master: Migrate TripleO ppc jobs  https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/34653
14:10:00 <ykarel> yes let's see how it goes
14:10:58 <ykarel> Ok let's move to next topic
14:11:13 <ykarel> #topic jenkins jobs migration update
14:11:36 <ykarel> #link https://review.rdoproject.org/r/q/topic:jenkins-v2+(status:open%20OR%20status:merged)
14:12:24 <ykarel> #info almost all patches are merged, just 1 pending
14:12:33 <ykarel> weshay|ruck, chandankumar jpena when you get chance ^
14:13:16 <ykarel> will monitor these jobs for few days, and once all ready will remove jobs from old jenkins, update promoter config
14:14:12 <ykarel> i noticed once issue with urltrigger, will check and look for the fix
14:14:15 <weshay|ruck> ykarel, as always.. you da man! ++
14:15:31 <ykarel> Thanks weshay|ruck jpena chandankumar for all the reviews
14:15:41 <ykarel> Ok that's it in this topic, moving to next
14:16:06 <ykarel> #topic Drop kolla package from Xena?
14:16:28 <ykarel> #info It was added for Building TripleO Containers, but since Train+ releases TripleO not using it
14:16:33 <spotz> If we're not using it, do e need to deprecate iit?
14:17:37 <ykarel> #info With https://github.com/openstack/kolla/commit/383364 kolla moved to jinja2 > 3.0.0
14:18:59 <ykarel> #info we consume jinja2 from centos base repos which is still < 3.0.0, and we avoid updates to deps from base repos until and unless really needed, for kolla it's really needed as codebase requires it, but if we plan to drop kolla then we can avoid it
14:20:07 <ykarel> spotz, we either include a package or drop when it's not being used
14:20:13 <spotz> Yeah seems like we remove them both at the same time
14:20:46 <spotz> I vote for remove then
14:21:06 <ykarel> mwhahaha, stevebaker any concern with removal?
14:21:30 <mwhahaha> removal of what?
14:21:36 <ykarel> kolla
14:21:40 <ykarel> rpm
14:21:50 <mwhahaha> as of xena?
14:21:54 <ykarel> yes
14:22:07 <mwhahaha> i don't believe we are still using it (if we are we need to nuke that code)
14:22:20 <ykarel> Okk
14:22:23 <mwhahaha> though maybe ask openstack-discuss?
14:22:29 <mwhahaha> because someone might be using it
14:22:46 <ykarel> yes sure, i tried looking with codesearch but didn't find it
14:22:51 <spotz> Someoone outside of Tripleo?
14:22:59 <mwhahaha> yea someone using the packaging
14:23:15 <ykarel> will also look for possibility of moving to jinja 3.0.0 and then raise on openstack-discuss
14:23:20 <ykarel> probably next week
14:23:43 <spotz> +1
14:23:49 <mwhahaha> i think we resolved our problems with jinja 3 via source at previously when they released it so likely we can get away with updating
14:23:57 <mwhahaha> of course, i'm sure CI will prove otherwise
14:24:37 <ykarel> yeap multiple projects using it, let's see
14:26:00 <ykarel> Ok that's it on this topic, moving ahead
14:26:20 <ykarel> #topic chair for next week
14:26:27 <ykarel> any volunteer?
14:26:57 <ykarel> so only spotz you around, if you are willing to take else i will re take
14:27:13 <spotz> Let me check the calendar real quick
14:27:24 <ykarel> from next week Alfredo will be back and the other next week joel, then will have more strength :)
14:27:49 <spotz> I can take it
14:28:21 <ykarel> Thanks spotz
14:28:28 <ykarel> #action spotz to chair next week
14:28:33 <ykarel> #topic Open Floor
14:28:39 <ykarel> Feel free to bring any topic now
14:33:31 <spotz> I say we close it down:)
14:33:38 <ykarel> yeap was thinking same :)
14:33:47 <ykarel> Thanks all
14:33:49 <ykarel> #endmeeting