14:00:48 <jcapitao> #startmeeting RDO meeting - 2021-09-08
14:00:48 <opendevmeet> Meeting started Wed Sep  8 14:00:48 2021 UTC and is due to finish in 60 minutes.  The chair is jcapitao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:48 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:48 <opendevmeet> The meeting name has been set to 'rdo_meeting___2021_09_08'
14:01:14 <jcapitao> #topic roll call
14:01:49 <rdogerrit> Merged gating_scripts master: Ignore CBS validation when version in spec is XXX  https://review.rdoproject.org/r/c/gating_scripts/+/35368
14:01:51 <spotz> o/
14:02:03 <amoralej> o/
14:03:39 <jcapitao> #chair spotz amoralej
14:03:39 <opendevmeet> Current chairs: amoralej jcapitao spotz
14:06:33 <jcapitao> I think we can start with first topic
14:06:41 <jcapitao> #topic Status of Xena GA preparation
14:07:20 <jcapitao> so we are currently building libs and clients projects
14:07:28 <jcapitao> #link https://review.rdoproject.org/r/q/topic:%22xena-branching%22+(status:open%20OR%20status:merged)
14:07:45 <jcapitao> #link https://review.rdoproject.org/etherpad/p/xena-release-preparation
14:08:30 <jcapitao> the DLRN instance for Xena is bootstrapped and ready, thanks jpena
14:08:47 <jcapitao> #link https://trunk.rdoproject.org/centos8-xena/report.html
14:09:18 <jcapitao> so business as usual
14:09:37 <jcapitao> once client released, we'll be able to sync to Fedora
14:10:12 <amoralej> nice
14:10:42 <spotz> Are we going back to Fedora?
14:11:19 <amoralej> wdym?
14:11:46 <spotz> able to sync to Fedora
14:11:52 <jcapitao> we update client openstack packages in Fedora from RDO
14:12:01 <spotz> Ahh thanks:)
14:12:23 <amoralej> we'll sync clients to fedora after xena GA
14:12:50 <spotz> I knew we had migrated off their mirrors befoore I became involved so was confused
14:13:04 <chandankumar> Tengu: bandini amoralej https://review.rdoproject.org/r/c/testproject/+/18953/104#message-7a726859e5190101b7c9f9bab37d9f8ae3a4c13d container-tools 3:0 gone fyi, teesting with latest container tools
14:13:20 <jcapitao> why after GA ?
14:13:25 <bandini> ack. that is what i have been using since forever
14:13:57 <amoralej> well, i think it's the most natural path to first release RDO Xena and then move clients in fedora to xena
14:14:05 <amoralej> said this, we may do it before if we prefer
14:14:09 <amoralej> we did it in wallaby
14:14:22 <amoralej> because we needed some releases to fix compatibility with python in fedora iirc
14:14:33 <jcapitao> ah right
14:15:10 <jcapitao> so let's do it after GA
14:16:16 <jcapitao> let's follow to next topic
14:16:30 <jcapitao> #topic Update about preparation for CS9
14:16:51 <jcapitao> w/ fresh news
14:17:10 <spotz> woohoo
14:17:24 <amoralej> #info CentOS infra team has created the tags in CBS for cloudsig so we can start building
14:17:37 <amoralej> #info dependencies bootstrap is in progress
14:17:46 <amoralej> #link https://cbs.centos.org/koji/builds?start=0&tagID=2392&order=-build_id&inherited=1&latest=1
14:18:08 <amoralej> so, we have built now 186 deps
14:18:29 <amoralej> also i've been working on building openvswitch and ovn in NFV SIG
14:18:38 <amoralej> and involving other SIGs
14:18:51 <Tengu> chandankumar: "great"... things are getting wilder now.
14:19:13 <amoralej> there is quite much activity on CS9 buildroots last days
14:19:23 <amoralej> so i think we are doing good progress
14:20:21 <spotz> How do you think we look timing wise?
14:20:47 <jcapitao> great
14:21:01 <amoralej> hard to say...
14:21:18 <amoralej> spotz, i think we are late for Xena GA, that's for sure
14:21:25 <amoralej> but good enough for Yoga :)
14:21:40 <amoralej> i hope to finish deps by next week
14:21:47 <amoralej> or something like that
14:22:11 <amoralej> then we'll start creating RDO Trunk worker centos9-master
14:22:12 <rdogerrit> Merged openstack/oslo-policy-distgit xena-rdo: python-oslo-policy-3.8.2-1  https://review.rdoproject.org/r/c/openstack/oslo-policy-distgit/+/35375
14:22:14 <amoralej> and bootstrap it
14:22:48 <spotz> That gives us plan and means noo hereoics or killing yourself to make an unrealistic deadline:)
14:22:54 <amoralej> and we know there are some issues that are still work in progress from upstream point of view
14:23:22 <amoralej> yeap
14:23:38 <amoralej> however... at some point we'll probably backport xena to centos9
14:23:59 <amoralej> once everything is ready in master branches during yoga cycle
14:24:37 <spotz> Sounds good
14:25:46 <jcapitao> the good point is that we'll have plenty of time to catch issues until then
14:27:13 <amoralej> it's never plenty of time :)
14:27:21 <amoralej> but at least we'll have *more* time
14:28:05 <spotz> hehe
14:28:34 <spotz> I'm sure new things will pop up but that's normal
14:29:50 <amoralej> yes, every OS major update is tricky
14:30:16 <rdogerrit> Merged openstack/oslo-vmware-distgit xena-rdo: python-oslo-vmware-3.9.1-1  https://review.rdoproject.org/r/c/openstack/oslo-vmware-distgit/+/35377
14:31:13 <jcapitao> aha yeah *more* time you're right
14:31:52 <amoralej> i think that's it wrt cs9
14:32:01 <amoralej> we are a bit closer
14:32:23 <jcapitao> huge step since last week
14:32:35 <jcapitao> let's move to next topic then
14:33:05 <jcapitao> who did add "Release prep?" topic ?
14:33:17 <spotz> I think all our topics are related this week. That was me
14:33:17 <jcapitao> it was related to Xena ?
14:33:33 <jcapitao> okk
14:33:46 <jcapitao> we're out of topic then
14:33:53 <spotz> Are we close to needing our etherpads for the release oro still a bit off?
14:34:42 <amoralej> for announcement?
14:34:55 <amoralej> next week is rc1, so can be a good time to start it
14:34:59 <spotz> Announcement, check list, etc
14:35:10 <spotz> Don't we normally have 2-3
14:35:12 <spotz> ?
14:36:04 <amoralej> yes
14:36:07 <amoralej> right
14:36:29 <spotz> It sounds like we're close to needing to starrt them but not yet
14:37:20 <amoralej> anyway, it's not a problem if you create them
14:37:56 <amoralej> spotz, something we must agree with tripleo project is the plan for tripleo releases in Xena
14:38:04 <amoralej> as they don't plan to cut branches
14:38:33 <amoralej> but we will probably build from some tags that they will provide us
14:38:46 <amoralej> we need to discuss about timings with them
14:38:53 <spotz> amoralej: let's try to get something on their meeting agenda or invite them to ours? I don't think we can wait 6 weeks for the PTG
14:38:58 <amoralej> and about how we we'll announce it
14:39:17 <amoralej> no, i think we can add a topic about it for next week
14:39:27 <spotz> Sounds good
14:39:27 <amoralej> and invite them to the mtg
14:39:41 <amoralej> marios, ^ who may be the right person for it?
14:40:11 <marios> o/ amoralej so slagle is the new ptl now
14:40:32 <amoralej> spotz, but let's add a reminder that we need to explain a bit about the situation of Tripleo in RDO Xena in the release notes or in the web site
14:40:34 <amoralej> ack, thanks marios
14:40:39 <spotz> I think you should be involved for this one tooo so we have outgoing and incoming:)
14:40:54 <amoralej> ok
14:41:00 <marios> ack spotz
14:41:45 <spotz> Cause we release the past but need to plan the future. And yeah we'll do a bloog/email/etc on the change once we know as much as poossible
14:42:22 <amoralej> let's add the topic for next week already so i don't forget it
14:42:35 <spotz> OOk
14:43:50 <rdogerrit> Merged openstack/os-win-distgit xena-rdo: python-os-win-5.5.0-1  https://review.rdoproject.org/r/c/openstack/os-win-distgit/+/35380
14:44:05 <rdogerrit> Merged openstack/oslo-metrics-distgit xena-rdo: python-oslo-metrics-0.3.0-1  https://review.rdoproject.org/r/c/openstack/oslo-metrics-distgit/+/35378
14:44:18 <jcapitao> speaking of
14:44:26 <jcapitao> any volunteer for next week chair ?
14:44:36 <jcapitao> #topic Next week chair
14:44:42 <amoralej> i can take it
14:45:07 <spotz> Thanks amoralej
14:45:07 <jcapitao> #action amoralej to chair next week
14:45:12 <jcapitao> thx amoralej
14:45:20 <jcapitao> #topic open floor
14:47:25 <spotz> Everyoone registereed for the PTG?:)
14:47:37 <rdogerrit> Joel Capitao created openstack/automaton-distgit xena-rdo: python-automaton-2.4.0-1  https://review.rdoproject.org/r/c/openstack/automaton-distgit/+/35381
14:47:49 <amoralej> mmm thanks for the reminder spotz :)
14:47:51 <jcapitao> yeap!
14:48:09 <spotz> That's what I'm here for:) That and typoes
14:48:27 <amoralej> :)
14:48:35 <amoralej> there is also centos dojo in october https://wiki.centos.org/Events/Dojo/October2021
14:49:53 <rdogerrit> Joel Capitao created openstack/taskflow-distgit xena-rdo: python-taskflow-4.6.2-1  https://review.rdoproject.org/r/c/openstack/taskflow-distgit/+/35382
14:50:01 <spotz> Yeah we need to oget back to more organization for Cloud SiG
14:50:39 <spotz> Dojo might be a good place too talk about the CS9 issues?
14:51:29 <amoralej> i expect so
14:51:47 <rdogerrit> Joel Capitao created openstack/osprofiler-distgit xena-rdo: python-osprofiler-3.4.2-1  https://review.rdoproject.org/r/c/openstack/osprofiler-distgit/+/35383
14:52:46 <spotz> Leet's chat oout oof meeeting on that as it's not really RDO meeting related
14:54:11 <jcapitao> registered as well to CentOS Dojo ! thanks for the reminder
14:54:31 <jcapitao> I'm going to close the meeting
14:54:45 <jcapitao> #endmeeting